Hippo Namespace

[image]

.NET Framework Class Library
Hippo Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalysisItem | 통계 분석 아이템 클래스
Public class | AnalysisItemCollection | 통계 분석 아이템(AnalysisItem)의 컬렉션을 관리합니다.
Public class | Angles | 비좌표 차트(파이차트 등)의 각 시리즈아이템들의 각도값 컬렉션을 관리하는 클래스
Public class | Axis | 축을 나타내는 클래스
Public class | AxisArea | 영역 마커 클래스
Public class | AxisAreaCollection | 영역 마커 컬렉션 클래스
Public class | AxisFactors | 좌표가 가져야할 요소들을 정의하는 클래스
Public class | AxisList | 축(Axis) 클래스의 컬렉션을 관리합니다.
Public class | AxisMarker | 축 마커 클래스
Public class | AxisMarkerCollection | 차트 마커 컬렉션을 관리합니다.
Public class | AxisScaleRange | 축 Scale Range 클래스
Public class | AxisScaleRangeCollection | 축 Scale Range 컬렉션 클래스
Public class | AxisTick | 축의 눈금을 생성하는 클래스
Public class | AxisTickCollection | 차트 Tick 컬렉션을 관리합니다.
Public class | AxisTickPointList | 축의 각 눈금 포인트를 관리합니다.
Public class | Balloon | 풍선 도움말 클래스
Public class | BaseChart | 히포차트의 추상 클래스 - 차트가 반드시 가져야할 기본적인 기능과 속성을 정의합니다.
Public class | BoxPlotList | 박스플롯 리스트
Public class | BoxPlots | 박스 플롯 클래스 (사용자 호출 대상이 아닙니다)
Public class | BoxPlotsAttributes | 박스 플롯 설정 클래스 (사용자 호출 대상)
Public class | ChartDesigner | 차트 디자이너 클래스
Public class | ChartUtility | 유틸리티 클래스
Public class | ColorMap | 칼라맵 차트의 특징을 정의합니다.
Public class | ColorSchema |
Public class | ColorSystem | ColorSystem - 그래프의 컬러를 결정합니다.
Public class | Column | Column 클래스
Public class | CultureInfo | 문화권 정보 클래스
Public class | Descriptions | Description(설명) 클래스
Public class | EventLogHelper | 이벤트로그 등록 클래스
Public class | Figures | 중요 고정값 관리 클래스
Public class | FileSystemLogHelper | 파일 시스템 로그를 생성해 주는 클래스
Public class | FunctionCompiler | Compiles functions as runtime. This class cannot be inherited.
Public class | FunctionNotCompiledException | The exception is thrown when function was not compiled.
Public class | Gantt | Gantt 차트의 특성을 정의하는 클래스입니다.
Public class | GanttProcess | 간트프로세스
Public class | Gauge | 게이지, 계기판형 차트의 속성을 관리하는 클래스입니다.
Public class | GraphArea | 그래프 영역
Public class | GraphColorItem | 그래프 칼라 아이템 클래스
Public class | Grid | 그리드 클래스
Public class | HippoChart | 히포차트를 나타내는 대표 클래스
Public class | HippoCollectionBase<(Of <(<'T>)>)> | 히포차트 기본 컬렉션 베이스 클래스
Public class | HippoCollectionBase2<(Of <(<'E, T>)>)> | 히포차트 기본 컬렉션 베이스 클래스 두가지 타입 버전
Public class | HippoEngine | 데이터베이스와 히포차트를 연동해주는 데이터 소스 엔진 클래스입니다.
Public class | ItemNames | 비좌표 차트(파이차트 등)의 각 시리즈아이템들의 이름 컬렉션을 관리하는 클래스
Public class | Kagi | Kagi 차트의 특성을 정의하는 클래스입니다.
Public class | Label | 라벨 클래스
Public class | LabelList | 라벨 컬렉션 클래스
Public class | Layout | 레이아웃 클래스 - 타이틀영역, 로고영역, 범례영역, 내부차트영역의 사각형을 관리합니다.
Public class | LegendBox | 범례 클래스
Public class | LegendBoxItem | 범례박스아이템 클래스
Public class | LegendBoxItemDictionary | 범례박스아이템 컬렉션 클래스
Public class | LegendCell | 범례 하나의 셀을 나타내는 클래스
Public class | LegendCellDictionary | 범례 셀 컬렉션 클래스
Public class | LegendHeader | 범례 헤더 클래스
Public class | LegendItem | 범례 아이템 클래스
Public class | LegendRow | 범례박스아이템 로우 클래스
Public class | LegendRowDictionary | 범례박스아이템 로우 컬렉션 클래스
Public class | Line | 각종 라인의 속성을 관리합니다.
Public class | Logo | 차트 로고(logo) 요소
Public class | OrganizationElement | 조직도 구성원 클래스
Public class | Outlier | 박스플롯 이상치 객체 - 이상치 데이터는, 현재 CHART에서 제공하는 SeriesItem 객체와 유사한 객체의 배열로 데이터를 등록할 수 있도록 함
Public class | OutlierList | 박스플롯 이상치 리스트
Public class | Palette | Palette 클래스
Public class | Palette10 | Palette10 클래스
Public class | Palette11 | Palette11 클래스
Public class | Palette12 | Palette12 클래스
Public class | Palette2 | Palette2 클래스
Public class | Palette3 | Palette3 클래스
Public class | Palette4 | Palette4 클래스
Public class | Palette5 | Palette5 클래스
Public class | Palette6 | Palette6 클래스
Public class | Palette7 | Palette7 클래스
Public class | Palette8 | Palette8 클래스
Public class | Palette9 | Palette9 클래스
Public class | Percentages | 비좌표 차트(파이차트 등)의 각 시리즈아이템들의 퍼센트값 컬렉션을 관리하는 클래스
Public class | PieFigures | 비좌표 차트(파이차트 등)의 각 시리즈아이템들의 실제값 컬렉션을 관리하는 클래스
Public class | Points | 점(포인트)를 나타내는 클래스
Public class | PropertyEditorFormCore | PropertyEditorFormCore
Public class | Radar | 방사형 차트의 특성을 정의합니다.
Public class | Series | Series (시리즈)
Public class | SeriesCollection | SeriesCollection
Public class | SeriesCollectionEditor | SeriesCollectionEditor
Public class | SeriesItem | SeriesItem
Public class | SeriesItemCollection | SeriesItemCollection
Public class | SeriesList | SeriesList (시리즈리스트)
Public class | SeriesListDictionary | SeriesListDictionary
Public class | Theme | Theme
Public class | Title | 차트 타이틀 요소
Public class | UnAxisDrawer | 좌표 성질이 없는 차트의 기본 환경을 그린다.
Public class | UnAxisFactors | 비좌표 특징요소 클래스
Public class | Vector | 벡터 클래스
Public class | VectorList | 벡터 컬렉션 클래스

Structures

 | Structure | Description
Public structure | ColorHsl | Represents an AHSL color.
Public structure | ColorHsv | Represents an AHSV color.
Public structure | ColorRgb | Represents an ARGB color.

Interfaces

 | Interface | Description
Public interface | IChart | 차트가 가져야할 가장 기본적인 특징을 정의합니다.
Public interface | ILegendEntry | 범례에 표시되어야 하는 객체들이 구현합니다.

Delegates

 | Delegate | Description
Public delegate | CompiledFunction | Represents a function that was compiled at runtime.

Enumerations

 | Enumeration | Description
Public enumeration | AnalysisCategory | 통계분석 표시할 항목
Public enumeration | AreaDesignType | 면적 디자인 타입
Public enumeration | AreaType | 영역 차트 타입
Public enumeration | ArrowType | ArrowType
Public enumeration | AxisDataType | 좌표의 데이터 타입
Public enumeration | AxisDirection | 축의 방향
Public enumeration | AxisDisplayItemType | 좌표 차트 수치표시시 표시되는 내용
Public enumeration | AxisOrientation | 축의 8방향 (4.3 버전 이후로 사용되지 않음)
Public enumeration | AxisType | 축의 종류
Public enumeration | BalloonType | 풍선 도움말 모양
Public enumeration | ChartDesignType | 차트 디자인 타입(차트의 배경 디자인)
Public enumeration | ChartType | 차트의 종류
Public enumeration | ColumnRangeType | 컬럼 차트의 Range 타입
Public enumeration | ColumnWidthType | 컬럼의 굵기 타입
Public enumeration | CoordinateType | 좌표 성질 타입
Public enumeration | CoordinativeDirection | 그래프의 축의 방향
Public enumeration | DataSourceType | 히포엔진에 사용할 데이터소스 종류
Public enumeration | DateTimeLabelType | 날짜형 축의 라벨리스트를 기간으로 정의. 히포차트 4.3 버전에서 추가된 열거형입니다.
Public enumeration | DateType | 날짜형 간트차트의 날짜 형태
Public enumeration | ErrorBarType | 에러바차트 종류
Public enumeration | FigureFormat | 숫자 포맷
Public enumeration | FigureTextLocation | 좌표형 차트의 수치 표시 위치
Public enumeration | GaugeType | 게이치 타입
Public enumeration | GraphAreaLocation | 그래프 영역이 2개 이상일때 나누어지는 방향
Public enumeration | GraphColorType | 그래프 그리는 색상 타입
Public enumeration | GridDirection | 좌표 그리드 방향
Public enumeration | HeightType | 높낮이
Public enumeration | KagiType | KagiType
Public enumeration | LegendFormat | 범례 포맷
Public enumeration | LegendHeaderCellType | 범례 헤더의 셀 타입
Public enumeration | LegendLocation | 범례 박스 위치
Public enumeration | LegendValueType | 범례 value 부분에 표시할 값의 타입
Public enumeration | LineNullType | 라인류 차트의 데이터가 널일 경우 표시하는 종류
Public enumeration | OrganizationType | 조직원 타입
Public enumeration | PaletteType | 팔레트 타입
Public enumeration | PieType | PieType
Public enumeration | PointType | 포인트 모양
Public enumeration | RadarPointType | 방사형 차트 타입
Public enumeration | RadarShapeType | 방사형 차트의 외곽 모양
Public enumeration | ScaleBreakType | 스케일 브레이크의 모양
Public enumeration | ShapeType | 온도계 모양
Public enumeration | ShapeType2 | 게이지 모양
Public enumeration | StackType | 스택차트 타입
Public enumeration | UnAxisDisplayItemType | 파이 등 비좌표 차트에 표시할 내용
Public enumeration | UnAxisFigureTextLocation | 비좌표 차트의 수치 텍스트가 그려지는 영역을 나타냄
Send feedback on this topic to Microsoft.


AnalysisCategory Enumeration

[image]

.NET Framework Class Library
AnalysisCategory Enumeration
See Also Send Feedback

통계분석 표시할 항목

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AnalysisCategory
C#
public enum AnalysisCategory
Visual C++
public enum class AnalysisCategory
JavaScript
Hippo.AnalysisCategory = function();
Hippo.AnalysisCategory.createEnum('Hippo.AnalysisCategory', false);

Members

Member name | Description
Max |
Min |
Average |
Sum |
Variance |
StandardDeviation |
StandardError |
Median |

See Also

Hippo Namespace


AnalysisItem Class

[image]

.NET Framework Class Library
AnalysisItem Class
Members Example See Also Send Feedback

통계 분석 아이템 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AnalysisItem _
    Implements ILegendEntry
C#
[SerializableAttribute]
public class AnalysisItem : ILegendEntry
Visual C++
[SerializableAttribute]
public ref class AnalysisItem : ILegendEntry
JavaScript
Hippo.AnalysisItem = function();

Type.createClass(
    'Hippo.AnalysisItem',
    null,
    Hippo.ILegendEntry);

Remarks

좌표 축의 반대편에 평균, 총합, 최대값, 최소값, 표준편차, 중앙값, 분산 등을 표시해줍니다.

Examples

Copy image Copy Code

               SeriesList slist = new SeriesList();
               slist.ChartType = ChartType.Column;

               slist.AxisFactor.YAxis.AnalysisItems[AnalysisCategory.Average].Visible = true;

               Series sr = new Series();

               SeriesItem item1 = new SeriesItem(47);
               item1.Name = "item1";
               SeriesItem item2 = new SeriesItem(-167);
               item2.Name = "item2";
               SeriesItem item3 = new SeriesItem(232);
               item3.Name = "item3";

               sr.items.Add(item1);
               sr.items.Add(item2);
               sr.items.Add(item3);

               slist.SeriesCollection.Add(sr);
               this.hHippoChart1.DrawChart(slist);

Inheritance Hierarchy

System..::..Object
Hippo..::..AnalysisItem

See Also

AnalysisItem Members


AnalysisItem Members

[image] [image]

.NET Framework Class Library
AnalysisItem Members
AnalysisItem Class Constructors Methods Properties See Also Send Feedback

The AnalysisItem type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisItem | AnalysisItem 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalysisCategory | 통계분석 아이템 카테고리를 설정하고 가져옵니다.
Public property | DateTimeValue | 통계 값이 날짜형일 경우의 값을 설정하고 가져옵니다.
Public property | Decimalpoint | 통계 수치의 표시할 소수점을 설정하고 가져옵니다.
Public property | Label | 통계분석아이템 라벨를 설정하고 가져옵니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 통계분석아이템 라인를 설정하고 가져옵니다.
Public property | Name | 통계아이템의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | Value | 통계분석 값를 설정하고 가져옵니다.
Public property | Visible | 통계 분석을 표시할 것인가 여부를 설정하고 가져옵니다.

See Also

AnalysisItem Class


AnalysisItem Constructor

[image]

.NET Framework Class Library
AnalysisItem Constructor
AnalysisItem Class See Also Send Feedback

AnalysisItem 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    category As AnalysisCategory _
)
C#
public AnalysisItem(
    AnalysisCategory category
)
Visual C++
public:
AnalysisItem(
    AnalysisCategory category
)
JavaScript
Hippo.AnalysisItem = function(category);

Parameters

category
Type: Hippo..::..AnalysisCategory

See Also

AnalysisItem Class


AnalysisItem Methods

[image] [image]

.NET Framework Class Library
AnalysisItem Methods
AnalysisItem Class See Also Send Feedback

The AnalysisItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AnalysisItem Class


AnalysisItem Properties

[image] [image]

.NET Framework Class Library
AnalysisItem Properties
AnalysisItem Class See Also Send Feedback

The AnalysisItem type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisCategory | 통계분석 아이템 카테고리를 설정하고 가져옵니다.
Public property | DateTimeValue | 통계 값이 날짜형일 경우의 값을 설정하고 가져옵니다.
Public property | Decimalpoint | 통계 수치의 표시할 소수점을 설정하고 가져옵니다.
Public property | Label | 통계분석아이템 라벨를 설정하고 가져옵니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 통계분석아이템 라인를 설정하고 가져옵니다.
Public property | Name | 통계아이템의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | Value | 통계분석 값를 설정하고 가져옵니다.
Public property | Visible | 통계 분석을 표시할 것인가 여부를 설정하고 가져옵니다.

See Also

AnalysisItem Class


AnalysisCategory Property

[image]

.NET Framework Class Library
AnalysisItem..::..AnalysisCategory Property
AnalysisItem Class See Also Send Feedback

통계분석 아이템 카테고리를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AnalysisCategory As AnalysisCategory
    Get
    Set
C#
public AnalysisCategory AnalysisCategory { get; set; }
Visual C++
public:
property AnalysisCategory AnalysisCategory {
    AnalysisCategory get ();
    void set (AnalysisCategory value);
}
JavaScript
function get_analysisCategory();
function set_analysisCategory(value);

See Also

AnalysisItem Class


DateTimeValue Property

[image]

.NET Framework Class Library
AnalysisItem..::..DateTimeValue Property
AnalysisItem Class See Also Send Feedback

통계 값이 날짜형일 경우의 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateTimeValue As DateTime
    Get
    Set
C#
public DateTime DateTimeValue { get; set; }
Visual C++
public:
property DateTime DateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_dateTimeValue();
function set_dateTimeValue(value);

See Also

AnalysisItem Class


Decimalpoint Property

[image]

.NET Framework Class Library
AnalysisItem..::..Decimalpoint Property
AnalysisItem Class See Also Send Feedback

통계 수치의 표시할 소수점을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Decimalpoint As Integer
    Get
    Set
C#
public int Decimalpoint { get; set; }
Visual C++
public:
property int Decimalpoint {
    int get ();
    void set (int value);
}
JavaScript
function get_decimalpoint();
function set_decimalpoint(value);

See Also

AnalysisItem Class


Label Property

[image]

.NET Framework Class Library
AnalysisItem..::..Label Property
AnalysisItem Class See Also Send Feedback

통계분석아이템 라벨를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Label As Label
    Get
    Set
C#
public Label Label { get; set; }
Visual C++
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

AnalysisItem Class


LegendVisible Property

[image]

.NET Framework Class Library
AnalysisItem..::..LegendVisible Property
AnalysisItem Class See Also Send Feedback

범례에 보여줄 것인지 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendVisible As Boolean
    Get
    Set
C#
public bool LegendVisible { get; set; }
Visual C++
public:
virtual property bool LegendVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_legendVisible();
function set_legendVisible(value);

Implements

ILegendEntry..::..LegendVisible

See Also

AnalysisItem Class


Line Property

[image]

.NET Framework Class Library
AnalysisItem..::..Line Property
AnalysisItem Class See Also Send Feedback

통계분석아이템 라인를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Line As Line
    Get
    Set
C#
public Line Line { get; set; }
Visual C++
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

AnalysisItem Class


Name Property

[image]

.NET Framework Class Library
AnalysisItem..::..Name Property
AnalysisItem Class See Also Send Feedback

통계아이템의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

AnalysisItem Class


Value Property

[image]

.NET Framework Class Library
AnalysisItem..::..Value Property
AnalysisItem Class See Also Send Feedback

통계분석 값를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As Double
    Get
    Set
C#
public double Value { get; set; }
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}
JavaScript
function get_value();
function set_value(value);

See Also

AnalysisItem Class


Visible Property

[image]

.NET Framework Class Library
AnalysisItem..::..Visible Property
AnalysisItem Class See Also Send Feedback

통계 분석을 표시할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

AnalysisItem Class


AnalysisItemCollection Class

[image]

.NET Framework Class Library
AnalysisItemCollection Class
Members See Also Send Feedback

통계 분석 아이템(AnalysisItem)의 컬렉션을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AnalysisItemCollection _
    Inherits HippoCollectionBase2(Of AnalysisCategory, AnalysisItem)
C#
[SerializableAttribute]
public class AnalysisItemCollection : HippoCollectionBase2<AnalysisCategory, AnalysisItem>
Visual C++
[SerializableAttribute]
public ref class AnalysisItemCollection : public HippoCollectionBase2<AnalysisCategory, AnalysisItem^>
JavaScript
Hippo.AnalysisItemCollection = function();

Type.createClass(
    'Hippo.AnalysisItemCollection',
    Hippo.HippoCollectionBase2`2);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>
Hippo..::..HippoCollectionBase2 <(Of <(<' AnalysisCategory, AnalysisItem >)>)>
Hippo..::..AnalysisItemCollection

See Also

AnalysisItemCollection Members


AnalysisItemCollection Members

[image] [image]

.NET Framework Class Library
AnalysisItemCollection Members
AnalysisItemCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AnalysisItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisItemCollection | AnalysisItemCollection 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | Clear | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ContainsKey | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ContainsValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOfKey | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | IndexOfValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | RemoveAt | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | TryGetValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Comparer | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Count | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Item | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Contains | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Contains | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..CopyTo | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..IsFixedSize | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..IsReadOnly | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..IsReadOnly | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Item | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

See Also

AnalysisItemCollection Class


AnalysisItemCollection Constructor

[image]

.NET Framework Class Library
AnalysisItemCollection Constructor
AnalysisItemCollection Class See Also Send Feedback

AnalysisItemCollection 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AnalysisItemCollection()
Visual C++
public:
AnalysisItemCollection()
JavaScript
Hippo.AnalysisItemCollection = function();

See Also

AnalysisItemCollection Class


AnalysisItemCollection Methods

[image] [image]

.NET Framework Class Library
AnalysisItemCollection Methods
AnalysisItemCollection Class See Also Send Feedback

The AnalysisItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | Clear | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ContainsKey | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ContainsValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOfKey | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | IndexOfValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | RemoveAt | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public method | TryGetValue | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Add | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Contains | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Contains | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..CopyTo | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Remove | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

See Also

AnalysisItemCollection Class


AnalysisItemCollection Properties

[image] [image]

.NET Framework Class Library
AnalysisItemCollection Properties
AnalysisItemCollection Class See Also Send Feedback

The AnalysisItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Comparer | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Count | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Item | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Public property | Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IDictionary..::..IsFixedSize | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..IsReadOnly | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..IsReadOnly | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Item | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Keys | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)
Explicit interface implemetation | IDictionary..::..Values | (Inherited from SortedList <(Of <(<' AnalysisCategory, AnalysisItem >)>)>.)

See Also

AnalysisItemCollection Class


Angles Class

[image]

.NET Framework Class Library
Angles Class
Members See Also Send Feedback

비좌표 차트(파이차트 등)의 각 시리즈아이템들의 각도값 컬렉션을 관리하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Angles _
    Inherits HippoCollectionBase(Of Single)
C#
[SerializableAttribute]
public class Angles : HippoCollectionBase<float>
Visual C++
[SerializableAttribute]
public ref class Angles : public HippoCollectionBase<float>
JavaScript
Hippo.Angles = function();

Type.createClass(
    'Hippo.Angles',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Single >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Single >)>)>
Hippo..::..Angles

See Also

Angles Members


Angles Members

[image] [image]

.NET Framework Class Library
Angles Members
Angles Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Angles type exposes the following members.

Constructors

 | Name | Description
Public method | Angles |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class


Angles Constructor

[image]

.NET Framework Class Library
Angles Constructor
Angles Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Angles()
Visual C++
public:
Angles()
JavaScript
Hippo.Angles = function();

See Also

Angles Class


Angles Methods

[image] [image]

.NET Framework Class Library
Angles Methods
Angles Class See Also Send Feedback

The Angles type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
Angles..::..BinarySearch Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


CopyTo Method

[image] [image]

.NET Framework Class Library
Angles..::..CopyTo Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


FindIndex Method

[image] [image]

.NET Framework Class Library
Angles..::..FindIndex Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
Angles..::..FindLastIndex Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


IndexOf Method

[image] [image]

.NET Framework Class Library
Angles..::..IndexOf Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
Angles..::..LastIndexOf Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


Reverse Method

[image] [image]

.NET Framework Class Library
Angles..::..Reverse Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


Sort Method

[image] [image]

.NET Framework Class Library
Angles..::..Sort Method
Angles Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class
Angles Members


Angles Properties

[image] [image]

.NET Framework Class Library
Angles Properties
Angles Class See Also Send Feedback

The Angles type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Angles Class


AreaDesignType Enumeration

[image]

.NET Framework Class Library
AreaDesignType Enumeration
See Also Send Feedback

면적 디자인 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AreaDesignType
C#
public enum AreaDesignType
Visual C++
public enum class AreaDesignType
JavaScript
Hippo.AreaDesignType = function();
Hippo.AreaDesignType.createEnum('Hippo.AreaDesignType', false);

Members

Member name | Description
Default |
Gradation |
Dark |
Shadow |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


AreaType Enumeration

[image]

.NET Framework Class Library
AreaType Enumeration
See Also Send Feedback

영역 차트 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AreaType
C#
public enum AreaType
Visual C++
public enum class AreaType
JavaScript
Hippo.AreaType = function();
Hippo.AreaType.createEnum('Hippo.AreaType', false);

Members

Member name | Description
None |
LineArea |
CurvedArea |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ArrowType Enumeration

[image]

.NET Framework Class Library
ArrowType Enumeration
See Also Send Feedback

ArrowType

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ArrowType
C#
public enum ArrowType
Visual C++
public enum class ArrowType
JavaScript
Hippo.ArrowType = function();
Hippo.ArrowType.createEnum('Hippo.ArrowType', false);

Members

Member name | Description
Arrow |
Line |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Axis Class

[image]

.NET Framework Class Library
Axis Class
Members See Also Send Feedback

축을 나타내는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Axis
C#
[SerializableAttribute]
public class Axis
Visual C++
[SerializableAttribute]
public ref class Axis
JavaScript
Hippo.Axis = function();

Type.createClass(
    'Hippo.Axis');

Remarks

좌표 차트의 축을 나타내며 비좌표 차트(게이지, 방사형)의 축을 나타내기도합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Axis

See Also

Axis Members


Axis Members

[image] [image]

.NET Framework Class Library
Axis Members
Axis Class Constructors Methods Properties See Also Send Feedback

The Axis type exposes the following members.

Constructors

 | Name | Description
Public method | Axis | Axis 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetAxisStep(DateTime, DateTime, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.
Public method | SetAxisStep(Double, Double, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalysisItems | 통계분석 아이템을 설정하고 가져온다.
Public property | Areas | 영역 마커을 설정하고 가져온다.
Public property | AutoScaleBreak | 스케일 브레이크를 자동으로 설정할 것인지 여부를 설정하고 가져온다.
Public property | AxisMagin | 축이 그려지는 공간의 넓이를 설정하고 가져옵니다. (미설정시에는 자동으로 처리됨)
Public property | AxisScaleRanges | 축의 스케일 범위를 조절할 수 있는 ScaleRange 컬렉션을 설정하고 가져온다.
Public property | AxisType | 축의 종류를 설정하고 가져옵니다.
Public property | AxisUnitText | 단위를 나타내는 문자열(예: 원, km, $)을 설정하고 가져온다.
Public property | BackColor | 축 영역의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | ColorMaps | 컬러맵 차트의 속성들을 설정하고 가져옵니다.
Public property | CultureInfo | 문화권 정보를 설정하고 가져옵니다.
Public property | DataType | 축 데이터 타입을 설정하고 가져옵니다.
Public property | DateTimeFormat | 축의 라벨에 표시되는 날짜형 데이터의 포맷을 설정하고 가져옵니다. (예, 기본값은 "m" 이며 간트 차트에 사용됩니다.)
Public property | DateTimeLabelType | 날짜형 축의 라벨 형태를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | DateType | 축이 날짜형일 경우 Date Type을 설정하고 가져옵니다. (기본값 Day)
Public property | Decimalpoint | Y축 라벨의 수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다. ex) 2 라고 설정할 경우 소수점 둘째자리까지 표현합니다.
Public property | Direction | 축의 위치(방향)를 설정하고 가져옵니다.
Public property | ExtraTicks | 축의 추가 눈금을 설정하고 가져온다.
Public property | FigureFormat | 숫자 포맷을 설정하고 가져온다.
Public property | Font | 축 라벨들의 공통 폰트를 설정하고 가져온다.
Public property | ForeColor | 축의 텍스트 색상을 설정하고 가져온다.
Public property | Interval | 축 눈금 간격을 설정하고 가져온다.
Public property | IsAutoSetting | 차트 y축을 자동 설정할 것인지 여부를 설정하고 가져옵니다. 최근 코드 경향은 이 속성을 이용하기 보다는 SetAxisStep() 메소드를 사용합니다.
Public property | IsAxisVerticalRotate | 축 타이틀 텍스트를 회전시킬것인가 여부를 설정하고 가져옵니다.
Public property | IsInverseAxis | 축을 역전 시켜서 표시할 것인지 여부를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | IsShorterFigures | 축 스케일의 숫자 크기가 너무 클 경우 단축된 형태 200k, 1.5M 과 같은 모습으로 표현할 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowTick | 눈금을 보여줄것인지 여부를 설정하고 가져온다.
Public property | IsShowUnitText | 단위 글자를 쓸것인가 여부를 설정하고 가져온다.
Public property | IsVisibleFigures | 축의 수치를 표시할것인가를 설정하고 가져옵니다.
Public property | IsZeroStartScale | 축 스케일을 무조건 0부터 시작할것인가 여부를 설정하고 가져옵니다. 일부 차트는 강제 적용됩니다(예, AreaLine Chart)
Public property | itemCount | x 아이템 개수을 설정하고 가져옵니다.
Public property | LabelFormat | 축 수치 라벨 포맷를 설정하고 가져옵니다.
Public property | LabelItems | 축 단계별 수치 라벨를 설정하고 가져옵니다. (호출 대상이 아닙니다)
Public property | Line | 축 라인을 설정하고 가져온다.
Public property | Logarithmic | 로그 스케일의 축으로 설정할 것인지 여부를 설정하고 가져옵니다.
Public property | LogBase | 로그 스케일의 축으로 설정할 경우 그 베이스 값을 설정하고 가져옵니다.(기본값 10)
Public property | Markers | 마커을 설정하고 가져온다.
Public property | MaxTickCount | 눈금의 최대 간격 수를 설정하고 가져옵니다. (기본값은 5)
Public property | MaxUnitDateTimeValue | 단위 최대 값(날짜형)을 설정하고 가져온다.
Public property | MaxUnitValue | 축스케일에서 단위 최대 값을 설정하고 가져온다.
Public property | MinUnitDateTimeValue | 단위 최소값(날짜형)을 설정하고 가져온다.
Public property | MinUnitValue | 축스케일에서 단위 최소값을 설정하고 가져온다.
Public property | Points | 축의 각 눈금 포인트들을 설정하고 가져온다.
Public property | SmallInterval | 축 눈금 사이 작은 눈금 간격을 설정하고 가져온다.
Public property | StackedSumLabel | 스택형 차트의 아이템 합계를 표시하는 텍스트 라벨을 설정하고 가져옵니다.
Public property | Ticks | 축의 눈금(Tick)을 설정하고 가져온다.
Public property | TitleFormat | 축 타이틀 포맷를 설정하고 가져옵니다.
Public property | TitleLabel | 축의 타이틀 라벨를 설정하고 가져옵니다.
Public property | UnitPixel | 축 눈금간의 한 단계 길이을 설정하고 가져옵니다.
Public property | Visible | 축을 보일것인가 여부를 설정하고 가져온다.
Public property | Width | 축이 그려지는 공간의 넓이(읽기전용)를 설정하고 가져온다.
Public property | X | x축 양의 끝 포인트을 설정하고 가져온다.
Public property | XMinus | x축 음의 끝 포인트을 설정하고 가져온다.
Public property | Y | y축 양의 끝 포인트을 설정하고 가져온다.
Public property | YMinus | y축 음의 끝 포인트을 설정하고 가져온다.
Public property | Zero | 축의 제로 포인트를 설정하고 가져온다.

See Also

Axis Class


Axis Constructor

[image]

.NET Framework Class Library
Axis Constructor
Axis Class See Also Send Feedback

Axis 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    axisType As AxisType _
)
C#
public Axis(
    AxisType axisType
)
Visual C++
public:
Axis(
    AxisType axisType
)
JavaScript
Hippo.Axis = function(axisType);

Parameters

axisType
Type: Hippo..::..AxisType

See Also

Axis Class


Axis Methods

[image] [image]

.NET Framework Class Library
Axis Methods
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetAxisStep(DateTime, DateTime, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.
Public method | SetAxisStep(Double, Double, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.
Public method | ToString | (Inherited from Object.)

See Also

Axis Class


SetAxisStep Method

[image] [image]

.NET Framework Class Library
Axis..::..SetAxisStep Method
Axis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAxisStep(DateTime, DateTime, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.
Public method | SetAxisStep(Double, Double, Double) | 좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.

See Also

Axis Class
Axis Members


SetAxisStep Method (DateTime, DateTime, Double)

[image]

.NET Framework Class Library
Axis..::..SetAxisStep Method (DateTime, DateTime, Double)
Axis Class See Also Send Feedback

좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub SetAxisStep ( _
    minUnitValue As DateTime, _
    maxUnitValuem As DateTime, _
    interval As Double _
)
C#
public void SetAxisStep(
    DateTime minUnitValue,
    DateTime maxUnitValuem,
    double interval
)
Visual C++
public:
void SetAxisStep(
    DateTime minUnitValue,
    DateTime maxUnitValuem,
    double interval
)
JavaScript
function setAxisStep(minUnitValue, maxUnitValuem, interval);

Parameters

minUnitValue
Type: System..::..DateTime
maxUnitValuem
Type: System..::..DateTime
interval
Type: System..::..Double

See Also

Axis Class
SetAxisStep Overload


SetAxisStep Method (Double, Double, Double)

[image]

.NET Framework Class Library
Axis..::..SetAxisStep Method (Double, Double, Double)
Axis Class See Also Send Feedback

좌표 축의 단계 수치를 사용자가 임의로 설정할 수 있습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub SetAxisStep ( _
    minUnitValue As Double, _
    maxUnitValuem As Double, _
    interval As Double _
)
C#
public void SetAxisStep(
    double minUnitValue,
    double maxUnitValuem,
    double interval
)
Visual C++
public:
void SetAxisStep(
    double minUnitValue,
    double maxUnitValuem,
    double interval
)
JavaScript
function setAxisStep(minUnitValue, maxUnitValuem, interval);

Parameters

minUnitValue
Type: System..::..Double
maxUnitValuem
Type: System..::..Double
interval
Type: System..::..Double

See Also

Axis Class
SetAxisStep Overload


Axis Properties

[image] [image]

.NET Framework Class Library
Axis Properties
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisItems | 통계분석 아이템을 설정하고 가져온다.
Public property | Areas | 영역 마커을 설정하고 가져온다.
Public property | AutoScaleBreak | 스케일 브레이크를 자동으로 설정할 것인지 여부를 설정하고 가져온다.
Public property | AxisMagin | 축이 그려지는 공간의 넓이를 설정하고 가져옵니다. (미설정시에는 자동으로 처리됨)
Public property | AxisScaleRanges | 축의 스케일 범위를 조절할 수 있는 ScaleRange 컬렉션을 설정하고 가져온다.
Public property | AxisType | 축의 종류를 설정하고 가져옵니다.
Public property | AxisUnitText | 단위를 나타내는 문자열(예: 원, km, $)을 설정하고 가져온다.
Public property | BackColor | 축 영역의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | ColorMaps | 컬러맵 차트의 속성들을 설정하고 가져옵니다.
Public property | CultureInfo | 문화권 정보를 설정하고 가져옵니다.
Public property | DataType | 축 데이터 타입을 설정하고 가져옵니다.
Public property | DateTimeFormat | 축의 라벨에 표시되는 날짜형 데이터의 포맷을 설정하고 가져옵니다. (예, 기본값은 "m" 이며 간트 차트에 사용됩니다.)
Public property | DateTimeLabelType | 날짜형 축의 라벨 형태를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | DateType | 축이 날짜형일 경우 Date Type을 설정하고 가져옵니다. (기본값 Day)
Public property | Decimalpoint | Y축 라벨의 수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다. ex) 2 라고 설정할 경우 소수점 둘째자리까지 표현합니다.
Public property | Direction | 축의 위치(방향)를 설정하고 가져옵니다.
Public property | ExtraTicks | 축의 추가 눈금을 설정하고 가져온다.
Public property | FigureFormat | 숫자 포맷을 설정하고 가져온다.
Public property | Font | 축 라벨들의 공통 폰트를 설정하고 가져온다.
Public property | ForeColor | 축의 텍스트 색상을 설정하고 가져온다.
Public property | Interval | 축 눈금 간격을 설정하고 가져온다.
Public property | IsAutoSetting | 차트 y축을 자동 설정할 것인지 여부를 설정하고 가져옵니다. 최근 코드 경향은 이 속성을 이용하기 보다는 SetAxisStep() 메소드를 사용합니다.
Public property | IsAxisVerticalRotate | 축 타이틀 텍스트를 회전시킬것인가 여부를 설정하고 가져옵니다.
Public property | IsInverseAxis | 축을 역전 시켜서 표시할 것인지 여부를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | IsShorterFigures | 축 스케일의 숫자 크기가 너무 클 경우 단축된 형태 200k, 1.5M 과 같은 모습으로 표현할 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowTick | 눈금을 보여줄것인지 여부를 설정하고 가져온다.
Public property | IsShowUnitText | 단위 글자를 쓸것인가 여부를 설정하고 가져온다.
Public property | IsVisibleFigures | 축의 수치를 표시할것인가를 설정하고 가져옵니다.
Public property | IsZeroStartScale | 축 스케일을 무조건 0부터 시작할것인가 여부를 설정하고 가져옵니다. 일부 차트는 강제 적용됩니다(예, AreaLine Chart)
Public property | itemCount | x 아이템 개수을 설정하고 가져옵니다.
Public property | LabelFormat | 축 수치 라벨 포맷를 설정하고 가져옵니다.
Public property | LabelItems | 축 단계별 수치 라벨를 설정하고 가져옵니다. (호출 대상이 아닙니다)
Public property | Line | 축 라인을 설정하고 가져온다.
Public property | Logarithmic | 로그 스케일의 축으로 설정할 것인지 여부를 설정하고 가져옵니다.
Public property | LogBase | 로그 스케일의 축으로 설정할 경우 그 베이스 값을 설정하고 가져옵니다.(기본값 10)
Public property | Markers | 마커을 설정하고 가져온다.
Public property | MaxTickCount | 눈금의 최대 간격 수를 설정하고 가져옵니다. (기본값은 5)
Public property | MaxUnitDateTimeValue | 단위 최대 값(날짜형)을 설정하고 가져온다.
Public property | MaxUnitValue | 축스케일에서 단위 최대 값을 설정하고 가져온다.
Public property | MinUnitDateTimeValue | 단위 최소값(날짜형)을 설정하고 가져온다.
Public property | MinUnitValue | 축스케일에서 단위 최소값을 설정하고 가져온다.
Public property | Points | 축의 각 눈금 포인트들을 설정하고 가져온다.
Public property | SmallInterval | 축 눈금 사이 작은 눈금 간격을 설정하고 가져온다.
Public property | StackedSumLabel | 스택형 차트의 아이템 합계를 표시하는 텍스트 라벨을 설정하고 가져옵니다.
Public property | Ticks | 축의 눈금(Tick)을 설정하고 가져온다.
Public property | TitleFormat | 축 타이틀 포맷를 설정하고 가져옵니다.
Public property | TitleLabel | 축의 타이틀 라벨를 설정하고 가져옵니다.
Public property | UnitPixel | 축 눈금간의 한 단계 길이을 설정하고 가져옵니다.
Public property | Visible | 축을 보일것인가 여부를 설정하고 가져온다.
Public property | Width | 축이 그려지는 공간의 넓이(읽기전용)를 설정하고 가져온다.
Public property | X | x축 양의 끝 포인트을 설정하고 가져온다.
Public property | XMinus | x축 음의 끝 포인트을 설정하고 가져온다.
Public property | Y | y축 양의 끝 포인트을 설정하고 가져온다.
Public property | YMinus | y축 음의 끝 포인트을 설정하고 가져온다.
Public property | Zero | 축의 제로 포인트를 설정하고 가져온다.

See Also

Axis Class


AnalysisItems Property

[image]

.NET Framework Class Library
Axis..::..AnalysisItems Property
Axis Class See Also Send Feedback

통계분석 아이템을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AnalysisItems As AnalysisItemCollection
    Get
    Set
C#
public AnalysisItemCollection AnalysisItems { get; set; }
Visual C++
public:
property AnalysisItemCollection^ AnalysisItems {
    AnalysisItemCollection^ get ();
    void set (AnalysisItemCollection^ value);
}
JavaScript
function get_analysisItems();
function set_analysisItems(value);

See Also

Axis Class


Areas Property

[image]

.NET Framework Class Library
Axis..::..Areas Property
Axis Class See Also Send Feedback

영역 마커을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Areas As AxisAreaCollection
    Get
    Set
C#
public AxisAreaCollection Areas { get; set; }
Visual C++
public:
property AxisAreaCollection^ Areas {
    AxisAreaCollection^ get ();
    void set (AxisAreaCollection^ value);
}
JavaScript
function get_areas();
function set_areas(value);

See Also

Axis Class


AutoScaleBreak Property

[image]

.NET Framework Class Library
Axis..::..AutoScaleBreak Property
Axis Class See Also Send Feedback

스케일 브레이크를 자동으로 설정할 것인지 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AutoScaleBreak As Boolean
    Get
    Set
C#
public bool AutoScaleBreak { get; set; }
Visual C++
public:
property bool AutoScaleBreak {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoScaleBreak();
function set_autoScaleBreak(value);

See Also

Axis Class


AxisMagin Property

[image]

.NET Framework Class Library
Axis..::..AxisMagin Property
Axis Class See Also Send Feedback

축이 그려지는 공간의 넓이를 설정하고 가져옵니다. (미설정시에는 자동으로 처리됨)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisMagin As Double
    Get
    Set
C#
public double AxisMagin { get; set; }
Visual C++
public:
property double AxisMagin {
    double get ();
    void set (double value);
}
JavaScript
function get_axisMagin();
function set_axisMagin(value);

See Also

Axis Class


AxisScaleRanges Property

[image]

.NET Framework Class Library
Axis..::..AxisScaleRanges Property
Axis Class See Also Send Feedback

축의 스케일 범위를 조절할 수 있는 ScaleRange 컬렉션을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisScaleRanges As AxisScaleRangeCollection
    Get
    Set
C#
public AxisScaleRangeCollection AxisScaleRanges { get; set; }
Visual C++
public:
property AxisScaleRangeCollection^ AxisScaleRanges {
    AxisScaleRangeCollection^ get ();
    void set (AxisScaleRangeCollection^ value);
}
JavaScript
function get_axisScaleRanges();
function set_axisScaleRanges(value);

See Also

Axis Class


AxisType Property

[image]

.NET Framework Class Library
Axis..::..AxisType Property
Axis Class See Also Send Feedback

축의 종류를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisType As AxisType
    Get
    Set
C#
public AxisType AxisType { get; set; }
Visual C++
public:
property AxisType AxisType {
    AxisType get ();
    void set (AxisType value);
}
JavaScript
function get_axisType();
function set_axisType(value);

See Also

Axis Class


AxisUnitText Property

[image]

.NET Framework Class Library
Axis..::..AxisUnitText Property
Axis Class See Also Send Feedback

단위를 나타내는 문자열(예: 원, km, $)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisUnitText As String
    Get
    Set
C#
public string AxisUnitText { get; set; }
Visual C++
public:
property String^ AxisUnitText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_axisUnitText();
function set_axisUnitText(value);

See Also

Axis Class


BackColor Property

[image]

.NET Framework Class Library
Axis..::..BackColor Property
Axis Class See Also Send Feedback

축 영역의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

Axis Class


ColorMaps Property

[image]

.NET Framework Class Library
Axis..::..ColorMaps Property
Axis Class See Also Send Feedback

컬러맵 차트의 속성들을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColorMaps As ColorMap
    Get
    Set
C#
public ColorMap ColorMaps { get; set; }
Visual C++
public:
property ColorMap^ ColorMaps {
    ColorMap^ get ();
    void set (ColorMap^ value);
}
JavaScript
function get_colorMaps();
function set_colorMaps(value);

See Also

Axis Class


CultureInfo Property

[image]

.NET Framework Class Library
Axis..::..CultureInfo Property
Axis Class See Also Send Feedback

문화권 정보를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property CultureInfo As CultureInfo
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public CultureInfo CultureInfo { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
JavaScript
function get_cultureInfo();
function set_cultureInfo(value);

See Also

Axis Class


DataType Property

[image]

.NET Framework Class Library
Axis..::..DataType Property
Axis Class See Also Send Feedback

축 데이터 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DataType As AxisDataType
    Get
    Set
C#
public AxisDataType DataType { get; set; }
Visual C++
public:
property AxisDataType DataType {
    AxisDataType get ();
    void set (AxisDataType value);
}
JavaScript
function get_dataType();
function set_dataType(value);

See Also

Axis Class


DateTimeFormat Property

[image]

.NET Framework Class Library
Axis..::..DateTimeFormat Property
Axis Class See Also Send Feedback

축의 라벨에 표시되는 날짜형 데이터의 포맷을 설정하고 가져옵니다. (예, 기본값은 "m" 이며 간트 차트에 사용됩니다.)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateTimeFormat As String
    Get
    Set
C#
public string DateTimeFormat { get; set; }
Visual C++
public:
property String^ DateTimeFormat {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dateTimeFormat();
function set_dateTimeFormat(value);

See Also

Axis Class


DateTimeLabelType Property

[image]

.NET Framework Class Library
Axis..::..DateTimeLabelType Property
Axis Class See Also Send Feedback

날짜형 축의 라벨 형태를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateTimeLabelType As DateTimeLabelType
    Get
    Set
C#
public DateTimeLabelType DateTimeLabelType { get; set; }
Visual C++
public:
property DateTimeLabelType DateTimeLabelType {
    DateTimeLabelType get ();
    void set (DateTimeLabelType value);
}
JavaScript
function get_dateTimeLabelType();
function set_dateTimeLabelType(value);

See Also

Axis Class


DateType Property

[image]

.NET Framework Class Library
Axis..::..DateType Property
Axis Class See Also Send Feedback

축이 날짜형일 경우 Date Type을 설정하고 가져옵니다. (기본값 Day)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateType As DateType
    Get
    Set
C#
public DateType DateType { get; set; }
Visual C++
public:
property DateType DateType {
    DateType get ();
    void set (DateType value);
}
JavaScript
function get_dateType();
function set_dateType(value);

See Also

Axis Class


Decimalpoint Property

[image]

.NET Framework Class Library
Axis..::..Decimalpoint Property
Axis Class See Also Send Feedback

Y축 라벨의 수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다. ex) 2 라고 설정할 경우 소수점 둘째자리까지 표현합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Decimalpoint As Integer
    Get
    Set
C#
public int Decimalpoint { get; set; }
Visual C++
public:
property int Decimalpoint {
    int get ();
    void set (int value);
}
JavaScript
function get_decimalpoint();
function set_decimalpoint(value);

See Also

Axis Class


Direction Property

[image]

.NET Framework Class Library
Axis..::..Direction Property
Axis Class See Also Send Feedback

축의 위치(방향)를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Direction As AxisDirection
    Get
    Set
C#
public AxisDirection Direction { get; set; }
Visual C++
public:
property AxisDirection Direction {
    AxisDirection get ();
    void set (AxisDirection value);
}
JavaScript
function get_direction();
function set_direction(value);

See Also

Axis Class


ExtraTicks Property

[image]

.NET Framework Class Library
Axis..::..ExtraTicks Property
Axis Class See Also Send Feedback

축의 추가 눈금을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ExtraTicks As AxisTickCollection
    Get
    Set
C#
public AxisTickCollection ExtraTicks { get; set; }
Visual C++
public:
property AxisTickCollection^ ExtraTicks {
    AxisTickCollection^ get ();
    void set (AxisTickCollection^ value);
}
JavaScript
function get_extraTicks();
function set_extraTicks(value);

See Also

Axis Class


FigureFormat Property

[image]

.NET Framework Class Library
Axis..::..FigureFormat Property
Axis Class See Also Send Feedback

숫자 포맷을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigureFormat As FigureFormat
    Get
    Set
C#
public FigureFormat FigureFormat { get; set; }
Visual C++
public:
property FigureFormat FigureFormat {
    FigureFormat get ();
    void set (FigureFormat value);
}
JavaScript
function get_figureFormat();
function set_figureFormat(value);

See Also

Axis Class


Font Property

[image]

.NET Framework Class Library
Axis..::..Font Property
Axis Class See Also Send Feedback

축 라벨들의 공통 폰트를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Font As Font
    Get
    Set
C#
public Font Font { get; set; }
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_font();
function set_font(value);

See Also

Axis Class


ForeColor Property

[image]

.NET Framework Class Library
Axis..::..ForeColor Property
Axis Class See Also Send Feedback

축의 텍스트 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

Axis Class


Interval Property

[image]

.NET Framework Class Library
Axis..::..Interval Property
Axis Class See Also Send Feedback

축 눈금 간격을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Interval As Double
    Get
    Set
C#
public double Interval { get; set; }
Visual C++
public:
property double Interval {
    double get ();
    void set (double value);
}
JavaScript
function get_interval();
function set_interval(value);

Remarks

본 속성을 활용하는 공식 ex) [차트내에서의 상대적 값] = 픽셀값 * (Interval / UnitPixel)

See Also

Axis Class


IsAutoSetting Property

[image]

.NET Framework Class Library
Axis..::..IsAutoSetting Property
Axis Class See Also Send Feedback

차트 y축을 자동 설정할 것인지 여부를 설정하고 가져옵니다. 최근 코드 경향은 이 속성을 이용하기 보다는 SetAxisStep() 메소드를 사용합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsAutoSetting As Boolean
    Get
    Set
C#
public bool IsAutoSetting { get; set; }
Visual C++
public:
property bool IsAutoSetting {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAutoSetting();
function set_isAutoSetting(value);

See Also

Axis Class


IsAxisVerticalRotate Property

[image]

.NET Framework Class Library
Axis..::..IsAxisVerticalRotate Property
Axis Class See Also Send Feedback

축 타이틀 텍스트를 회전시킬것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsAxisVerticalRotate As Boolean
    Get
    Set
C#
public bool IsAxisVerticalRotate { get; set; }
Visual C++
public:
property bool IsAxisVerticalRotate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAxisVerticalRotate();
function set_isAxisVerticalRotate(value);

See Also

Axis Class


IsInverseAxis Property

[image]

.NET Framework Class Library
Axis..::..IsInverseAxis Property
Axis Class See Also Send Feedback

축을 역전 시켜서 표시할 것인지 여부를 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsInverseAxis As Boolean
    Get
    Set
C#
public bool IsInverseAxis { get; set; }
Visual C++
public:
property bool IsInverseAxis {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isInverseAxis();
function set_isInverseAxis(value);

See Also

Axis Class


IsShorterFigures Property

[image]

.NET Framework Class Library
Axis..::..IsShorterFigures Property
Axis Class See Also Send Feedback

축 스케일의 숫자 크기가 너무 클 경우 단축된 형태 200k, 1.5M 과 같은 모습으로 표현할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShorterFigures As Boolean
    Get
    Set
C#
public bool IsShorterFigures { get; set; }
Visual C++
public:
property bool IsShorterFigures {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShorterFigures();
function set_isShorterFigures(value);

See Also

Axis Class


IsShowTick Property

[image]

.NET Framework Class Library
Axis..::..IsShowTick Property
Axis Class See Also Send Feedback

눈금을 보여줄것인지 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowTick As Boolean
    Get
    Set
C#
public bool IsShowTick { get; set; }
Visual C++
public:
property bool IsShowTick {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowTick();
function set_isShowTick(value);

See Also

Axis Class


IsShowUnitText Property

[image]

.NET Framework Class Library
Axis..::..IsShowUnitText Property
Axis Class See Also Send Feedback

단위 글자를 쓸것인가 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowUnitText As Boolean
    Get
    Set
C#
public bool IsShowUnitText { get; set; }
Visual C++
public:
property bool IsShowUnitText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowUnitText();
function set_isShowUnitText(value);

See Also

Axis Class


IsVisibleFigures Property

[image]

.NET Framework Class Library
Axis..::..IsVisibleFigures Property
Axis Class See Also Send Feedback

축의 수치를 표시할것인가를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsVisibleFigures As Boolean
    Get
    Set
C#
public bool IsVisibleFigures { get; set; }
Visual C++
public:
property bool IsVisibleFigures {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isVisibleFigures();
function set_isVisibleFigures(value);

See Also

Axis Class


IsZeroStartScale Property

[image]

.NET Framework Class Library
Axis..::..IsZeroStartScale Property
Axis Class See Also Send Feedback

축 스케일을 무조건 0부터 시작할것인가 여부를 설정하고 가져옵니다. 일부 차트는 강제 적용됩니다(예, AreaLine Chart)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsZeroStartScale As Boolean
    Get
    Set
C#
public bool IsZeroStartScale { get; set; }
Visual C++
public:
property bool IsZeroStartScale {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isZeroStartScale();
function set_isZeroStartScale(value);

See Also

Axis Class


itemCount Property

[image]

.NET Framework Class Library
Axis..::..itemCount Property
Axis Class See Also Send Feedback

x 아이템 개수을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property itemCount As Integer
    Get
    Set
C#
public int itemCount { get; set; }
Visual C++
public:
property int itemCount {
    int get ();
    void set (int value);
}
JavaScript
function get_itemCount();
function set_itemCount(value);

See Also

Axis Class


LabelFormat Property

[image]

.NET Framework Class Library
Axis..::..LabelFormat Property
Axis Class See Also Send Feedback

축 수치 라벨 포맷를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LabelFormat As StringFormat
    Get
    Set
C#
public StringFormat LabelFormat { get; set; }
Visual C++
public:
property StringFormat^ LabelFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
JavaScript
function get_labelFormat();
function set_labelFormat(value);

See Also

Axis Class


LabelItems Property

[image]

.NET Framework Class Library
Axis..::..LabelItems Property
Axis Class See Also Send Feedback

축 단계별 수치 라벨를 설정하고 가져옵니다. (호출 대상이 아닙니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property LabelItems As LabelList
    Get
C#
public LabelList LabelItems { get; }
Visual C++
public:
property LabelList^ LabelItems {
    LabelList^ get ();
}
JavaScript
function get_labelItems();

See Also

Axis Class


Line Property

[image]

.NET Framework Class Library
Axis..::..Line Property
Axis Class See Also Send Feedback

축 라인을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Line As Line
    Get
    Set
C#
public Line Line { get; set; }
Visual C++
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

Axis Class


Logarithmic Property

[image]

.NET Framework Class Library
Axis..::..Logarithmic Property
Axis Class See Also Send Feedback

로그 스케일의 축으로 설정할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Logarithmic As Boolean
    Get
    Set
C#
public bool Logarithmic { get; set; }
Visual C++
public:
property bool Logarithmic {
    bool get ();
    void set (bool value);
}
JavaScript
function get_logarithmic();
function set_logarithmic(value);

See Also

Axis Class


LogBase Property

[image]

.NET Framework Class Library
Axis..::..LogBase Property
Axis Class See Also Send Feedback

로그 스케일의 축으로 설정할 경우 그 베이스 값을 설정하고 가져옵니다.(기본값 10)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LogBase As Integer
    Get
    Set
C#
public int LogBase { get; set; }
Visual C++
public:
property int LogBase {
    int get ();
    void set (int value);
}
JavaScript
function get_logBase();
function set_logBase(value);

See Also

Axis Class


Markers Property

[image]

.NET Framework Class Library
Axis..::..Markers Property
Axis Class See Also Send Feedback

마커을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Markers As AxisMarkerCollection
    Get
    Set
C#
public AxisMarkerCollection Markers { get; set; }
Visual C++
public:
property AxisMarkerCollection^ Markers {
    AxisMarkerCollection^ get ();
    void set (AxisMarkerCollection^ value);
}
JavaScript
function get_markers();
function set_markers(value);

See Also

Axis Class


MaxTickCount Property

[image]

.NET Framework Class Library
Axis..::..MaxTickCount Property
Axis Class See Also Send Feedback

눈금의 최대 간격 수를 설정하고 가져옵니다. (기본값은 5)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxTickCount As Double
    Get
    Set
C#
public double MaxTickCount { get; set; }
Visual C++
public:
property double MaxTickCount {
    double get ();
    void set (double value);
}
JavaScript
function get_maxTickCount();
function set_maxTickCount(value);

See Also

Axis Class


MaxUnitDateTimeValue Property

[image]

.NET Framework Class Library
Axis..::..MaxUnitDateTimeValue Property
Axis Class See Also Send Feedback

단위 최대 값(날짜형)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxUnitDateTimeValue As DateTime
    Get
    Set
C#
public DateTime MaxUnitDateTimeValue { get; set; }
Visual C++
public:
property DateTime MaxUnitDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_maxUnitDateTimeValue();
function set_maxUnitDateTimeValue(value);

See Also

Axis Class


MaxUnitValue Property

[image]

.NET Framework Class Library
Axis..::..MaxUnitValue Property
Axis Class See Also Send Feedback

축스케일에서 단위 최대 값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxUnitValue As Double
    Get
    Set
C#
public double MaxUnitValue { get; set; }
Visual C++
public:
property double MaxUnitValue {
    double get ();
    void set (double value);
}
JavaScript
function get_maxUnitValue();
function set_maxUnitValue(value);

See Also

Axis Class


MinUnitDateTimeValue Property

[image]

.NET Framework Class Library
Axis..::..MinUnitDateTimeValue Property
Axis Class See Also Send Feedback

단위 최소값(날짜형)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MinUnitDateTimeValue As DateTime
    Get
    Set
C#
public DateTime MinUnitDateTimeValue { get; set; }
Visual C++
public:
property DateTime MinUnitDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_minUnitDateTimeValue();
function set_minUnitDateTimeValue(value);

See Also

Axis Class


MinUnitValue Property

[image]

.NET Framework Class Library
Axis..::..MinUnitValue Property
Axis Class See Also Send Feedback

축스케일에서 단위 최소값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MinUnitValue As Double
    Get
    Set
C#
public double MinUnitValue { get; set; }
Visual C++
public:
property double MinUnitValue {
    double get ();
    void set (double value);
}
JavaScript
function get_minUnitValue();
function set_minUnitValue(value);

See Also

Axis Class


Points Property

[image]

.NET Framework Class Library
Axis..::..Points Property
Axis Class See Also Send Feedback

축의 각 눈금 포인트들을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Points As AxisTickPointList
    Get
    Set
C#
public AxisTickPointList Points { get; set; }
Visual C++
public:
property AxisTickPointList^ Points {
    AxisTickPointList^ get ();
    void set (AxisTickPointList^ value);
}
JavaScript
function get_points();
function set_points(value);

See Also

Axis Class


SmallInterval Property

[image]

.NET Framework Class Library
Axis..::..SmallInterval Property
Axis Class See Also Send Feedback

축 눈금 사이 작은 눈금 간격을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SmallInterval As Double
    Get
    Set
C#
public double SmallInterval { get; set; }
Visual C++
public:
property double SmallInterval {
    double get ();
    void set (double value);
}
JavaScript
function get_smallInterval();
function set_smallInterval(value);

See Also

Axis Class


StackedSumLabel Property

[image]

.NET Framework Class Library
Axis..::..StackedSumLabel Property
Axis Class See Also Send Feedback

스택형 차트의 아이템 합계를 표시하는 텍스트 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StackedSumLabel As Label
    Get
    Set
C#
public Label StackedSumLabel { get; set; }
Visual C++
public:
property Label^ StackedSumLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_stackedSumLabel();
function set_stackedSumLabel(value);

See Also

Axis Class


Ticks Property

[image]

.NET Framework Class Library
Axis..::..Ticks Property
Axis Class See Also Send Feedback

축의 눈금(Tick)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Ticks As AxisTickCollection
    Get
    Set
C#
public AxisTickCollection Ticks { get; set; }
Visual C++
public:
property AxisTickCollection^ Ticks {
    AxisTickCollection^ get ();
    void set (AxisTickCollection^ value);
}
JavaScript
function get_ticks();
function set_ticks(value);

See Also

Axis Class


TitleFormat Property

[image]

.NET Framework Class Library
Axis..::..TitleFormat Property
Axis Class See Also Send Feedback

축 타이틀 포맷를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleFormat As StringFormat
    Get
    Set
C#
public StringFormat TitleFormat { get; set; }
Visual C++
public:
property StringFormat^ TitleFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
JavaScript
function get_titleFormat();
function set_titleFormat(value);

See Also

Axis Class


TitleLabel Property

[image]

.NET Framework Class Library
Axis..::..TitleLabel Property
Axis Class See Also Send Feedback

축의 타이틀 라벨를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleLabel As Label
    Get
    Set
C#
public Label TitleLabel { get; set; }
Visual C++
public:
property Label^ TitleLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_titleLabel();
function set_titleLabel(value);

See Also

Axis Class


UnitPixel Property

[image]

.NET Framework Class Library
Axis..::..UnitPixel Property
Axis Class Example See Also Send Feedback

축 눈금간의 한 단계 길이을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property UnitPixel As Single
    Get
    Set
C#
public float UnitPixel { get; set; }
Visual C++
public:
property float UnitPixel {
    float get ();
    void set (float value);
}
JavaScript
function get_unitPixel();
function set_unitPixel(value);

Remarks

본 속성은 차트내에서의 상대적 크기를 가늠하는 기준이 되는 값으로 다음과 같은 공식을 활용할 수 있습니다. ex) [차트내에서의 상대적 값] = 픽셀값 * (Interval / UnitPixel) 한 마디로 표현하자면 현실 세계의 실제 값이 차트내에서 얼마에 표시가 되느냐하는 식인데, 천만이라는 숫자가 차트내로 들어갔을때 몇 픽셀로 표시가 되느냐를 결정하는 공식이라고 할 수 있습니다.

Examples

Copy image Copy Code
                    double zeroY = this.hHippoChart1.SeriesListDictionary[0].AxisFactor.Zero.Y;

                    float cY = (float)(zeroY - (e.Y));

                    this.hHippoChart1.SeriesListDictionary[0].AxisFactor.YAxis.ExtraTicks[0].Value =
                        cY* this.hHippoChart1.SeriesListDictionary[0].AxisFactor.YAxis.Interval / this.hHippoChart1.SeriesListDictionary[0].AxisFactor.YAxis.UnitPixel;

See Also

Axis Class


Visible Property

[image]

.NET Framework Class Library
Axis..::..Visible Property
Axis Class See Also Send Feedback

축을 보일것인가 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

Axis Class


Width Property

[image]

.NET Framework Class Library
Axis..::..Width Property
Axis Class See Also Send Feedback

축이 그려지는 공간의 넓이(읽기전용)를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Single
    Get
    Set
C#
public float Width { get; set; }
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}
JavaScript
function get_width();
function set_width(value);

See Also

Axis Class


X Property

[image]

.NET Framework Class Library
Axis..::..X Property
Axis Class See Also Send Feedback

x축 양의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property X As PointF
    Get
    Set
C#
public PointF X { get; set; }
Visual C++
public:
property PointF X {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_x();
function set_x(value);

See Also

Axis Class


XMinus Property

[image]

.NET Framework Class Library
Axis..::..XMinus Property
Axis Class See Also Send Feedback

x축 음의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XMinus As PointF
    Get
    Set
C#
public PointF XMinus { get; set; }
Visual C++
public:
property PointF XMinus {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_xMinus();
function set_xMinus(value);

See Also

Axis Class


Y Property

[image]

.NET Framework Class Library
Axis..::..Y Property
Axis Class See Also Send Feedback

y축 양의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Y As PointF
    Get
    Set
C#
public PointF Y { get; set; }
Visual C++
public:
property PointF Y {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_y();
function set_y(value);

See Also

Axis Class


YMinus Property

[image]

.NET Framework Class Library
Axis..::..YMinus Property
Axis Class See Also Send Feedback

y축 음의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YMinus As PointF
    Get
    Set
C#
public PointF YMinus { get; set; }
Visual C++
public:
property PointF YMinus {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_yMinus();
function set_yMinus(value);

See Also

Axis Class


Zero Property

[image]

.NET Framework Class Library
Axis..::..Zero Property
Axis Class See Also Send Feedback

축의 제로 포인트를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Zero As PointF
    Get
    Set
C#
public PointF Zero { get; set; }
Visual C++
public:
property PointF Zero {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_zero();
function set_zero(value);

See Also

Axis Class


AxisArea Class

[image]

.NET Framework Class Library
AxisArea Class
Members Example See Also Send Feedback

영역 마커 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisArea _
    Implements ILegendEntry
C#
[SerializableAttribute]
public class AxisArea : ILegendEntry
Visual C++
[SerializableAttribute]
public ref class AxisArea : ILegendEntry
JavaScript
Hippo.AxisArea = function();

Type.createClass(
    'Hippo.AxisArea',
    null,
    Hippo.ILegendEntry);

Remarks

축에 데이터의 간격(영역)을 지정하여 표시할 수 있습니다. 시작 값과 마지막 값을 이용해서 배경색을 줄 수 있고 해당 코멘트를 달수 있습니다. x, y축 모두 지원합니다. (예, 위험 구간)

Examples

Copy image Copy Code
                    SeriesList slist = new SeriesList();
                    slist.ChartType = ChartType.Column;

                    AxisArea area = new AxisArea("Dangerous", 30, 100);
                    area.TextFormat.Alignment = StringAlignment.Near;
                    area.BackColor = Color.FromArgb(250, Color.Red);
                    slist.AxisFactor.Areas.Add(area);

                    Series sr = new Series();
                    sr.SeriesColor = Color.YellowGreen;

                    SeriesItem item1 = new SeriesItem(23);
                    item1.Name = "item1";
                    SeriesItem item2 = new SeriesItem(77);
                    item2.Name = "item2";
                    SeriesItem item3 = new SeriesItem(120);
                    item3.Name = "item3";
                    sr.items.Add(item1);
                    sr.items.Add(item2);
                    sr.items.Add(item3);

                    slist.SeriesCollection.Add(sr);
                    this.hHippoChart1.DrawChart(slist);

Inheritance Hierarchy

System..::..Object
Hippo..::..AxisArea

See Also

AxisArea Members


AxisArea Members

[image] [image]

.NET Framework Class Library
AxisArea Members
AxisArea Class Constructors Methods Properties See Also Send Feedback

The AxisArea type exposes the following members.

Constructors

 | Name | Description
Public method | AxisArea()()()() | AxisArea 인스턴스를 생성합니다.(기본 생성자)
Public method | AxisArea(String, DateTime, DateTime) | AxisArea 인스턴스를 생성합니다.
Public method | AxisArea(String, Single, Single) | AxisArea 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 배경색을 가져오고 설정합니다.
Public property | BringToFront | 영역 마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.
Public property | EndDateTimeValue | 영역 마커 표시 종료값(날짜형식)을 가져오고 설정합니다.
Public property | EndValue | 영역 마커 표시 종료값를 가져오고 설정합니다.
Public property | IsGradation | 배경에 그라데이션 효과를 줄 것인지 여부를 가져오고 설장합니다.
Public property | Label | 영역 마커 라벨를 가져오고 설정합니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 영역 마커 라인를 가져오고 설정합니다.
Public property | Name | 영역 마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | StartDateTimeValue | 영역 마커 표시 시작값(날짜형식)을 가져오고 설정합니다.
Public property | StartValue | 영역 마커 표시 시작값를 가져오고 설정합니다.
Public property | TextFormat | 영역 마커 문자열포맷를 가져오고 설정합니다.

See Also

AxisArea Class


AxisArea Constructor

[image] [image]

.NET Framework Class Library
AxisArea Constructor
AxisArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AxisArea()()()() | AxisArea 인스턴스를 생성합니다.(기본 생성자)
Public method | AxisArea(String, DateTime, DateTime) | AxisArea 인스턴스를 생성합니다.
Public method | AxisArea(String, Single, Single) | AxisArea 인스턴스를 생성합니다.

See Also

AxisArea Class
AxisArea Members


AxisArea Constructor

[image]

.NET Framework Class Library
AxisArea Constructor
AxisArea Class See Also Send Feedback

AxisArea 인스턴스를 생성합니다.(기본 생성자)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisArea()
Visual C++
public:
AxisArea()
JavaScript
Hippo.AxisArea = function();

See Also

AxisArea Class
AxisArea Overload


AxisArea Constructor (String, DateTime, DateTime)

[image]

.NET Framework Class Library
AxisArea Constructor (String, DateTime, DateTime)
AxisArea Class See Also Send Feedback

AxisArea 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    LabelText As String, _
    StartDatetimevalue As DateTime, _
    EndDatetimevalue As DateTime _
)
C#
public AxisArea(
    string LabelText,
    DateTime StartDatetimevalue,
    DateTime EndDatetimevalue
)
Visual C++
public:
AxisArea(
    String^ LabelText,
    DateTime StartDatetimevalue,
    DateTime EndDatetimevalue
)
JavaScript
Hippo.AxisArea = function(LabelText, StartDatetimevalue, EndDatetimevalue);

Parameters

LabelText
Type: System..::..String
텍스트
StartDatetimevalue
Type: System..::..DateTime
시작값
EndDatetimevalue
Type: System..::..DateTime
종료값

See Also

AxisArea Class
AxisArea Overload


AxisArea Constructor (String, Single, Single)

[image]

.NET Framework Class Library
AxisArea Constructor (String, Single, Single)
AxisArea Class See Also Send Feedback

AxisArea 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    LabelText As String, _
    Startvalue As Single, _
    Endvalue As Single _
)
C#
public AxisArea(
    string LabelText,
    float Startvalue,
    float Endvalue
)
Visual C++
public:
AxisArea(
    String^ LabelText,
    float Startvalue,
    float Endvalue
)
JavaScript
Hippo.AxisArea = function(LabelText, Startvalue, Endvalue);

Parameters

LabelText
Type: System..::..String
텍스트
Startvalue
Type: System..::..Single
시작값
Endvalue
Type: System..::..Single
종료값

See Also

AxisArea Class
AxisArea Overload


AxisArea Methods

[image] [image]

.NET Framework Class Library
AxisArea Methods
AxisArea Class See Also Send Feedback

The AxisArea type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AxisArea Class


AxisArea Properties

[image] [image]

.NET Framework Class Library
AxisArea Properties
AxisArea Class See Also Send Feedback

The AxisArea type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 배경색을 가져오고 설정합니다.
Public property | BringToFront | 영역 마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.
Public property | EndDateTimeValue | 영역 마커 표시 종료값(날짜형식)을 가져오고 설정합니다.
Public property | EndValue | 영역 마커 표시 종료값를 가져오고 설정합니다.
Public property | IsGradation | 배경에 그라데이션 효과를 줄 것인지 여부를 가져오고 설장합니다.
Public property | Label | 영역 마커 라벨를 가져오고 설정합니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 영역 마커 라인를 가져오고 설정합니다.
Public property | Name | 영역 마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | StartDateTimeValue | 영역 마커 표시 시작값(날짜형식)을 가져오고 설정합니다.
Public property | StartValue | 영역 마커 표시 시작값를 가져오고 설정합니다.
Public property | TextFormat | 영역 마커 문자열포맷를 가져오고 설정합니다.

See Also

AxisArea Class


BackColor Property

[image]

.NET Framework Class Library
AxisArea..::..BackColor Property
AxisArea Class See Also Send Feedback

배경색을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

AxisArea Class


BringToFront Property

[image]

.NET Framework Class Library
AxisArea..::..BringToFront Property
AxisArea Class See Also Send Feedback

영역 마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BringToFront As Boolean
    Get
    Set
C#
public bool BringToFront { get; set; }
Visual C++
public:
property bool BringToFront {
    bool get ();
    void set (bool value);
}
JavaScript
function get_bringToFront();
function set_bringToFront(value);

See Also

AxisArea Class


EndDateTimeValue Property

[image]

.NET Framework Class Library
AxisArea..::..EndDateTimeValue Property
AxisArea Class See Also Send Feedback

영역 마커 표시 종료값(날짜형식)을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property EndDateTimeValue As DateTime
    Get
    Set
C#
public DateTime EndDateTimeValue { get; set; }
Visual C++
public:
property DateTime EndDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_endDateTimeValue();
function set_endDateTimeValue(value);

See Also

AxisArea Class


EndValue Property

[image]

.NET Framework Class Library
AxisArea..::..EndValue Property
AxisArea Class See Also Send Feedback

영역 마커 표시 종료값를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property EndValue As Single
    Get
    Set
C#
public float EndValue { get; set; }
Visual C++
public:
property float EndValue {
    float get ();
    void set (float value);
}
JavaScript
function get_endValue();
function set_endValue(value);

See Also

AxisArea Class


IsGradation Property

[image]

.NET Framework Class Library
AxisArea..::..IsGradation Property
AxisArea Class See Also Send Feedback

배경에 그라데이션 효과를 줄 것인지 여부를 가져오고 설장합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsGradation As Boolean
    Get
    Set
C#
public bool IsGradation { get; set; }
Visual C++
public:
property bool IsGradation {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGradation();
function set_isGradation(value);

See Also

AxisArea Class


Label Property

[image]

.NET Framework Class Library
AxisArea..::..Label Property
AxisArea Class See Also Send Feedback

영역 마커 라벨를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

AxisArea Class


LegendVisible Property

[image]

.NET Framework Class Library
AxisArea..::..LegendVisible Property
AxisArea Class See Also Send Feedback

범례에 보여줄 것인지 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendVisible As Boolean
    Get
    Set
C#
public bool LegendVisible { get; set; }
Visual C++
public:
virtual property bool LegendVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_legendVisible();
function set_legendVisible(value);

Implements

ILegendEntry..::..LegendVisible

See Also

AxisArea Class


Line Property

[image]

.NET Framework Class Library
AxisArea..::..Line Property
AxisArea Class See Also Send Feedback

영역 마커 라인를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Line As Line
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line Line { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

AxisArea Class


Name Property

[image]

.NET Framework Class Library
AxisArea..::..Name Property
AxisArea Class See Also Send Feedback

영역 마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

AxisArea Class


StartDateTimeValue Property

[image]

.NET Framework Class Library
AxisArea..::..StartDateTimeValue Property
AxisArea Class See Also Send Feedback

영역 마커 표시 시작값(날짜형식)을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StartDateTimeValue As DateTime
    Get
    Set
C#
public DateTime StartDateTimeValue { get; set; }
Visual C++
public:
property DateTime StartDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_startDateTimeValue();
function set_startDateTimeValue(value);

See Also

AxisArea Class


StartValue Property

[image]

.NET Framework Class Library
AxisArea..::..StartValue Property
AxisArea Class See Also Send Feedback

영역 마커 표시 시작값를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StartValue As Single
    Get
    Set
C#
public float StartValue { get; set; }
Visual C++
public:
property float StartValue {
    float get ();
    void set (float value);
}
JavaScript
function get_startValue();
function set_startValue(value);

See Also

AxisArea Class


TextFormat Property

[image]

.NET Framework Class Library
AxisArea..::..TextFormat Property
AxisArea Class See Also Send Feedback

영역 마커 문자열포맷를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TextFormat As StringFormat
    Get
    Set
C#
public StringFormat TextFormat { get; set; }
Visual C++
public:
property StringFormat^ TextFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
JavaScript
function get_textFormat();
function set_textFormat(value);

See Also

AxisArea Class


AxisAreaCollection Class

[image]

.NET Framework Class Library
AxisAreaCollection Class
Members See Also Send Feedback

영역 마커 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisAreaCollection _
    Inherits HippoCollectionBase(Of AxisArea)
C#
[SerializableAttribute]
public class AxisAreaCollection : HippoCollectionBase<AxisArea>
Visual C++
[SerializableAttribute]
public ref class AxisAreaCollection : public HippoCollectionBase<AxisArea^>
JavaScript
Hippo.AxisAreaCollection = function();

Type.createClass(
    'Hippo.AxisAreaCollection',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' AxisArea >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' AxisArea >)>)>
Hippo..::..AxisAreaCollection

See Also

AxisAreaCollection Members


AxisAreaCollection Members

[image] [image]

.NET Framework Class Library
AxisAreaCollection Members
AxisAreaCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisAreaCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AxisAreaCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisArea >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class


AxisAreaCollection Constructor

[image]

.NET Framework Class Library
AxisAreaCollection Constructor
AxisAreaCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisAreaCollection()
Visual C++
public:
AxisAreaCollection()
JavaScript
Hippo.AxisAreaCollection = function();

See Also

AxisAreaCollection Class


AxisAreaCollection Methods

[image] [image]

.NET Framework Class Library
AxisAreaCollection Methods
AxisAreaCollection Class See Also Send Feedback

The AxisAreaCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisArea >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..BinarySearch Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..CopyTo Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..FindIndex Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..FindLastIndex Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..IndexOf Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..LastIndexOf Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..Reverse Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisAreaCollection..::..Sort Method
AxisAreaCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class
AxisAreaCollection Members


AxisAreaCollection Properties

[image] [image]

.NET Framework Class Library
AxisAreaCollection Properties
AxisAreaCollection Class See Also Send Feedback

The AxisAreaCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisArea >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisArea >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisArea >)>)>.)

See Also

AxisAreaCollection Class


AxisDataType Enumeration

[image]

.NET Framework Class Library
AxisDataType Enumeration
See Also Send Feedback

좌표의 데이터 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AxisDataType
C#
public enum AxisDataType
Visual C++
public enum class AxisDataType
JavaScript
Hippo.AxisDataType = function();
Hippo.AxisDataType.createEnum('Hippo.AxisDataType', false);

Members

Member name | Description
Number |
DateTime |
String |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


AxisDirection Enumeration

[image]

.NET Framework Class Library
AxisDirection Enumeration
See Also Send Feedback

축의 방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AxisDirection
C#
public enum AxisDirection
Visual C++
public enum class AxisDirection
JavaScript
Hippo.AxisDirection = function();
Hippo.AxisDirection.createEnum('Hippo.AxisDirection', false);

Members

Member name | Description
Left |
Right |
Top |
Bottom |
None |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


AxisDisplayItemType Enumeration

[image]

.NET Framework Class Library
AxisDisplayItemType Enumeration
See Also Send Feedback

좌표 차트 수치표시시 표시되는 내용

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AxisDisplayItemType
C#
public enum AxisDisplayItemType
Visual C++
public enum class AxisDisplayItemType
JavaScript
Hippo.AxisDisplayItemType = function();
Hippo.AxisDisplayItemType.createEnum('Hippo.AxisDisplayItemType', false);

Members

Member name | Description
Figure |
Name |
Figure_Name |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


AxisFactors Class

[image]

.NET Framework Class Library
AxisFactors Class
Members See Also Send Feedback

좌표가 가져야할 요소들을 정의하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisFactors
C#
[SerializableAttribute]
public class AxisFactors
Visual C++
[SerializableAttribute]
public ref class AxisFactors
JavaScript
Hippo.AxisFactors = function();

Type.createClass(
    'Hippo.AxisFactors');

Remarks

좌표 차트(라인, 컬럼, 스플라인 등) 의 중요 속성을 관리하는 클래스입니다. x축, y축 설정과 축 방향 등을 정의할 수 있습니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..AxisFactors

See Also

AxisFactors Members


AxisFactors Members

[image] [image]

.NET Framework Class Library
AxisFactors Members
AxisFactors Class Constructors Methods Properties See Also Send Feedback

The AxisFactors type exposes the following members.

Constructors

 | Name | Description
Public method | AxisFactors | AxisFactors 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AxisItems | 축 리스트을 설정하고 가져온다.
Public property | BackColor | 좌표 영역의 배경색을 설정하고 가져온다.
Public property | CoordinateRectangle | 실질적인 좌표 그래프가 그려지는 렉텡글을 설정하고 가져옵니다.
Public property | DisplayItemType | 수치표시시 표시되는 내용을 설정하고 가져온다.(수치, 이름, 수치+이름)
Public property | Orientation | 축의 방향을 설정하고 가져온다. (본 속성은 4.3 버전 이후로 사용되지 않습니다. Direction 객체로 대체되었습니다)
Public property | ThreeDstepDepth | 입체일 경우 한 아이템당 넓이을 설정하고 가져옵니다.
Public property | X | x축 양의 끝 포인트을 설정하고 가져온다.
Public property | XAxis | x축 을 설정하고 가져온다.
Public property | XMinus | x축 음의 끝 포인트을 설정하고 가져온다.
Public property | Y | y축 양의 끝 포인트을 설정하고 가져온다.
Public property | YAxis | y축 을 설정하고 가져온다.
Public property | YMinus | y축 음의 끝 포인트을 설정하고 가져온다.
Public property | Zero | 제로 포인트을 설정하고 가져온다.

See Also

AxisFactors Class


AxisFactors Constructor

[image]

.NET Framework Class Library
AxisFactors Constructor
AxisFactors Class See Also Send Feedback

AxisFactors 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisFactors()
Visual C++
public:
AxisFactors()
JavaScript
Hippo.AxisFactors = function();

See Also

AxisFactors Class


AxisFactors Methods

[image] [image]

.NET Framework Class Library
AxisFactors Methods
AxisFactors Class See Also Send Feedback

The AxisFactors type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AxisFactors Class


AxisFactors Properties

[image] [image]

.NET Framework Class Library
AxisFactors Properties
AxisFactors Class See Also Send Feedback

The AxisFactors type exposes the following members.

Properties

 | Name | Description
Public property | AxisItems | 축 리스트을 설정하고 가져온다.
Public property | BackColor | 좌표 영역의 배경색을 설정하고 가져온다.
Public property | CoordinateRectangle | 실질적인 좌표 그래프가 그려지는 렉텡글을 설정하고 가져옵니다.
Public property | DisplayItemType | 수치표시시 표시되는 내용을 설정하고 가져온다.(수치, 이름, 수치+이름)
Public property | Orientation | 축의 방향을 설정하고 가져온다. (본 속성은 4.3 버전 이후로 사용되지 않습니다. Direction 객체로 대체되었습니다)
Public property | ThreeDstepDepth | 입체일 경우 한 아이템당 넓이을 설정하고 가져옵니다.
Public property | X | x축 양의 끝 포인트을 설정하고 가져온다.
Public property | XAxis | x축 을 설정하고 가져온다.
Public property | XMinus | x축 음의 끝 포인트을 설정하고 가져온다.
Public property | Y | y축 양의 끝 포인트을 설정하고 가져온다.
Public property | YAxis | y축 을 설정하고 가져온다.
Public property | YMinus | y축 음의 끝 포인트을 설정하고 가져온다.
Public property | Zero | 제로 포인트을 설정하고 가져온다.

See Also

AxisFactors Class


AxisItems Property

[image]

.NET Framework Class Library
AxisFactors..::..AxisItems Property
AxisFactors Class See Also Send Feedback

축 리스트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisItems As AxisList
    Get
    Set
C#
public AxisList AxisItems { get; set; }
Visual C++
public:
property AxisList^ AxisItems {
    AxisList^ get ();
    void set (AxisList^ value);
}
JavaScript
function get_axisItems();
function set_axisItems(value);

See Also

AxisFactors Class


BackColor Property

[image]

.NET Framework Class Library
AxisFactors..::..BackColor Property
AxisFactors Class See Also Send Feedback

좌표 영역의 배경색을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

AxisFactors Class


CoordinateRectangle Property

[image]

.NET Framework Class Library
AxisFactors..::..CoordinateRectangle Property
AxisFactors Class See Also Send Feedback

실질적인 좌표 그래프가 그려지는 렉텡글을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property CoordinateRectangle As RectangleF
    Get
    Set
C#
public RectangleF CoordinateRectangle { get; set; }
Visual C++
public:
property RectangleF CoordinateRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_coordinateRectangle();
function set_coordinateRectangle(value);

See Also

AxisFactors Class


DisplayItemType Property

[image]

.NET Framework Class Library
AxisFactors..::..DisplayItemType Property
AxisFactors Class See Also Send Feedback

수치표시시 표시되는 내용을 설정하고 가져온다.(수치, 이름, 수치+이름)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DisplayItemType As AxisDisplayItemType
    Get
    Set
C#
public AxisDisplayItemType DisplayItemType { get; set; }
Visual C++
public:
property AxisDisplayItemType DisplayItemType {
    AxisDisplayItemType get ();
    void set (AxisDisplayItemType value);
}
JavaScript
function get_displayItemType();
function set_displayItemType(value);

See Also

AxisFactors Class


Orientation Property

[image]

.NET Framework Class Library
AxisFactors..::..Orientation Property
AxisFactors Class See Also Send Feedback

축의 방향을 설정하고 가져온다. (본 속성은 4.3 버전 이후로 사용되지 않습니다. Direction 객체로 대체되었습니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Orientation As AxisOrientation
    Get
    Set
C#
public AxisOrientation Orientation { get; set; }
Visual C++
public:
property AxisOrientation Orientation {
    AxisOrientation get ();
    void set (AxisOrientation value);
}
JavaScript
function get_orientation();
function set_orientation(value);

See Also

AxisFactors Class


ThreeDstepDepth Property

[image]

.NET Framework Class Library
AxisFactors..::..ThreeDstepDepth Property
AxisFactors Class See Also Send Feedback

입체일 경우 한 아이템당 넓이을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ThreeDstepDepth As Single
    Get
    Set
C#
public float ThreeDstepDepth { get; set; }
Visual C++
public:
property float ThreeDstepDepth {
    float get ();
    void set (float value);
}
JavaScript
function get_threeDstepDepth();
function set_threeDstepDepth(value);

See Also

AxisFactors Class


X Property

[image]

.NET Framework Class Library
AxisFactors..::..X Property
AxisFactors Class See Also Send Feedback

x축 양의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property X As PointF
    Get
    Set
C#
public PointF X { get; set; }
Visual C++
public:
property PointF X {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_x();
function set_x(value);

See Also

AxisFactors Class


XAxis Property

[image]

.NET Framework Class Library
AxisFactors..::..XAxis Property
AxisFactors Class See Also Send Feedback

x축 을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property XAxis As Axis
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Axis XAxis { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Axis^ XAxis {
    Axis^ get ();
    void set (Axis^ value);
}
JavaScript
function get_xAxis();
function set_xAxis(value);

See Also

AxisFactors Class


XMinus Property

[image]

.NET Framework Class Library
AxisFactors..::..XMinus Property
AxisFactors Class See Also Send Feedback

x축 음의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XMinus As PointF
    Get
    Set
C#
public PointF XMinus { get; set; }
Visual C++
public:
property PointF XMinus {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_xMinus();
function set_xMinus(value);

See Also

AxisFactors Class


Y Property

[image]

.NET Framework Class Library
AxisFactors..::..Y Property
AxisFactors Class See Also Send Feedback

y축 양의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Y As PointF
    Get
    Set
C#
public PointF Y { get; set; }
Visual C++
public:
property PointF Y {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_y();
function set_y(value);

See Also

AxisFactors Class


YAxis Property

[image]

.NET Framework Class Library
AxisFactors..::..YAxis Property
AxisFactors Class See Also Send Feedback

y축 을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property YAxis As Axis
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Axis YAxis { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Axis^ YAxis {
    Axis^ get ();
    void set (Axis^ value);
}
JavaScript
function get_yAxis();
function set_yAxis(value);

See Also

AxisFactors Class


YMinus Property

[image]

.NET Framework Class Library
AxisFactors..::..YMinus Property
AxisFactors Class See Also Send Feedback

y축 음의 끝 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YMinus As PointF
    Get
    Set
C#
public PointF YMinus { get; set; }
Visual C++
public:
property PointF YMinus {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_yMinus();
function set_yMinus(value);

See Also

AxisFactors Class


Zero Property

[image]

.NET Framework Class Library
AxisFactors..::..Zero Property
AxisFactors Class Example See Also Send Feedback

제로 포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Zero As PointF
    Get
    Set
C#
public PointF Zero { get; set; }
Visual C++
public:
property PointF Zero {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_zero();
function set_zero(value);

Remarks

제로 포인트는 차트의 (0, 0)의 위치를 표시합니다. 이 값을 활용해 차트 내의 세부 객체들로 엑세스할 수 있습니다.

Examples

Copy image Copy Code
                    double zeroY = this.hHippoChart1.SeriesListDictionary[0].AxisFactor.Zero.Y;

                    float cY = (float)(zeroY - (e.Y));

See Also

AxisFactors Class


AxisList Class

[image]

.NET Framework Class Library
AxisList Class
Members See Also Send Feedback

축(Axis) 클래스의 컬렉션을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisList _
    Inherits HippoCollectionBase(Of Axis)
C#
[SerializableAttribute]
public class AxisList : HippoCollectionBase<Axis>
Visual C++
[SerializableAttribute]
public ref class AxisList : public HippoCollectionBase<Axis^>
JavaScript
Hippo.AxisList = function();

Type.createClass(
    'Hippo.AxisList',
    Hippo.HippoCollectionBase`1);

Remarks

히포차트에서 지원하는 추가축(멀티축) 들을 관리하는 클래스입니다. 히포차트에는 기본적으로 내장된 Y축과 X축이 있으며 Y축에 n개의 축을 추가하여 사용할 수 있습니다.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Axis >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Axis >)>)>
Hippo..::..AxisList

See Also

AxisList Members


AxisList Members

[image] [image]

.NET Framework Class Library
AxisList Members
AxisList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisList type exposes the following members.

Constructors

 | Name | Description
Public method | AxisList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Axis >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Axis >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Axis >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Axis >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Axis >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class


AxisList Constructor

[image]

.NET Framework Class Library
AxisList Constructor
AxisList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisList()
Visual C++
public:
AxisList()
JavaScript
Hippo.AxisList = function();

See Also

AxisList Class


AxisList Methods

[image] [image]

.NET Framework Class Library
AxisList Methods
AxisList Class See Also Send Feedback

The AxisList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Axis >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Axis >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisList..::..BinarySearch Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisList..::..CopyTo Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisList..::..FindIndex Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisList..::..FindLastIndex Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisList..::..IndexOf Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisList..::..LastIndexOf Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisList..::..Reverse Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisList..::..Sort Method
AxisList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class
AxisList Members


AxisList Properties

[image] [image]

.NET Framework Class Library
AxisList Properties
AxisList Class See Also Send Feedback

The AxisList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Axis >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Axis >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Axis >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Axis >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Axis >)>)>.)

See Also

AxisList Class


AxisMarker Class

[image]

.NET Framework Class Library
AxisMarker Class
Members Example See Also Send Feedback

축 마커 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisMarker _
    Implements ILegendEntry
C#
[SerializableAttribute]
public class AxisMarker : ILegendEntry
Visual C++
[SerializableAttribute]
public ref class AxisMarker : ILegendEntry
JavaScript
Hippo.AxisMarker = function();

Type.createClass(
    'Hippo.AxisMarker',
    null,
    Hippo.ILegendEntry);

Remarks

축에 해당 값에 대한 라인 표시를 할 수 있고 그에 대한 간단한 코멘트 등록이 가능합니다. x, y축 모두 지원합니다. (예, 상한선, 하한선)

Examples

Copy image Copy Code
                    SeriesList slist = new SeriesList();
                    slist.ChartType = ChartType.Column;

                    AxisMarker mk = new AxisMarker("하한선", 34);
                    mk.Line.LineColor = Color.Blue;
                    mk.Label.ForeColor = Color.Blue;
                    mk.TextFormat.Alignment = StringAlignment.Near;

                    AxisMarker mk2 = new AxisMarker("상한선", 178);
                    mk2.TextFormat.Alignment = StringAlignment.Near;

                    slist.AxisFactor.Markers.Add(mk);
                    slist.AxisFactor.Markers.Add(mk2);

                    Series sr = new Series();
                    sr.SeriesColor = Color.YellowGreen;

                    SeriesItem item1 = new SeriesItem(23);
                    item1.Name = "item1";
                    SeriesItem item2 = new SeriesItem(77);
                    item2.Name = "item2";
                    SeriesItem item3 = new SeriesItem(120);
                    item3.Name = "item3";
                    sr.items.Add(item1);
                    sr.items.Add(item2);
                    sr.items.Add(item3);

                    slist.SeriesCollection.Add(sr);
                    this.hHippoChart1.DrawChart(slist);

Inheritance Hierarchy

System..::..Object
Hippo..::..AxisMarker

See Also

AxisMarker Members


AxisMarker Members

[image] [image]

.NET Framework Class Library
AxisMarker Members
AxisMarker Class Constructors Methods Properties See Also Send Feedback

The AxisMarker type exposes the following members.

Constructors

 | Name | Description
Public method | AxisMarker()()()() | AxisMarker 인스턴스를 생성합니다.(기본 생성자)
Public method | AxisMarker(String, DateTime) | AxisMarker 인스턴스를 생성합니다.
Public method | AxisMarker(String, PointF) | AxisMarker 인스턴스를 생성합니다.
Public method | AxisMarker(String, Single) | AxisMarker 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BringToFront | 마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.
Public property | DateTimeValue | 마커 표시 날짜 형식 값을 가져오고 설정합니다. (간트차트 등에 시용됩니다)
Public property | Label | 좌표마커 라벨를 가져오고 설정합니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 좌표마커 라인를 가져오고 설정합니다.
Public property | MarkerPoint | 마커의 실제 포인트 값을 설정하고 가져옵니다.
Public property | Name | 마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | TextFormat | 마커 문자열포맷를 가져오고 설정합니다.
Public property | Value | 마커 표시 값를 가져오고 설정합니다.
Public property | Visible | 객체의 보이기/안보이기 를 설정하고 가져옵니다.

See Also

AxisMarker Class


AxisMarker Constructor

[image] [image]

.NET Framework Class Library
AxisMarker Constructor
AxisMarker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AxisMarker()()()() | AxisMarker 인스턴스를 생성합니다.(기본 생성자)
Public method | AxisMarker(String, DateTime) | AxisMarker 인스턴스를 생성합니다.
Public method | AxisMarker(String, PointF) | AxisMarker 인스턴스를 생성합니다.
Public method | AxisMarker(String, Single) | AxisMarker 인스턴스를 생성합니다.

See Also

AxisMarker Class
AxisMarker Members


AxisMarker Constructor

[image]

.NET Framework Class Library
AxisMarker Constructor
AxisMarker Class See Also Send Feedback

AxisMarker 인스턴스를 생성합니다.(기본 생성자)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisMarker()
Visual C++
public:
AxisMarker()
JavaScript
Hippo.AxisMarker = function();

See Also

AxisMarker Class
AxisMarker Overload


AxisMarker Constructor (String, DateTime)

[image]

.NET Framework Class Library
AxisMarker Constructor (String, DateTime)
AxisMarker Class See Also Send Feedback

AxisMarker 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    LabelText As String, _
    value As DateTime _
)
C#
public AxisMarker(
    string LabelText,
    DateTime value
)
Visual C++
public:
AxisMarker(
    String^ LabelText,
    DateTime value
)
JavaScript
Hippo.AxisMarker = function(LabelText, value);

Parameters

LabelText
Type: System..::..String
마커 라벨 텍스트
value
Type: System..::..DateTime
마커 수치값

See Also

AxisMarker Class
AxisMarker Overload


AxisMarker Constructor (String, PointF)

[image]

.NET Framework Class Library
AxisMarker Constructor (String, PointF)
AxisMarker Class See Also Send Feedback

AxisMarker 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    LabelText As String, _
    points As PointF _
)
C#
public AxisMarker(
    string LabelText,
    PointF points
)
Visual C++
public:
AxisMarker(
    String^ LabelText,
    PointF points
)
JavaScript
Hippo.AxisMarker = function(LabelText, points);

Parameters

LabelText
Type: System..::..String
마커 라벨 텍스트
points
Type: System.Drawing..::..PointF
마커 포인트 위치값

See Also

AxisMarker Class
AxisMarker Overload


AxisMarker Constructor (String, Single)

[image]

.NET Framework Class Library
AxisMarker Constructor (String, Single)
AxisMarker Class See Also Send Feedback

AxisMarker 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    LabelText As String, _
    value As Single _
)
C#
public AxisMarker(
    string LabelText,
    float value
)
Visual C++
public:
AxisMarker(
    String^ LabelText,
    float value
)
JavaScript
Hippo.AxisMarker = function(LabelText, value);

Parameters

LabelText
Type: System..::..String
마커 라벨 텍스트
value
Type: System..::..Single
마커 수치값

See Also

AxisMarker Class
AxisMarker Overload


AxisMarker Methods

[image] [image]

.NET Framework Class Library
AxisMarker Methods
AxisMarker Class See Also Send Feedback

The AxisMarker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AxisMarker Class


AxisMarker Properties

[image] [image]

.NET Framework Class Library
AxisMarker Properties
AxisMarker Class See Also Send Feedback

The AxisMarker type exposes the following members.

Properties

 | Name | Description
Public property | BringToFront | 마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.
Public property | DateTimeValue | 마커 표시 날짜 형식 값을 가져오고 설정합니다. (간트차트 등에 시용됩니다)
Public property | Label | 좌표마커 라벨를 가져오고 설정합니다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 좌표마커 라인를 가져오고 설정합니다.
Public property | MarkerPoint | 마커의 실제 포인트 값을 설정하고 가져옵니다.
Public property | Name | 마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)
Public property | TextFormat | 마커 문자열포맷를 가져오고 설정합니다.
Public property | Value | 마커 표시 값를 가져오고 설정합니다.
Public property | Visible | 객체의 보이기/안보이기 를 설정하고 가져옵니다.

See Also

AxisMarker Class


BringToFront Property

[image]

.NET Framework Class Library
AxisMarker..::..BringToFront Property
AxisMarker Class See Also Send Feedback

마커를 맨 앞으로 보낼 것인가 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BringToFront As Boolean
    Get
    Set
C#
public bool BringToFront { get; set; }
Visual C++
public:
property bool BringToFront {
    bool get ();
    void set (bool value);
}
JavaScript
function get_bringToFront();
function set_bringToFront(value);

See Also

AxisMarker Class


DateTimeValue Property

[image]

.NET Framework Class Library
AxisMarker..::..DateTimeValue Property
AxisMarker Class See Also Send Feedback

마커 표시 날짜 형식 값을 가져오고 설정합니다. (간트차트 등에 시용됩니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateTimeValue As DateTime
    Get
    Set
C#
public DateTime DateTimeValue { get; set; }
Visual C++
public:
property DateTime DateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_dateTimeValue();
function set_dateTimeValue(value);

See Also

AxisMarker Class


Label Property

[image]

.NET Framework Class Library
AxisMarker..::..Label Property
AxisMarker Class See Also Send Feedback

좌표마커 라벨를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

AxisMarker Class


LegendVisible Property

[image]

.NET Framework Class Library
AxisMarker..::..LegendVisible Property
AxisMarker Class See Also Send Feedback

범례에 보여줄 것인지 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendVisible As Boolean
    Get
    Set
C#
public bool LegendVisible { get; set; }
Visual C++
public:
virtual property bool LegendVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_legendVisible();
function set_legendVisible(value);

Implements

ILegendEntry..::..LegendVisible

See Also

AxisMarker Class


Line Property

[image]

.NET Framework Class Library
AxisMarker..::..Line Property
AxisMarker Class See Also Send Feedback

좌표마커 라인를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Line As Line
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line Line { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

AxisMarker Class


MarkerPoint Property

[image]

.NET Framework Class Library
AxisMarker..::..MarkerPoint Property
AxisMarker Class See Also Send Feedback

마커의 실제 포인트 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MarkerPoint As PointF
    Get
    Set
C#
public PointF MarkerPoint { get; set; }
Visual C++
public:
property PointF MarkerPoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_markerPoint();
function set_markerPoint(value);

See Also

AxisMarker Class


Name Property

[image]

.NET Framework Class Library
AxisMarker..::..Name Property
AxisMarker Class See Also Send Feedback

마커의 이름을 설정하고 가져옵니다. (범례에 표시됩니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

AxisMarker Class


TextFormat Property

[image]

.NET Framework Class Library
AxisMarker..::..TextFormat Property
AxisMarker Class See Also Send Feedback

마커 문자열포맷를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TextFormat As StringFormat
    Get
    Set
C#
public StringFormat TextFormat { get; set; }
Visual C++
public:
property StringFormat^ TextFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
JavaScript
function get_textFormat();
function set_textFormat(value);

See Also

AxisMarker Class


Value Property

[image]

.NET Framework Class Library
AxisMarker..::..Value Property
AxisMarker Class See Also Send Feedback

마커 표시 값를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As Single
    Get
    Set
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

See Also

AxisMarker Class


Visible Property

[image]

.NET Framework Class Library
AxisMarker..::..Visible Property
AxisMarker Class See Also Send Feedback

객체의 보이기/안보이기 를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

AxisMarker Class


AxisMarkerCollection Class

[image]

.NET Framework Class Library
AxisMarkerCollection Class
Members See Also Send Feedback

차트 마커 컬렉션을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisMarkerCollection _
    Inherits HippoCollectionBase(Of AxisMarker)
C#
[SerializableAttribute]
public class AxisMarkerCollection : HippoCollectionBase<AxisMarker>
Visual C++
[SerializableAttribute]
public ref class AxisMarkerCollection : public HippoCollectionBase<AxisMarker^>
JavaScript
Hippo.AxisMarkerCollection = function();

Type.createClass(
    'Hippo.AxisMarkerCollection',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' AxisMarker >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' AxisMarker >)>)>
Hippo..::..AxisMarkerCollection

See Also

AxisMarkerCollection Members


AxisMarkerCollection Members

[image] [image]

.NET Framework Class Library
AxisMarkerCollection Members
AxisMarkerCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisMarkerCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AxisMarkerCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class


AxisMarkerCollection Constructor

[image]

.NET Framework Class Library
AxisMarkerCollection Constructor
AxisMarkerCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisMarkerCollection()
Visual C++
public:
AxisMarkerCollection()
JavaScript
Hippo.AxisMarkerCollection = function();

See Also

AxisMarkerCollection Class


AxisMarkerCollection Methods

[image] [image]

.NET Framework Class Library
AxisMarkerCollection Methods
AxisMarkerCollection Class See Also Send Feedback

The AxisMarkerCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..BinarySearch Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..CopyTo Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..FindIndex Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..FindLastIndex Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..IndexOf Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..LastIndexOf Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..Reverse Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisMarkerCollection..::..Sort Method
AxisMarkerCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class
AxisMarkerCollection Members


AxisMarkerCollection Properties

[image] [image]

.NET Framework Class Library
AxisMarkerCollection Properties
AxisMarkerCollection Class See Also Send Feedback

The AxisMarkerCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisMarker >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisMarker >)>)>.)

See Also

AxisMarkerCollection Class


AxisOrientation Enumeration

[image]

.NET Framework Class Library
AxisOrientation Enumeration
See Also Send Feedback

축의 8방향 (4.3 버전 이후로 사용되지 않음)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AxisOrientation
C#
public enum AxisOrientation
Visual C++
public enum class AxisOrientation
JavaScript
Hippo.AxisOrientation = function();
Hippo.AxisOrientation.createEnum('Hippo.AxisOrientation', false);

Members

Member name | Description
None |
BottomLeft |
TopLeft |
BottomRight |
TopRight |
LeftTop |
LeftBottom |
RightTop |
RightBottom |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


AxisScaleRange Class

[image]

.NET Framework Class Library
AxisScaleRange Class
Members Example See Also Send Feedback

축 Scale Range 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisScaleRange
C#
[SerializableAttribute]
public class AxisScaleRange
Visual C++
[SerializableAttribute]
public ref class AxisScaleRange
JavaScript
Hippo.AxisScaleRange = function();

Type.createClass(
    'Hippo.AxisScaleRange');

Remarks

값의 격차가 심한 데이터로 차트를 그릴 경우 축의 범위를 조절하므로써 보다 원활하게 차트를 그릴 수 있습니다.

Examples

Copy image Copy Code
                  sList.AxisFactor.AxisScaleRanges.Add(new AxisScaleRange(200, 950));
                  sList.AxisFactor.AxisScaleRanges.Add(new AxisScaleRange(1100, 11950));

Inheritance Hierarchy

System..::..Object
Hippo..::..AxisScaleRange

See Also

AxisScaleRange Members


AxisScaleRange Members

[image] [image]

.NET Framework Class Library
AxisScaleRange Members
AxisScaleRange Class Constructors Methods Properties See Also Send Feedback

The AxisScaleRange type exposes the following members.

Constructors

 | Name | Description
Public method | AxisScaleRange | AxisScaleRange 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | RangeEnd | 스케일 범위 끝 지점을 가져옵니다.
Public property | RangeStart | 스케일 범위 시작 지점을 가져옵니다.

See Also

AxisScaleRange Class


AxisScaleRange Constructor

[image]

.NET Framework Class Library
AxisScaleRange Constructor
AxisScaleRange Class See Also Send Feedback

AxisScaleRange 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    rangestart As Double, _
    rangeend As Double _
)
C#
public AxisScaleRange(
    double rangestart,
    double rangeend
)
Visual C++
public:
AxisScaleRange(
    double rangestart,
    double rangeend
)
JavaScript
Hippo.AxisScaleRange = function(rangestart, rangeend);

Parameters

rangestart
Type: System..::..Double
rangeend
Type: System..::..Double

See Also

AxisScaleRange Class


AxisScaleRange Methods

[image] [image]

.NET Framework Class Library
AxisScaleRange Methods
AxisScaleRange Class See Also Send Feedback

The AxisScaleRange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AxisScaleRange Class


AxisScaleRange Properties

[image] [image]

.NET Framework Class Library
AxisScaleRange Properties
AxisScaleRange Class See Also Send Feedback

The AxisScaleRange type exposes the following members.

Properties

 | Name | Description
Public property | RangeEnd | 스케일 범위 끝 지점을 가져옵니다.
Public property | RangeStart | 스케일 범위 시작 지점을 가져옵니다.

See Also

AxisScaleRange Class


RangeEnd Property

[image]

.NET Framework Class Library
AxisScaleRange..::..RangeEnd Property
AxisScaleRange Class See Also Send Feedback

스케일 범위 끝 지점을 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property RangeEnd As Double
    Get
C#
public double RangeEnd { get; }
Visual C++
public:
property double RangeEnd {
    double get ();
}
JavaScript
function get_rangeEnd();

See Also

AxisScaleRange Class


RangeStart Property

[image]

.NET Framework Class Library
AxisScaleRange..::..RangeStart Property
AxisScaleRange Class See Also Send Feedback

스케일 범위 시작 지점을 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property RangeStart As Double
    Get
C#
public double RangeStart { get; }
Visual C++
public:
property double RangeStart {
    double get ();
}
JavaScript
function get_rangeStart();

See Also

AxisScaleRange Class


AxisScaleRangeCollection Class

[image]

.NET Framework Class Library
AxisScaleRangeCollection Class
Members See Also Send Feedback

축 Scale Range 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisScaleRangeCollection _
    Inherits HippoCollectionBase(Of AxisScaleRange)
C#
[SerializableAttribute]
public class AxisScaleRangeCollection : HippoCollectionBase<AxisScaleRange>
Visual C++
[SerializableAttribute]
public ref class AxisScaleRangeCollection : public HippoCollectionBase<AxisScaleRange^>
JavaScript
Hippo.AxisScaleRangeCollection = function();

Type.createClass(
    'Hippo.AxisScaleRangeCollection',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' AxisScaleRange >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' AxisScaleRange >)>)>
Hippo..::..AxisScaleRangeCollection

See Also

AxisScaleRangeCollection Members


AxisScaleRangeCollection Members

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection Members
AxisScaleRangeCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisScaleRangeCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AxisScaleRangeCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class


AxisScaleRangeCollection Constructor

[image]

.NET Framework Class Library
AxisScaleRangeCollection Constructor
AxisScaleRangeCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisScaleRangeCollection()
Visual C++
public:
AxisScaleRangeCollection()
JavaScript
Hippo.AxisScaleRangeCollection = function();

See Also

AxisScaleRangeCollection Class


AxisScaleRangeCollection Methods

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection Methods
AxisScaleRangeCollection Class See Also Send Feedback

The AxisScaleRangeCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..BinarySearch Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..CopyTo Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..FindIndex Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..FindLastIndex Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..IndexOf Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..LastIndexOf Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..Reverse Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection..::..Sort Method
AxisScaleRangeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class
AxisScaleRangeCollection Members


AxisScaleRangeCollection Properties

[image] [image]

.NET Framework Class Library
AxisScaleRangeCollection Properties
AxisScaleRangeCollection Class See Also Send Feedback

The AxisScaleRangeCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisScaleRange >)>)>.)

See Also

AxisScaleRangeCollection Class


AxisTick Class

[image]

.NET Framework Class Library
AxisTick Class
Members Example See Also Send Feedback

축의 눈금을 생성하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisTick
C#
[SerializableAttribute]
public class AxisTick
Visual C++
[SerializableAttribute]
public ref class AxisTick
JavaScript
Hippo.AxisTick = function();

Type.createClass(
    'Hippo.AxisTick');

Remarks

축에 표시된 눈금의 디자인 및 글자를 변경할 수 있고 해당 그리드 라인을 그릴 수 있는 클래스입니다. x, y축 모두 지원합니다. (예를 들어, 100, 200, 300 ... 이라는 단위 눈금들이 표시되어 있을 때 200이라는 눈금을 "위험한 단계" 또는 200이라고 쓰되 글자 폰트나 폰트사이즈 등을 조절하여 강조효과를 줄 수 있습니다.)

Examples

Copy image Copy Code
                    SeriesList slist = new SeriesList();
                    slist.ChartType = ChartType.Column;

                    AxisTick tick4 = new AxisTick("$1,000,000");
                    tick4.Label.Text = "100만$";
                    tick4.Label.Font = new Font("HippoFont", 11, FontStyle.Bold);
                    tick4.Label.ForeColor = Color.Orange;

                    slist.AxisFactor.YAxis.Ticks.Add(tick4);

                    Series sr = new Series();
                    sr.SeriesColor = Color.YellowGreen;

                    SeriesItem item1 = new SeriesItem(470000);
                    item1.Name = "item1";
                    SeriesItem item2 = new SeriesItem(2300000);
                    item2.Name = "item2";
                    SeriesItem item3 = new SeriesItem(1120000);
                    item3.Name = "item3";
                    sr.items.Add(item1);
                    sr.items.Add(item2);
                    sr.items.Add(item3);

                    slist.SeriesCollection.Add(sr);
                    this.hHippoChart1.DrawChart(slist);

Inheritance Hierarchy

System..::..Object
Hippo..::..AxisTick

See Also

AxisTick Members


AxisTick Members

[image] [image]

.NET Framework Class Library
AxisTick Members
AxisTick Class Constructors Methods Properties See Also Send Feedback

The AxisTick type exposes the following members.

Constructors

 | Name | Description
Public method | AxisTick()()()() | Tick 기본 인스턴스를 생성합니다.
Public method | AxisTick(DateTime) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(Double) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(PointF) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(DateTime, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(Double, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(PointF, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(String, String) | Tick 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | Tick의 배경색을 설정하고 가져옵니다.
Public property | DateTimeValue | 눈금 실제 날짜형 값을 설정하고 가져옵니다.
Public property | GridLine | Tick 라인을 설정하고 가져옵니다.
Public property | IconPath | Tick 이미지 경로을 설정하고 가져옵니다.
Public property | IsShowGridLine | 그리드 라인을 표시할 것인지 여부을 설정하고 가져옵니다.
Public property | ItemName | Tick 값을 설정하고 가져옵니다.
Public property | Label | Tick 라벨을 설정하고 가져옵니다.
Public property | TickPoint | Tick의 실제 PointF 값을 설정하고 가져옵니다.
Public property | Value | 눈금 실제값을 설정하고 가져옵니다.
Public property | Visible | Tick 객체의 보이기/안보이기 를 설정하고 가져옵니다.

See Also

AxisTick Class


AxisTick Constructor

[image] [image]

.NET Framework Class Library
AxisTick Constructor
AxisTick Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AxisTick()()()() | Tick 기본 인스턴스를 생성합니다.
Public method | AxisTick(DateTime) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(Double) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(PointF) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(DateTime, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(Double, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(PointF, String) | Tick 인스턴스를 생성합니다.
Public method | AxisTick(String, String) | Tick 인스턴스를 생성합니다.

See Also

AxisTick Class
AxisTick Members


AxisTick Constructor

[image]

.NET Framework Class Library
AxisTick Constructor
AxisTick Class See Also Send Feedback

Tick 기본 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisTick()
Visual C++
public:
AxisTick()
JavaScript
Hippo.AxisTick = function();

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (DateTime)

[image]

.NET Framework Class Library
AxisTick Constructor (DateTime)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    datetimeValue As DateTime _
)
C#
public AxisTick(
    DateTime datetimeValue
)
Visual C++
public:
AxisTick(
    DateTime datetimeValue
)
JavaScript
Hippo.AxisTick = function(datetimeValue);

Parameters

datetimeValue
Type: System..::..DateTime
Tick 날짜 값

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (Double)

[image]

.NET Framework Class Library
AxisTick Constructor (Double)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    value As Double _
)
C#
public AxisTick(
    double value
)
Visual C++
public:
AxisTick(
    double value
)
JavaScript
Hippo.AxisTick = function(value);

Parameters

value
Type: System..::..Double
Tick 값

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (PointF)

[image]

.NET Framework Class Library
AxisTick Constructor (PointF)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    points As PointF _
)
C#
public AxisTick(
    PointF points
)
Visual C++
public:
AxisTick(
    PointF points
)
JavaScript
Hippo.AxisTick = function(points);

Parameters

points
Type: System.Drawing..::..PointF
눈금의 실제 포인트 값

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (String)

[image]

.NET Framework Class Library
AxisTick Constructor (String)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    Item As String _
)
C#
public AxisTick(
    string Item
)
Visual C++
public:
AxisTick(
    String^ Item
)
JavaScript
Hippo.AxisTick = function(Item);

Parameters

Item
Type: System..::..String
아이템 이름

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (DateTime, String)

[image]

.NET Framework Class Library
AxisTick Constructor (DateTime, String)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    datetimeValue As DateTime, _
    DisplayText As String _
)
C#
public AxisTick(
    DateTime datetimeValue,
    string DisplayText
)
Visual C++
public:
AxisTick(
    DateTime datetimeValue,
    String^ DisplayText
)
JavaScript
Hippo.AxisTick = function(datetimeValue, DisplayText);

Parameters

datetimeValue
Type: System..::..DateTime
Tick 날짜값
DisplayText
Type: System..::..String
표시 글자

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (Double, String)

[image]

.NET Framework Class Library
AxisTick Constructor (Double, String)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    value As Double, _
    DisplayText As String _
)
C#
public AxisTick(
    double value,
    string DisplayText
)
Visual C++
public:
AxisTick(
    double value,
    String^ DisplayText
)
JavaScript
Hippo.AxisTick = function(value, DisplayText);

Parameters

value
Type: System..::..Double
Tick 값
DisplayText
Type: System..::..String
표시 글자

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (PointF, String)

[image]

.NET Framework Class Library
AxisTick Constructor (PointF, String)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    points As PointF, _
    DisplayText As String _
)
C#
public AxisTick(
    PointF points,
    string DisplayText
)
Visual C++
public:
AxisTick(
    PointF points,
    String^ DisplayText
)
JavaScript
Hippo.AxisTick = function(points, DisplayText);

Parameters

points
Type: System.Drawing..::..PointF
눈금의 실제 포인트 값
DisplayText
Type: System..::..String
표시 글자

See Also

AxisTick Class
AxisTick Overload


AxisTick Constructor (String, String)

[image]

.NET Framework Class Library
AxisTick Constructor (String, String)
AxisTick Class See Also Send Feedback

Tick 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    Item As String, _
    DisplayText As String _
)
C#
public AxisTick(
    string Item,
    string DisplayText
)
Visual C++
public:
AxisTick(
    String^ Item,
    String^ DisplayText
)
JavaScript
Hippo.AxisTick = function(Item, DisplayText);

Parameters

Item
Type: System..::..String
아이템 이름
DisplayText
Type: System..::..String
표시 글자

See Also

AxisTick Class
AxisTick Overload


AxisTick Methods

[image] [image]

.NET Framework Class Library
AxisTick Methods
AxisTick Class See Also Send Feedback

The AxisTick type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AxisTick Class


AxisTick Properties

[image] [image]

.NET Framework Class Library
AxisTick Properties
AxisTick Class See Also Send Feedback

The AxisTick type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Tick의 배경색을 설정하고 가져옵니다.
Public property | DateTimeValue | 눈금 실제 날짜형 값을 설정하고 가져옵니다.
Public property | GridLine | Tick 라인을 설정하고 가져옵니다.
Public property | IconPath | Tick 이미지 경로을 설정하고 가져옵니다.
Public property | IsShowGridLine | 그리드 라인을 표시할 것인지 여부을 설정하고 가져옵니다.
Public property | ItemName | Tick 값을 설정하고 가져옵니다.
Public property | Label | Tick 라벨을 설정하고 가져옵니다.
Public property | TickPoint | Tick의 실제 PointF 값을 설정하고 가져옵니다.
Public property | Value | 눈금 실제값을 설정하고 가져옵니다.
Public property | Visible | Tick 객체의 보이기/안보이기 를 설정하고 가져옵니다.

See Also

AxisTick Class


BackColor Property

[image]

.NET Framework Class Library
AxisTick..::..BackColor Property
AxisTick Class See Also Send Feedback

Tick의 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

AxisTick Class


DateTimeValue Property

[image]

.NET Framework Class Library
AxisTick..::..DateTimeValue Property
AxisTick Class See Also Send Feedback

눈금 실제 날짜형 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateTimeValue As DateTime
    Get
    Set
C#
public DateTime DateTimeValue { get; set; }
Visual C++
public:
property DateTime DateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_dateTimeValue();
function set_dateTimeValue(value);

See Also

AxisTick Class


GridLine Property

[image]

.NET Framework Class Library
AxisTick..::..GridLine Property
AxisTick Class See Also Send Feedback

Tick 라인을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property GridLine As Line
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line GridLine { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ GridLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_gridLine();
function set_gridLine(value);

See Also

AxisTick Class


IconPath Property

[image]

.NET Framework Class Library
AxisTick..::..IconPath Property
AxisTick Class See Also Send Feedback

Tick 이미지 경로을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IconPath As String
    Get
    Set
C#
public string IconPath { get; set; }
Visual C++
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iconPath();
function set_iconPath(value);

See Also

AxisTick Class


IsShowGridLine Property

[image]

.NET Framework Class Library
AxisTick..::..IsShowGridLine Property
AxisTick Class See Also Send Feedback

그리드 라인을 표시할 것인지 여부을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowGridLine As Boolean
    Get
    Set
C#
public bool IsShowGridLine { get; set; }
Visual C++
public:
property bool IsShowGridLine {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowGridLine();
function set_isShowGridLine(value);

See Also

AxisTick Class


ItemName Property

[image]

.NET Framework Class Library
AxisTick..::..ItemName Property
AxisTick Class See Also Send Feedback

Tick 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ItemName As String
    Get
    Set
C#
public string ItemName { get; set; }
Visual C++
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_itemName();
function set_itemName(value);

See Also

AxisTick Class


Label Property

[image]

.NET Framework Class Library
AxisTick..::..Label Property
AxisTick Class See Also Send Feedback

Tick 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

AxisTick Class


TickPoint Property

[image]

.NET Framework Class Library
AxisTick..::..TickPoint Property
AxisTick Class See Also Send Feedback

Tick의 실제 PointF 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TickPoint As PointF
    Get
    Set
C#
public PointF TickPoint { get; set; }
Visual C++
public:
property PointF TickPoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_tickPoint();
function set_tickPoint(value);

See Also

AxisTick Class


Value Property

[image]

.NET Framework Class Library
AxisTick..::..Value Property
AxisTick Class See Also Send Feedback

눈금 실제값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As Double
    Get
    Set
C#
public double Value { get; set; }
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}
JavaScript
function get_value();
function set_value(value);

See Also

AxisTick Class


Visible Property

[image]

.NET Framework Class Library
AxisTick..::..Visible Property
AxisTick Class See Also Send Feedback

Tick 객체의 보이기/안보이기 를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

AxisTick Class


AxisTickCollection Class

[image]

.NET Framework Class Library
AxisTickCollection Class
Members See Also Send Feedback

차트 Tick 컬렉션을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisTickCollection _
    Inherits HippoCollectionBase(Of AxisTick)
C#
[SerializableAttribute]
public class AxisTickCollection : HippoCollectionBase<AxisTick>
Visual C++
[SerializableAttribute]
public ref class AxisTickCollection : public HippoCollectionBase<AxisTick^>
JavaScript
Hippo.AxisTickCollection = function();

Type.createClass(
    'Hippo.AxisTickCollection',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' AxisTick >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' AxisTick >)>)>
Hippo..::..AxisTickCollection

See Also

AxisTickCollection Members


AxisTickCollection Members

[image] [image]

.NET Framework Class Library
AxisTickCollection Members
AxisTickCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisTickCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AxisTickCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisTick >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class


AxisTickCollection Constructor

[image]

.NET Framework Class Library
AxisTickCollection Constructor
AxisTickCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisTickCollection()
Visual C++
public:
AxisTickCollection()
JavaScript
Hippo.AxisTickCollection = function();

See Also

AxisTickCollection Class


AxisTickCollection Methods

[image] [image]

.NET Framework Class Library
AxisTickCollection Methods
AxisTickCollection Class See Also Send Feedback

The AxisTickCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' AxisTick >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..BinarySearch Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..CopyTo Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..FindIndex Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..FindLastIndex Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..IndexOf Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..LastIndexOf Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..Reverse Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisTickCollection..::..Sort Method
AxisTickCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class
AxisTickCollection Members


AxisTickCollection Properties

[image] [image]

.NET Framework Class Library
AxisTickCollection Properties
AxisTickCollection Class See Also Send Feedback

The AxisTickCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' AxisTick >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' AxisTick >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' AxisTick >)>)>.)

See Also

AxisTickCollection Class


AxisTickPointList Class

[image]

.NET Framework Class Library
AxisTickPointList Class
Members See Also Send Feedback

축의 각 눈금 포인트를 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class AxisTickPointList _
    Inherits HippoCollectionBase(Of PointF)
C#
[SerializableAttribute]
public class AxisTickPointList : HippoCollectionBase<PointF>
Visual C++
[SerializableAttribute]
public ref class AxisTickPointList : public HippoCollectionBase<PointF>
JavaScript
Hippo.AxisTickPointList = function();

Type.createClass(
    'Hippo.AxisTickPointList',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' PointF >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' PointF >)>)>
Hippo..::..AxisTickPointList

See Also

AxisTickPointList Members


AxisTickPointList Members

[image] [image]

.NET Framework Class Library
AxisTickPointList Members
AxisTickPointList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisTickPointList type exposes the following members.

Constructors

 | Name | Description
Public method | AxisTickPointList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' PointF >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' PointF >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' PointF >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' PointF >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' PointF >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class


AxisTickPointList Constructor

[image]

.NET Framework Class Library
AxisTickPointList Constructor
AxisTickPointList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public AxisTickPointList()
Visual C++
public:
AxisTickPointList()
JavaScript
Hippo.AxisTickPointList = function();

See Also

AxisTickPointList Class


AxisTickPointList Methods

[image] [image]

.NET Framework Class Library
AxisTickPointList Methods
AxisTickPointList Class See Also Send Feedback

The AxisTickPointList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' PointF >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' PointF >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..BinarySearch Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..CopyTo Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..FindIndex Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..FindLastIndex Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..IndexOf Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..LastIndexOf Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


Reverse Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..Reverse Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


Sort Method

[image] [image]

.NET Framework Class Library
AxisTickPointList..::..Sort Method
AxisTickPointList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class
AxisTickPointList Members


AxisTickPointList Properties

[image] [image]

.NET Framework Class Library
AxisTickPointList Properties
AxisTickPointList Class See Also Send Feedback

The AxisTickPointList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' PointF >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' PointF >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' PointF >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' PointF >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' PointF >)>)>.)

See Also

AxisTickPointList Class


AxisType Enumeration

[image]

.NET Framework Class Library
AxisType Enumeration
See Also Send Feedback

축의 종류

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration AxisType
C#
public enum AxisType
Visual C++
public enum class AxisType
JavaScript
Hippo.AxisType = function();
Hippo.AxisType.createEnum('Hippo.AxisType', false);

Members

Member name | Description
Xtype |
Ytype |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Balloon Class

[image]

.NET Framework Class Library
Balloon Class
Members Example See Also Send Feedback

풍선 도움말 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Balloon
C#
[SerializableAttribute]
public class Balloon
Visual C++
[SerializableAttribute]
public ref class Balloon
JavaScript
Hippo.Balloon = function();

Type.createClass(
    'Hippo.Balloon');

Remarks

좌표평면에 특정 시리즈아이템에 소속된 객체로 풍선 모양의 말풍선을 표시합니다. 이 아이템의 visible 속성을 활용하여 마우스무브이벤트로 수치를 보이는 액션을 구현할 수 있습니다. 본 객체는 기본 값이 null 이므로 반드시 인스턴스를 생성한 후 사용해야합니다.

Examples

Copy image Copy Code
                    SeriesItem item = new SeriesItem();
                    item.Name = "item" + x.ToString();

                    item.Balloon = new Balloon();
                    item.Balloon.Label.Text = "수치정보!";

Inheritance Hierarchy

System..::..Object
Hippo..::..Balloon

See Also

Balloon Members


Balloon Members

[image] [image]

.NET Framework Class Library
Balloon Members
Balloon Class Constructors Methods Properties See Also Send Feedback

The Balloon type exposes the following members.

Constructors

 | Name | Description
Public method | Balloon | 풍선 도움말 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 풍선의 배경색을 설정하고 가져옵니다.
Public property | BalloonType | 풍선 도움말 모양을 설정하고 가져옵니다.
Public property | Height | 풍선의 세로길이을 설정하고 가져옵니다.
Public property | HeightType | 풍선 도움말을 표시할 위치를 설정하고 가져옵니다.
Public property | IsShadow | 풍선의 그림자를 표시할것인가 여부를 설정하고 가져옵니다.
Public property | Label | 풍선 라벨을 설정하고 가져옵니다.
Public property | Line | 풍선 라인을 설정하고 가져옵니다.
Public property | TextLocation | 풍선 내부 글자의 정렬을 설정하고 가져옵니다.
Public property | Visible | 풍선을 보이게 할 것인가 여부를 설정하고 가져옵니다.
Public property | Width | 풍선의 가로길이을 설정하고 가져옵니다.
Public property | X | 풍선의 Left위치을 설정하고 가져옵니다.
Public property | Y | 풍선의 top 위치을 설정하고 가져옵니다.

See Also

Balloon Class


Balloon Constructor

[image]

.NET Framework Class Library
Balloon Constructor
Balloon Class See Also Send Feedback

풍선 도움말 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Balloon()
Visual C++
public:
Balloon()
JavaScript
Hippo.Balloon = function();

See Also

Balloon Class


Balloon Methods

[image] [image]

.NET Framework Class Library
Balloon Methods
Balloon Class See Also Send Feedback

The Balloon type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Balloon Class


Balloon Properties

[image] [image]

.NET Framework Class Library
Balloon Properties
Balloon Class See Also Send Feedback

The Balloon type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 풍선의 배경색을 설정하고 가져옵니다.
Public property | BalloonType | 풍선 도움말 모양을 설정하고 가져옵니다.
Public property | Height | 풍선의 세로길이을 설정하고 가져옵니다.
Public property | HeightType | 풍선 도움말을 표시할 위치를 설정하고 가져옵니다.
Public property | IsShadow | 풍선의 그림자를 표시할것인가 여부를 설정하고 가져옵니다.
Public property | Label | 풍선 라벨을 설정하고 가져옵니다.
Public property | Line | 풍선 라인을 설정하고 가져옵니다.
Public property | TextLocation | 풍선 내부 글자의 정렬을 설정하고 가져옵니다.
Public property | Visible | 풍선을 보이게 할 것인가 여부를 설정하고 가져옵니다.
Public property | Width | 풍선의 가로길이을 설정하고 가져옵니다.
Public property | X | 풍선의 Left위치을 설정하고 가져옵니다.
Public property | Y | 풍선의 top 위치을 설정하고 가져옵니다.

See Also

Balloon Class


BackColor Property

[image]

.NET Framework Class Library
Balloon..::..BackColor Property
Balloon Class See Also Send Feedback

풍선의 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

Balloon Class


BalloonType Property

[image]

.NET Framework Class Library
Balloon..::..BalloonType Property
Balloon Class See Also Send Feedback

풍선 도움말 모양을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BalloonType As BalloonType
    Get
    Set
C#
public BalloonType BalloonType { get; set; }
Visual C++
public:
property BalloonType BalloonType {
    BalloonType get ();
    void set (BalloonType value);
}
JavaScript
function get_balloonType();
function set_balloonType(value);

See Also

Balloon Class


Height Property

[image]

.NET Framework Class Library
Balloon..::..Height Property
Balloon Class See Also Send Feedback

풍선의 세로길이을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height As Integer
    Get
    Set
C#
public int Height { get; set; }
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}
JavaScript
function get_height();
function set_height(value);

See Also

Balloon Class


HeightType Property

[image]

.NET Framework Class Library
Balloon..::..HeightType Property
Balloon Class See Also Send Feedback

풍선 도움말을 표시할 위치를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property HeightType As HeightType
    Get
    Set
C#
public HeightType HeightType { get; set; }
Visual C++
public:
property HeightType HeightType {
    HeightType get ();
    void set (HeightType value);
}
JavaScript
function get_heightType();
function set_heightType(value);

See Also

Balloon Class


IsShadow Property

[image]

.NET Framework Class Library
Balloon..::..IsShadow Property
Balloon Class See Also Send Feedback

풍선의 그림자를 표시할것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShadow As Boolean
    Get
    Set
C#
public bool IsShadow { get; set; }
Visual C++
public:
property bool IsShadow {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShadow();
function set_isShadow(value);

See Also

Balloon Class


Label Property

[image]

.NET Framework Class Library
Balloon..::..Label Property
Balloon Class See Also Send Feedback

풍선 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Balloon Class


Line Property

[image]

.NET Framework Class Library
Balloon..::..Line Property
Balloon Class See Also Send Feedback

풍선 라인을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Line As Line
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line Line { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

Balloon Class


TextLocation Property

[image]

.NET Framework Class Library
Balloon..::..TextLocation Property
Balloon Class See Also Send Feedback

풍선 내부 글자의 정렬을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TextLocation As StringAlignment
    Get
    Set
C#
public StringAlignment TextLocation { get; set; }
Visual C++
public:
property StringAlignment TextLocation {
    StringAlignment get ();
    void set (StringAlignment value);
}
JavaScript
function get_textLocation();
function set_textLocation(value);

See Also

Balloon Class


Visible Property

[image]

.NET Framework Class Library
Balloon..::..Visible Property
Balloon Class See Also Send Feedback

풍선을 보이게 할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

Balloon Class


Width Property

[image]

.NET Framework Class Library
Balloon..::..Width Property
Balloon Class See Also Send Feedback

풍선의 가로길이을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Integer
    Get
    Set
C#
public int Width { get; set; }
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}
JavaScript
function get_width();
function set_width(value);

See Also

Balloon Class


X Property

[image]

.NET Framework Class Library
Balloon..::..X Property
Balloon Class See Also Send Feedback

풍선의 Left위치을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property X As Single
    Get
    Set
C#
public float X { get; set; }
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}
JavaScript
function get_x();
function set_x(value);

See Also

Balloon Class


Y Property

[image]

.NET Framework Class Library
Balloon..::..Y Property
Balloon Class See Also Send Feedback

풍선의 top 위치을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Y As Single
    Get
    Set
C#
public float Y { get; set; }
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}
JavaScript
function get_y();
function set_y(value);

See Also

Balloon Class


BalloonType Enumeration

[image]

.NET Framework Class Library
BalloonType Enumeration
See Also Send Feedback

풍선 도움말 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration BalloonType
C#
public enum BalloonType
Visual C++
public enum class BalloonType
JavaScript
Hippo.BalloonType = function();
Hippo.BalloonType.createEnum('Hippo.BalloonType', false);

Members

Member name | Description
Default |
Rectangle |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


BaseChart Class

[image]

.NET Framework Class Library
BaseChart Class
Members See Also Send Feedback

히포차트의 추상 클래스 - 차트가 반드시 가져야할 기본적인 기능과 속성을 정의합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public MustInherit Class BaseChart _
    Implements IChart
C#
public abstract class BaseChart : IChart
Visual C++
public ref class BaseChart abstract : IChart
JavaScript
Hippo.BaseChart = function();

Type.createClass(
    'Hippo.BaseChart',
    null,
    Hippo.IChart);

Inheritance Hierarchy

System..::..Object
Hippo..::..BaseChart
Hippo..::..HippoChart

See Also

BaseChart Members


BaseChart Members

[image] [image]

.NET Framework Class Library
BaseChart Members
BaseChart Class Constructors Methods Fields Properties See Also Send Feedback

The BaseChart type exposes the following members.

Constructors

 | Name | Description
Public method | BaseChart | BaseChart 인스턴스를 셍성합니다.

Methods

 | Name | Description
Public method | DrawChart()()()() | DrawChart
Public method | DrawChart(SeriesList) | DrawChart
Public method | DrawChart(SeriesListDictionary) | DrawChart
Public method | DrawDefault | DrawDefault
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Protected field | InnerRecPaddings | 내부 사각형 패딩값 - 좌우위아래 , 3번째는 유동적
 | Tension | 배경 라운드 처리를 위한 장렬

Properties

 | Name | Description
Public property | BaseGraphic | 차트 기본 그래픽을 설정하고 가져옵니다.
Public property | BaseImage | 차트 기본 바탕 이미지를 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다.
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.

See Also

BaseChart Class


BaseChart Constructor

[image]

.NET Framework Class Library
BaseChart Constructor
BaseChart Class See Also Send Feedback

BaseChart 인스턴스를 셍성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public BaseChart()
Visual C++
public:
BaseChart()
JavaScript
Hippo.BaseChart = function();

See Also

BaseChart Class


BaseChart Fields

[image] [image]

.NET Framework Class Library
BaseChart Fields
BaseChart Class See Also Send Feedback

The BaseChart type exposes the following members.

Fields

 | Name | Description
Protected field | InnerRecPaddings | 내부 사각형 패딩값 - 좌우위아래 , 3번째는 유동적
 | Tension | 배경 라운드 처리를 위한 장렬

See Also

BaseChart Class


InnerRecPaddings Field

[image]

.NET Framework Class Library
BaseChart..::..InnerRecPaddings Field
BaseChart Class See Also Send Feedback

내부 사각형 패딩값 - 좌우위아래 , 3번째는 유동적

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Friend InnerRecPaddings As Integer()
C#
protected internal int[] InnerRecPaddings
Visual C++
protected public:
array<int>^ InnerRecPaddings
JavaScript
innerRecPaddings

See Also

BaseChart Class


Tension Field

[image]

.NET Framework Class Library
BaseChart..::..Tension Field
BaseChart Class See Also Send Feedback

배경 라운드 처리를 위한 장렬

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Friend Const Tension As Single
C#
protected internal const float Tension
Visual C++
protected public:
literal float Tension
JavaScript
Hippo.BaseChart.tension

See Also

BaseChart Class


BaseChart Methods

[image] [image]

.NET Framework Class Library
BaseChart Methods
BaseChart Class See Also Send Feedback

The BaseChart type exposes the following members.

Methods

 | Name | Description
Public method | DrawChart()()()() | DrawChart
Public method | DrawChart(SeriesList) | DrawChart
Public method | DrawChart(SeriesListDictionary) | DrawChart
Public method | DrawDefault | DrawDefault
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BaseChart Class


DrawChart Method

[image] [image]

.NET Framework Class Library
BaseChart..::..DrawChart Method
BaseChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawChart()()()() | DrawChart
Public method | DrawChart(SeriesList) | DrawChart
Public method | DrawChart(SeriesListDictionary) | DrawChart

See Also

BaseChart Class
BaseChart Members


DrawChart Method

[image]

.NET Framework Class Library
BaseChart..::..DrawChart Method
BaseChart Class See Also Send Feedback

DrawChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public MustOverride Sub DrawChart
C#
public abstract void DrawChart()
Visual C++
public:
virtual void DrawChart() abstract
JavaScript
function drawChart();

Implements

IChart..::..DrawChart()()()()

See Also

BaseChart Class
DrawChart Overload


DrawChart Method (SeriesList)

[image]

.NET Framework Class Library
BaseChart..::..DrawChart Method (SeriesList)
BaseChart Class See Also Send Feedback

DrawChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public MustOverride Sub DrawChart ( _
    SeriesList As SeriesList _
)
C#
public abstract void DrawChart(
    SeriesList SeriesList
)
Visual C++
public:
virtual void DrawChart(
    SeriesList^ SeriesList
) abstract
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesList

Implements

IChart..::..DrawChart(SeriesList)

See Also

BaseChart Class
DrawChart Overload


DrawChart Method (SeriesListDictionary)

[image]

.NET Framework Class Library
BaseChart..::..DrawChart Method (SeriesListDictionary)
BaseChart Class See Also Send Feedback

DrawChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public MustOverride Sub DrawChart ( _
    SeriesList As SeriesListDictionary _
)
C#
public abstract void DrawChart(
    SeriesListDictionary SeriesList
)
Visual C++
public:
virtual void DrawChart(
    SeriesListDictionary^ SeriesList
) abstract
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesListDictionary

Implements

IChart..::..DrawChart(SeriesListDictionary)

See Also

BaseChart Class
DrawChart Overload


DrawDefault Method

[image]

.NET Framework Class Library
BaseChart..::..DrawDefault Method
BaseChart Class See Also Send Feedback

DrawDefault

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public MustOverride Sub DrawDefault
C#
public abstract void DrawDefault()
Visual C++
public:
virtual void DrawDefault() abstract
JavaScript
function drawDefault();

Implements

IChart..::..DrawDefault()()()()

See Also

BaseChart Class


BaseChart Properties

[image] [image]

.NET Framework Class Library
BaseChart Properties
BaseChart Class See Also Send Feedback

The BaseChart type exposes the following members.

Properties

 | Name | Description
Public property | BaseGraphic | 차트 기본 그래픽을 설정하고 가져옵니다.
Public property | BaseImage | 차트 기본 바탕 이미지를 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다.
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.

See Also

BaseChart Class


BaseGraphic Property

[image]

.NET Framework Class Library
BaseChart..::..BaseGraphic Property
BaseChart Class See Also Send Feedback

차트 기본 그래픽을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BaseGraphic As Graphics
    Get
    Set
C#
public Graphics BaseGraphic { get; set; }
Visual C++
public:
property Graphics^ BaseGraphic {
    Graphics^ get ();
    void set (Graphics^ value);
}
JavaScript
function get_baseGraphic();
function set_baseGraphic(value);

See Also

BaseChart Class


BaseImage Property

[image]

.NET Framework Class Library
BaseChart..::..BaseImage Property
BaseChart Class See Also Send Feedback

차트 기본 바탕 이미지를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BaseImage As Bitmap
    Get
    Set
C#
public Bitmap BaseImage { get; set; }
Visual C++
public:
property Bitmap^ BaseImage {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
JavaScript
function get_baseImage();
function set_baseImage(value);

See Also

BaseChart Class


ChartGraphic Property

[image]

.NET Framework Class Library
BaseChart..::..ChartGraphic Property
BaseChart Class See Also Send Feedback

차트 그래픽를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartGraphic As Graphics
    Get
    Set
C#
public Graphics ChartGraphic { get; set; }
Visual C++
public:
virtual property Graphics^ ChartGraphic {
    Graphics^ get () sealed;
    void set (Graphics^ value) sealed;
}
JavaScript
function get_chartGraphic();
function set_chartGraphic(value);

Implements

IChart..::..ChartGraphic

See Also

BaseChart Class


ChartID Property

[image]

.NET Framework Class Library
BaseChart..::..ChartID Property
BaseChart Class See Also Send Feedback

현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartID As String
    Get
    Set
C#
public string ChartID { get; set; }
Visual C++
public:
virtual property String^ ChartID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_chartID();
function set_chartID(value);

Implements

IChart..::..ChartID

See Also

BaseChart Class


ChartImage Property

[image]

.NET Framework Class Library
BaseChart..::..ChartImage Property
BaseChart Class See Also Send Feedback

차트 이미지를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartImage As Bitmap
    Get
    Set
C#
public Bitmap ChartImage { get; set; }
Visual C++
public:
virtual property Bitmap^ ChartImage {
    Bitmap^ get () sealed;
    void set (Bitmap^ value) sealed;
}
JavaScript
function get_chartImage();
function set_chartImage(value);

Implements

IChart..::..ChartImage

See Also

BaseChart Class


ChartRectangle Property

[image]

.NET Framework Class Library
BaseChart..::..ChartRectangle Property
BaseChart Class See Also Send Feedback

히포차트 전체 사각형를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartRectangle As RectangleF
    Get
    Set
C#
public RectangleF ChartRectangle { get; set; }
Visual C++
public:
virtual property RectangleF ChartRectangle {
    RectangleF get () sealed;
    void set (RectangleF value) sealed;
}
JavaScript
function get_chartRectangle();
function set_chartRectangle(value);

Implements

IChart..::..ChartRectangle

See Also

BaseChart Class


Designer Property

[image]

.NET Framework Class Library
BaseChart..::..Designer Property
BaseChart Class See Also Send Feedback

차트 디자이너를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Designer As ChartDesigner
    Get
    Set
C#
public ChartDesigner Designer { get; set; }
Visual C++
public:
virtual property ChartDesigner^ Designer {
    ChartDesigner^ get () sealed;
    void set (ChartDesigner^ value) sealed;
}
JavaScript
function get_designer();
function set_designer(value);

Implements

IChart..::..Designer

See Also

BaseChart Class


DesignType Property

[image]

.NET Framework Class Library
BaseChart..::..DesignType Property
BaseChart Class See Also Send Feedback

차트 디자인 타입를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DesignType As ChartDesignType
    Get
    Set
C#
public ChartDesignType DesignType { get; set; }
Visual C++
public:
virtual property ChartDesignType DesignType {
    ChartDesignType get () sealed;
    void set (ChartDesignType value) sealed;
}
JavaScript
function get_designType();
function set_designType(value);

Implements

IChart..::..DesignType

See Also

BaseChart Class


Direction Property

[image]

.NET Framework Class Library
BaseChart..::..Direction Property
BaseChart Class See Also Send Feedback

그래프 영역의 방향를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Direction As GraphAreaLocation
    Get
    Set
C#
public GraphAreaLocation Direction { get; set; }
Visual C++
public:
virtual property GraphAreaLocation Direction {
    GraphAreaLocation get () sealed;
    void set (GraphAreaLocation value) sealed;
}
JavaScript
function get_direction();
function set_direction(value);

Implements

IChart..::..Direction

See Also

BaseChart Class


Height2 Property

[image]

.NET Framework Class Library
BaseChart..::..Height2 Property
BaseChart Class See Also Send Feedback

차트 세로 길이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height2 As Single
    Get
    Set
C#
public float Height2 { get; set; }
Visual C++
public:
virtual property float Height2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_height2();
function set_height2(value);

Implements

IChart..::..Height2

See Also

BaseChart Class


Layout Property

[image]

.NET Framework Class Library
BaseChart..::..Layout Property
BaseChart Class See Also Send Feedback

히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Layout As Layout
    Get
    Set
C#
public Layout Layout { get; set; }
Visual C++
public:
virtual property Layout^ Layout {
    Layout^ get () sealed;
    void set (Layout^ value) sealed;
}
JavaScript
function get_layout();
function set_layout(value);

Implements

IChart..::..Layout

See Also

BaseChart Class


Left Property

[image]

.NET Framework Class Library
BaseChart..::..Left Property
BaseChart Class See Also Send Feedback

차트 X 위치를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Left As Single
    Get
    Set
C#
public float Left { get; set; }
Visual C++
public:
virtual property float Left {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_left();
function set_left(value);

Implements

IChart..::..Left

See Also

BaseChart Class


LegendBox Property

[image]

.NET Framework Class Library
BaseChart..::..LegendBox Property
BaseChart Class See Also Send Feedback

범례를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendBox As LegendBox
    Get
    Set
C#
public LegendBox LegendBox { get; set; }
Visual C++
public:
virtual property LegendBox^ LegendBox {
    LegendBox^ get () sealed;
    void set (LegendBox^ value) sealed;
}
JavaScript
function get_legendBox();
function set_legendBox(value);

Implements

IChart..::..LegendBox

See Also

BaseChart Class


Logo Property

[image]

.NET Framework Class Library
BaseChart..::..Logo Property
BaseChart Class See Also Send Feedback

로고를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Logo As Logo
    Get
    Set
C#
public Logo Logo { get; set; }
Visual C++
public:
virtual property Logo^ Logo {
    Logo^ get () sealed;
    void set (Logo^ value) sealed;
}
JavaScript
function get_logo();
function set_logo(value);

Implements

IChart..::..Logo

See Also

BaseChart Class


PaletteType Property

[image]

.NET Framework Class Library
BaseChart..::..PaletteType Property
BaseChart Class See Also Send Feedback

팔레트 종류를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PaletteType As PaletteType
    Get
    Set
C#
public PaletteType PaletteType { get; set; }
Visual C++
public:
virtual property PaletteType PaletteType {
    PaletteType get () sealed;
    void set (PaletteType value) sealed;
}
JavaScript
function get_paletteType();
function set_paletteType(value);

Implements

IChart..::..PaletteType

See Also

BaseChart Class


SeriesAreaRate Property

[image]

.NET Framework Class Library
BaseChart..::..SeriesAreaRate Property
BaseChart Class See Also Send Feedback

시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesAreaRate As String
    Get
    Set
C#
public string SeriesAreaRate { get; set; }
Visual C++
public:
property String^ SeriesAreaRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_seriesAreaRate();
function set_seriesAreaRate(value);

See Also

BaseChart Class


SeriesListDictionary Property

[image]

.NET Framework Class Library
BaseChart..::..SeriesListDictionary Property
BaseChart Class See Also Send Feedback

시리즈 리스트 컬렉션를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesListDictionary As SeriesListDictionary
    Get
    Set
C#
public SeriesListDictionary SeriesListDictionary { get; set; }
Visual C++
public:
virtual property SeriesListDictionary^ SeriesListDictionary {
    SeriesListDictionary^ get () sealed;
    void set (SeriesListDictionary^ value) sealed;
}
JavaScript
function get_seriesListDictionary();
function set_seriesListDictionary(value);

Implements

IChart..::..SeriesListDictionary

See Also

BaseChart Class


Titles Property

[image]

.NET Framework Class Library
BaseChart..::..Titles Property
BaseChart Class See Also Send Feedback

차트 타이틀를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Titles As Title
    Get
    Set
C#
public Title Titles { get; set; }
Visual C++
public:
virtual property Title^ Titles {
    Title^ get () sealed;
    void set (Title^ value) sealed;
}
JavaScript
function get_titles();
function set_titles(value);

Implements

IChart..::..Titles

See Also

BaseChart Class


Top Property

[image]

.NET Framework Class Library
BaseChart..::..Top Property
BaseChart Class See Also Send Feedback

차트 Y 위치를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Top As Single
    Get
    Set
C#
public float Top { get; set; }
Visual C++
public:
virtual property float Top {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_top();
function set_top(value);

Implements

IChart..::..Top

See Also

BaseChart Class


Width2 Property

[image]

.NET Framework Class Library
BaseChart..::..Width2 Property
BaseChart Class See Also Send Feedback

차트 가로길이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width2 As Single
    Get
    Set
C#
public float Width2 { get; set; }
Visual C++
public:
virtual property float Width2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_width2();
function set_width2(value);

Implements

IChart..::..Width2

See Also

BaseChart Class


BoxPlotList Class

[image]

.NET Framework Class Library
BoxPlotList Class
Members See Also Send Feedback

박스플롯 리스트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class BoxPlotList _
    Inherits HippoCollectionBase(Of BoxPlots)
C#
[SerializableAttribute]
public class BoxPlotList : HippoCollectionBase<BoxPlots>
Visual C++
[SerializableAttribute]
public ref class BoxPlotList : public HippoCollectionBase<BoxPlots^>
JavaScript
Hippo.BoxPlotList = function();

Type.createClass(
    'Hippo.BoxPlotList',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BoxPlots >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' BoxPlots >)>)>
Hippo..::..BoxPlotList

See Also

BoxPlotList Members


BoxPlotList Members

[image] [image]

.NET Framework Class Library
BoxPlotList Members
BoxPlotList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The BoxPlotList type exposes the following members.

Constructors

 | Name | Description
Public method | BoxPlotList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class


BoxPlotList Constructor

[image]

.NET Framework Class Library
BoxPlotList Constructor
BoxPlotList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public BoxPlotList()
Visual C++
public:
BoxPlotList()
JavaScript
Hippo.BoxPlotList = function();

See Also

BoxPlotList Class


BoxPlotList Methods

[image] [image]

.NET Framework Class Library
BoxPlotList Methods
BoxPlotList Class See Also Send Feedback

The BoxPlotList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..BinarySearch Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..CopyTo Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..FindIndex Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..FindLastIndex Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..IndexOf Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..LastIndexOf Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


Reverse Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..Reverse Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


Sort Method

[image] [image]

.NET Framework Class Library
BoxPlotList..::..Sort Method
BoxPlotList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class
BoxPlotList Members


BoxPlotList Properties

[image] [image]

.NET Framework Class Library
BoxPlotList Properties
BoxPlotList Class See Also Send Feedback

The BoxPlotList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' BoxPlots >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' BoxPlots >)>)>.)

See Also

BoxPlotList Class


BoxPlots Class

[image]

.NET Framework Class Library
BoxPlots Class
Members See Also Send Feedback

박스 플롯 클래스 (사용자 호출 대상이 아닙니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class BoxPlots
C#
[SerializableAttribute]
public class BoxPlots
Visual C++
[SerializableAttribute]
public ref class BoxPlots
JavaScript
Hippo.BoxPlots = function();

Type.createClass(
    'Hippo.BoxPlots');

Inheritance Hierarchy

System..::..Object
Hippo..::..BoxPlots

See Also

BoxPlots Members


BoxPlots Members

[image] [image]

.NET Framework Class Library
BoxPlots Members
BoxPlots Class Constructors Methods Properties See Also Send Feedback

The BoxPlots type exposes the following members.

Constructors

 | Name | Description
Public method | BoxPlots | 박스플롯 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Avg | 평균을 설정하고 가져옵니다.
Public property | BoxColor | 개별 박스플롯 색상을 설정하고 가져옵니다.
Public property | BoxWidth | 박스의 넓이를 설정하고 가져옵니다.
Public property | Column | 박스플롯 박스 컬럼을 설정하고 가져옵니다.
Public property | FigurePoint | 박스플롯 데이터 수치 포인트 위치를 설정하고 가져옵니다.
Public property | GroupName | 박스플롯 그룹 이름
Public property | IQR | interquartile range를 설정하고 가져옵니다.
Public property | IsShowAvg | 평균을 그래프에 보여줄 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowFigureText | 박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | Items | 그룹에 포함된 시리즈아이템을 설정하고 가져옵니다.
Public property | Label | 박스플롯 각 수치 라벨을 설정하고 가져옵니다.
Public property | Max | 최대값을 설정하고 가져옵니다.
Public property | MaxPercentage | 최대값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | Min | 최소값을 설정하고 가져옵니다.
Public property | MinPercentage | 최소값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | Outliers | 이상치 데이터 리스트를 설정하고 가져옵니다.
Public property | Q1 | 1 분위수를 설정하고 가져옵니다.
Public property | Q2_Median | 2분위수 (중앙값) 을 설정하고 가져옵니다.
Public property | Q3 | 3분위수를 설정하고 가져옵니다.
Public property | Sum | 총 합을 설정하고 가져옵니다.
Public property | WhiskerLine | 아래 Whisker를 설정하고 가져옵니다.

See Also

BoxPlots Class


BoxPlots Constructor

[image]

.NET Framework Class Library
BoxPlots Constructor
BoxPlots Class See Also Send Feedback

박스플롯 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public BoxPlots()
Visual C++
public:
BoxPlots()
JavaScript
Hippo.BoxPlots = function();

See Also

BoxPlots Class


BoxPlots Methods

[image] [image]

.NET Framework Class Library
BoxPlots Methods
BoxPlots Class See Also Send Feedback

The BoxPlots type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BoxPlots Class


BoxPlots Properties

[image] [image]

.NET Framework Class Library
BoxPlots Properties
BoxPlots Class See Also Send Feedback

The BoxPlots type exposes the following members.

Properties

 | Name | Description
Public property | Avg | 평균을 설정하고 가져옵니다.
Public property | BoxColor | 개별 박스플롯 색상을 설정하고 가져옵니다.
Public property | BoxWidth | 박스의 넓이를 설정하고 가져옵니다.
Public property | Column | 박스플롯 박스 컬럼을 설정하고 가져옵니다.
Public property | FigurePoint | 박스플롯 데이터 수치 포인트 위치를 설정하고 가져옵니다.
Public property | GroupName | 박스플롯 그룹 이름
Public property | IQR | interquartile range를 설정하고 가져옵니다.
Public property | IsShowAvg | 평균을 그래프에 보여줄 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowFigureText | 박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | Items | 그룹에 포함된 시리즈아이템을 설정하고 가져옵니다.
Public property | Label | 박스플롯 각 수치 라벨을 설정하고 가져옵니다.
Public property | Max | 최대값을 설정하고 가져옵니다.
Public property | MaxPercentage | 최대값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | Min | 최소값을 설정하고 가져옵니다.
Public property | MinPercentage | 최소값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | Outliers | 이상치 데이터 리스트를 설정하고 가져옵니다.
Public property | Q1 | 1 분위수를 설정하고 가져옵니다.
Public property | Q2_Median | 2분위수 (중앙값) 을 설정하고 가져옵니다.
Public property | Q3 | 3분위수를 설정하고 가져옵니다.
Public property | Sum | 총 합을 설정하고 가져옵니다.
Public property | WhiskerLine | 아래 Whisker를 설정하고 가져옵니다.

See Also

BoxPlots Class


Avg Property

[image]

.NET Framework Class Library
BoxPlots..::..Avg Property
BoxPlots Class See Also Send Feedback

평균을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Avg As Double
    Get
    Set
C#
public double Avg { get; set; }
Visual C++
public:
property double Avg {
    double get ();
    void set (double value);
}
JavaScript
function get_avg();
function set_avg(value);

See Also

BoxPlots Class


BoxColor Property

[image]

.NET Framework Class Library
BoxPlots..::..BoxColor Property
BoxPlots Class See Also Send Feedback

개별 박스플롯 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BoxColor As Color
    Get
    Set
C#
public Color BoxColor { get; set; }
Visual C++
public:
property Color BoxColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_boxColor();
function set_boxColor(value);

See Also

BoxPlots Class


BoxWidth Property

[image]

.NET Framework Class Library
BoxPlots..::..BoxWidth Property
BoxPlots Class See Also Send Feedback

박스의 넓이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BoxWidth As Single
    Get
    Set
C#
public float BoxWidth { get; set; }
Visual C++
public:
property float BoxWidth {
    float get ();
    void set (float value);
}
JavaScript
function get_boxWidth();
function set_boxWidth(value);

See Also

BoxPlots Class


Column Property

[image]

.NET Framework Class Library
BoxPlots..::..Column Property
BoxPlots Class See Also Send Feedback

박스플롯 박스 컬럼을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Column As Column
    Get
    Set
C#
[BindableAttribute(true)]
public Column Column { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Column^ Column {
    Column^ get ();
    void set (Column^ value);
}
JavaScript
function get_column();
function set_column(value);

See Also

BoxPlots Class


FigurePoint Property

[image]

.NET Framework Class Library
BoxPlots..::..FigurePoint Property
BoxPlots Class See Also Send Feedback

박스플롯 데이터 수치 포인트 위치를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigurePoint As PointF
    Get
    Set
C#
public PointF FigurePoint { get; set; }
Visual C++
public:
property PointF FigurePoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_figurePoint();
function set_figurePoint(value);

See Also

BoxPlots Class


GroupName Property

[image]

.NET Framework Class Library
BoxPlots..::..GroupName Property
BoxPlots Class See Also Send Feedback

박스플롯 그룹 이름

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GroupName As String
    Get
    Set
C#
public string GroupName { get; set; }
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupName();
function set_groupName(value);

See Also

BoxPlots Class


IQR Property

[image]

.NET Framework Class Library
BoxPlots..::..IQR Property
BoxPlots Class See Also Send Feedback

interquartile range를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IQR As Double
    Get
    Set
C#
public double IQR { get; set; }
Visual C++
public:
property double IQR {
    double get ();
    void set (double value);
}
JavaScript
function get_IQR();
function set_IQR(value);

See Also

BoxPlots Class


IsShowAvg Property

[image]

.NET Framework Class Library
BoxPlots..::..IsShowAvg Property
BoxPlots Class See Also Send Feedback

평균을 그래프에 보여줄 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowAvg As Boolean
    Get
    Set
C#
public bool IsShowAvg { get; set; }
Visual C++
public:
property bool IsShowAvg {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowAvg();
function set_isShowAvg(value);

See Also

BoxPlots Class


IsShowFigureText Property

[image]

.NET Framework Class Library
BoxPlots..::..IsShowFigureText Property
BoxPlots Class See Also Send Feedback

박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowFigureText As Boolean
    Get
    Set
C#
public bool IsShowFigureText { get; set; }
Visual C++
public:
property bool IsShowFigureText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowFigureText();
function set_isShowFigureText(value);

See Also

BoxPlots Class


Items Property

[image]

.NET Framework Class Library
BoxPlots..::..Items Property
BoxPlots Class See Also Send Feedback

그룹에 포함된 시리즈아이템을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Items As SeriesItemCollection
    Get
    Set
C#
[BindableAttribute(true)]
public SeriesItemCollection Items { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property SeriesItemCollection^ Items {
    SeriesItemCollection^ get ();
    void set (SeriesItemCollection^ value);
}
JavaScript
function get_items();
function set_items(value);

See Also

BoxPlots Class


Label Property

[image]

.NET Framework Class Library
BoxPlots..::..Label Property
BoxPlots Class See Also Send Feedback

박스플롯 각 수치 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Label As Label
    Get
    Set
C#
[BindableAttribute(true)]
public Label Label { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

BoxPlots Class


Max Property

[image]

.NET Framework Class Library
BoxPlots..::..Max Property
BoxPlots Class See Also Send Feedback

최대값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Max As Double
    Get
    Set
C#
public double Max { get; set; }
Visual C++
public:
property double Max {
    double get ();
    void set (double value);
}
JavaScript
function get_max();
function set_max(value);

See Also

BoxPlots Class


MaxPercentage Property

[image]

.NET Framework Class Library
BoxPlots..::..MaxPercentage Property
BoxPlots Class See Also Send Feedback

최대값 퍼센트 지정값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxPercentage As Double
    Get
    Set
C#
public double MaxPercentage { get; set; }
Visual C++
public:
property double MaxPercentage {
    double get ();
    void set (double value);
}
JavaScript
function get_maxPercentage();
function set_maxPercentage(value);

See Also

BoxPlots Class


Min Property

[image]

.NET Framework Class Library
BoxPlots..::..Min Property
BoxPlots Class See Also Send Feedback

최소값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Min As Double
    Get
    Set
C#
public double Min { get; set; }
Visual C++
public:
property double Min {
    double get ();
    void set (double value);
}
JavaScript
function get_min();
function set_min(value);

See Also

BoxPlots Class


MinPercentage Property

[image]

.NET Framework Class Library
BoxPlots..::..MinPercentage Property
BoxPlots Class See Also Send Feedback

최소값 퍼센트 지정값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MinPercentage As Double
    Get
    Set
C#
public double MinPercentage { get; set; }
Visual C++
public:
property double MinPercentage {
    double get ();
    void set (double value);
}
JavaScript
function get_minPercentage();
function set_minPercentage(value);

See Also

BoxPlots Class


Outliers Property

[image]

.NET Framework Class Library
BoxPlots..::..Outliers Property
BoxPlots Class See Also Send Feedback

이상치 데이터 리스트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Outliers As OutlierList
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public OutlierList Outliers { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property OutlierList^ Outliers {
    OutlierList^ get ();
    void set (OutlierList^ value);
}
JavaScript
function get_outliers();
function set_outliers(value);

See Also

BoxPlots Class


Q1 Property

[image]

.NET Framework Class Library
BoxPlots..::..Q1 Property
BoxPlots Class See Also Send Feedback

1 분위수를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Q1 As Double
    Get
    Set
C#
public double Q1 { get; set; }
Visual C++
public:
property double Q1 {
    double get ();
    void set (double value);
}
JavaScript
function get_q1();
function set_q1(value);

See Also

BoxPlots Class


Q2_Median Property

[image]

.NET Framework Class Library
BoxPlots..::..Q2_Median Property
BoxPlots Class See Also Send Feedback

2분위수 (중앙값) 을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Q2_Median As Double
    Get
    Set
C#
public double Q2_Median { get; set; }
Visual C++
public:
property double Q2_Median {
    double get ();
    void set (double value);
}
JavaScript
function get_q2_Median();
function set_q2_Median(value);

See Also

BoxPlots Class


Q3 Property

[image]

.NET Framework Class Library
BoxPlots..::..Q3 Property
BoxPlots Class See Also Send Feedback

3분위수를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Q3 As Double
    Get
    Set
C#
public double Q3 { get; set; }
Visual C++
public:
property double Q3 {
    double get ();
    void set (double value);
}
JavaScript
function get_q3();
function set_q3(value);

See Also

BoxPlots Class


Sum Property

[image]

.NET Framework Class Library
BoxPlots..::..Sum Property
BoxPlots Class See Also Send Feedback

총 합을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Sum As Double
    Get
    Set
C#
public double Sum { get; set; }
Visual C++
public:
property double Sum {
    double get ();
    void set (double value);
}
JavaScript
function get_sum();
function set_sum(value);

See Also

BoxPlots Class


WhiskerLine Property

[image]

.NET Framework Class Library
BoxPlots..::..WhiskerLine Property
BoxPlots Class See Also Send Feedback

아래 Whisker를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property WhiskerLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line WhiskerLine { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ WhiskerLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_whiskerLine();
function set_whiskerLine(value);

See Also

BoxPlots Class


BoxPlotsAttributes Class

[image]

.NET Framework Class Library
BoxPlotsAttributes Class
Members See Also Send Feedback

박스 플롯 설정 클래스 (사용자 호출 대상)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class BoxPlotsAttributes
C#
[SerializableAttribute]
public class BoxPlotsAttributes
Visual C++
[SerializableAttribute]
public ref class BoxPlotsAttributes
JavaScript
Hippo.BoxPlotsAttributes = function();

Type.createClass(
    'Hippo.BoxPlotsAttributes');

Remarks

BoxPlot Chart 를 작성하기 위한 외부 설정 클래스입니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..BoxPlotsAttributes

See Also

BoxPlotsAttributes Members


BoxPlotsAttributes Members

[image] [image]

.NET Framework Class Library
BoxPlotsAttributes Members
BoxPlotsAttributes Class Constructors Methods Properties See Also Send Feedback

The BoxPlotsAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | BoxPlotsAttributes | 박스플롯 설정 클래스 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsShowFigureText | 박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | Label | 박스플롯 각 수치 라벨을 설정하고 가져옵니다.
Public property | MaxPercentage | 최대값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | MinPercentage | 최소값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | OutlierPointLabel | 이상치 표현 텍스트를 설정하고 가져옵니다.

See Also

BoxPlotsAttributes Class


BoxPlotsAttributes Constructor

[image]

.NET Framework Class Library
BoxPlotsAttributes Constructor
BoxPlotsAttributes Class See Also Send Feedback

박스플롯 설정 클래스 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public BoxPlotsAttributes()
Visual C++
public:
BoxPlotsAttributes()
JavaScript
Hippo.BoxPlotsAttributes = function();

See Also

BoxPlotsAttributes Class


BoxPlotsAttributes Methods

[image] [image]

.NET Framework Class Library
BoxPlotsAttributes Methods
BoxPlotsAttributes Class See Also Send Feedback

The BoxPlotsAttributes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BoxPlotsAttributes Class


BoxPlotsAttributes Properties

[image] [image]

.NET Framework Class Library
BoxPlotsAttributes Properties
BoxPlotsAttributes Class See Also Send Feedback

The BoxPlotsAttributes type exposes the following members.

Properties

 | Name | Description
Public property | IsShowFigureText | 박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | Label | 박스플롯 각 수치 라벨을 설정하고 가져옵니다.
Public property | MaxPercentage | 최대값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | MinPercentage | 최소값 퍼센트 지정값을 설정하고 가져옵니다.
Public property | OutlierPointLabel | 이상치 표현 텍스트를 설정하고 가져옵니다.

See Also

BoxPlotsAttributes Class


IsShowFigureText Property

[image]

.NET Framework Class Library
BoxPlotsAttributes..::..IsShowFigureText Property
BoxPlotsAttributes Class See Also Send Feedback

박스플롯 중요 값들의 수치를 보일 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowFigureText As Boolean
    Get
    Set
C#
public bool IsShowFigureText { get; set; }
Visual C++
public:
property bool IsShowFigureText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowFigureText();
function set_isShowFigureText(value);

See Also

BoxPlotsAttributes Class


Label Property

[image]

.NET Framework Class Library
BoxPlotsAttributes..::..Label Property
BoxPlotsAttributes Class See Also Send Feedback

박스플롯 각 수치 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Label As Label
    Get
    Set
C#
public Label Label { get; set; }
Visual C++
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

BoxPlotsAttributes Class


MaxPercentage Property

[image]

.NET Framework Class Library
BoxPlotsAttributes..::..MaxPercentage Property
BoxPlotsAttributes Class See Also Send Feedback

최대값 퍼센트 지정값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxPercentage As Double
    Get
    Set
C#
public double MaxPercentage { get; set; }
Visual C++
public:
property double MaxPercentage {
    double get ();
    void set (double value);
}
JavaScript
function get_maxPercentage();
function set_maxPercentage(value);

See Also

BoxPlotsAttributes Class


MinPercentage Property

[image]

.NET Framework Class Library
BoxPlotsAttributes..::..MinPercentage Property
BoxPlotsAttributes Class See Also Send Feedback

최소값 퍼센트 지정값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MinPercentage As Double
    Get
    Set
C#
public double MinPercentage { get; set; }
Visual C++
public:
property double MinPercentage {
    double get ();
    void set (double value);
}
JavaScript
function get_minPercentage();
function set_minPercentage(value);

See Also

BoxPlotsAttributes Class


OutlierPointLabel Property

[image]

.NET Framework Class Library
BoxPlotsAttributes..::..OutlierPointLabel Property
BoxPlotsAttributes Class See Also Send Feedback

이상치 표현 텍스트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property OutlierPointLabel As Label
    Get
    Set
C#
public Label OutlierPointLabel { get; set; }
Visual C++
public:
property Label^ OutlierPointLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_outlierPointLabel();
function set_outlierPointLabel(value);

See Also

BoxPlotsAttributes Class


ChartDesigner Class

[image]

.NET Framework Class Library
ChartDesigner Class
Members See Also Send Feedback

차트 디자이너 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class ChartDesigner
C#
[SerializableAttribute]
public class ChartDesigner
Visual C++
[SerializableAttribute]
public ref class ChartDesigner
JavaScript
Hippo.ChartDesigner = function();

Type.createClass(
    'Hippo.ChartDesigner');

Inheritance Hierarchy

System..::..Object
Hippo..::..ChartDesigner

See Also

ChartDesigner Members


ChartDesigner Members

[image] [image]

.NET Framework Class Library
ChartDesigner Members
ChartDesigner Class Constructors Methods Properties See Also Send Feedback

The ChartDesigner type exposes the following members.

Constructors

 | Name | Description
Public method | ChartDesigner | ChartDesigner 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 차트 배경색을 설정하고 가져옵니다.
Public property | BackLineColor | 보더 라인 색상을 설정하고 가져옵니다.
Public property | InnerBackColor | 차트 내부 배경색을 설정하고 가져옵니다.
Public property | IsGradation | 차트 배경색을 그라데이션 처리할것인가 여부을 설정하고 가져옵니다.
Public property | IsShowBorder | 차트 배경라인을 그릴것인가 여부을 설정하고 가져옵니다.

See Also

ChartDesigner Class


ChartDesigner Constructor

[image]

.NET Framework Class Library
ChartDesigner Constructor
ChartDesigner Class See Also Send Feedback

ChartDesigner 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ChartDesigner()
Visual C++
public:
ChartDesigner()
JavaScript
Hippo.ChartDesigner = function();

See Also

ChartDesigner Class


ChartDesigner Methods

[image] [image]

.NET Framework Class Library
ChartDesigner Methods
ChartDesigner Class See Also Send Feedback

The ChartDesigner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChartDesigner Class


ChartDesigner Properties

[image] [image]

.NET Framework Class Library
ChartDesigner Properties
ChartDesigner Class See Also Send Feedback

The ChartDesigner type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 차트 배경색을 설정하고 가져옵니다.
Public property | BackLineColor | 보더 라인 색상을 설정하고 가져옵니다.
Public property | InnerBackColor | 차트 내부 배경색을 설정하고 가져옵니다.
Public property | IsGradation | 차트 배경색을 그라데이션 처리할것인가 여부을 설정하고 가져옵니다.
Public property | IsShowBorder | 차트 배경라인을 그릴것인가 여부을 설정하고 가져옵니다.

See Also

ChartDesigner Class


BackColor Property

[image]

.NET Framework Class Library
ChartDesigner..::..BackColor Property
ChartDesigner Class See Also Send Feedback

차트 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

ChartDesigner Class


BackLineColor Property

[image]

.NET Framework Class Library
ChartDesigner..::..BackLineColor Property
ChartDesigner Class See Also Send Feedback

보더 라인 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackLineColor As Color
    Get
    Set
C#
public Color BackLineColor { get; set; }
Visual C++
public:
property Color BackLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backLineColor();
function set_backLineColor(value);

See Also

ChartDesigner Class


InnerBackColor Property

[image]

.NET Framework Class Library
ChartDesigner..::..InnerBackColor Property
ChartDesigner Class See Also Send Feedback

차트 내부 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property InnerBackColor As Color
    Get
    Set
C#
public Color InnerBackColor { get; set; }
Visual C++
public:
property Color InnerBackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_innerBackColor();
function set_innerBackColor(value);

See Also

ChartDesigner Class


IsGradation Property

[image]

.NET Framework Class Library
ChartDesigner..::..IsGradation Property
ChartDesigner Class See Also Send Feedback

차트 배경색을 그라데이션 처리할것인가 여부을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsGradation As Boolean
    Get
    Set
C#
public bool IsGradation { get; set; }
Visual C++
public:
property bool IsGradation {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGradation();
function set_isGradation(value);

See Also

ChartDesigner Class


IsShowBorder Property

[image]

.NET Framework Class Library
ChartDesigner..::..IsShowBorder Property
ChartDesigner Class See Also Send Feedback

차트 배경라인을 그릴것인가 여부을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowBorder As Boolean
    Get
    Set
C#
public bool IsShowBorder { get; set; }
Visual C++
public:
property bool IsShowBorder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowBorder();
function set_isShowBorder(value);

See Also

ChartDesigner Class


ChartDesignType Enumeration

[image]

.NET Framework Class Library
ChartDesignType Enumeration
See Also Send Feedback

차트 디자인 타입(차트의 배경 디자인)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ChartDesignType
C#
public enum ChartDesignType
Visual C++
public enum class ChartDesignType
JavaScript
Hippo.ChartDesignType = function();
Hippo.ChartDesignType.createEnum('Hippo.ChartDesignType', false);

Members

Member name | Description
Main |
Flat |
Simple |
Simple2 |
None |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ChartType Enumeration

[image]

.NET Framework Class Library
ChartType Enumeration
See Also Send Feedback

차트의 종류

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ChartType
C#
public enum ChartType
Visual C++
public enum class ChartType
JavaScript
Hippo.ChartType = function();
Hippo.ChartType.createEnum('Hippo.ChartType', false);

Members

Member name | Description
Line |
Spline |
Column |
ImageBar |
Pie |
Bar |
Gantt |
Circular |
Cone |
PylamidColumn |
Radar |
Stepline |
Pylamid |
Scatter |
Doughnut |
Gauge |
Gauge2 |
CandleStick |
StackedColumn |
StackedCircular |
StackedLine |
StackedSpline |
StackedBar |
ErrorBar |
BarLine |
Funnel |
Surface |
AreaLine |
BoxPlot |
Vector |
ColorMap |
Contour |
Organization |
None |

Remarks

히포차트에서 지원하는 차트타입을 나타내는 열거형

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ChartUtility Class

[image]

.NET Framework Class Library
ChartUtility Class
Members See Also Send Feedback

유틸리티 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class ChartUtility
C#
public class ChartUtility
Visual C++
public ref class ChartUtility
JavaScript
Hippo.ChartUtility = function();

Type.createClass(
    'Hippo.ChartUtility');

Inheritance Hierarchy

System..::..Object
Hippo..::..ChartUtility

See Also

ChartUtility Members


ChartUtility Members

[image] [image]

.NET Framework Class Library
ChartUtility Members
ChartUtility Class Constructors Methods See Also Send Feedback

The ChartUtility type exposes the following members.

Constructors

 | Name | Description
Public method | ChartUtility |

Methods

 | Name | Description
 | CheckDataValidation | 차트를 그리는 데이터의 값을 분석하여 올바른(그리기에 적당한) 데이터로 반환합니다. - 숫자가 맞는지? - 기타 등등
 | CheckDataValidation2 | CheckDataValidation2
 | CheckDataValidation3 | CheckDataValidation3
 | CheckDataValidation4 | CheckDataValidation4
 | CheckDateTimeDataValidation | 데이터가 데이트형식인지를 체크한다.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetColorByFigues |
 | GetColorByFigues2 | 색상 수치 값을 받아서 특정 색을 반환하는 메소드
 | GetColorByFiguesByArray | GetColorByFigues
 | GetFigureFormatString | GetFigureFormatString - 숫자 포맷 설정을 위한 문자를 리턴합니다.
Public method | GetHashCode | (Inherited from Object.)
 | GetRound | GetRound
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChartUtility Class


ChartUtility Constructor

[image]

.NET Framework Class Library
ChartUtility Constructor
ChartUtility Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ChartUtility()
Visual C++
public:
ChartUtility()
JavaScript
Hippo.ChartUtility = function();

See Also

ChartUtility Class


ChartUtility Methods

[image] [image]

.NET Framework Class Library
ChartUtility Methods
ChartUtility Class See Also Send Feedback

The ChartUtility type exposes the following members.

Methods

 | Name | Description
 | CheckDataValidation | 차트를 그리는 데이터의 값을 분석하여 올바른(그리기에 적당한) 데이터로 반환합니다. - 숫자가 맞는지? - 기타 등등
 | CheckDataValidation2 | CheckDataValidation2
 | CheckDataValidation3 | CheckDataValidation3
 | CheckDataValidation4 | CheckDataValidation4
 | CheckDateTimeDataValidation | 데이터가 데이트형식인지를 체크한다.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetColorByFigues |
 | GetColorByFigues2 | 색상 수치 값을 받아서 특정 색을 반환하는 메소드
 | GetColorByFiguesByArray | GetColorByFigues
 | GetFigureFormatString | GetFigureFormatString - 숫자 포맷 설정을 위한 문자를 리턴합니다.
Public method | GetHashCode | (Inherited from Object.)
 | GetRound | GetRound
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChartUtility Class


CheckDataValidation Method

[image]

.NET Framework Class Library
ChartUtility..::..CheckDataValidation Method
ChartUtility Class See Also Send Feedback

차트를 그리는 데이터의 값을 분석하여 올바른(그리기에 적당한) 데이터로 반환합니다. - 숫자가 맞는지? - 기타 등등

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function CheckDataValidation ( _
    chartdata As String _
) As String
C#
public static string CheckDataValidation(
    string chartdata
)
Visual C++
public:
static String^ CheckDataValidation(
    String^ chartdata
)
JavaScript
Hippo.ChartUtility.checkDataValidation = function(chartdata);

Parameters

chartdata
Type: System..::..String

Return Value

See Also

ChartUtility Class


CheckDataValidation2 Method

[image]

.NET Framework Class Library
ChartUtility..::..CheckDataValidation2 Method
ChartUtility Class See Also Send Feedback

CheckDataValidation2

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function CheckDataValidation2 ( _
    chartdata As String _
) As Double
C#
public static double CheckDataValidation2(
    string chartdata
)
Visual C++
public:
static double CheckDataValidation2(
    String^ chartdata
)
JavaScript
Hippo.ChartUtility.checkDataValidation2 = function(chartdata);

Parameters

chartdata
Type: System..::..String

Return Value

See Also

ChartUtility Class


CheckDataValidation3 Method

[image]

.NET Framework Class Library
ChartUtility..::..CheckDataValidation3 Method
ChartUtility Class See Also Send Feedback

CheckDataValidation3

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function CheckDataValidation3 ( _
    chartdata As String, _
    IsLog As Boolean, _
    LogBase As Integer _
) As String
C#
public static string CheckDataValidation3(
    string chartdata,
    bool IsLog,
    int LogBase
)
Visual C++
public:
static String^ CheckDataValidation3(
    String^ chartdata,
    bool IsLog,
    int LogBase
)
JavaScript
Hippo.ChartUtility.checkDataValidation3 = function(chartdata, IsLog, LogBase);

Parameters

chartdata
Type: System..::..String
IsLog
Type: System..::..Boolean
LogBase
Type: System..::..Int32

Return Value

See Also

ChartUtility Class


CheckDataValidation4 Method

[image]

.NET Framework Class Library
ChartUtility..::..CheckDataValidation4 Method
ChartUtility Class See Also Send Feedback

CheckDataValidation4

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function CheckDataValidation4 ( _
    chartdata As String, _
    IsLog As Boolean, _
    LogBase As Integer _
) As Double
C#
public static double CheckDataValidation4(
    string chartdata,
    bool IsLog,
    int LogBase
)
Visual C++
public:
static double CheckDataValidation4(
    String^ chartdata,
    bool IsLog,
    int LogBase
)
JavaScript
Hippo.ChartUtility.checkDataValidation4 = function(chartdata, IsLog, LogBase);

Parameters

chartdata
Type: System..::..String
IsLog
Type: System..::..Boolean
LogBase
Type: System..::..Int32

Return Value

See Also

ChartUtility Class


CheckDateTimeDataValidation Method

[image]

.NET Framework Class Library
ChartUtility..::..CheckDateTimeDataValidation Method
ChartUtility Class See Also Send Feedback

데이터가 데이트형식인지를 체크한다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function CheckDateTimeDataValidation ( _
    chartdata As String _
) As String
C#
public static string CheckDateTimeDataValidation(
    string chartdata
)
Visual C++
public:
static String^ CheckDateTimeDataValidation(
    String^ chartdata
)
JavaScript
Hippo.ChartUtility.checkDateTimeDataValidation = function(chartdata);

Parameters

chartdata
Type: System..::..String

Return Value

See Also

ChartUtility Class


GetColorByFigues Method

[image]

.NET Framework Class Library
ChartUtility..::..GetColorByFigues Method
ChartUtility Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetColorByFigues ( _
    maxUnitValue As Integer, _
    minUnitValue As Integer, _
    decimalpoint As Integer _
) As SortedList(Of Double, Color)
C#
public static SortedList<double, Color> GetColorByFigues(
    int maxUnitValue,
    int minUnitValue,
    int decimalpoint
)
Visual C++
public:
static SortedList<double, Color>^ GetColorByFigues(
    int maxUnitValue,
    int minUnitValue,
    int decimalpoint
)
JavaScript
Hippo.ChartUtility.getColorByFigues = function(maxUnitValue, minUnitValue, decimalpoint);

Parameters

maxUnitValue
Type: System..::..Int32
minUnitValue
Type: System..::..Int32
decimalpoint
Type: System..::..Int32

See Also

ChartUtility Class


GetColorByFigues2 Method

[image]

.NET Framework Class Library
ChartUtility..::..GetColorByFigues2 Method
ChartUtility Class See Also Send Feedback

색상 수치 값을 받아서 특정 색을 반환하는 메소드

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetColorByFigues2 ( _
    maxUnitValue As Integer, _
    minUnitValue As Integer _
) As SortedList(Of Integer, Color)
C#
public static SortedList<int, Color> GetColorByFigues2(
    int maxUnitValue,
    int minUnitValue
)
Visual C++
public:
static SortedList<int, Color>^ GetColorByFigues2(
    int maxUnitValue,
    int minUnitValue
)
JavaScript
Hippo.ChartUtility.getColorByFigues2 = function(maxUnitValue, minUnitValue);

Parameters

maxUnitValue
Type: System..::..Int32
minUnitValue
Type: System..::..Int32

Return Value

See Also

ChartUtility Class


GetColorByFiguesByArray Method

[image]

.NET Framework Class Library
ChartUtility..::..GetColorByFiguesByArray Method
ChartUtility Class See Also Send Feedback

GetColorByFigues

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetColorByFiguesByArray ( _
    maxUnitValue As Integer, _
    minUnitValue As Integer _
) As Color()
C#
public static Color[] GetColorByFiguesByArray(
    int maxUnitValue,
    int minUnitValue
)
Visual C++
public:
static array<Color>^ GetColorByFiguesByArray(
    int maxUnitValue,
    int minUnitValue
)
JavaScript
Hippo.ChartUtility.getColorByFiguesByArray = function(maxUnitValue, minUnitValue);

Parameters

maxUnitValue
Type: System..::..Int32
minUnitValue
Type: System..::..Int32

Return Value

See Also

ChartUtility Class


GetFigureFormatString Method

[image]

.NET Framework Class Library
ChartUtility..::..GetFigureFormatString Method
ChartUtility Class See Also Send Feedback

GetFigureFormatString - 숫자 포맷 설정을 위한 문자를 리턴합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetFigureFormatString ( _
    format As FigureFormat _
) As String
C#
public static string GetFigureFormatString(
    FigureFormat format
)
Visual C++
public:
static String^ GetFigureFormatString(
    FigureFormat format
)
JavaScript
Hippo.ChartUtility.getFigureFormatString = function(format);

Parameters

format
Type: Hippo..::..FigureFormat

Return Value

See Also

ChartUtility Class


GetRound Method

[image]

.NET Framework Class Library
ChartUtility..::..GetRound Method
ChartUtility Class See Also Send Feedback

GetRound

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetRound ( _
    Figure As Double, _
    RoundFigure As Integer _
) As Double
C#
public static double GetRound(
    double Figure,
    int RoundFigure
)
Visual C++
public:
static double GetRound(
    double Figure,
    int RoundFigure
)
JavaScript
Hippo.ChartUtility.getRound = function(Figure, RoundFigure);

Parameters

Figure
Type: System..::..Double
RoundFigure
Type: System..::..Int32

Return Value

See Also

ChartUtility Class


ColorHsl Structure

[image]

.NET Framework Class Library
ColorHsl Structure
Members See Also Send Feedback

Represents an AHSL color.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Structure ColorHsl _
    Implements IEquatable(Of Color)
C#
[SerializableAttribute]
public struct ColorHsl : IEquatable<Color>
Visual C++
[SerializableAttribute]
public value class ColorHsl : IEquatable<Color>
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

ColorHsl Members


ColorHsl Members

[image] [image]

.NET Framework Class Library
ColorHsl Members
ColorHsl Structure Constructors Methods Fields See Also Send Feedback

The ColorHsl type exposes the following members.

Constructors

 | Name | Description
Public method | ColorHsl(Double, Double, Double) | Initializes a new instance of the ColorHsl structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorHsl(Double, Double, Double, Double) | Initializes a new instance of the ColorHsl structure from the specified double values.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor |
Public method | ToColorHsv |
Public method | ToColorRgb |
Public method | ToString | Converts this ColorHsl structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | H | Gets the hue component value.
Public field | L | Gets the lightness component value.
Public field | S | Gets the saturation component value.

See Also

ColorHsl Structure


ColorHsl Constructor

[image] [image]

.NET Framework Class Library
ColorHsl Constructor
ColorHsl Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorHsl(Double, Double, Double) | Initializes a new instance of the ColorHsl structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorHsl(Double, Double, Double, Double) | Initializes a new instance of the ColorHsl structure from the specified double values.

See Also

ColorHsl Structure
ColorHsl Members


ColorHsl Constructor (Double, Double, Double)

[image]

.NET Framework Class Library
ColorHsl Constructor (Double, Double, Double)
ColorHsl Structure See Also Send Feedback

Initializes a new instance of the ColorHsl structure from the specified double values. The alpha value is implicitly 1 (fully opaque).

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    hue As Double, _
    saturation As Double, _
    lightness As Double _
)
C#
public ColorHsl(
    double hue,
    double saturation,
    double lightness
)
Visual C++
public:
ColorHsl(
    double hue,
    double saturation,
    double lightness
)
JavaScript
Hippo.ColorHsl = function(hue, saturation, lightness);

Parameters

hue
Type: System..::..Double
The hue component value. Valid values are 0 through 360.
saturation
Type: System..::..Double
The saturation component value. Valid values are 0 through 1.
lightness
Type: System..::..Double
The lightness component value. Valid values are 0 through 1.

See Also

ColorHsl Structure
ColorHsl Overload


ColorHsl Constructor (Double, Double, Double, Double)

[image]

.NET Framework Class Library
ColorHsl Constructor (Double, Double, Double, Double)
ColorHsl Structure See Also Send Feedback

Initializes a new instance of the ColorHsl structure from the specified double values.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    alpha As Double, _
    hue As Double, _
    saturation As Double, _
    lightness As Double _
)
C#
public ColorHsl(
    double alpha,
    double hue,
    double saturation,
    double lightness
)
Visual C++
public:
ColorHsl(
    double alpha,
    double hue,
    double saturation,
    double lightness
)
JavaScript
Hippo.ColorHsl = function(alpha, hue, saturation, lightness);

Parameters

alpha
Type: System..::..Double
The alpha component value. Valid values are 0 through 1.
hue
Type: System..::..Double
The hue component value. Valid values are 0 through 360.
saturation
Type: System..::..Double
The saturation component value. Valid values are 0 through 1.
lightness
Type: System..::..Double
The lightness component value. Valid values are 0 through 1.

See Also

ColorHsl Structure
ColorHsl Overload


ColorHsl Fields

[image] [image]

.NET Framework Class Library
ColorHsl Fields
ColorHsl Structure See Also Send Feedback

The ColorHsl type exposes the following members.

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | H | Gets the hue component value.
Public field | L | Gets the lightness component value.
Public field | S | Gets the saturation component value.

See Also

ColorHsl Structure


A Field

[image]

.NET Framework Class Library
ColorHsl..::..A Field
ColorHsl Structure See Also Send Feedback

Gets the alpha component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly A As Double
C#
public readonly double A
Visual C++
public:
initonly double A
JavaScript
a

See Also

ColorHsl Structure


H Field

[image]

.NET Framework Class Library
ColorHsl..::..H Field
ColorHsl Structure See Also Send Feedback

Gets the hue component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly H As Double
C#
public readonly double H
Visual C++
public:
initonly double H
JavaScript
h

See Also

ColorHsl Structure


L Field

[image]

.NET Framework Class Library
ColorHsl..::..L Field
ColorHsl Structure See Also Send Feedback

Gets the lightness component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly L As Double
C#
public readonly double L
Visual C++
public:
initonly double L
JavaScript
l

See Also

ColorHsl Structure


S Field

[image]

.NET Framework Class Library
ColorHsl..::..S Field
ColorHsl Structure See Also Send Feedback

Gets the saturation component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly S As Double
C#
public readonly double S
Visual C++
public:
initonly double S
JavaScript
s

See Also

ColorHsl Structure


ColorHsl Methods

[image] [image]

.NET Framework Class Library
ColorHsl Methods
ColorHsl Structure See Also Send Feedback

The ColorHsl type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor |
Public method | ToColorHsv |
Public method | ToColorRgb |
Public method | ToString | Converts this ColorHsl structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

ColorHsl Structure


Equals Method

[image] [image]

.NET Framework Class Library
ColorHsl..::..Equals Method
ColorHsl Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)

See Also

ColorHsl Structure
ColorHsl Members


Equals Method (Color)

[image]

.NET Framework Class Library
ColorHsl..::..Equals Method (Color)
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function Equals ( _
    other As Color _
) As Boolean
C#
public bool Equals(
    Color other
)
Visual C++
public:
virtual bool Equals(
    Color other
) sealed
JavaScript
function equals(other);

Parameters

other
Type: System.Drawing..::..Color

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

ColorHsl Structure
Equals Overload


Equals Method (Object)

[image]

.NET Framework Class Library
ColorHsl..::..Equals Method (Object)
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object

See Also

ColorHsl Structure
Equals Overload


FromColor Method

[image]

.NET Framework Class Library
ColorHsl..::..FromColor Method
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    color As Color _
) As ColorHsl
C#
public static ColorHsl FromColor(
    Color color
)
Visual C++
public:
static ColorHsl FromColor(
    Color color
)
JavaScript
Hippo.ColorHsl.fromColor = function(color);

Parameters

color
Type: System.Drawing..::..Color

See Also

ColorHsl Structure


GetHashCode Method

[image]

.NET Framework Class Library
ColorHsl..::..GetHashCode Method
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

See Also

ColorHsl Structure


ToColor Method

[image]

.NET Framework Class Library
ColorHsl..::..ToColor Method
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColor As Color
C#
public Color ToColor()
Visual C++
public:
Color ToColor()
JavaScript
function toColor();

See Also

ColorHsl Structure


ToColorHsv Method

[image]

.NET Framework Class Library
ColorHsl..::..ToColorHsv Method
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorHsv As ColorHsv
C#
public ColorHsv ToColorHsv()
Visual C++
public:
ColorHsv ToColorHsv()
JavaScript
function toColorHsv();

See Also

ColorHsl Structure


ToColorRgb Method

[image]

.NET Framework Class Library
ColorHsl..::..ToColorRgb Method
ColorHsl Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorRgb As ColorRgb
C#
public ColorRgb ToColorRgb()
Visual C++
public:
ColorRgb ToColorRgb()
JavaScript
function toColorRgb();

See Also

ColorHsl Structure


ToString Method

[image]

.NET Framework Class Library
ColorHsl..::..ToString Method
ColorHsl Structure See Also Send Feedback

Converts this ColorHsl structure to a human-readable string.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

String that consists of the AHSL component names and their values.

See Also

ColorHsl Structure


ColorHsv Structure

[image]

.NET Framework Class Library
ColorHsv Structure
Members See Also Send Feedback

Represents an AHSV color.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Structure ColorHsv _
    Implements IEquatable(Of Color)
C#
[SerializableAttribute]
public struct ColorHsv : IEquatable<Color>
Visual C++
[SerializableAttribute]
public value class ColorHsv : IEquatable<Color>
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

ColorHsv Members


ColorHsv Members

[image] [image]

.NET Framework Class Library
ColorHsv Members
ColorHsv Structure Constructors Methods Fields See Also Send Feedback

The ColorHsv type exposes the following members.

Constructors

 | Name | Description
Public method | ColorHsv(Double, Double, Double) | Initializes a new instance of the ColorHsv structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorHsv(Double, Double, Double, Double) | Initializes a new instance of the ColorHsv structure from the specified double values.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor |
Public method | ToColorHsl |
Public method | ToColorRgb |
Public method | ToString | Converts this ColorHsv structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | H | Gets the hue component value.
Public field | S | Gets the saturation component value.
Public field | V | Gets the value component value.

See Also

ColorHsv Structure


ColorHsv Constructor

[image] [image]

.NET Framework Class Library
ColorHsv Constructor
ColorHsv Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorHsv(Double, Double, Double) | Initializes a new instance of the ColorHsv structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorHsv(Double, Double, Double, Double) | Initializes a new instance of the ColorHsv structure from the specified double values.

See Also

ColorHsv Structure
ColorHsv Members


ColorHsv Constructor (Double, Double, Double)

[image]

.NET Framework Class Library
ColorHsv Constructor (Double, Double, Double)
ColorHsv Structure See Also Send Feedback

Initializes a new instance of the ColorHsv structure from the specified double values. The alpha value is implicitly 1 (fully opaque).

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    hue As Double, _
    saturation As Double, _
    value As Double _
)
C#
public ColorHsv(
    double hue,
    double saturation,
    double value
)
Visual C++
public:
ColorHsv(
    double hue,
    double saturation,
    double value
)
JavaScript
Hippo.ColorHsv = function(hue, saturation, value);

Parameters

hue
Type: System..::..Double
The hue component value. Valid values are 0 through 360.
saturation
Type: System..::..Double
The saturation component value. Valid values are 0 through 1.
value
Type: System..::..Double
The value component value. Valid values are 0 through 1.

See Also

ColorHsv Structure
ColorHsv Overload


ColorHsv Constructor (Double, Double, Double, Double)

[image]

.NET Framework Class Library
ColorHsv Constructor (Double, Double, Double, Double)
ColorHsv Structure See Also Send Feedback

Initializes a new instance of the ColorHsv structure from the specified double values.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    alpha As Double, _
    hue As Double, _
    saturation As Double, _
    value As Double _
)
C#
public ColorHsv(
    double alpha,
    double hue,
    double saturation,
    double value
)
Visual C++
public:
ColorHsv(
    double alpha,
    double hue,
    double saturation,
    double value
)
JavaScript
Hippo.ColorHsv = function(alpha, hue, saturation, value);

Parameters

alpha
Type: System..::..Double
The alpha component value. Valid values are 0 through 1.
hue
Type: System..::..Double
The hue component value. Valid values are 0 through 360.
saturation
Type: System..::..Double
The saturation component value. Valid values are 0 through 1.
value
Type: System..::..Double
The value component value. Valid values are 0 through 1.

See Also

ColorHsv Structure
ColorHsv Overload


ColorHsv Fields

[image] [image]

.NET Framework Class Library
ColorHsv Fields
ColorHsv Structure See Also Send Feedback

The ColorHsv type exposes the following members.

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | H | Gets the hue component value.
Public field | S | Gets the saturation component value.
Public field | V | Gets the value component value.

See Also

ColorHsv Structure


A Field

[image]

.NET Framework Class Library
ColorHsv..::..A Field
ColorHsv Structure See Also Send Feedback

Gets the alpha component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly A As Double
C#
public readonly double A
Visual C++
public:
initonly double A
JavaScript
a

See Also

ColorHsv Structure


H Field

[image]

.NET Framework Class Library
ColorHsv..::..H Field
ColorHsv Structure See Also Send Feedback

Gets the hue component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly H As Double
C#
public readonly double H
Visual C++
public:
initonly double H
JavaScript
h

See Also

ColorHsv Structure


S Field

[image]

.NET Framework Class Library
ColorHsv..::..S Field
ColorHsv Structure See Also Send Feedback

Gets the saturation component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly S As Double
C#
public readonly double S
Visual C++
public:
initonly double S
JavaScript
s

See Also

ColorHsv Structure


V Field

[image]

.NET Framework Class Library
ColorHsv..::..V Field
ColorHsv Structure See Also Send Feedback

Gets the value component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly V As Double
C#
public readonly double V
Visual C++
public:
initonly double V
JavaScript
v

See Also

ColorHsv Structure


ColorHsv Methods

[image] [image]

.NET Framework Class Library
ColorHsv Methods
ColorHsv Structure See Also Send Feedback

The ColorHsv type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor |
Public method | ToColorHsl |
Public method | ToColorRgb |
Public method | ToString | Converts this ColorHsv structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

ColorHsv Structure


Equals Method

[image] [image]

.NET Framework Class Library
ColorHsv..::..Equals Method
ColorHsv Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)

See Also

ColorHsv Structure
ColorHsv Members


Equals Method (Color)

[image]

.NET Framework Class Library
ColorHsv..::..Equals Method (Color)
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function Equals ( _
    other As Color _
) As Boolean
C#
public bool Equals(
    Color other
)
Visual C++
public:
virtual bool Equals(
    Color other
) sealed
JavaScript
function equals(other);

Parameters

other
Type: System.Drawing..::..Color

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

ColorHsv Structure
Equals Overload


Equals Method (Object)

[image]

.NET Framework Class Library
ColorHsv..::..Equals Method (Object)
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object

See Also

ColorHsv Structure
Equals Overload


FromColor Method

[image]

.NET Framework Class Library
ColorHsv..::..FromColor Method
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    color As Color _
) As ColorHsv
C#
public static ColorHsv FromColor(
    Color color
)
Visual C++
public:
static ColorHsv FromColor(
    Color color
)
JavaScript
Hippo.ColorHsv.fromColor = function(color);

Parameters

color
Type: System.Drawing..::..Color

See Also

ColorHsv Structure


GetHashCode Method

[image]

.NET Framework Class Library
ColorHsv..::..GetHashCode Method
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

See Also

ColorHsv Structure


ToColor Method

[image]

.NET Framework Class Library
ColorHsv..::..ToColor Method
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColor As Color
C#
public Color ToColor()
Visual C++
public:
Color ToColor()
JavaScript
function toColor();

See Also

ColorHsv Structure


ToColorHsl Method

[image]

.NET Framework Class Library
ColorHsv..::..ToColorHsl Method
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorHsl As ColorHsl
C#
public ColorHsl ToColorHsl()
Visual C++
public:
ColorHsl ToColorHsl()
JavaScript
function toColorHsl();

See Also

ColorHsv Structure


ToColorRgb Method

[image]

.NET Framework Class Library
ColorHsv..::..ToColorRgb Method
ColorHsv Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorRgb As ColorRgb
C#
public ColorRgb ToColorRgb()
Visual C++
public:
ColorRgb ToColorRgb()
JavaScript
function toColorRgb();

See Also

ColorHsv Structure


ToString Method

[image]

.NET Framework Class Library
ColorHsv..::..ToString Method
ColorHsv Structure See Also Send Feedback

Converts this ColorHsv structure to a human-readable string.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

String that consists of the AHSV component names and their values.

See Also

ColorHsv Structure


ColorMap Class

[image]

.NET Framework Class Library
ColorMap Class
Members See Also Send Feedback

칼라맵 차트의 특징을 정의합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class ColorMap
C#
[SerializableAttribute]
public class ColorMap
Visual C++
[SerializableAttribute]
public ref class ColorMap
JavaScript
Hippo.ColorMap = function();

Type.createClass(
    'Hippo.ColorMap');

Inheritance Hierarchy

System..::..Object
Hippo..::..ColorMap

See Also

ColorMap Members


ColorMap Members

[image] [image]

.NET Framework Class Library
ColorMap Members
ColorMap Class Constructors Methods Properties See Also Send Feedback

The ColorMap type exposes the following members.

Constructors

 | Name | Description
Public method | ColorMap | 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorSet | 색상셋을 설정하고 가져옵니다.
Public property | ColorSet2 | 색상셋을 설정하고 가져옵니다.
Public property | ColorSetArray | 색상셋 배열을 설정하고 가져옵니다.
Public property | DecimalPoint | 소수점을 설정하고 가져옵니다.
Public property | IsAutoColorSet | 색상셋을 자동으로 설정할 것인지 여부를 설정하고 가져옵니다.
Public property | MaxColorValue | 색상 값의 최대값을 설정하고 가져옵니다.
Public property | MinColorValue | 색상 값의 최소값을 설정하고 가져옵니다.

See Also

ColorMap Class


ColorMap Constructor

[image]

.NET Framework Class Library
ColorMap Constructor
ColorMap Class See Also Send Feedback

생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ColorMap()
Visual C++
public:
ColorMap()
JavaScript
Hippo.ColorMap = function();

See Also

ColorMap Class


ColorMap Methods

[image] [image]

.NET Framework Class Library
ColorMap Methods
ColorMap Class See Also Send Feedback

The ColorMap type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ColorMap Class


ColorMap Properties

[image] [image]

.NET Framework Class Library
ColorMap Properties
ColorMap Class See Also Send Feedback

The ColorMap type exposes the following members.

Properties

 | Name | Description
Public property | ColorSet | 색상셋을 설정하고 가져옵니다.
Public property | ColorSet2 | 색상셋을 설정하고 가져옵니다.
Public property | ColorSetArray | 색상셋 배열을 설정하고 가져옵니다.
Public property | DecimalPoint | 소수점을 설정하고 가져옵니다.
Public property | IsAutoColorSet | 색상셋을 자동으로 설정할 것인지 여부를 설정하고 가져옵니다.
Public property | MaxColorValue | 색상 값의 최대값을 설정하고 가져옵니다.
Public property | MinColorValue | 색상 값의 최소값을 설정하고 가져옵니다.

See Also

ColorMap Class


ColorSet Property

[image]

.NET Framework Class Library
ColorMap..::..ColorSet Property
ColorMap Class See Also Send Feedback

색상셋을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColorSet As SortedList(Of Double, Color)
    Get
    Set
C#
public SortedList<double, Color> ColorSet { get; set; }
Visual C++
public:
property SortedList<double, Color>^ ColorSet {
    SortedList<double, Color>^ get ();
    void set (SortedList<double, Color>^ value);
}
JavaScript
function get_colorSet();
function set_colorSet(value);

See Also

ColorMap Class


ColorSet2 Property

[image]

.NET Framework Class Library
ColorMap..::..ColorSet2 Property
ColorMap Class See Also Send Feedback

색상셋을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColorSet2 As SortedList(Of Integer, Color)
    Get
    Set
C#
public SortedList<int, Color> ColorSet2 { get; set; }
Visual C++
public:
property SortedList<int, Color>^ ColorSet2 {
    SortedList<int, Color>^ get ();
    void set (SortedList<int, Color>^ value);
}
JavaScript
function get_colorSet2();
function set_colorSet2(value);

See Also

ColorMap Class


ColorSetArray Property

[image]

.NET Framework Class Library
ColorMap..::..ColorSetArray Property
ColorMap Class See Also Send Feedback

색상셋 배열을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColorSetArray As Color()
    Get
    Set
C#
public Color[] ColorSetArray { get; set; }
Visual C++
public:
property array<Color>^ ColorSetArray {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
JavaScript
function get_colorSetArray();
function set_colorSetArray(value);

See Also

ColorMap Class


DecimalPoint Property

[image]

.NET Framework Class Library
ColorMap..::..DecimalPoint Property
ColorMap Class See Also Send Feedback

소수점을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DecimalPoint As Integer
    Get
    Set
C#
public int DecimalPoint { get; set; }
Visual C++
public:
property int DecimalPoint {
    int get ();
    void set (int value);
}
JavaScript
function get_decimalPoint();
function set_decimalPoint(value);

See Also

ColorMap Class


IsAutoColorSet Property

[image]

.NET Framework Class Library
ColorMap..::..IsAutoColorSet Property
ColorMap Class See Also Send Feedback

색상셋을 자동으로 설정할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsAutoColorSet As Boolean
    Get
    Set
C#
public bool IsAutoColorSet { get; set; }
Visual C++
public:
property bool IsAutoColorSet {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAutoColorSet();
function set_isAutoColorSet(value);

See Also

ColorMap Class


MaxColorValue Property

[image]

.NET Framework Class Library
ColorMap..::..MaxColorValue Property
ColorMap Class See Also Send Feedback

색상 값의 최대값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MaxColorValue As Integer
    Get
    Set
C#
public int MaxColorValue { get; set; }
Visual C++
public:
property int MaxColorValue {
    int get ();
    void set (int value);
}
JavaScript
function get_maxColorValue();
function set_maxColorValue(value);

See Also

ColorMap Class


MinColorValue Property

[image]

.NET Framework Class Library
ColorMap..::..MinColorValue Property
ColorMap Class See Also Send Feedback

색상 값의 최소값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MinColorValue As Integer
    Get
    Set
C#
public int MinColorValue { get; set; }
Visual C++
public:
property int MinColorValue {
    int get ();
    void set (int value);
}
JavaScript
function get_minColorValue();
function set_minColorValue(value);

See Also

ColorMap Class


ColorRgb Structure

[image]

.NET Framework Class Library
ColorRgb Structure
Members See Also Send Feedback

Represents an ARGB color.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Structure ColorRgb _
    Implements IEquatable(Of Color)
C#
[SerializableAttribute]
public struct ColorRgb : IEquatable<Color>
Visual C++
[SerializableAttribute]
public value class ColorRgb : IEquatable<Color>
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

ColorRgb Members


ColorRgb Members

[image] [image]

.NET Framework Class Library
ColorRgb Members
ColorRgb Structure Constructors Methods Operators Fields See Also Send Feedback

The ColorRgb type exposes the following members.

Constructors

 | Name | Description
Public method | ColorRgb(Double, Double, Double) | Initializes a new instance of the ColorRgb structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorRgb(Double, Double, Double, Double) | Initializes a new instance of the ColorRgb structure from the specified double values.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor(Color) |
 | FromColor(ColorHsl) |
 | FromColor(ColorHsv) |
 | FromColor(Double, Color) |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor | Returns a Color reprezentation of current instance.
Public method | ToColorHsl | Returns a ColorHsl reprezentation of current instance.
Public method | ToColorHsv | Returns a ColorHsv reprezentation of current instance.
Public method | ToString | Converts this ColorRgb structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality |
ExplicitNarrowingExplicitExplicitExplicit(ColorRgb to Color) |
ImplicitWideningImplicitImplicitImplicit(Color to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsl to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsv to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsv) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsl) |
Inequality |

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | B | Gets the blue component value.
Public field | G | Gets the green component value.
Public field | R | Gets the red component value.

See Also

ColorRgb Structure


ColorRgb Constructor

[image] [image]

.NET Framework Class Library
ColorRgb Constructor
ColorRgb Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorRgb(Double, Double, Double) | Initializes a new instance of the ColorRgb structure from the specified double values. The alpha value is implicitly 1 (fully opaque).
Public method | ColorRgb(Double, Double, Double, Double) | Initializes a new instance of the ColorRgb structure from the specified double values.

See Also

ColorRgb Structure
ColorRgb Members


ColorRgb Constructor (Double, Double, Double)

[image]

.NET Framework Class Library
ColorRgb Constructor (Double, Double, Double)
ColorRgb Structure See Also Send Feedback

Initializes a new instance of the ColorRgb structure from the specified double values. The alpha value is implicitly 1 (fully opaque).

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    red As Double, _
    green As Double, _
    blue As Double _
)
C#
public ColorRgb(
    double red,
    double green,
    double blue
)
Visual C++
public:
ColorRgb(
    double red,
    double green,
    double blue
)
JavaScript
Hippo.ColorRgb = function(red, green, blue);

Parameters

red
Type: System..::..Double
The red component value. Valid values are 0 through 1.
green
Type: System..::..Double
The green component value. Valid values are 0 through 1.
blue
Type: System..::..Double
The blue component value. Valid values are 0 through 1.

See Also

ColorRgb Structure
ColorRgb Overload


ColorRgb Constructor (Double, Double, Double, Double)

[image]

.NET Framework Class Library
ColorRgb Constructor (Double, Double, Double, Double)
ColorRgb Structure See Also Send Feedback

Initializes a new instance of the ColorRgb structure from the specified double values.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    alpha As Double, _
    red As Double, _
    green As Double, _
    blue As Double _
)
C#
public ColorRgb(
    double alpha,
    double red,
    double green,
    double blue
)
Visual C++
public:
ColorRgb(
    double alpha,
    double red,
    double green,
    double blue
)
JavaScript
Hippo.ColorRgb = function(alpha, red, green, blue);

Parameters

alpha
Type: System..::..Double
The alpha component value. Valid values are 0 through 1.
red
Type: System..::..Double
The red component value. Valid values are 0 through 1.
green
Type: System..::..Double
The green component value. Valid values are 0 through 1.
blue
Type: System..::..Double
The blue component value. Valid values are 0 through 1.

See Also

ColorRgb Structure
ColorRgb Overload


ColorRgb Fields

[image] [image]

.NET Framework Class Library
ColorRgb Fields
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Fields

 | Name | Description
Public field | A | Gets the alpha component value.
Public field | B | Gets the blue component value.
Public field | G | Gets the green component value.
Public field | R | Gets the red component value.

See Also

ColorRgb Structure


A Field

[image]

.NET Framework Class Library
ColorRgb..::..A Field
ColorRgb Structure See Also Send Feedback

Gets the alpha component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly A As Double
C#
public readonly double A
Visual C++
public:
initonly double A
JavaScript
a

See Also

ColorRgb Structure


B Field

[image]

.NET Framework Class Library
ColorRgb..::..B Field
ColorRgb Structure See Also Send Feedback

Gets the blue component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly B As Double
C#
public readonly double B
Visual C++
public:
initonly double B
JavaScript
b

See Also

ColorRgb Structure


G Field

[image]

.NET Framework Class Library
ColorRgb..::..G Field
ColorRgb Structure See Also Send Feedback

Gets the green component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly G As Double
C#
public readonly double G
Visual C++
public:
initonly double G
JavaScript
g

See Also

ColorRgb Structure


R Field

[image]

.NET Framework Class Library
ColorRgb..::..R Field
ColorRgb Structure See Also Send Feedback

Gets the red component value.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly R As Double
C#
public readonly double R
Visual C++
public:
initonly double R
JavaScript
r

See Also

ColorRgb Structure


ColorRgb Methods

[image] [image]

.NET Framework Class Library
ColorRgb Methods
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromColor(Color) |
 | FromColor(ColorHsl) |
 | FromColor(ColorHsv) |
 | FromColor(Double, Color) |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToColor | Returns a Color reprezentation of current instance.
Public method | ToColorHsl | Returns a ColorHsl reprezentation of current instance.
Public method | ToColorHsv | Returns a ColorHsv reprezentation of current instance.
Public method | ToString | Converts this ColorRgb structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

ColorRgb Structure


Equals Method

[image] [image]

.NET Framework Class Library
ColorRgb..::..Equals Method
ColorRgb Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Color) |
Public method | Equals(Object) | (Overrides ValueType..::..Equals(Object).)

See Also

ColorRgb Structure
ColorRgb Members


Equals Method (Color)

[image]

.NET Framework Class Library
ColorRgb..::..Equals Method (Color)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function Equals ( _
    other As Color _
) As Boolean
C#
public bool Equals(
    Color other
)
Visual C++
public:
virtual bool Equals(
    Color other
) sealed
JavaScript
function equals(other);

Parameters

other
Type: System.Drawing..::..Color

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

ColorRgb Structure
Equals Overload


Equals Method (Object)

[image]

.NET Framework Class Library
ColorRgb..::..Equals Method (Object)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object

See Also

ColorRgb Structure
Equals Overload


FromColor Method

[image] [image]

.NET Framework Class Library
ColorRgb..::..FromColor Method
ColorRgb Structure See Also Send Feedback

Overload List

Name | Description
FromColor(Color) |
FromColor(ColorHsl) |
FromColor(ColorHsv) |
FromColor(Double, Color) |

See Also

ColorRgb Structure
ColorRgb Members


FromColor Method (Color)

[image]

.NET Framework Class Library
ColorRgb..::..FromColor Method (Color)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    color As Color _
) As ColorRgb
C#
public static ColorRgb FromColor(
    Color color
)
Visual C++
public:
static ColorRgb FromColor(
    Color color
)
JavaScript
Hippo.ColorRgb.fromColor = function(color);

Parameters

color
Type: System.Drawing..::..Color

See Also

ColorRgb Structure
FromColor Overload


FromColor Method (ColorHsl)

[image]

.NET Framework Class Library
ColorRgb..::..FromColor Method (ColorHsl)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    hsl As ColorHsl _
) As ColorRgb
C#
public static ColorRgb FromColor(
    ColorHsl hsl
)
Visual C++
public:
static ColorRgb FromColor(
    ColorHsl hsl
)
JavaScript
Hippo.ColorRgb.fromColor = function(hsl);

Parameters

hsl
Type: Hippo..::..ColorHsl

See Also

ColorRgb Structure
FromColor Overload


FromColor Method (ColorHsv)

[image]

.NET Framework Class Library
ColorRgb..::..FromColor Method (ColorHsv)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    hsv As ColorHsv _
) As ColorRgb
C#
public static ColorRgb FromColor(
    ColorHsv hsv
)
Visual C++
public:
static ColorRgb FromColor(
    ColorHsv hsv
)
JavaScript
Hippo.ColorRgb.fromColor = function(hsv);

Parameters

hsv
Type: Hippo..::..ColorHsv

See Also

ColorRgb Structure
FromColor Overload


FromColor Method (Double, Color)

[image]

.NET Framework Class Library
ColorRgb..::..FromColor Method (Double, Color)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function FromColor ( _
    alpha As Double, _
    baseColor As Color _
) As ColorRgb
C#
public static ColorRgb FromColor(
    double alpha,
    Color baseColor
)
Visual C++
public:
static ColorRgb FromColor(
    double alpha,
    Color baseColor
)
JavaScript
Hippo.ColorRgb.fromColor = function(alpha, baseColor);

Parameters

alpha
Type: System..::..Double
baseColor
Type: System.Drawing..::..Color

See Also

ColorRgb Structure
FromColor Overload


GetHashCode Method

[image]

.NET Framework Class Library
ColorRgb..::..GetHashCode Method
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

See Also

ColorRgb Structure


ToColor Method

[image]

.NET Framework Class Library
ColorRgb..::..ToColor Method
ColorRgb Structure See Also Send Feedback

Returns a Color reprezentation of current instance.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColor As Color
C#
public Color ToColor()
Visual C++
public:
Color ToColor()
JavaScript
function toColor();

Return Value

A Color reprezentation of current instance

See Also

ColorRgb Structure


ToColorHsl Method

[image]

.NET Framework Class Library
ColorRgb..::..ToColorHsl Method
ColorRgb Structure See Also Send Feedback

Returns a ColorHsl reprezentation of current instance.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorHsl As ColorHsl
C#
public ColorHsl ToColorHsl()
Visual C++
public:
ColorHsl ToColorHsl()
JavaScript
function toColorHsl();

Return Value

A ColorHsl reprezentation of current instance

See Also

ColorRgb Structure


ToColorHsv Method

[image]

.NET Framework Class Library
ColorRgb..::..ToColorHsv Method
ColorRgb Structure See Also Send Feedback

Returns a ColorHsv reprezentation of current instance.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function ToColorHsv As ColorHsv
C#
public ColorHsv ToColorHsv()
Visual C++
public:
ColorHsv ToColorHsv()
JavaScript
function toColorHsv();

Return Value

A ColorHsv reprezentation of current instance

See Also

ColorRgb Structure


ToString Method

[image]

.NET Framework Class Library
ColorRgb..::..ToString Method
ColorRgb Structure See Also Send Feedback

Converts this ColorRgb structure to a human-readable string.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

String that consists of the ARGB component names and their values.

See Also

ColorRgb Structure


ColorRgb Operators and Type Conversions

[image] [image]

.NET Framework Class Library
ColorRgb Operators and Type Conversions
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Operators

Name | Description
Equality |
ExplicitNarrowingExplicitExplicitExplicit(ColorRgb to Color) |
ImplicitWideningImplicitImplicitImplicit(Color to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsl to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsv to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsv) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsl) |
Inequality |

See Also

ColorRgb Structure


Equality Operator

[image]

.NET Framework Class Library
ColorRgb..::..Equality Operator
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Operator = ( _
    c1 As ColorRgb, _
    c2 As ColorRgb _
) As Boolean
C#
public static bool operator ==(
    ColorRgb c1,
    ColorRgb c2
)
Visual C++
public:
static bool operator ==(
    ColorRgb c1,
    ColorRgb c2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

c1
Type: Hippo..::..ColorRgb
c2
Type: Hippo..::..ColorRgb

See Also

ColorRgb Structure


Explicit Conversion (ColorRgb to Color)

[image]

.NET Framework Class Library
ColorRgb ExplicitNarrowingExplicitExplicitExplicit Conversion (ColorRgb to Color)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Narrowing Operator CType ( _
    rgb As ColorRgb _
) As Color
C#
public static explicit operator Color (
    ColorRgb rgb
)
Visual C++
static explicit operator Color (
    ColorRgb rgb
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

rgb
Type: Hippo..::..ColorRgb

See Also

ColorRgb Structure


Implicit Conversion Operators

[image] [image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion Operators
ColorRgb Structure See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Color to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsl to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorHsv to ColorRgb) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsv) |
ImplicitWideningImplicitImplicitImplicit(ColorRgb to ColorHsl) |

See Also

ColorRgb Structure
ColorRgb Members


Implicit Conversion (Color to ColorRgb)

[image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion (Color to ColorRgb)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    color As Color _
) As ColorRgb
C#
public static implicit operator ColorRgb (
    Color color
)
Visual C++
static implicit operator ColorRgb (
    Color color
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

color
Type: System.Drawing..::..Color

See Also

ColorRgb Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (ColorHsl to ColorRgb)

[image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion (ColorHsl to ColorRgb)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    hsl As ColorHsl _
) As ColorRgb
C#
public static implicit operator ColorRgb (
    ColorHsl hsl
)
Visual C++
static implicit operator ColorRgb (
    ColorHsl hsl
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

hsl
Type: Hippo..::..ColorHsl

See Also

ColorRgb Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (ColorHsv to ColorRgb)

[image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion (ColorHsv to ColorRgb)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    hsv As ColorHsv _
) As ColorRgb
C#
public static implicit operator ColorRgb (
    ColorHsv hsv
)
Visual C++
static implicit operator ColorRgb (
    ColorHsv hsv
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

hsv
Type: Hippo..::..ColorHsv

See Also

ColorRgb Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (ColorRgb to ColorHsv)

[image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion (ColorRgb to ColorHsv)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    rgb As ColorRgb _
) As ColorHsv
C#
public static implicit operator ColorHsv (
    ColorRgb rgb
)
Visual C++
static implicit operator ColorHsv (
    ColorRgb rgb
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

rgb
Type: Hippo..::..ColorRgb

See Also

ColorRgb Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (ColorRgb to ColorHsl)

[image]

.NET Framework Class Library
ColorRgb ImplicitWideningImplicitImplicitImplicit Conversion (ColorRgb to ColorHsl)
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    rgb As ColorRgb _
) As ColorHsl
C#
public static implicit operator ColorHsl (
    ColorRgb rgb
)
Visual C++
static implicit operator ColorHsl (
    ColorRgb rgb
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

rgb
Type: Hippo..::..ColorRgb

See Also

ColorRgb Structure
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image]

.NET Framework Class Library
ColorRgb..::..Inequality Operator
ColorRgb Structure See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Operator <> ( _
    c1 As ColorRgb, _
    c2 As ColorRgb _
) As Boolean
C#
public static bool operator !=(
    ColorRgb c1,
    ColorRgb c2
)
Visual C++
public:
static bool operator !=(
    ColorRgb c1,
    ColorRgb c2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

c1
Type: Hippo..::..ColorRgb
c2
Type: Hippo..::..ColorRgb

See Also

ColorRgb Structure


ColorSchema Class

[image]

.NET Framework Class Library
ColorSchema Class
Members See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class ColorSchema
C#
public class ColorSchema
Visual C++
public ref class ColorSchema
JavaScript
Hippo.ColorSchema = function();

Type.createClass(
    'Hippo.ColorSchema');

Inheritance Hierarchy

System..::..Object
Hippo..::..ColorSchema

See Also

ColorSchema Members


ColorSchema Members

[image] [image]

.NET Framework Class Library
ColorSchema Members
ColorSchema Class Constructors Methods Fields Properties See Also Send Feedback

The ColorSchema type exposes the following members.

Constructors

 | Name | Description
Protected method | ColorSchema(array<Byte,2>[,](,)[,][,]) |
Public method | ColorSchema(Double) |
Public method | ColorSchema(Color) |
Public method | ColorSchema(array<Color>[]()[][]) |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
Autumn |
Colorcube |
Cool |
Copper |
Flag |
Hot |
Hsv |
Jet |
Lines |
Pink |
Prism |
Spring |
Summer |
Winter |

Properties

 | Name | Description
Public property | Item |
Public property | Length |
Public property | Schema |

See Also

ColorSchema Class


ColorSchema Constructor

[image] [image]

.NET Framework Class Library
ColorSchema Constructor
ColorSchema Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ColorSchema(array<Byte,2>[,](,)[,][,]) |
Public method | ColorSchema(Double) |
Public method | ColorSchema(Color) |
Public method | ColorSchema(array<Color>[]()[][]) |

See Also

ColorSchema Class
ColorSchema Members


ColorSchema Constructor (Byte[,])

[image]

.NET Framework Class Library
ColorSchema Constructor (array<Byte,2>[,](,)[,][,])
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Sub New ( _
    schema As Byte(,) _
)
C#
protected ColorSchema(
    byte[,] schema
)
Visual C++
protected:
ColorSchema(
    array<unsigned char,2>^ schema
)
JavaScript
Hippo.ColorSchema = function(schema);

Parameters

schema
Type: array< System..::..Byte ,2>[,](,)[,][,]

See Also

ColorSchema Class
ColorSchema Overload


ColorSchema Constructor (Double)

[image]

.NET Framework Class Library
ColorSchema Constructor (Double)
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    baseHue As Double _
)
C#
public ColorSchema(
    double baseHue
)
Visual C++
public:
ColorSchema(
    double baseHue
)
JavaScript
Hippo.ColorSchema = function(baseHue);

Parameters

baseHue
Type: System..::..Double

See Also

ColorSchema Class
ColorSchema Overload


ColorSchema Constructor (Color)

[image]

.NET Framework Class Library
ColorSchema Constructor (Color)
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    baseColor As Color _
)
C#
public ColorSchema(
    Color baseColor
)
Visual C++
public:
ColorSchema(
    Color baseColor
)
JavaScript
Hippo.ColorSchema = function(baseColor);

Parameters

baseColor
Type: System.Drawing..::..Color

See Also

ColorSchema Class
ColorSchema Overload


ColorSchema Constructor (Color[])

[image]

.NET Framework Class Library
ColorSchema Constructor (array<Color>[]()[][])
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    schema As Color() _
)
C#
public ColorSchema(
    Color[] schema
)
Visual C++
public:
ColorSchema(
    array<Color>^ schema
)
JavaScript
Hippo.ColorSchema = function(schema);

Parameters

schema
Type: array< System.Drawing..::..Color >[]()[][]

See Also

ColorSchema Class
ColorSchema Overload


ColorSchema Fields

[image] [image]

.NET Framework Class Library
ColorSchema Fields
ColorSchema Class See Also Send Feedback

The ColorSchema type exposes the following members.

Fields

Name | Description
Autumn |
Colorcube |
Cool |
Copper |
Flag |
Hot |
Hsv |
Jet |
Lines |
Pink |
Prism |
Spring |
Summer |
Winter |

See Also

ColorSchema Class


Autumn Field

[image]

.NET Framework Class Library
ColorSchema..::..Autumn Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Autumn As ColorSchema
C#
public static readonly ColorSchema Autumn
Visual C++
public:
static initonly ColorSchema^ Autumn
JavaScript
Hippo.ColorSchema.autumn

See Also

ColorSchema Class


Colorcube Field

[image]

.NET Framework Class Library
ColorSchema..::..Colorcube Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Colorcube As ColorSchema
C#
public static readonly ColorSchema Colorcube
Visual C++
public:
static initonly ColorSchema^ Colorcube
JavaScript
Hippo.ColorSchema.colorcube

See Also

ColorSchema Class


Cool Field

[image]

.NET Framework Class Library
ColorSchema..::..Cool Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Cool As ColorSchema
C#
public static readonly ColorSchema Cool
Visual C++
public:
static initonly ColorSchema^ Cool
JavaScript
Hippo.ColorSchema.cool

See Also

ColorSchema Class


Copper Field

[image]

.NET Framework Class Library
ColorSchema..::..Copper Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Copper As ColorSchema
C#
public static readonly ColorSchema Copper
Visual C++
public:
static initonly ColorSchema^ Copper
JavaScript
Hippo.ColorSchema.copper

See Also

ColorSchema Class


Flag Field

[image]

.NET Framework Class Library
ColorSchema..::..Flag Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Flag As ColorSchema
C#
public static readonly ColorSchema Flag
Visual C++
public:
static initonly ColorSchema^ Flag
JavaScript
Hippo.ColorSchema.flag

See Also

ColorSchema Class


Hot Field

[image]

.NET Framework Class Library
ColorSchema..::..Hot Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Hot As ColorSchema
C#
public static readonly ColorSchema Hot
Visual C++
public:
static initonly ColorSchema^ Hot
JavaScript
Hippo.ColorSchema.hot

See Also

ColorSchema Class


Hsv Field

[image]

.NET Framework Class Library
ColorSchema..::..Hsv Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Hsv As ColorSchema
C#
public static readonly ColorSchema Hsv
Visual C++
public:
static initonly ColorSchema^ Hsv
JavaScript
Hippo.ColorSchema.hsv

See Also

ColorSchema Class


Jet Field

[image]

.NET Framework Class Library
ColorSchema..::..Jet Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Jet As ColorSchema
C#
public static readonly ColorSchema Jet
Visual C++
public:
static initonly ColorSchema^ Jet
JavaScript
Hippo.ColorSchema.jet

See Also

ColorSchema Class


Lines Field

[image]

.NET Framework Class Library
ColorSchema..::..Lines Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Lines As ColorSchema
C#
public static readonly ColorSchema Lines
Visual C++
public:
static initonly ColorSchema^ Lines
JavaScript
Hippo.ColorSchema.lines

See Also

ColorSchema Class


Pink Field

[image]

.NET Framework Class Library
ColorSchema..::..Pink Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Pink As ColorSchema
C#
public static readonly ColorSchema Pink
Visual C++
public:
static initonly ColorSchema^ Pink
JavaScript
Hippo.ColorSchema.pink

See Also

ColorSchema Class


Prism Field

[image]

.NET Framework Class Library
ColorSchema..::..Prism Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Prism As ColorSchema
C#
public static readonly ColorSchema Prism
Visual C++
public:
static initonly ColorSchema^ Prism
JavaScript
Hippo.ColorSchema.prism

See Also

ColorSchema Class


Spring Field

[image]

.NET Framework Class Library
ColorSchema..::..Spring Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Spring As ColorSchema
C#
public static readonly ColorSchema Spring
Visual C++
public:
static initonly ColorSchema^ Spring
JavaScript
Hippo.ColorSchema.spring

See Also

ColorSchema Class


Summer Field

[image]

.NET Framework Class Library
ColorSchema..::..Summer Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Summer As ColorSchema
C#
public static readonly ColorSchema Summer
Visual C++
public:
static initonly ColorSchema^ Summer
JavaScript
Hippo.ColorSchema.summer

See Also

ColorSchema Class


Winter Field

[image]

.NET Framework Class Library
ColorSchema..::..Winter Field
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ReadOnly Winter As ColorSchema
C#
public static readonly ColorSchema Winter
Visual C++
public:
static initonly ColorSchema^ Winter
JavaScript
Hippo.ColorSchema.winter

See Also

ColorSchema Class


ColorSchema Methods

[image] [image]

.NET Framework Class Library
ColorSchema Methods
ColorSchema Class See Also Send Feedback

The ColorSchema type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ColorSchema Class


ColorSchema Properties

[image] [image]

.NET Framework Class Library
ColorSchema Properties
ColorSchema Class See Also Send Feedback

The ColorSchema type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | Length |
Public property | Schema |

See Also

ColorSchema Class


Item Property

[image]

.NET Framework Class Library
ColorSchema..::..Item Property
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Color
    Get
C#
public Color this[
    int index
] { get; }
Visual C++
public:
property Color default[int index] {
    Color get (int index);
}
JavaScript
function get_item(index);

Parameters

index
Type: System..::..Int32

See Also

ColorSchema Class


Length Property

[image]

.NET Framework Class Library
ColorSchema..::..Length Property
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property Length As Integer
    Get
C#
public int Length { get; }
Visual C++
public:
property int Length {
    int get ();
}
JavaScript
function get_length();

See Also

ColorSchema Class


Schema Property

[image]

.NET Framework Class Library
ColorSchema..::..Schema Property
ColorSchema Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property Schema As ReadOnlyCollection(Of Color)
    Get
C#
public ReadOnlyCollection<Color> Schema { get; }
Visual C++
public:
property ReadOnlyCollection<Color>^ Schema {
    ReadOnlyCollection<Color>^ get ();
}
JavaScript
function get_schema();

See Also

ColorSchema Class


ColorSystem Class

[image]

.NET Framework Class Library
ColorSystem Class
Members See Also Send Feedback

ColorSystem - 그래프의 컬러를 결정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class ColorSystem
C#
public class ColorSystem
Visual C++
public ref class ColorSystem
JavaScript
Hippo.ColorSystem = function();

Type.createClass(
    'Hippo.ColorSystem');

Inheritance Hierarchy

System..::..Object
Hippo..::..ColorSystem

See Also

ColorSystem Members


ColorSystem Members

[image] [image]

.NET Framework Class Library
ColorSystem Members
ColorSystem Class Constructors Methods See Also Send Feedback

The ColorSystem type exposes the following members.

Constructors

 | Name | Description
Public method | ColorSystem |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetGraphColor(GraphColorType, Color, Int32) | GetGraphColor
 | GetGraphColor(GraphColorType, PaletteType, Color, Int32, Int32) | GetGraphColor
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ColorSystem Class


ColorSystem Constructor

[image]

.NET Framework Class Library
ColorSystem Constructor
ColorSystem Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ColorSystem()
Visual C++
public:
ColorSystem()
JavaScript
Hippo.ColorSystem = function();

See Also

ColorSystem Class


ColorSystem Methods

[image] [image]

.NET Framework Class Library
ColorSystem Methods
ColorSystem Class See Also Send Feedback

The ColorSystem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetGraphColor(GraphColorType, Color, Int32) | GetGraphColor
 | GetGraphColor(GraphColorType, PaletteType, Color, Int32, Int32) | GetGraphColor
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ColorSystem Class


GetGraphColor Method

[image] [image]

.NET Framework Class Library
ColorSystem..::..GetGraphColor Method
ColorSystem Class See Also Send Feedback

Overload List

Name | Description
GetGraphColor(GraphColorType, Color, Int32) | GetGraphColor
GetGraphColor(GraphColorType, PaletteType, Color, Int32, Int32) | GetGraphColor

See Also

ColorSystem Class
ColorSystem Members


GetGraphColor Method (GraphColorType, Color, Int32)

[image]

.NET Framework Class Library
ColorSystem..::..GetGraphColor Method (GraphColorType, Color, Int32)
ColorSystem Class See Also Send Feedback

GetGraphColor

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetGraphColor ( _
    colorType As GraphColorType, _
    MainColor As Color, _
    Transparency As Integer _
) As Color
C#
public static Color GetGraphColor(
    GraphColorType colorType,
    Color MainColor,
    int Transparency
)
Visual C++
public:
static Color GetGraphColor(
    GraphColorType colorType,
    Color MainColor,
    int Transparency
)
JavaScript
Hippo.ColorSystem.getGraphColor = function(colorType, MainColor, Transparency);

Parameters

colorType
Type: Hippo..::..GraphColorType
MainColor
Type: System.Drawing..::..Color
Transparency
Type: System..::..Int32

Return Value

See Also

ColorSystem Class
GetGraphColor Overload


GetGraphColor Method (GraphColorType, PaletteType, Color, Int32, Int32)

[image]

.NET Framework Class Library
ColorSystem..::..GetGraphColor Method (GraphColorType, PaletteType, Color, Int32, Int32)
ColorSystem Class See Also Send Feedback

GetGraphColor

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function GetGraphColor ( _
    colorType As GraphColorType, _
    paletteType As PaletteType, _
    MainColor As Color, _
    Transparency As Integer, _
    ColorIndex As Integer _
) As Color
C#
public static Color GetGraphColor(
    GraphColorType colorType,
    PaletteType paletteType,
    Color MainColor,
    int Transparency,
    int ColorIndex
)
Visual C++
public:
static Color GetGraphColor(
    GraphColorType colorType,
    PaletteType paletteType,
    Color MainColor,
    int Transparency,
    int ColorIndex
)
JavaScript
Hippo.ColorSystem.getGraphColor = function(colorType, paletteType, MainColor, Transparency, ColorIndex);

Parameters

colorType
Type: Hippo..::..GraphColorType
paletteType
Type: Hippo..::..PaletteType
MainColor
Type: System.Drawing..::..Color
Transparency
Type: System..::..Int32
ColorIndex
Type: System..::..Int32

Return Value

See Also

ColorSystem Class
GetGraphColor Overload


Column Class

[image]

.NET Framework Class Library
Column Class
Members See Also Send Feedback

Column 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Column
C#
[SerializableAttribute]
public class Column
Visual C++
[SerializableAttribute]
public ref class Column
JavaScript
Hippo.Column = function();

Type.createClass(
    'Hippo.Column');

Remarks

히포차트 내에서 막대 모양을 의미하는 코어 클래스입니다. Column chart 에서 굵기 설정 등에 사용됩니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Column

See Also

Column Members


Column Members

[image] [image]

.NET Framework Class Library
Column Members
Column Class Constructors Methods Properties See Also Send Feedback

The Column type exposes the following members.

Constructors

 | Name | Description
Public method | Column | Column 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignType | 컬럼 디자인 종류를 가져오고 설정합니다.
Public property | ImagesBarPath | 컬럼 바 이미지를 가져오고 설정합니다.
Public property | Line | 컬럼의 외곽 라인 디자인을 설정하고 가져옵니다.
Public property | Width | 컬럼 넓이를 가져오고 설정합니다. 컬럼의 넓이는 기본적으로 ColumnWidthType 열거형으로 지정을 할 수 있으며 custom 으로 설정할 경우 디테일한 값으로 설정 가능합니다.
Public property | WidthType | 컬럼의 넓이를 가져오고 설정합니다.

See Also

Column Class


Column Constructor

[image]

.NET Framework Class Library
Column Constructor
Column Class See Also Send Feedback

Column 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Column()
Visual C++
public:
Column()
JavaScript
Hippo.Column = function();

See Also

Column Class


Column Methods

[image] [image]

.NET Framework Class Library
Column Methods
Column Class See Also Send Feedback

The Column type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Column Class


Column Properties

[image] [image]

.NET Framework Class Library
Column Properties
Column Class See Also Send Feedback

The Column type exposes the following members.

Properties

 | Name | Description
Public property | DesignType | 컬럼 디자인 종류를 가져오고 설정합니다.
Public property | ImagesBarPath | 컬럼 바 이미지를 가져오고 설정합니다.
Public property | Line | 컬럼의 외곽 라인 디자인을 설정하고 가져옵니다.
Public property | Width | 컬럼 넓이를 가져오고 설정합니다. 컬럼의 넓이는 기본적으로 ColumnWidthType 열거형으로 지정을 할 수 있으며 custom 으로 설정할 경우 디테일한 값으로 설정 가능합니다.
Public property | WidthType | 컬럼의 넓이를 가져오고 설정합니다.

See Also

Column Class


DesignType Property

[image]

.NET Framework Class Library
Column..::..DesignType Property
Column Class See Also Send Feedback

컬럼 디자인 종류를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DesignType As AreaDesignType
    Get
    Set
C#
public AreaDesignType DesignType { get; set; }
Visual C++
public:
property AreaDesignType DesignType {
    AreaDesignType get ();
    void set (AreaDesignType value);
}
JavaScript
function get_designType();
function set_designType(value);

See Also

Column Class


ImagesBarPath Property

[image]

.NET Framework Class Library
Column..::..ImagesBarPath Property
Column Class See Also Send Feedback

컬럼 바 이미지를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ImagesBarPath As String
    Get
    Set
C#
public string ImagesBarPath { get; set; }
Visual C++
public:
property String^ ImagesBarPath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_imagesBarPath();
function set_imagesBarPath(value);

See Also

Column Class


Line Property

[image]

.NET Framework Class Library
Column..::..Line Property
Column Class See Also Send Feedback

컬럼의 외곽 라인 디자인을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Line As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line Line { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

Column Class


Width Property

[image]

.NET Framework Class Library
Column..::..Width Property
Column Class See Also Send Feedback

컬럼 넓이를 가져오고 설정합니다. 컬럼의 넓이는 기본적으로 ColumnWidthType 열거형으로 지정을 할 수 있으며 custom 으로 설정할 경우 디테일한 값으로 설정 가능합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Single
    Get
    Set
C#
public float Width { get; set; }
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}
JavaScript
function get_width();
function set_width(value);

See Also

Column Class


WidthType Property

[image]

.NET Framework Class Library
Column..::..WidthType Property
Column Class See Also Send Feedback

컬럼의 넓이를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property WidthType As ColumnWidthType
    Get
    Set
C#
public ColumnWidthType WidthType { get; set; }
Visual C++
public:
property ColumnWidthType WidthType {
    ColumnWidthType get ();
    void set (ColumnWidthType value);
}
JavaScript
function get_widthType();
function set_widthType(value);

See Also

Column Class


ColumnRangeType Enumeration

[image]

.NET Framework Class Library
ColumnRangeType Enumeration
See Also Send Feedback

컬럼 차트의 Range 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ColumnRangeType
C#
public enum ColumnRangeType
Visual C++
public enum class ColumnRangeType
JavaScript
Hippo.ColumnRangeType = function();
Hippo.ColumnRangeType.createEnum('Hippo.ColumnRangeType', false);

Members

Member name | Description
Default |
Range |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ColumnWidthType Enumeration

[image]

.NET Framework Class Library
ColumnWidthType Enumeration
See Also Send Feedback

컬럼의 굵기 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ColumnWidthType
C#
public enum ColumnWidthType
Visual C++
public enum class ColumnWidthType
JavaScript
Hippo.ColumnWidthType = function();
Hippo.ColumnWidthType.createEnum('Hippo.ColumnWidthType', false);

Members

Member name | Description
Default |
Dynamic |
Tight |
Custom |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


CompiledFunction Delegate

[image]

.NET Framework Class Library
CompiledFunction Delegate
See Also Send Feedback

Represents a function that was compiled at runtime.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Delegate Function CompiledFunction ( _
    ParamArray x As Double() _
) As Double
C#
public delegate double CompiledFunction(
    params double[] x
)
Visual C++
public delegate double CompiledFunction(
    ... array<double>^ x
)
JavaScript
function(... x);

Parameters

x
Type: array< System..::..Double >[]()[][]
Function input parameter.

Return Value

Result value of function.

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


CoordinateType Enumeration

[image]

.NET Framework Class Library
CoordinateType Enumeration
See Also Send Feedback

좌표 성질 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration CoordinateType
C#
public enum CoordinateType
Visual C++
public enum class CoordinateType
JavaScript
Hippo.CoordinateType = function();
Hippo.CoordinateType.createEnum('Hippo.CoordinateType', false);

Members

Member name | Description
Coordinate |
UnCoordinate |
Coordinate3D |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


CoordinativeDirection Enumeration

[image]

.NET Framework Class Library
CoordinativeDirection Enumeration
See Also Send Feedback

그래프의 축의 방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration CoordinativeDirection
C#
public enum CoordinativeDirection
Visual C++
public enum class CoordinativeDirection
JavaScript
Hippo.CoordinativeDirection = function();
Hippo.CoordinativeDirection.createEnum('Hippo.CoordinativeDirection', false);

Members

Member name | Description
Vertical |
Horizontal |
None |

Remarks

컬럼 차트류는 Vertical, 바 차트류 Horizontal

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


CultureInfo Class

[image]

.NET Framework Class Library
CultureInfo Class
Members Example See Also Send Feedback

문화권 정보 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class CultureInfo
C#
[SerializableAttribute]
public class CultureInfo
Visual C++
[SerializableAttribute]
public ref class CultureInfo
JavaScript
Hippo.CultureInfo = function();

Type.createClass(
    'Hippo.CultureInfo');

Remarks

차트에 표시되는 날짜, 화페 등의 표시를 문화권 정보에 맞게 표시할 수 있습니다. (Name 속성의 기본값은 "ko-KR" 입니다.)

Examples

Copy image Copy Code
                slist.CultureInfo.Name = "en-US";

Inheritance Hierarchy

System..::..Object
Hippo..::..CultureInfo

See Also

CultureInfo Members


CultureInfo Members

[image] [image]

.NET Framework Class Library
CultureInfo Members
CultureInfo Class Constructors Methods Properties See Also Send Feedback

The CultureInfo type exposes the following members.

Constructors

 | Name | Description
Public method | CultureInfo | CultureInfo 의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | 문화권 정보 이름을 설정하고 가져옵니다.

See Also

CultureInfo Class


CultureInfo Constructor

[image]

.NET Framework Class Library
CultureInfo Constructor
CultureInfo Class See Also Send Feedback

CultureInfo 의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public CultureInfo()
Visual C++
public:
CultureInfo()
JavaScript
Hippo.CultureInfo = function();

See Also

CultureInfo Class


CultureInfo Methods

[image] [image]

.NET Framework Class Library
CultureInfo Methods
CultureInfo Class See Also Send Feedback

The CultureInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CultureInfo Class


CultureInfo Properties

[image] [image]

.NET Framework Class Library
CultureInfo Properties
CultureInfo Class See Also Send Feedback

The CultureInfo type exposes the following members.

Properties

 | Name | Description
Public property | Name | 문화권 정보 이름을 설정하고 가져옵니다.

See Also

CultureInfo Class


Name Property

[image]

.NET Framework Class Library
CultureInfo..::..Name Property
CultureInfo Class See Also Send Feedback

문화권 정보 이름을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CultureInfo Class


DataSourceType Enumeration

[image]

.NET Framework Class Library
DataSourceType Enumeration
See Also Send Feedback

히포엔진에 사용할 데이터소스 종류

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration DataSourceType
C#
public enum DataSourceType
Visual C++
public enum class DataSourceType
JavaScript
Hippo.DataSourceType = function();
Hippo.DataSourceType.createEnum('Hippo.DataSourceType', false);

Members

Member name | Description
Default |
Access |
Excel |
Xml |
Oracle |
MySql |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


DateTimeLabelType Enumeration

[image]

.NET Framework Class Library
DateTimeLabelType Enumeration
See Also Send Feedback

날짜형 축의 라벨리스트를 기간으로 정의. 히포차트 4.3 버전에서 추가된 열거형입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration DateTimeLabelType
C#
public enum DateTimeLabelType
Visual C++
public enum class DateTimeLabelType
JavaScript
Hippo.DateTimeLabelType = function();
Hippo.DateTimeLabelType.createEnum('Hippo.DateTimeLabelType', false);

Members

Member name | Description
None |
Day |
Week |
Month |
Year |
DayOfWeek |
WeekOfYear |
Quarter |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


DateType Enumeration

[image]

.NET Framework Class Library
DateType Enumeration
See Also Send Feedback

날짜형 간트차트의 날짜 형태

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration DateType
C#
public enum DateType
Visual C++
public enum class DateType
JavaScript
Hippo.DateType = function();
Hippo.DateType.createEnum('Hippo.DateType', false);

Members

Member name | Description
Day |
Minute |
Second |
MilliSecond |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Descriptions Class

[image]

.NET Framework Class Library
Descriptions Class
Members Example See Also Send Feedback

Description(설명) 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Descriptions
C#
[SerializableAttribute]
public class Descriptions
Visual C++
[SerializableAttribute]
public ref class Descriptions
JavaScript
Hippo.Descriptions = function();

Type.createClass(
    'Hippo.Descriptions');

Remarks

좌표평면을 4등분하여 특정 공간에 차트에 대한 설명 문구를 삽입할 수 있습니다.

Examples

Copy image Copy Code
                    sList.Description.Label.Text = "차트에대한 설명";

Inheritance Hierarchy

System..::..Object
Hippo..::..Descriptions

See Also

Descriptions Members


Descriptions Members

[image] [image]

.NET Framework Class Library
Descriptions Members
Descriptions Class Constructors Methods Properties See Also Send Feedback

The Descriptions type exposes the following members.

Constructors

 | Name | Description
Public method | Descriptions | Descriptions 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Label | Description 의 Label을 가져오고 설정합니다.
Public property | Left | Description 의 사용자정의 위치 Left 를 설정하고 가져옵니다.
Public property | Top | Description 의 사용자정의 위치 Top 를 설정하고 가져옵니다.
Public property | XDirection | Description의 좌우 위치를 가져오고 설정합니다.
Public property | YDirection | Description의 아래 위 위치를 가져오고 설정합니다.

See Also

Descriptions Class


Descriptions Constructor

[image]

.NET Framework Class Library
Descriptions Constructor
Descriptions Class See Also Send Feedback

Descriptions 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Descriptions()
Visual C++
public:
Descriptions()
JavaScript
Hippo.Descriptions = function();

See Also

Descriptions Class


Descriptions Methods

[image] [image]

.NET Framework Class Library
Descriptions Methods
Descriptions Class See Also Send Feedback

The Descriptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Descriptions Class


Descriptions Properties

[image] [image]

.NET Framework Class Library
Descriptions Properties
Descriptions Class See Also Send Feedback

The Descriptions type exposes the following members.

Properties

 | Name | Description
Public property | Label | Description 의 Label을 가져오고 설정합니다.
Public property | Left | Description 의 사용자정의 위치 Left 를 설정하고 가져옵니다.
Public property | Top | Description 의 사용자정의 위치 Top 를 설정하고 가져옵니다.
Public property | XDirection | Description의 좌우 위치를 가져오고 설정합니다.
Public property | YDirection | Description의 아래 위 위치를 가져오고 설정합니다.

See Also

Descriptions Class


Label Property

[image]

.NET Framework Class Library
Descriptions..::..Label Property
Descriptions Class See Also Send Feedback

Description 의 Label을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Descriptions Class


Left Property

[image]

.NET Framework Class Library
Descriptions..::..Left Property
Descriptions Class See Also Send Feedback

Description 의 사용자정의 위치 Left 를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Left As Single
    Get
    Set
C#
public float Left { get; set; }
Visual C++
public:
property float Left {
    float get ();
    void set (float value);
}
JavaScript
function get_left();
function set_left(value);

See Also

Descriptions Class


Top Property

[image]

.NET Framework Class Library
Descriptions..::..Top Property
Descriptions Class See Also Send Feedback

Description 의 사용자정의 위치 Top 를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Top As Single
    Get
    Set
C#
public float Top { get; set; }
Visual C++
public:
property float Top {
    float get ();
    void set (float value);
}
JavaScript
function get_top();
function set_top(value);

See Also

Descriptions Class


XDirection Property

[image]

.NET Framework Class Library
Descriptions..::..XDirection Property
Descriptions Class See Also Send Feedback

Description의 좌우 위치를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XDirection As AxisDirection
    Get
    Set
C#
public AxisDirection XDirection { get; set; }
Visual C++
public:
property AxisDirection XDirection {
    AxisDirection get ();
    void set (AxisDirection value);
}
JavaScript
function get_xDirection();
function set_xDirection(value);

See Also

Descriptions Class


YDirection Property

[image]

.NET Framework Class Library
Descriptions..::..YDirection Property
Descriptions Class See Also Send Feedback

Description의 아래 위 위치를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YDirection As AxisDirection
    Get
    Set
C#
public AxisDirection YDirection { get; set; }
Visual C++
public:
property AxisDirection YDirection {
    AxisDirection get ();
    void set (AxisDirection value);
}
JavaScript
function get_yDirection();
function set_yDirection(value);

See Also

Descriptions Class


ErrorBarType Enumeration

[image]

.NET Framework Class Library
ErrorBarType Enumeration
See Also Send Feedback

에러바차트 종류

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ErrorBarType
C#
public enum ErrorBarType
Visual C++
public enum class ErrorBarType
JavaScript
Hippo.ErrorBarType = function();
Hippo.ErrorBarType.createEnum('Hippo.ErrorBarType', false);

Members

Member name | Description
StandardError |
StandardDeviation |
Percentage |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


EventLogHelper Class

[image]

.NET Framework Class Library
EventLogHelper Class
Members See Also Send Feedback

이벤트로그 등록 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class EventLogHelper
C#
public class EventLogHelper
Visual C++
public ref class EventLogHelper
JavaScript
Hippo.EventLogHelper = function();

Type.createClass(
    'Hippo.EventLogHelper');

Inheritance Hierarchy

System..::..Object
Hippo..::..EventLogHelper

See Also

EventLogHelper Members


EventLogHelper Members

[image] [image]

.NET Framework Class Library
EventLogHelper Members
EventLogHelper Class Constructors Methods Properties See Also Send Feedback

The EventLogHelper type exposes the following members.

Constructors

 | Name | Description
Public method | EventLogHelper |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterEventLog | 이벤트 로그를 등록합니다.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EventLogMessage | 이벤트 로그 메세지

See Also

EventLogHelper Class


EventLogHelper Constructor

[image]

.NET Framework Class Library
EventLogHelper Constructor
EventLogHelper Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public EventLogHelper()
Visual C++
public:
EventLogHelper()
JavaScript
Hippo.EventLogHelper = function();

See Also

EventLogHelper Class


EventLogHelper Methods

[image] [image]

.NET Framework Class Library
EventLogHelper Methods
EventLogHelper Class See Also Send Feedback

The EventLogHelper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterEventLog | 이벤트 로그를 등록합니다.
Public method | ToString | (Inherited from Object.)

See Also

EventLogHelper Class


RegisterEventLog Method

[image]

.NET Framework Class Library
EventLogHelper..::..RegisterEventLog Method
EventLogHelper Class See Also Send Feedback

이벤트 로그를 등록합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function RegisterEventLog ( _
    logname As String, _
    sourceName As String, _
    message As String, _
    type As EventLogEntryType _
) As Boolean
C#
public bool RegisterEventLog(
    string logname,
    string sourceName,
    string message,
    EventLogEntryType type
)
Visual C++
public:
bool RegisterEventLog(
    String^ logname,
    String^ sourceName,
    String^ message,
    EventLogEntryType type
)
JavaScript
function registerEventLog(logname, sourceName, message, type);

Parameters

logname
Type: System..::..String
로그이름
sourceName
Type: System..::..String
소스이름
message
Type: System..::..String
내용
type
Type: System.Diagnostics..::..EventLogEntryType
EventLogEntryType

See Also

EventLogHelper Class


EventLogHelper Properties

[image] [image]

.NET Framework Class Library
EventLogHelper Properties
EventLogHelper Class See Also Send Feedback

The EventLogHelper type exposes the following members.

Properties

 | Name | Description
Public property | EventLogMessage | 이벤트 로그 메세지

See Also

EventLogHelper Class


EventLogMessage Property

[image]

.NET Framework Class Library
EventLogHelper..::..EventLogMessage Property
EventLogHelper Class See Also Send Feedback

이벤트 로그 메세지

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property EventLogMessage As String
    Get
C#
public string EventLogMessage { get; }
Visual C++
public:
property String^ EventLogMessage {
    String^ get ();
}
JavaScript
function get_eventLogMessage();

See Also

EventLogHelper Class


FigureFormat Enumeration

[image]

.NET Framework Class Library
FigureFormat Enumeration
See Also Send Feedback

숫자 포맷

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration FigureFormat
C#
public enum FigureFormat
Visual C++
public enum class FigureFormat
JavaScript
Hippo.FigureFormat = function();
Hippo.FigureFormat.createEnum('Hippo.FigureFormat', false);

Members

Member name | Description
None |
Number |
Percent |
Currency |
FixedPoint |
Exponential |
Custom |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Figures Class

[image]

.NET Framework Class Library
Figures Class
Members See Also Send Feedback

중요 고정값 관리 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Figures
C#
public class Figures
Visual C++
public ref class Figures
JavaScript
Hippo.Figures = function();

Type.createClass(
    'Hippo.Figures');

Inheritance Hierarchy

System..::..Object
Hippo..::..Figures

See Also

Figures Members


Figures Members

[image] [image]

.NET Framework Class Library
Figures Members
Figures Class Constructors Methods Fields See Also Send Feedback

The Figures type exposes the following members.

Constructors

 | Name | Description
Public method | Figures |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
ColumnValueRecWidth | 컬럼 차트에서 벨류렉텡글의 넓이 한계값
Coordinate3DWidth | 좌표 타입 그래프의 3D 를 위해 루프를 도는 수
CoordinateRecRightEmpty | 좌표 타입 그래프의 오른쪽 고정 여백
CoordinateRecTopEmpty | 좌표 타입 그래프의 위 고정 여백
CoordinateXtextLimitEmpty | x 좌표 부분 텍스트 들어가는 공간의 최소값
CoordinateXtextMaxEmpty | x 좌표 부분 텍스트 들어가는 공간의 최대값
CoordinateYnameEmpty | y 좌표 제목 부분 가로 넓이
CoordinateYnameMinEmpty | y 좌표 제목 부분이 공백일경우 넓이
DefalutWidth | 차트 기본 가로길이
DefaultCoordinateWidth | 좌표 타입 그래프 모눈 라인 넓이
DefaultHeight | 차트 기본 세로길이
DefaultLimitWidthCoordinate | 그래프를 그리는 최소한의 공간(좌표)
DefaultLimitWidthUncoordinate | 그래프를 그리는 최소한의 공간(비좌표)
DefaultLimitWidthUncoordinateGauge | 그래프를 그리는 최소한의 공간(게이지)
DefaultLineWidth | 좌표 타입 그래프 x, y 축 라인과 대표값 굵기
GaugeMaxiumHeight | 게이지 짧은 쪽 넓이 최대값
GaugeMinimumHeight | 게이지 짧은 쪽 넓이 최소값
HippoFontFamily | 히포차트 대표 폰트 패밀리
InnerPadding | 가장 바깥 큰 사각형의 바로 안쪽 패딩
InnerVSGraphAreaSpan | InnerRectangle 과 내부 그래프 영역과의 공간
LegendBoxHeight | 범례 아이템 한칸 높이
LegendBoxWidth | 범례 가로 길이 고정
LegendHeaderHeight | 범례 헤더 높이
LineChartCurvedTention | 라인 그래프 곡선일 경우 장력
LineChartDefaultTention | 라인 그래프 직선일 경우 장력(너무 직선으로 그리면 뽀죡해지는 문제 발생)
LogoSpareEmpty | 맨 하단 로고 없을시 최종 남아있을 공간
MaximumMargins | 차트 최대 마진 값
MaxLineWidth | Line 객체의 최대 굵기
Pie3DWidth | 파이 그래프 3D 를 위해 루프를 도는 수. 4.3 버전에서 28 ==> 15 로 본경되었습니다.
PieForTextArea | 파이 그래프 소수 % 텍스트를 쓰기 위한 공간을 위해
PieMargins | 파이 그래프의 여백(마진)
PiePercentLineDisplayvalue | 수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.(기본값 :5%)
PylamidEmptyArea | 피라미드 공백
PylamidMinPercent | 피라미드 차트 라인 빼기 위한 최소 퍼센트값
PylamidMinTextHeight | 피라미드 차트 라인 빼기 위한 최소 렉텡글 높이
PylamidMinTextwidth | 피라미드 차트 라인 빼기 위한 최소 넓이
ScrollDefaultWidth | 스크롤 차트인 경우 X축 간격 기본 값
SplineChartDefaultTention | 스플라인 차트 장력 기본값
StarChartEmpty | 방사형 차트 항목 이름 공간
StarChartInnerCircleAlpha | 방사형 차트 내부 영역 투명도
StarChartItemTextLimitLength | 방사형 차트 항목 이름 제한 길이
StarItemViewLimitCount | 방사형 차트 항목 이름 그리는 개수는 36개, 그 이상 그리면 너무 복잡해지므로 다른 조치취함.
StockColumnValueRecWidth | w주식 차트에서 벨류렉텡글의 넓이 한계값
TitleSpareEmpty | 타이틀 부분의 약간의 여유 공간
xTitlebHeight | x 축...
XunitLimitPixel | 그래프 그릴 시 x 아이템이 너무 많을 경우를 지칭하는 값

See Also

Figures Class


Figures Constructor

[image]

.NET Framework Class Library
Figures Constructor
Figures Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Figures()
Visual C++
public:
Figures()
JavaScript
Hippo.Figures = function();

See Also

Figures Class


Figures Fields

[image] [image]

.NET Framework Class Library
Figures Fields
Figures Class See Also Send Feedback

The Figures type exposes the following members.

Fields

Name | Description
ColumnValueRecWidth | 컬럼 차트에서 벨류렉텡글의 넓이 한계값
Coordinate3DWidth | 좌표 타입 그래프의 3D 를 위해 루프를 도는 수
CoordinateRecRightEmpty | 좌표 타입 그래프의 오른쪽 고정 여백
CoordinateRecTopEmpty | 좌표 타입 그래프의 위 고정 여백
CoordinateXtextLimitEmpty | x 좌표 부분 텍스트 들어가는 공간의 최소값
CoordinateXtextMaxEmpty | x 좌표 부분 텍스트 들어가는 공간의 최대값
CoordinateYnameEmpty | y 좌표 제목 부분 가로 넓이
CoordinateYnameMinEmpty | y 좌표 제목 부분이 공백일경우 넓이
DefalutWidth | 차트 기본 가로길이
DefaultCoordinateWidth | 좌표 타입 그래프 모눈 라인 넓이
DefaultHeight | 차트 기본 세로길이
DefaultLimitWidthCoordinate | 그래프를 그리는 최소한의 공간(좌표)
DefaultLimitWidthUncoordinate | 그래프를 그리는 최소한의 공간(비좌표)
DefaultLimitWidthUncoordinateGauge | 그래프를 그리는 최소한의 공간(게이지)
DefaultLineWidth | 좌표 타입 그래프 x, y 축 라인과 대표값 굵기
GaugeMaxiumHeight | 게이지 짧은 쪽 넓이 최대값
GaugeMinimumHeight | 게이지 짧은 쪽 넓이 최소값
HippoFontFamily | 히포차트 대표 폰트 패밀리
InnerPadding | 가장 바깥 큰 사각형의 바로 안쪽 패딩
InnerVSGraphAreaSpan | InnerRectangle 과 내부 그래프 영역과의 공간
LegendBoxHeight | 범례 아이템 한칸 높이
LegendBoxWidth | 범례 가로 길이 고정
LegendHeaderHeight | 범례 헤더 높이
LineChartCurvedTention | 라인 그래프 곡선일 경우 장력
LineChartDefaultTention | 라인 그래프 직선일 경우 장력(너무 직선으로 그리면 뽀죡해지는 문제 발생)
LogoSpareEmpty | 맨 하단 로고 없을시 최종 남아있을 공간
MaximumMargins | 차트 최대 마진 값
MaxLineWidth | Line 객체의 최대 굵기
Pie3DWidth | 파이 그래프 3D 를 위해 루프를 도는 수. 4.3 버전에서 28 ==> 15 로 본경되었습니다.
PieForTextArea | 파이 그래프 소수 % 텍스트를 쓰기 위한 공간을 위해
PieMargins | 파이 그래프의 여백(마진)
PiePercentLineDisplayvalue | 수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.(기본값 :5%)
PylamidEmptyArea | 피라미드 공백
PylamidMinPercent | 피라미드 차트 라인 빼기 위한 최소 퍼센트값
PylamidMinTextHeight | 피라미드 차트 라인 빼기 위한 최소 렉텡글 높이
PylamidMinTextwidth | 피라미드 차트 라인 빼기 위한 최소 넓이
ScrollDefaultWidth | 스크롤 차트인 경우 X축 간격 기본 값
SplineChartDefaultTention | 스플라인 차트 장력 기본값
StarChartEmpty | 방사형 차트 항목 이름 공간
StarChartInnerCircleAlpha | 방사형 차트 내부 영역 투명도
StarChartItemTextLimitLength | 방사형 차트 항목 이름 제한 길이
StarItemViewLimitCount | 방사형 차트 항목 이름 그리는 개수는 36개, 그 이상 그리면 너무 복잡해지므로 다른 조치취함.
StockColumnValueRecWidth | w주식 차트에서 벨류렉텡글의 넓이 한계값
TitleSpareEmpty | 타이틀 부분의 약간의 여유 공간
xTitlebHeight | x 축...
XunitLimitPixel | 그래프 그릴 시 x 아이템이 너무 많을 경우를 지칭하는 값

See Also

Figures Class


ColumnValueRecWidth Field

[image]

.NET Framework Class Library
Figures..::..ColumnValueRecWidth Field
Figures Class See Also Send Feedback

컬럼 차트에서 벨류렉텡글의 넓이 한계값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ColumnValueRecWidth As Integer
C#
public static int ColumnValueRecWidth
Visual C++
public:
static int ColumnValueRecWidth
JavaScript
Hippo.Figures.columnValueRecWidth

See Also

Figures Class


Coordinate3DWidth Field

[image]

.NET Framework Class Library
Figures..::..Coordinate3DWidth Field
Figures Class See Also Send Feedback

좌표 타입 그래프의 3D 를 위해 루프를 도는 수

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Coordinate3DWidth As Integer
C#
public static int Coordinate3DWidth
Visual C++
public:
static int Coordinate3DWidth
JavaScript
Hippo.Figures.coordinate3DWidth

See Also

Figures Class


CoordinateRecRightEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateRecRightEmpty Field
Figures Class See Also Send Feedback

좌표 타입 그래프의 오른쪽 고정 여백

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateRecRightEmpty As Integer
C#
public static int CoordinateRecRightEmpty
Visual C++
public:
static int CoordinateRecRightEmpty
JavaScript
Hippo.Figures.coordinateRecRightEmpty

See Also

Figures Class


CoordinateRecTopEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateRecTopEmpty Field
Figures Class See Also Send Feedback

좌표 타입 그래프의 위 고정 여백

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateRecTopEmpty As Integer
C#
public static int CoordinateRecTopEmpty
Visual C++
public:
static int CoordinateRecTopEmpty
JavaScript
Hippo.Figures.coordinateRecTopEmpty

See Also

Figures Class


CoordinateXtextLimitEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateXtextLimitEmpty Field
Figures Class See Also Send Feedback

x 좌표 부분 텍스트 들어가는 공간의 최소값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateXtextLimitEmpty As Integer
C#
public static int CoordinateXtextLimitEmpty
Visual C++
public:
static int CoordinateXtextLimitEmpty
JavaScript
Hippo.Figures.coordinateXtextLimitEmpty

See Also

Figures Class


CoordinateXtextMaxEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateXtextMaxEmpty Field
Figures Class See Also Send Feedback

x 좌표 부분 텍스트 들어가는 공간의 최대값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateXtextMaxEmpty As Integer
C#
public static int CoordinateXtextMaxEmpty
Visual C++
public:
static int CoordinateXtextMaxEmpty
JavaScript
Hippo.Figures.coordinateXtextMaxEmpty

See Also

Figures Class


CoordinateYnameEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateYnameEmpty Field
Figures Class See Also Send Feedback

y 좌표 제목 부분 가로 넓이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateYnameEmpty As Integer
C#
public static int CoordinateYnameEmpty
Visual C++
public:
static int CoordinateYnameEmpty
JavaScript
Hippo.Figures.coordinateYnameEmpty

See Also

Figures Class


CoordinateYnameMinEmpty Field

[image]

.NET Framework Class Library
Figures..::..CoordinateYnameMinEmpty Field
Figures Class See Also Send Feedback

y 좌표 제목 부분이 공백일경우 넓이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared CoordinateYnameMinEmpty As Integer
C#
public static int CoordinateYnameMinEmpty
Visual C++
public:
static int CoordinateYnameMinEmpty
JavaScript
Hippo.Figures.coordinateYnameMinEmpty

See Also

Figures Class


DefalutWidth Field

[image]

.NET Framework Class Library
Figures..::..DefalutWidth Field
Figures Class See Also Send Feedback

차트 기본 가로길이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefalutWidth As Integer
C#
public static int DefalutWidth
Visual C++
public:
static int DefalutWidth
JavaScript
Hippo.Figures.defalutWidth

See Also

Figures Class


DefaultCoordinateWidth Field

[image]

.NET Framework Class Library
Figures..::..DefaultCoordinateWidth Field
Figures Class See Also Send Feedback

좌표 타입 그래프 모눈 라인 넓이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultCoordinateWidth As Integer
C#
public static int DefaultCoordinateWidth
Visual C++
public:
static int DefaultCoordinateWidth
JavaScript
Hippo.Figures.defaultCoordinateWidth

See Also

Figures Class


DefaultHeight Field

[image]

.NET Framework Class Library
Figures..::..DefaultHeight Field
Figures Class See Also Send Feedback

차트 기본 세로길이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultHeight As Integer
C#
public static int DefaultHeight
Visual C++
public:
static int DefaultHeight
JavaScript
Hippo.Figures.defaultHeight

See Also

Figures Class


DefaultLimitWidthCoordinate Field

[image]

.NET Framework Class Library
Figures..::..DefaultLimitWidthCoordinate Field
Figures Class See Also Send Feedback

그래프를 그리는 최소한의 공간(좌표)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultLimitWidthCoordinate As Integer
C#
public static int DefaultLimitWidthCoordinate
Visual C++
public:
static int DefaultLimitWidthCoordinate
JavaScript
Hippo.Figures.defaultLimitWidthCoordinate

See Also

Figures Class


DefaultLimitWidthUncoordinate Field

[image]

.NET Framework Class Library
Figures..::..DefaultLimitWidthUncoordinate Field
Figures Class See Also Send Feedback

그래프를 그리는 최소한의 공간(비좌표)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultLimitWidthUncoordinate As Integer
C#
public static int DefaultLimitWidthUncoordinate
Visual C++
public:
static int DefaultLimitWidthUncoordinate
JavaScript
Hippo.Figures.defaultLimitWidthUncoordinate

See Also

Figures Class


DefaultLimitWidthUncoordinateGauge Field

[image]

.NET Framework Class Library
Figures..::..DefaultLimitWidthUncoordinateGauge Field
Figures Class See Also Send Feedback

그래프를 그리는 최소한의 공간(게이지)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultLimitWidthUncoordinateGauge As Integer
C#
public static int DefaultLimitWidthUncoordinateGauge
Visual C++
public:
static int DefaultLimitWidthUncoordinateGauge
JavaScript
Hippo.Figures.defaultLimitWidthUncoordinateGauge

See Also

Figures Class


DefaultLineWidth Field

[image]

.NET Framework Class Library
Figures..::..DefaultLineWidth Field
Figures Class See Also Send Feedback

좌표 타입 그래프 x, y 축 라인과 대표값 굵기

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared DefaultLineWidth As Integer
C#
public static int DefaultLineWidth
Visual C++
public:
static int DefaultLineWidth
JavaScript
Hippo.Figures.defaultLineWidth

See Also

Figures Class


GaugeMaxiumHeight Field

[image]

.NET Framework Class Library
Figures..::..GaugeMaxiumHeight Field
Figures Class See Also Send Feedback

게이지 짧은 쪽 넓이 최대값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared GaugeMaxiumHeight As Single
C#
public static float GaugeMaxiumHeight
Visual C++
public:
static float GaugeMaxiumHeight
JavaScript
Hippo.Figures.gaugeMaxiumHeight

See Also

Figures Class


GaugeMinimumHeight Field

[image]

.NET Framework Class Library
Figures..::..GaugeMinimumHeight Field
Figures Class See Also Send Feedback

게이지 짧은 쪽 넓이 최소값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared GaugeMinimumHeight As Single
C#
public static float GaugeMinimumHeight
Visual C++
public:
static float GaugeMinimumHeight
JavaScript
Hippo.Figures.gaugeMinimumHeight

See Also

Figures Class


HippoFontFamily Field

[image]

.NET Framework Class Library
Figures..::..HippoFontFamily Field
Figures Class See Also Send Feedback

히포차트 대표 폰트 패밀리

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared HippoFontFamily As String
C#
public static string HippoFontFamily
Visual C++
public:
static String^ HippoFontFamily
JavaScript
Hippo.Figures.hippoFontFamily

See Also

Figures Class


InnerPadding Field

[image]

.NET Framework Class Library
Figures..::..InnerPadding Field
Figures Class See Also Send Feedback

가장 바깥 큰 사각형의 바로 안쪽 패딩

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared InnerPadding As Integer
C#
public static int InnerPadding
Visual C++
public:
static int InnerPadding
JavaScript
Hippo.Figures.innerPadding

See Also

Figures Class


InnerVSGraphAreaSpan Field

[image]

.NET Framework Class Library
Figures..::..InnerVSGraphAreaSpan Field
Figures Class See Also Send Feedback

InnerRectangle 과 내부 그래프 영역과의 공간

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared InnerVSGraphAreaSpan As Single
C#
public static float InnerVSGraphAreaSpan
Visual C++
public:
static float InnerVSGraphAreaSpan
JavaScript
Hippo.Figures.innerVSGraphAreaSpan

See Also

Figures Class


LegendBoxHeight Field

[image]

.NET Framework Class Library
Figures..::..LegendBoxHeight Field
Figures Class See Also Send Feedback

범례 아이템 한칸 높이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LegendBoxHeight As Integer
C#
public static int LegendBoxHeight
Visual C++
public:
static int LegendBoxHeight
JavaScript
Hippo.Figures.legendBoxHeight

See Also

Figures Class


LegendBoxWidth Field

[image]

.NET Framework Class Library
Figures..::..LegendBoxWidth Field
Figures Class See Also Send Feedback

범례 가로 길이 고정

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LegendBoxWidth As Integer
C#
public static int LegendBoxWidth
Visual C++
public:
static int LegendBoxWidth
JavaScript
Hippo.Figures.legendBoxWidth

See Also

Figures Class


LegendHeaderHeight Field

[image]

.NET Framework Class Library
Figures..::..LegendHeaderHeight Field
Figures Class See Also Send Feedback

범례 헤더 높이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LegendHeaderHeight As Integer
C#
public static int LegendHeaderHeight
Visual C++
public:
static int LegendHeaderHeight
JavaScript
Hippo.Figures.legendHeaderHeight

See Also

Figures Class


LineChartCurvedTention Field

[image]

.NET Framework Class Library
Figures..::..LineChartCurvedTention Field
Figures Class See Also Send Feedback

라인 그래프 곡선일 경우 장력

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LineChartCurvedTention As Single
C#
public static float LineChartCurvedTention
Visual C++
public:
static float LineChartCurvedTention
JavaScript
Hippo.Figures.lineChartCurvedTention

See Also

Figures Class


LineChartDefaultTention Field

[image]

.NET Framework Class Library
Figures..::..LineChartDefaultTention Field
Figures Class See Also Send Feedback

라인 그래프 직선일 경우 장력(너무 직선으로 그리면 뽀죡해지는 문제 발생)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LineChartDefaultTention As Single
C#
public static float LineChartDefaultTention
Visual C++
public:
static float LineChartDefaultTention
JavaScript
Hippo.Figures.lineChartDefaultTention

See Also

Figures Class


LogoSpareEmpty Field

[image]

.NET Framework Class Library
Figures..::..LogoSpareEmpty Field
Figures Class See Also Send Feedback

맨 하단 로고 없을시 최종 남아있을 공간

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared LogoSpareEmpty As Integer
C#
public static int LogoSpareEmpty
Visual C++
public:
static int LogoSpareEmpty
JavaScript
Hippo.Figures.logoSpareEmpty

See Also

Figures Class


MaximumMargins Field

[image]

.NET Framework Class Library
Figures..::..MaximumMargins Field
Figures Class See Also Send Feedback

차트 최대 마진 값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared MaximumMargins As Integer
C#
public static int MaximumMargins
Visual C++
public:
static int MaximumMargins
JavaScript
Hippo.Figures.maximumMargins

See Also

Figures Class


MaxLineWidth Field

[image]

.NET Framework Class Library
Figures..::..MaxLineWidth Field
Figures Class See Also Send Feedback

Line 객체의 최대 굵기

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared MaxLineWidth As Single
C#
public static float MaxLineWidth
Visual C++
public:
static float MaxLineWidth
JavaScript
Hippo.Figures.maxLineWidth

See Also

Figures Class


Pie3DWidth Field

[image]

.NET Framework Class Library
Figures..::..Pie3DWidth Field
Figures Class See Also Send Feedback

파이 그래프 3D 를 위해 루프를 도는 수. 4.3 버전에서 28 ==> 15 로 본경되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Pie3DWidth As Integer
C#
public static int Pie3DWidth
Visual C++
public:
static int Pie3DWidth
JavaScript
Hippo.Figures.pie3DWidth

See Also

Figures Class


PieForTextArea Field

[image]

.NET Framework Class Library
Figures..::..PieForTextArea Field
Figures Class See Also Send Feedback

파이 그래프 소수 % 텍스트를 쓰기 위한 공간을 위해

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PieForTextArea As Integer
C#
public static int PieForTextArea
Visual C++
public:
static int PieForTextArea
JavaScript
Hippo.Figures.pieForTextArea

See Also

Figures Class


PieMargins Field

[image]

.NET Framework Class Library
Figures..::..PieMargins Field
Figures Class See Also Send Feedback

파이 그래프의 여백(마진)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PieMargins As Integer
C#
public static int PieMargins
Visual C++
public:
static int PieMargins
JavaScript
Hippo.Figures.pieMargins

See Also

Figures Class


PiePercentLineDisplayvalue Field

[image]

.NET Framework Class Library
Figures..::..PiePercentLineDisplayvalue Field
Figures Class See Also Send Feedback

수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.(기본값 :5%)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PiePercentLineDisplayvalue As Integer
C#
public static int PiePercentLineDisplayvalue
Visual C++
public:
static int PiePercentLineDisplayvalue
JavaScript
Hippo.Figures.piePercentLineDisplayvalue

See Also

Figures Class


PylamidEmptyArea Field

[image]

.NET Framework Class Library
Figures..::..PylamidEmptyArea Field
Figures Class See Also Send Feedback

피라미드 공백

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PylamidEmptyArea As Integer
C#
public static int PylamidEmptyArea
Visual C++
public:
static int PylamidEmptyArea
JavaScript
Hippo.Figures.pylamidEmptyArea

See Also

Figures Class


PylamidMinPercent Field

[image]

.NET Framework Class Library
Figures..::..PylamidMinPercent Field
Figures Class See Also Send Feedback

피라미드 차트 라인 빼기 위한 최소 퍼센트값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PylamidMinPercent As Integer
C#
public static int PylamidMinPercent
Visual C++
public:
static int PylamidMinPercent
JavaScript
Hippo.Figures.pylamidMinPercent

See Also

Figures Class


PylamidMinTextHeight Field

[image]

.NET Framework Class Library
Figures..::..PylamidMinTextHeight Field
Figures Class See Also Send Feedback

피라미드 차트 라인 빼기 위한 최소 렉텡글 높이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PylamidMinTextHeight As Integer
C#
public static int PylamidMinTextHeight
Visual C++
public:
static int PylamidMinTextHeight
JavaScript
Hippo.Figures.pylamidMinTextHeight

See Also

Figures Class


PylamidMinTextwidth Field

[image]

.NET Framework Class Library
Figures..::..PylamidMinTextwidth Field
Figures Class See Also Send Feedback

피라미드 차트 라인 빼기 위한 최소 넓이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared PylamidMinTextwidth As Integer
C#
public static int PylamidMinTextwidth
Visual C++
public:
static int PylamidMinTextwidth
JavaScript
Hippo.Figures.pylamidMinTextwidth

See Also

Figures Class


ScrollDefaultWidth Field

[image]

.NET Framework Class Library
Figures..::..ScrollDefaultWidth Field
Figures Class See Also Send Feedback

스크롤 차트인 경우 X축 간격 기본 값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared ScrollDefaultWidth As Integer
C#
public static int ScrollDefaultWidth
Visual C++
public:
static int ScrollDefaultWidth
JavaScript
Hippo.Figures.scrollDefaultWidth

See Also

Figures Class


SplineChartDefaultTention Field

[image]

.NET Framework Class Library
Figures..::..SplineChartDefaultTention Field
Figures Class See Also Send Feedback

스플라인 차트 장력 기본값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared SplineChartDefaultTention As Single
C#
public static float SplineChartDefaultTention
Visual C++
public:
static float SplineChartDefaultTention
JavaScript
Hippo.Figures.splineChartDefaultTention

See Also

Figures Class


StarChartEmpty Field

[image]

.NET Framework Class Library
Figures..::..StarChartEmpty Field
Figures Class See Also Send Feedback

방사형 차트 항목 이름 공간

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared StarChartEmpty As Integer
C#
public static int StarChartEmpty
Visual C++
public:
static int StarChartEmpty
JavaScript
Hippo.Figures.starChartEmpty

See Also

Figures Class


StarChartInnerCircleAlpha Field

[image]

.NET Framework Class Library
Figures..::..StarChartInnerCircleAlpha Field
Figures Class See Also Send Feedback

방사형 차트 내부 영역 투명도

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared StarChartInnerCircleAlpha As Integer
C#
public static int StarChartInnerCircleAlpha
Visual C++
public:
static int StarChartInnerCircleAlpha
JavaScript
Hippo.Figures.starChartInnerCircleAlpha

See Also

Figures Class


StarChartItemTextLimitLength Field

[image]

.NET Framework Class Library
Figures..::..StarChartItemTextLimitLength Field
Figures Class See Also Send Feedback

방사형 차트 항목 이름 제한 길이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared StarChartItemTextLimitLength As Integer
C#
public static int StarChartItemTextLimitLength
Visual C++
public:
static int StarChartItemTextLimitLength
JavaScript
Hippo.Figures.starChartItemTextLimitLength

See Also

Figures Class


StarItemViewLimitCount Field

[image]

.NET Framework Class Library
Figures..::..StarItemViewLimitCount Field
Figures Class See Also Send Feedback

방사형 차트 항목 이름 그리는 개수는 36개, 그 이상 그리면 너무 복잡해지므로 다른 조치취함.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared StarItemViewLimitCount As Integer
C#
public static int StarItemViewLimitCount
Visual C++
public:
static int StarItemViewLimitCount
JavaScript
Hippo.Figures.starItemViewLimitCount

See Also

Figures Class


StockColumnValueRecWidth Field

[image]

.NET Framework Class Library
Figures..::..StockColumnValueRecWidth Field
Figures Class See Also Send Feedback

w주식 차트에서 벨류렉텡글의 넓이 한계값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared StockColumnValueRecWidth As Integer
C#
public static int StockColumnValueRecWidth
Visual C++
public:
static int StockColumnValueRecWidth
JavaScript
Hippo.Figures.stockColumnValueRecWidth

See Also

Figures Class


TitleSpareEmpty Field

[image]

.NET Framework Class Library
Figures..::..TitleSpareEmpty Field
Figures Class See Also Send Feedback

타이틀 부분의 약간의 여유 공간

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared TitleSpareEmpty As Integer
C#
public static int TitleSpareEmpty
Visual C++
public:
static int TitleSpareEmpty
JavaScript
Hippo.Figures.titleSpareEmpty

See Also

Figures Class


xTitlebHeight Field

[image]

.NET Framework Class Library
Figures..::..xTitlebHeight Field
Figures Class See Also Send Feedback

x 축...

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared xTitlebHeight As Integer
C#
public static int xTitlebHeight
Visual C++
public:
static int xTitlebHeight
JavaScript
Hippo.Figures.xTitlebHeight

See Also

Figures Class


XunitLimitPixel Field

[image]

.NET Framework Class Library
Figures..::..XunitLimitPixel Field
Figures Class See Also Send Feedback

그래프 그릴 시 x 아이템이 너무 많을 경우를 지칭하는 값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared XunitLimitPixel As Integer
C#
public static int XunitLimitPixel
Visual C++
public:
static int XunitLimitPixel
JavaScript
Hippo.Figures.xunitLimitPixel

See Also

Figures Class


Figures Methods

[image] [image]

.NET Framework Class Library
Figures Methods
Figures Class See Also Send Feedback

The Figures type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Figures Class


FigureTextLocation Enumeration

[image]

.NET Framework Class Library
FigureTextLocation Enumeration
See Also Send Feedback

좌표형 차트의 수치 표시 위치

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration FigureTextLocation
C#
public enum FigureTextLocation
Visual C++
public enum class FigureTextLocation
JavaScript
Hippo.FigureTextLocation = function();
Hippo.FigureTextLocation.createEnum('Hippo.FigureTextLocation', false);

Members

Member name | Description
Default |
Top |
Bottom |
Left |
Right |
Center |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


FileSystemLogHelper Class

[image]

.NET Framework Class Library
FileSystemLogHelper Class
Members See Also Send Feedback

파일 시스템 로그를 생성해 주는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class FileSystemLogHelper
C#
public class FileSystemLogHelper
Visual C++
public ref class FileSystemLogHelper
JavaScript
Hippo.FileSystemLogHelper = function();

Type.createClass(
    'Hippo.FileSystemLogHelper');

Inheritance Hierarchy

System..::..Object
Hippo..::..FileSystemLogHelper

See Also

FileSystemLogHelper Members


FileSystemLogHelper Members

[image] [image]

.NET Framework Class Library
FileSystemLogHelper Members
FileSystemLogHelper Class Constructors Methods Properties See Also Send Feedback

The FileSystemLogHelper type exposes the following members.

Constructors

 | Name | Description
Public method | FileSystemLogHelper | FileSystemLogHelper 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteLog | 파일 시스템에 로그를 기록합니다.

Properties

 | Name | Description
Public property | ErrorMessage | 에러 메세지를 가져옵니다.
Public property | LogFilePath | 로그파일경로

See Also

FileSystemLogHelper Class


FileSystemLogHelper Constructor

[image]

.NET Framework Class Library
FileSystemLogHelper Constructor
FileSystemLogHelper Class See Also Send Feedback

FileSystemLogHelper 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public FileSystemLogHelper()
Visual C++
public:
FileSystemLogHelper()
JavaScript
Hippo.FileSystemLogHelper = function();

See Also

FileSystemLogHelper Class


FileSystemLogHelper Methods

[image] [image]

.NET Framework Class Library
FileSystemLogHelper Methods
FileSystemLogHelper Class See Also Send Feedback

The FileSystemLogHelper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteLog | 파일 시스템에 로그를 기록합니다.

See Also

FileSystemLogHelper Class


WriteLog Method

[image]

.NET Framework Class Library
FileSystemLogHelper..::..WriteLog Method
FileSystemLogHelper Class See Also Send Feedback

파일 시스템에 로그를 기록합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub WriteLog ( _
    logTitle As String, _
    message As String, _
    line As String, _
    id As String _
)
C#
public void WriteLog(
    string logTitle,
    string message,
    string line,
    string id
)
Visual C++
public:
void WriteLog(
    String^ logTitle,
    String^ message,
    String^ line,
    String^ id
)
JavaScript
function writeLog(logTitle, message, line, id);

Parameters

logTitle
Type: System..::..String
로그 제목
message
Type: System..::..String
로그 내용
line
Type: System..::..String
발생 위치
id
Type: System..::..String
차트 아이디

See Also

FileSystemLogHelper Class


FileSystemLogHelper Properties

[image] [image]

.NET Framework Class Library
FileSystemLogHelper Properties
FileSystemLogHelper Class See Also Send Feedback

The FileSystemLogHelper type exposes the following members.

Properties

 | Name | Description
Public property | ErrorMessage | 에러 메세지를 가져옵니다.
Public property | LogFilePath | 로그파일경로

See Also

FileSystemLogHelper Class


ErrorMessage Property

[image]

.NET Framework Class Library
FileSystemLogHelper..::..ErrorMessage Property
FileSystemLogHelper Class See Also Send Feedback

에러 메세지를 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorMessage As String
    Get
C#
public string ErrorMessage { get; }
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
}
JavaScript
function get_errorMessage();

See Also

FileSystemLogHelper Class


LogFilePath Property

[image]

.NET Framework Class Library
FileSystemLogHelper..::..LogFilePath Property
FileSystemLogHelper Class See Also Send Feedback

로그파일경로

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property LogFilePath As String
    Get
C#
public string LogFilePath { get; }
Visual C++
public:
property String^ LogFilePath {
    String^ get ();
}
JavaScript
function get_logFilePath();

See Also

FileSystemLogHelper Class


FunctionCompiler Class

[image]

.NET Framework Class Library
FunctionCompiler Class
Members See Also Send Feedback

Compiles functions as runtime. This class cannot be inherited.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public NotInheritable Class FunctionCompiler
C#
public static class FunctionCompiler
Visual C++
public ref class FunctionCompiler abstract sealed
JavaScript
Hippo.FunctionCompiler = function();

Type.createClass(
    'Hippo.FunctionCompiler');

Inheritance Hierarchy

System..::..Object
Hippo..::..FunctionCompiler

See Also

FunctionCompiler Members


FunctionCompiler Members

[image] [image]

.NET Framework Class Library
FunctionCompiler Members
FunctionCompiler Class Methods See Also Send Feedback

The FunctionCompiler type exposes the following members.

Methods

Name | Description
Compile | Compiles function at runtime.

See Also

FunctionCompiler Class


FunctionCompiler Methods

[image] [image]

.NET Framework Class Library
FunctionCompiler Methods
FunctionCompiler Class See Also Send Feedback

The FunctionCompiler type exposes the following members.

Methods

Name | Description
Compile | Compiles function at runtime.

See Also

FunctionCompiler Class


Compile Method

[image]

.NET Framework Class Library
FunctionCompiler..::..Compile Method
FunctionCompiler Class Example See Also Send Feedback

Compiles function at runtime.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Shared Function Compile ( _
    parametersCount As Integer, _
    functionBody As String _
) As CompiledFunction
C#
public static CompiledFunction Compile(
    int parametersCount,
    string functionBody
)
Visual C++
public:
static CompiledFunction^ Compile(
    int parametersCount,
    String^ functionBody
)
JavaScript
Hippo.FunctionCompiler.compile = function(parametersCount, functionBody);

Parameters

parametersCount
Type: System..::..Int32
Number of input parameters.
functionBody
Type: System..::..String
Function body.

Return Value

Compiled function.

Examples

This sample shows how to call the Compile method.
Copy image Copy Code
            CompiledFunction cf = FunctionCompiler.Compile(3, "y = x1 + x2 + x3;");
            double y = cf(2, 4, 7);

Exceptions

Exception | Condition
[!:LukeSw.Runtime.FunctionNotCompiledException] | Thrown when function was not compiled because of some errors in functions body.

See Also

FunctionCompiler Class


FunctionNotCompiledException Class

[image]

.NET Framework Class Library
FunctionNotCompiledException Class
Members See Also Send Feedback

The exception is thrown when function was not compiled.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class FunctionNotCompiledException _
    Inherits ApplicationException
C#
[SerializableAttribute]
public class FunctionNotCompiledException : ApplicationException
Visual C++
[SerializableAttribute]
public ref class FunctionNotCompiledException : public ApplicationException
JavaScript
Hippo.FunctionNotCompiledException = function();

Type.createClass(
    'Hippo.FunctionNotCompiledException',
    ApplicationException);

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Hippo..::..FunctionNotCompiledException

See Also

FunctionNotCompiledException Members


FunctionNotCompiledException Members

[image] [image]

.NET Framework Class Library
FunctionNotCompiledException Members
FunctionNotCompiledException Class Constructors Methods Properties See Also Send Feedback

The FunctionNotCompiledException type exposes the following members.

Constructors

 | Name | Description
Public method | FunctionNotCompiledException()()()() | Initializes a new instance of the FunctionNotCompiledException class.
Public method | FunctionNotCompiledException(String) | Initializes a new instance of the FunctionNotCompiledException class with a specified error message.
Protected method | FunctionNotCompiledException(SerializationInfo, StreamingContext) | Initializes a new instance of the FunctionNotCompiledException class with serialized data.
Public method | FunctionNotCompiledException(String, Exception) | Initializes a new instance of the FunctionNotCompiledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

FunctionNotCompiledException Class


FunctionNotCompiledException Constructor

[image] [image]

.NET Framework Class Library
FunctionNotCompiledException Constructor
FunctionNotCompiledException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FunctionNotCompiledException()()()() | Initializes a new instance of the FunctionNotCompiledException class.
Public method | FunctionNotCompiledException(String) | Initializes a new instance of the FunctionNotCompiledException class with a specified error message.
Protected method | FunctionNotCompiledException(SerializationInfo, StreamingContext) | Initializes a new instance of the FunctionNotCompiledException class with serialized data.
Public method | FunctionNotCompiledException(String, Exception) | Initializes a new instance of the FunctionNotCompiledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

FunctionNotCompiledException Class
FunctionNotCompiledException Members


FunctionNotCompiledException Constructor

[image]

.NET Framework Class Library
FunctionNotCompiledException Constructor
FunctionNotCompiledException Class See Also Send Feedback

Initializes a new instance of the FunctionNotCompiledException class.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public FunctionNotCompiledException()
Visual C++
public:
FunctionNotCompiledException()
JavaScript
Hippo.FunctionNotCompiledException = function();

See Also

FunctionNotCompiledException Class
FunctionNotCompiledException Overload


FunctionNotCompiledException Constructor (String)

[image]

.NET Framework Class Library
FunctionNotCompiledException Constructor (String)
FunctionNotCompiledException Class See Also Send Feedback

Initializes a new instance of the FunctionNotCompiledException class with a specified error message.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    message As String _
)
C#
public FunctionNotCompiledException(
    string message
)
Visual C++
public:
FunctionNotCompiledException(
    String^ message
)
JavaScript
Hippo.FunctionNotCompiledException = function(message);

Parameters

message
Type: System..::..String
A message that describes the error.

See Also

FunctionNotCompiledException Class
FunctionNotCompiledException Overload


FunctionNotCompiledException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
FunctionNotCompiledException Constructor (SerializationInfo, StreamingContext)
FunctionNotCompiledException Class See Also Send Feedback

Initializes a new instance of the FunctionNotCompiledException class with serialized data.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected FunctionNotCompiledException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
FunctionNotCompiledException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
Hippo.FunctionNotCompiledException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The contextual information about the source or destination.

See Also

FunctionNotCompiledException Class
FunctionNotCompiledException Overload


FunctionNotCompiledException Constructor (String, Exception)

[image]

.NET Framework Class Library
FunctionNotCompiledException Constructor (String, Exception)
FunctionNotCompiledException Class See Also Send Feedback

Initializes a new instance of the FunctionNotCompiledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public FunctionNotCompiledException(
    string message,
    Exception innerException
)
Visual C++
public:
FunctionNotCompiledException(
    String^ message,
    Exception^ innerException
)
JavaScript
Hippo.FunctionNotCompiledException = function(message, innerException);

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

FunctionNotCompiledException Class
FunctionNotCompiledException Overload


FunctionNotCompiledException Methods

[image] [image]

.NET Framework Class Library
FunctionNotCompiledException Methods
FunctionNotCompiledException Class See Also Send Feedback

The FunctionNotCompiledException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

See Also

FunctionNotCompiledException Class


FunctionNotCompiledException Properties

[image] [image]

.NET Framework Class Library
FunctionNotCompiledException Properties
FunctionNotCompiledException Class See Also Send Feedback

The FunctionNotCompiledException type exposes the following members.

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

FunctionNotCompiledException Class


Gantt Class

[image]

.NET Framework Class Library
Gantt Class
Members See Also Send Feedback

Gantt 차트의 특성을 정의하는 클래스입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Gantt
C#
[SerializableAttribute]
public class Gantt
Visual C++
[SerializableAttribute]
public ref class Gantt
JavaScript
Hippo.Gantt = function();

Type.createClass(
    'Hippo.Gantt');

Inheritance Hierarchy

System..::..Object
Hippo..::..Gantt

See Also

Gantt Members


Gantt Members

[image] [image]

.NET Framework Class Library
Gantt Members
Gantt Class Constructors Methods Properties See Also Send Feedback

The Gantt type exposes the following members.

Constructors

 | Name | Description
Public method | Gantt | 간트 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DateType | 날짜형 간트차트일 경우 날짜의 형태를 설정하고 가져옵니다. (일, 시간) - 이 속성은 더이상 사용되지 않습니다.
Public property | Suffix | 간트 차트의 수치 부분 끝에 붙여질 접미사를 설정하고 가져옵니다.

See Also

Gantt Class


Gantt Constructor

[image]

.NET Framework Class Library
Gantt Constructor
Gantt Class See Also Send Feedback

간트 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Gantt()
Visual C++
public:
Gantt()
JavaScript
Hippo.Gantt = function();

See Also

Gantt Class


Gantt Methods

[image] [image]

.NET Framework Class Library
Gantt Methods
Gantt Class See Also Send Feedback

The Gantt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Gantt Class


Gantt Properties

[image] [image]

.NET Framework Class Library
Gantt Properties
Gantt Class See Also Send Feedback

The Gantt type exposes the following members.

Properties

 | Name | Description
Public property | DateType | 날짜형 간트차트일 경우 날짜의 형태를 설정하고 가져옵니다. (일, 시간) - 이 속성은 더이상 사용되지 않습니다.
Public property | Suffix | 간트 차트의 수치 부분 끝에 붙여질 접미사를 설정하고 가져옵니다.

See Also

Gantt Class


DateType Property

[image]

.NET Framework Class Library
Gantt..::..DateType Property
Gantt Class See Also Send Feedback

날짜형 간트차트일 경우 날짜의 형태를 설정하고 가져옵니다. (일, 시간) - 이 속성은 더이상 사용되지 않습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DateType As DateType
    Get
    Set
C#
public DateType DateType { get; set; }
Visual C++
public:
property DateType DateType {
    DateType get ();
    void set (DateType value);
}
JavaScript
function get_dateType();
function set_dateType(value);

See Also

Gantt Class


Suffix Property

[image]

.NET Framework Class Library
Gantt..::..Suffix Property
Gantt Class See Also Send Feedback

간트 차트의 수치 부분 끝에 붙여질 접미사를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Suffix As String
    Get
    Set
C#
public string Suffix { get; set; }
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suffix();
function set_suffix(value);

See Also

Gantt Class


GanttProcess Class

[image]

.NET Framework Class Library
GanttProcess Class
Members See Also Send Feedback

간트프로세스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class GanttProcess
C#
[SerializableAttribute]
public class GanttProcess
Visual C++
[SerializableAttribute]
public ref class GanttProcess
JavaScript
Hippo.GanttProcess = function();

Type.createClass(
    'Hippo.GanttProcess');

Remarks

간트차트에서 진행율과 내부 표현양식에 대한 설정들을 관리하는 클래스입니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..GanttProcess

See Also

GanttProcess Members


GanttProcess Members

[image] [image]

.NET Framework Class Library
GanttProcess Members
GanttProcess Class Constructors Methods Properties See Also Send Feedback

The GanttProcess type exposes the following members.

Constructors

 | Name | Description
Public method | GanttProcess | GanttProcess()

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsShowPercent | 진행율 퍼센트 글자를 표시할지 여부를 설정하고 가져옵니다.
Public property | Label | 진행율 라벨을 설정하고 가져옵니다.
Public property | Percent | 일정의 진행율을 설정하고 가져옵니다. 간트차트일 경우 설정하며 퍼센트 값으로 소수로 설정합니다.
Public property | ProcessColor | 간트차트의 진행율 부분의 색상을 설정하고 가져옵니다.
Public property | TextLocation | 라벨 텍스트 위치를 설정합니다.

See Also

GanttProcess Class


GanttProcess Constructor

[image]

.NET Framework Class Library
GanttProcess Constructor
GanttProcess Class See Also Send Feedback

GanttProcess()

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public GanttProcess()
Visual C++
public:
GanttProcess()
JavaScript
Hippo.GanttProcess = function();

See Also

GanttProcess Class


GanttProcess Methods

[image] [image]

.NET Framework Class Library
GanttProcess Methods
GanttProcess Class See Also Send Feedback

The GanttProcess type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GanttProcess Class


GanttProcess Properties

[image] [image]

.NET Framework Class Library
GanttProcess Properties
GanttProcess Class See Also Send Feedback

The GanttProcess type exposes the following members.

Properties

 | Name | Description
Public property | IsShowPercent | 진행율 퍼센트 글자를 표시할지 여부를 설정하고 가져옵니다.
Public property | Label | 진행율 라벨을 설정하고 가져옵니다.
Public property | Percent | 일정의 진행율을 설정하고 가져옵니다. 간트차트일 경우 설정하며 퍼센트 값으로 소수로 설정합니다.
Public property | ProcessColor | 간트차트의 진행율 부분의 색상을 설정하고 가져옵니다.
Public property | TextLocation | 라벨 텍스트 위치를 설정합니다.

See Also

GanttProcess Class


IsShowPercent Property

[image]

.NET Framework Class Library
GanttProcess..::..IsShowPercent Property
GanttProcess Class See Also Send Feedback

진행율 퍼센트 글자를 표시할지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowPercent As Boolean
    Get
    Set
C#
public bool IsShowPercent { get; set; }
Visual C++
public:
property bool IsShowPercent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowPercent();
function set_isShowPercent(value);

See Also

GanttProcess Class


Label Property

[image]

.NET Framework Class Library
GanttProcess..::..Label Property
GanttProcess Class See Also Send Feedback

진행율 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

GanttProcess Class


Percent Property

[image]

.NET Framework Class Library
GanttProcess..::..Percent Property
GanttProcess Class See Also Send Feedback

일정의 진행율을 설정하고 가져옵니다. 간트차트일 경우 설정하며 퍼센트 값으로 소수로 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Percent As Double
    Get
    Set
C#
public double Percent { get; set; }
Visual C++
public:
property double Percent {
    double get ();
    void set (double value);
}
JavaScript
function get_percent();
function set_percent(value);

See Also

GanttProcess Class


ProcessColor Property

[image]

.NET Framework Class Library
GanttProcess..::..ProcessColor Property
GanttProcess Class See Also Send Feedback

간트차트의 진행율 부분의 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ProcessColor As Color
    Get
    Set
C#
public Color ProcessColor { get; set; }
Visual C++
public:
property Color ProcessColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_processColor();
function set_processColor(value);

See Also

GanttProcess Class


TextLocation Property

[image]

.NET Framework Class Library
GanttProcess..::..TextLocation Property
GanttProcess Class See Also Send Feedback

라벨 텍스트 위치를 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TextLocation As StringAlignment
    Get
    Set
C#
public StringAlignment TextLocation { get; set; }
Visual C++
public:
property StringAlignment TextLocation {
    StringAlignment get ();
    void set (StringAlignment value);
}
JavaScript
function get_textLocation();
function set_textLocation(value);

See Also

GanttProcess Class


Gauge Class

[image]

.NET Framework Class Library
Gauge Class
Members See Also Send Feedback

게이지, 계기판형 차트의 속성을 관리하는 클래스입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Gauge
C#
[SerializableAttribute]
public class Gauge
Visual C++
[SerializableAttribute]
public ref class Gauge
JavaScript
Hippo.Gauge = function();

Type.createClass(
    'Hippo.Gauge');

Inheritance Hierarchy

System..::..Object
Hippo..::..Gauge

See Also

Gauge Members


Gauge Members

[image] [image]

.NET Framework Class Library
Gauge Members
Gauge Class Constructors Methods Properties See Also Send Feedback

The Gauge type exposes the following members.

Constructors

 | Name | Description
Public method | Gauge | 게이지 속성 클래스의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrowColor | 게이지 화살표, 라인 색상을 설정하고 가져옵니다.
Public property | ArrowLine | 게이지 표시 화살표가 라인일경우 라인 객체를 설정하고 가져옵니다.
Public property | ArrowType | 게이지 화살표, 라인 타입을 설정하고 가져옵니다.
Public property | BackColor | 게이지 배경색을 설정하고 가져옵니다.
Public property | BackColor2 | 게이지차트 2 배경색을 설정하고 가져옵니다.
Public property | BorderColor | 게이지 외곽 라인 색상을 설정하고 가져옵니다.
Public property | Font | 게이지 수치 폰트를 설정하고 가져옵니다.
Public property | ForeColor | 계기판형 게이지 차트의 축 글자색상을 설정하고 가져옵니다.
Public property | Gauge2BackgroundImage | 계기판형 게이지차트의 타입의 실제 이미지를 가져옵니다.
Public property | GaugeType | 게이지 타입을 설정하고 가져옵니다.
Public property | Grid | 게이지 그리드를 설정하고 가져옵니다.
Public property | InnerBackColor | 게이지 내부 그리드 배경색을 설정하고 가져옵니다.
Public property | IsFillGrid | 게이지 그리드를 색칠할 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowBorderLine | 게이지의 외곽라인을 그릴 것인지 여부를 설정하고 가져옵니다.
Public property | IsShowSmallTick | 작은 눈금을 보일 것인가 여부를 설정하고 가져옵니다.
Public property | Label | 게이지차트의 라벨을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | Margin | 게이지 마진을 설정하고 가져옵니다.
Public property | ShapeType | 게이지 모양 종류를 설정하고 가져옵니다.
Public property | ShapeType2 | 계기판형 게이지 차트의 모양 종류를 설정하고 가져옵니다.
Public property | SmallTickCount | 게이지차트의 작은 눈금 수를 설정하고 가져옵니다.
Public property | TickColor | 게이지 눈금 색상을 설정하고 가져옵니다.

See Also

Gauge Class


Gauge Constructor

[image]

.NET Framework Class Library
Gauge Constructor
Gauge Class See Also Send Feedback

게이지 속성 클래스의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Gauge()
Visual C++
public:
Gauge()
JavaScript
Hippo.Gauge = function();

See Also

Gauge Class


Gauge Methods

[image] [image]

.NET Framework Class Library
Gauge Methods
Gauge Class See Also Send Feedback

The Gauge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Gauge Class


Gauge Properties

[image] [image]

.NET Framework Class Library
Gauge Properties
Gauge Class See Also Send Feedback

The Gauge type exposes the following members.

Properties

 | Name | Description
Public property | ArrowColor | 게이지 화살표, 라인 색상을 설정하고 가져옵니다.
Public property | ArrowLine | 게이지 표시 화살표가 라인일경우 라인 객체를 설정하고 가져옵니다.
Public property | ArrowType | 게이지 화살표, 라인 타입을 설정하고 가져옵니다.
Public property | BackColor | 게이지 배경색을 설정하고 가져옵니다.
Public property | BackColor2 | 게이지차트 2 배경색을 설정하고 가져옵니다.
Public property | BorderColor | 게이지 외곽 라인 색상을 설정하고 가져옵니다.
Public property | Font | 게이지 수치 폰트를 설정하고 가져옵니다.
Public property | ForeColor | 계기판형 게이지 차트의 축 글자색상을 설정하고 가져옵니다.
Public property | Gauge2BackgroundImage | 계기판형 게이지차트의 타입의 실제 이미지를 가져옵니다.
Public property | GaugeType | 게이지 타입을 설정하고 가져옵니다.
Public property | Grid | 게이지 그리드를 설정하고 가져옵니다.
Public property | InnerBackColor | 게이지 내부 그리드 배경색을 설정하고 가져옵니다.
Public property | IsFillGrid | 게이지 그리드를 색칠할 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowBorderLine | 게이지의 외곽라인을 그릴 것인지 여부를 설정하고 가져옵니다.
Public property | IsShowSmallTick | 작은 눈금을 보일 것인가 여부를 설정하고 가져옵니다.
Public property | Label | 게이지차트의 라벨을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | Margin | 게이지 마진을 설정하고 가져옵니다.
Public property | ShapeType | 게이지 모양 종류를 설정하고 가져옵니다.
Public property | ShapeType2 | 계기판형 게이지 차트의 모양 종류를 설정하고 가져옵니다.
Public property | SmallTickCount | 게이지차트의 작은 눈금 수를 설정하고 가져옵니다.
Public property | TickColor | 게이지 눈금 색상을 설정하고 가져옵니다.

See Also

Gauge Class


ArrowColor Property

[image]

.NET Framework Class Library
Gauge..::..ArrowColor Property
Gauge Class See Also Send Feedback

게이지 화살표, 라인 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ArrowColor As Color
    Get
    Set
C#
public Color ArrowColor { get; set; }
Visual C++
public:
property Color ArrowColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_arrowColor();
function set_arrowColor(value);

See Also

Gauge Class


ArrowLine Property

[image]

.NET Framework Class Library
Gauge..::..ArrowLine Property
Gauge Class See Also Send Feedback

게이지 표시 화살표가 라인일경우 라인 객체를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ArrowLine As Line
    Get
    Set
C#
public Line ArrowLine { get; set; }
Visual C++
public:
property Line^ ArrowLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_arrowLine();
function set_arrowLine(value);

See Also

Gauge Class


ArrowType Property

[image]

.NET Framework Class Library
Gauge..::..ArrowType Property
Gauge Class See Also Send Feedback

게이지 화살표, 라인 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ArrowType As ArrowType
    Get
    Set
C#
public ArrowType ArrowType { get; set; }
Visual C++
public:
property ArrowType ArrowType {
    ArrowType get ();
    void set (ArrowType value);
}
JavaScript
function get_arrowType();
function set_arrowType(value);

See Also

Gauge Class


BackColor Property

[image]

.NET Framework Class Library
Gauge..::..BackColor Property
Gauge Class See Also Send Feedback

게이지 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

Gauge Class


BackColor2 Property

[image]

.NET Framework Class Library
Gauge..::..BackColor2 Property
Gauge Class See Also Send Feedback

게이지차트 2 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor2 As Color
    Get
    Set
C#
public Color BackColor2 { get; set; }
Visual C++
public:
property Color BackColor2 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor2();
function set_backColor2(value);

See Also

Gauge Class


BorderColor Property

[image]

.NET Framework Class Library
Gauge..::..BorderColor Property
Gauge Class See Also Send Feedback

게이지 외곽 라인 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BorderColor As Color
    Get
    Set
C#
public Color BorderColor { get; set; }
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_borderColor();
function set_borderColor(value);

See Also

Gauge Class


Font Property

[image]

.NET Framework Class Library
Gauge..::..Font Property
Gauge Class See Also Send Feedback

게이지 수치 폰트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Font As Font
    Get
    Set
C#
public Font Font { get; set; }
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_font();
function set_font(value);

See Also

Gauge Class


ForeColor Property

[image]

.NET Framework Class Library
Gauge..::..ForeColor Property
Gauge Class See Also Send Feedback

계기판형 게이지 차트의 축 글자색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

Gauge Class


Gauge2BackgroundImage Property

[image]

.NET Framework Class Library
Gauge..::..Gauge2BackgroundImage Property
Gauge Class See Also Send Feedback

계기판형 게이지차트의 타입의 실제 이미지를 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Gauge2BackgroundImage As Bitmap
    Get
    Set
C#
public Bitmap Gauge2BackgroundImage { get; set; }
Visual C++
public:
property Bitmap^ Gauge2BackgroundImage {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
JavaScript
function get_gauge2BackgroundImage();
function set_gauge2BackgroundImage(value);

See Also

Gauge Class


GaugeType Property

[image]

.NET Framework Class Library
Gauge..::..GaugeType Property
Gauge Class See Also Send Feedback

게이지 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GaugeType As GaugeType
    Get
    Set
C#
public GaugeType GaugeType { get; set; }
Visual C++
public:
property GaugeType GaugeType {
    GaugeType get ();
    void set (GaugeType value);
}
JavaScript
function get_gaugeType();
function set_gaugeType(value);

See Also

Gauge Class


Grid Property

[image]

.NET Framework Class Library
Gauge..::..Grid Property
Gauge Class See Also Send Feedback

게이지 그리드를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Grid As Grid
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Grid Grid { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Grid^ Grid {
    Grid^ get ();
    void set (Grid^ value);
}
JavaScript
function get_grid();
function set_grid(value);

See Also

Gauge Class


InnerBackColor Property

[image]

.NET Framework Class Library
Gauge..::..InnerBackColor Property
Gauge Class See Also Send Feedback

게이지 내부 그리드 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property InnerBackColor As Color
    Get
    Set
C#
public Color InnerBackColor { get; set; }
Visual C++
public:
property Color InnerBackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_innerBackColor();
function set_innerBackColor(value);

See Also

Gauge Class


IsFillGrid Property

[image]

.NET Framework Class Library
Gauge..::..IsFillGrid Property
Gauge Class See Also Send Feedback

게이지 그리드를 색칠할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsFillGrid As Boolean
    Get
    Set
C#
public bool IsFillGrid { get; set; }
Visual C++
public:
property bool IsFillGrid {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isFillGrid();
function set_isFillGrid(value);

See Also

Gauge Class


IsShowBorderLine Property

[image]

.NET Framework Class Library
Gauge..::..IsShowBorderLine Property
Gauge Class See Also Send Feedback

게이지의 외곽라인을 그릴 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowBorderLine As Boolean
    Get
    Set
C#
public bool IsShowBorderLine { get; set; }
Visual C++
public:
property bool IsShowBorderLine {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowBorderLine();
function set_isShowBorderLine(value);

See Also

Gauge Class


IsShowSmallTick Property

[image]

.NET Framework Class Library
Gauge..::..IsShowSmallTick Property
Gauge Class See Also Send Feedback

작은 눈금을 보일 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowSmallTick As Boolean
    Get
    Set
C#
public bool IsShowSmallTick { get; set; }
Visual C++
public:
property bool IsShowSmallTick {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowSmallTick();
function set_isShowSmallTick(value);

See Also

Gauge Class


Label Property

[image]

.NET Framework Class Library
Gauge..::..Label Property
Gauge Class See Also Send Feedback

게이지차트의 라벨을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Gauge Class


Margin Property

[image]

.NET Framework Class Library
Gauge..::..Margin Property
Gauge Class See Also Send Feedback

게이지 마진을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Margin As Single
    Get
    Set
C#
public float Margin { get; set; }
Visual C++
public:
property float Margin {
    float get ();
    void set (float value);
}
JavaScript
function get_margin();
function set_margin(value);

See Also

Gauge Class


ShapeType Property

[image]

.NET Framework Class Library
Gauge..::..ShapeType Property
Gauge Class See Also Send Feedback

게이지 모양 종류를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ShapeType As ShapeType
    Get
    Set
C#
public ShapeType ShapeType { get; set; }
Visual C++
public:
property ShapeType ShapeType {
    ShapeType get ();
    void set (ShapeType value);
}
JavaScript
function get_shapeType();
function set_shapeType(value);

See Also

Gauge Class


ShapeType2 Property

[image]

.NET Framework Class Library
Gauge..::..ShapeType2 Property
Gauge Class See Also Send Feedback

계기판형 게이지 차트의 모양 종류를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ShapeType2 As ShapeType2
    Get
    Set
C#
public ShapeType2 ShapeType2 { get; set; }
Visual C++
public:
property ShapeType2 ShapeType2 {
    ShapeType2 get ();
    void set (ShapeType2 value);
}
JavaScript
function get_shapeType2();
function set_shapeType2(value);

See Also

Gauge Class


SmallTickCount Property

[image]

.NET Framework Class Library
Gauge..::..SmallTickCount Property
Gauge Class See Also Send Feedback

게이지차트의 작은 눈금 수를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SmallTickCount As Integer
    Get
    Set
C#
public int SmallTickCount { get; set; }
Visual C++
public:
property int SmallTickCount {
    int get ();
    void set (int value);
}
JavaScript
function get_smallTickCount();
function set_smallTickCount(value);

See Also

Gauge Class


TickColor Property

[image]

.NET Framework Class Library
Gauge..::..TickColor Property
Gauge Class See Also Send Feedback

게이지 눈금 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TickColor As Color
    Get
    Set
C#
public Color TickColor { get; set; }
Visual C++
public:
property Color TickColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_tickColor();
function set_tickColor(value);

See Also

Gauge Class


GaugeType Enumeration

[image]

.NET Framework Class Library
GaugeType Enumeration
See Also Send Feedback

게이치 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration GaugeType
C#
public enum GaugeType
Visual C++
public enum class GaugeType
JavaScript
Hippo.GaugeType = function();
Hippo.GaugeType.createEnum('Hippo.GaugeType', false);

Members

Member name | Description
Horizontal |
Vertical |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


GraphArea Class

[image]

.NET Framework Class Library
GraphArea Class
Members See Also Send Feedback

그래프 영역

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class GraphArea
C#
[SerializableAttribute]
public class GraphArea
Visual C++
[SerializableAttribute]
public ref class GraphArea
JavaScript
Hippo.GraphArea = function();

Type.createClass(
    'Hippo.GraphArea');

Remarks

축요소(AxisFactors) 가 관장하는 양축 영역과 별게로 그래프가 그려지는 영역의 관리를 담당합니다. 그리드와 그래프영역 배경색 등의 설정이 가능합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..GraphArea

See Also

GraphArea Members


GraphArea Members

[image] [image]

.NET Framework Class Library
GraphArea Members
GraphArea Class Constructors Methods Properties See Also Send Feedback

The GraphArea type exposes the following members.

Constructors

 | Name | Description
Public method | GraphArea | GraphArea 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 그래프 영역의 배경색을 가져오고 설정합니다.
Public property | BackgroundImage | 그래프 영역의 백그라운드 이미지 경로를 가져오고 설정합니다.
Public property | BorderColor | 그래프 영역의 배경라인 색을 가져오고 설정합니다.
Public property | BottomAxisRectangle | 하단 축 영역을 가져오고 설정합니다.
Public property | GraphRectangle | 이너사각형 안쪽 그래프 그려지는 영역을 가져오고 설정합니다.
Public property | Grid | 그리드 특성을 가져오고 설정합니다.
Public property | LeftAxisRectangle | 좌측 축 영역을 가져오고 설정합니다.
Public property | RightAxisRectangle | 우측 축 영역을 가져오고 설정합니다.
Public property | TopAxisRectangle | 상단 축 영역을 가져오고 설정합니다.

See Also

GraphArea Class


GraphArea Constructor

[image]

.NET Framework Class Library
GraphArea Constructor
GraphArea Class See Also Send Feedback

GraphArea 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public GraphArea()
Visual C++
public:
GraphArea()
JavaScript
Hippo.GraphArea = function();

See Also

GraphArea Class


GraphArea Methods

[image] [image]

.NET Framework Class Library
GraphArea Methods
GraphArea Class See Also Send Feedback

The GraphArea type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GraphArea Class


GraphArea Properties

[image] [image]

.NET Framework Class Library
GraphArea Properties
GraphArea Class See Also Send Feedback

The GraphArea type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 그래프 영역의 배경색을 가져오고 설정합니다.
Public property | BackgroundImage | 그래프 영역의 백그라운드 이미지 경로를 가져오고 설정합니다.
Public property | BorderColor | 그래프 영역의 배경라인 색을 가져오고 설정합니다.
Public property | BottomAxisRectangle | 하단 축 영역을 가져오고 설정합니다.
Public property | GraphRectangle | 이너사각형 안쪽 그래프 그려지는 영역을 가져오고 설정합니다.
Public property | Grid | 그리드 특성을 가져오고 설정합니다.
Public property | LeftAxisRectangle | 좌측 축 영역을 가져오고 설정합니다.
Public property | RightAxisRectangle | 우측 축 영역을 가져오고 설정합니다.
Public property | TopAxisRectangle | 상단 축 영역을 가져오고 설정합니다.

See Also

GraphArea Class


BackColor Property

[image]

.NET Framework Class Library
GraphArea..::..BackColor Property
GraphArea Class See Also Send Feedback

그래프 영역의 배경색을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

GraphArea Class


BackgroundImage Property

[image]

.NET Framework Class Library
GraphArea..::..BackgroundImage Property
GraphArea Class See Also Send Feedback

그래프 영역의 백그라운드 이미지 경로를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackgroundImage As String
    Get
    Set
C#
public string BackgroundImage { get; set; }
Visual C++
public:
property String^ BackgroundImage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_backgroundImage();
function set_backgroundImage(value);

See Also

GraphArea Class


BorderColor Property

[image]

.NET Framework Class Library
GraphArea..::..BorderColor Property
GraphArea Class See Also Send Feedback

그래프 영역의 배경라인 색을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BorderColor As Color
    Get
    Set
C#
public Color BorderColor { get; set; }
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_borderColor();
function set_borderColor(value);

See Also

GraphArea Class


BottomAxisRectangle Property

[image]

.NET Framework Class Library
GraphArea..::..BottomAxisRectangle Property
GraphArea Class See Also Send Feedback

하단 축 영역을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BottomAxisRectangle As RectangleF
    Get
    Set
C#
public RectangleF BottomAxisRectangle { get; set; }
Visual C++
public:
property RectangleF BottomAxisRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_bottomAxisRectangle();
function set_bottomAxisRectangle(value);

See Also

GraphArea Class


GraphRectangle Property

[image]

.NET Framework Class Library
GraphArea..::..GraphRectangle Property
GraphArea Class See Also Send Feedback

이너사각형 안쪽 그래프 그려지는 영역을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GraphRectangle As RectangleF
    Get
    Set
C#
public RectangleF GraphRectangle { get; set; }
Visual C++
public:
property RectangleF GraphRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_graphRectangle();
function set_graphRectangle(value);

See Also

GraphArea Class


Grid Property

[image]

.NET Framework Class Library
GraphArea..::..Grid Property
GraphArea Class See Also Send Feedback

그리드 특성을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Grid As Grid
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Grid Grid { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Grid^ Grid {
    Grid^ get ();
    void set (Grid^ value);
}
JavaScript
function get_grid();
function set_grid(value);

See Also

GraphArea Class


LeftAxisRectangle Property

[image]

.NET Framework Class Library
GraphArea..::..LeftAxisRectangle Property
GraphArea Class See Also Send Feedback

좌측 축 영역을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LeftAxisRectangle As RectangleF
    Get
    Set
C#
public RectangleF LeftAxisRectangle { get; set; }
Visual C++
public:
property RectangleF LeftAxisRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_leftAxisRectangle();
function set_leftAxisRectangle(value);

See Also

GraphArea Class


RightAxisRectangle Property

[image]

.NET Framework Class Library
GraphArea..::..RightAxisRectangle Property
GraphArea Class See Also Send Feedback

우측 축 영역을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property RightAxisRectangle As RectangleF
    Get
    Set
C#
public RectangleF RightAxisRectangle { get; set; }
Visual C++
public:
property RectangleF RightAxisRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_rightAxisRectangle();
function set_rightAxisRectangle(value);

See Also

GraphArea Class


TopAxisRectangle Property

[image]

.NET Framework Class Library
GraphArea..::..TopAxisRectangle Property
GraphArea Class See Also Send Feedback

상단 축 영역을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TopAxisRectangle As RectangleF
    Get
    Set
C#
public RectangleF TopAxisRectangle { get; set; }
Visual C++
public:
property RectangleF TopAxisRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_topAxisRectangle();
function set_topAxisRectangle(value);

See Also

GraphArea Class


GraphAreaLocation Enumeration

[image]

.NET Framework Class Library
GraphAreaLocation Enumeration
See Also Send Feedback

그래프 영역이 2개 이상일때 나누어지는 방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration GraphAreaLocation
C#
public enum GraphAreaLocation
Visual C++
public enum class GraphAreaLocation
JavaScript
Hippo.GraphAreaLocation = function();
Hippo.GraphAreaLocation.createEnum('Hippo.GraphAreaLocation', false);

Members

Member name | Description
Vertical |
Horizontal |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


GraphColorItem Class

[image]

.NET Framework Class Library
GraphColorItem Class
Members See Also Send Feedback

그래프 칼라 아이템 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class GraphColorItem
C#
[SerializableAttribute]
public class GraphColorItem
Visual C++
[SerializableAttribute]
public ref class GraphColorItem
JavaScript
Hippo.GraphColorItem = function();

Type.createClass(
    'Hippo.GraphColorItem');

Inheritance Hierarchy

System..::..Object
Hippo..::..GraphColorItem

See Also

GraphColorItem Members


GraphColorItem Members

[image] [image]

.NET Framework Class Library
GraphColorItem Members
GraphColorItem Class Constructors Methods Properties See Also Send Feedback

The GraphColorItem type exposes the following members.

Constructors

 | Name | Description
Public method | GraphColorItem |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | MainColor | 그래프 메인 색상를 설정하고 가져옵니다.
Public property | OutLineColor | 외곽 라인 색상를 설정하고 가져옵니다.
Public property | ShadowColor | 그림자 색상를 설정하고 가져옵니다.

See Also

GraphColorItem Class


GraphColorItem Constructor

[image]

.NET Framework Class Library
GraphColorItem Constructor
GraphColorItem Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public GraphColorItem()
Visual C++
public:
GraphColorItem()
JavaScript
Hippo.GraphColorItem = function();

See Also

GraphColorItem Class


GraphColorItem Methods

[image] [image]

.NET Framework Class Library
GraphColorItem Methods
GraphColorItem Class See Also Send Feedback

The GraphColorItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GraphColorItem Class


GraphColorItem Properties

[image] [image]

.NET Framework Class Library
GraphColorItem Properties
GraphColorItem Class See Also Send Feedback

The GraphColorItem type exposes the following members.

Properties

 | Name | Description
Public property | MainColor | 그래프 메인 색상를 설정하고 가져옵니다.
Public property | OutLineColor | 외곽 라인 색상를 설정하고 가져옵니다.
Public property | ShadowColor | 그림자 색상를 설정하고 가져옵니다.

See Also

GraphColorItem Class


MainColor Property

[image]

.NET Framework Class Library
GraphColorItem..::..MainColor Property
GraphColorItem Class See Also Send Feedback

그래프 메인 색상를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MainColor As Color
    Get
    Set
C#
public Color MainColor { get; set; }
Visual C++
public:
property Color MainColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_mainColor();
function set_mainColor(value);

See Also

GraphColorItem Class


OutLineColor Property

[image]

.NET Framework Class Library
GraphColorItem..::..OutLineColor Property
GraphColorItem Class See Also Send Feedback

외곽 라인 색상를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property OutLineColor As Color
    Get
    Set
C#
public Color OutLineColor { get; set; }
Visual C++
public:
property Color OutLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_outLineColor();
function set_outLineColor(value);

See Also

GraphColorItem Class


ShadowColor Property

[image]

.NET Framework Class Library
GraphColorItem..::..ShadowColor Property
GraphColorItem Class See Also Send Feedback

그림자 색상를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ShadowColor As Color
    Get
    Set
C#
public Color ShadowColor { get; set; }
Visual C++
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_shadowColor();
function set_shadowColor(value);

See Also

GraphColorItem Class


GraphColorType Enumeration

[image]

.NET Framework Class Library
GraphColorType Enumeration
See Also Send Feedback

그래프 그리는 색상 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration GraphColorType
C#
public enum GraphColorType
Visual C++
public enum class GraphColorType
JavaScript
Hippo.GraphColorType = function();
Hippo.GraphColorType.createEnum('Hippo.GraphColorType', false);

Members

Member name | Description
Default |
Shadow |
OutLine |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Grid Class

[image]

.NET Framework Class Library
Grid Class
Members Example See Also Send Feedback

그리드 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Grid
C#
[SerializableAttribute]
public class Grid
Visual C++
[SerializableAttribute]
public ref class Grid
JavaScript
Hippo.Grid = function();

Type.createClass(
    'Hippo.Grid');

Remarks

좌표평면에 표시되는 가로, 세로줄 그리드 객체로 시리즈리스트 > GraphArea 가 소유하여 관리합니다. 축과 관련된 속성이지만 양 축을 제외한 그래프 영역만을 표시하는 부분으로 시리즈리스트에 포함되어 별도로 관리됩니다. 그리드의 두가지 배경색 등을 설정할 수 있습니다.

Examples

Copy image Copy Code
sList.GraphArea.Grid.GridDirection = GridDirection.Horizontal;

Inheritance Hierarchy

System..::..Object
Hippo..::..Grid

See Also

Grid Members


Grid Members

[image] [image]

.NET Framework Class Library
Grid Members
Grid Class Constructors Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Constructors

 | Name | Description
Public method | Grid | Grid 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | GridBackColor1 | 그리드 배경색 1 을 설정하고 가져옵니다.
Public property | GridBackColor2 | 그리드 배경색 2 를 설정하고 가져옵니다.
Public property | GridDirection | 그리드 방향을 설정하고 가져옵니다.
Public property | GridLine | 그리드 라인을 가져오고 설정합니다.
Public property | Interval | 그리드 간격수(x축)를 설정하고 가져옵니다.
Public property | IsBackGridColor | 좌표 그리드의 지그재그 배경색을 넣을 것인가 여부를 설정하고 가져옵니다.
Public property | ScaleBreakLine | 스케일 브레이크 라인을 가져오고 설정합니다.
Public property | ZeroLineColor | 제로라인의 색상을 가져오고 설정합니다.

See Also

Grid Class


Grid Constructor

[image]

.NET Framework Class Library
Grid Constructor
Grid Class See Also Send Feedback

Grid 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Grid()
Visual C++
public:
Grid()
JavaScript
Hippo.Grid = function();

See Also

Grid Class


Grid Methods

[image] [image]

.NET Framework Class Library
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Grid Class


Grid Properties

[image] [image]

.NET Framework Class Library
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | GridBackColor1 | 그리드 배경색 1 을 설정하고 가져옵니다.
Public property | GridBackColor2 | 그리드 배경색 2 를 설정하고 가져옵니다.
Public property | GridDirection | 그리드 방향을 설정하고 가져옵니다.
Public property | GridLine | 그리드 라인을 가져오고 설정합니다.
Public property | Interval | 그리드 간격수(x축)를 설정하고 가져옵니다.
Public property | IsBackGridColor | 좌표 그리드의 지그재그 배경색을 넣을 것인가 여부를 설정하고 가져옵니다.
Public property | ScaleBreakLine | 스케일 브레이크 라인을 가져오고 설정합니다.
Public property | ZeroLineColor | 제로라인의 색상을 가져오고 설정합니다.

See Also

Grid Class


GridBackColor1 Property

[image]

.NET Framework Class Library
Grid..::..GridBackColor1 Property
Grid Class See Also Send Feedback

그리드 배경색 1 을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property GridBackColor1 As Color
    Get
    Set
C#
[BindableAttribute(true)]
public Color GridBackColor1 { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Color GridBackColor1 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_gridBackColor1();
function set_gridBackColor1(value);

See Also

Grid Class


GridBackColor2 Property

[image]

.NET Framework Class Library
Grid..::..GridBackColor2 Property
Grid Class See Also Send Feedback

그리드 배경색 2 를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property GridBackColor2 As Color
    Get
    Set
C#
[BindableAttribute(true)]
public Color GridBackColor2 { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Color GridBackColor2 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_gridBackColor2();
function set_gridBackColor2(value);

See Also

Grid Class


GridDirection Property

[image]

.NET Framework Class Library
Grid..::..GridDirection Property
Grid Class See Also Send Feedback

그리드 방향을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property GridDirection As GridDirection
    Get
    Set
C#
[BindableAttribute(true)]
public GridDirection GridDirection { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property GridDirection GridDirection {
    GridDirection get ();
    void set (GridDirection value);
}
JavaScript
function get_gridDirection();
function set_gridDirection(value);

See Also

Grid Class


GridLine Property

[image]

.NET Framework Class Library
Grid..::..GridLine Property
Grid Class See Also Send Feedback

그리드 라인을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property GridLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
public Line GridLine { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Line^ GridLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_gridLine();
function set_gridLine(value);

See Also

Grid Class


Interval Property

[image]

.NET Framework Class Library
Grid..::..Interval Property
Grid Class See Also Send Feedback

그리드 간격수(x축)를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Interval As Integer
    Get
    Set
C#
[BindableAttribute(true)]
public int Interval { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property int Interval {
    int get ();
    void set (int value);
}
JavaScript
function get_interval();
function set_interval(value);

See Also

Grid Class


IsBackGridColor Property

[image]

.NET Framework Class Library
Grid..::..IsBackGridColor Property
Grid Class See Also Send Feedback

좌표 그리드의 지그재그 배경색을 넣을 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property IsBackGridColor As Boolean
    Get
    Set
C#
[BindableAttribute(true)]
public bool IsBackGridColor { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property bool IsBackGridColor {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isBackGridColor();
function set_isBackGridColor(value);

See Also

Grid Class


ScaleBreakLine Property

[image]

.NET Framework Class Library
Grid..::..ScaleBreakLine Property
Grid Class See Also Send Feedback

스케일 브레이크 라인을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ScaleBreakLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
public Line ScaleBreakLine { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Line^ ScaleBreakLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_scaleBreakLine();
function set_scaleBreakLine(value);

See Also

Grid Class


ZeroLineColor Property

[image]

.NET Framework Class Library
Grid..::..ZeroLineColor Property
Grid Class See Also Send Feedback

제로라인의 색상을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ZeroLineColor As Color
    Get
    Set
C#
[BindableAttribute(true)]
public Color ZeroLineColor { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Color ZeroLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_zeroLineColor();
function set_zeroLineColor(value);

See Also

Grid Class


GridDirection Enumeration

[image]

.NET Framework Class Library
GridDirection Enumeration
See Also Send Feedback

좌표 그리드 방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration GridDirection
C#
public enum GridDirection
Visual C++
public enum class GridDirection
JavaScript
Hippo.GridDirection = function();
Hippo.GridDirection.createEnum('Hippo.GridDirection', false);

Members

Member name | Description
Both |
Horizontal |
Vertical |
None |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


HeightType Enumeration

[image]

.NET Framework Class Library
HeightType Enumeration
See Also Send Feedback

높낮이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration HeightType
C#
public enum HeightType
Visual C++
public enum class HeightType
JavaScript
Hippo.HeightType = function();
Hippo.HeightType.createEnum('Hippo.HeightType', false);

Members

Member name | Description
Top |
Center |
Bottom |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


HippoChart Class

[image]

.NET Framework Class Library
HippoChart Class
Members See Also Send Feedback

히포차트를 나타내는 대표 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public NotInheritable Class HippoChart _
    Inherits BaseChart _
    Implements IDisposable
C#
public sealed class HippoChart : BaseChart,
    IDisposable
Visual C++
public ref class HippoChart sealed : public BaseChart,
    IDisposable
JavaScript
Hippo.HippoChart = function();

Type.createClass(
    'Hippo.HippoChart',
    Hippo.BaseChart,
    IDisposable);

Inheritance Hierarchy

System..::..Object
Hippo..::..BaseChart
Hippo..::..HippoChart

See Also

HippoChart Members


HippoChart Members

[image] [image]

.NET Framework Class Library
HippoChart Members
HippoChart Class Constructors Methods Fields Properties See Also Send Feedback

The HippoChart type exposes the following members.

Constructors

 | Name | Description
Public method | HippoChart()()()() | HippoChart 기본 생성자
Public method | HippoChart(Single, Single) | HippoChart
Public method | HippoChart(Single, Single, Single, Single) | HippoChart

Methods

 | Name | Description
Public method | Dispose | 리소스 해제
Public method | DrawChart()()()() | DrawChart (Call Method) (Overrides BaseChart..::..DrawChart()()()().)
Public method | DrawChart(SeriesList) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesList).)
Public method | DrawChart(SeriesListDictionary) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesListDictionary).)
Public method | DrawDefault | 기본 바탕 차트를 그립니다. (Overrides BaseChart..::..DrawDefault()()()().)
Public method | DrawDefault2 | 기본 바탕 차트를 그립니다.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Protected field | InnerRecPaddings | 내부 사각형 패딩값 - 좌우위아래 , 3번째는 유동적 (Inherited from BaseChart.)

Properties

 | Name | Description
Public property | BaseGraphic | 차트 기본 그래픽을 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | BaseImage | 차트 기본 바탕 이미지를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartSource | 차트 데이터 소스를 설정하고 가져옵니다.
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ErrorMessage | 에러메세지를 가져옵니다.
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | IsComplete | 차트 생성의 완료 여부를 가져옵니다.
Public property | IsDisposable | 리소스를 자동 해제할 것인가 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석을 할 것인지 여부를 설정하고 가져옵니다.
Public property | IsScroll | 차트 스크롤을 사용하는지 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | LegendBox | 범례를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Logo | 로고를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | NameColumn | 차트 이름 컬럼를을 설정하고 가져옵니다.
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ValueColumns | 차트 값 컬럼들을 설정하고 가져옵니다.
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | WorkFlowMessage | 차트가 생성되는 진행 상황을 모니터링합니다.
Public property | WorkFlowStepIndex | 차트 생성 워크 플로우 단계 인덱스

See Also

HippoChart Class


HippoChart Constructor

[image] [image]

.NET Framework Class Library
HippoChart Constructor
HippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HippoChart()()()() | HippoChart 기본 생성자
Public method | HippoChart(Single, Single) | HippoChart
Public method | HippoChart(Single, Single, Single, Single) | HippoChart

See Also

HippoChart Class
HippoChart Members


HippoChart Constructor

[image]

.NET Framework Class Library
HippoChart Constructor
HippoChart Class See Also Send Feedback

HippoChart 기본 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoChart()
Visual C++
public:
HippoChart()
JavaScript
Hippo.HippoChart = function();

See Also

HippoChart Class
HippoChart Overload


HippoChart Constructor (Single, Single)

[image]

.NET Framework Class Library
HippoChart Constructor (Single, Single)
HippoChart Class See Also Send Feedback

HippoChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    width As Single, _
    height As Single _
)
C#
public HippoChart(
    float width,
    float height
)
Visual C++
public:
HippoChart(
    float width,
    float height
)
JavaScript
Hippo.HippoChart = function(width, height);

Parameters

width
Type: System..::..Single
차트 가로길이
height
Type: System..::..Single
차트 세로길이

See Also

HippoChart Class
HippoChart Overload


HippoChart Constructor (Single, Single, Single, Single)

[image]

.NET Framework Class Library
HippoChart Constructor (Single, Single, Single, Single)
HippoChart Class See Also Send Feedback

HippoChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    width As Single, _
    height As Single, _
    width2 As Single, _
    height2 As Single _
)
C#
public HippoChart(
    float width,
    float height,
    float width2,
    float height2
)
Visual C++
public:
HippoChart(
    float width,
    float height,
    float width2,
    float height2
)
JavaScript
Hippo.HippoChart = function(width, height, width2, height2);

Parameters

width
Type: System..::..Single
height
Type: System..::..Single
width2
Type: System..::..Single
height2
Type: System..::..Single

See Also

HippoChart Class
HippoChart Overload


HippoChart Fields

[image] [image]

.NET Framework Class Library
HippoChart Fields
HippoChart Class See Also Send Feedback

The HippoChart type exposes the following members.

Fields

 | Name | Description
Protected field | InnerRecPaddings | 내부 사각형 패딩값 - 좌우위아래 , 3번째는 유동적 (Inherited from BaseChart.)

See Also

HippoChart Class


HippoChart Methods

[image] [image]

.NET Framework Class Library
HippoChart Methods
HippoChart Class See Also Send Feedback

The HippoChart type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | 리소스 해제
Public method | DrawChart()()()() | DrawChart (Call Method) (Overrides BaseChart..::..DrawChart()()()().)
Public method | DrawChart(SeriesList) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesList).)
Public method | DrawChart(SeriesListDictionary) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesListDictionary).)
Public method | DrawDefault | 기본 바탕 차트를 그립니다. (Overrides BaseChart..::..DrawDefault()()()().)
Public method | DrawDefault2 | 기본 바탕 차트를 그립니다.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

HippoChart Class


Dispose Method

[image]

.NET Framework Class Library
HippoChart..::..Dispose Method
HippoChart Class See Also Send Feedback

리소스 해제

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

HippoChart Class


DrawChart Method

[image] [image]

.NET Framework Class Library
HippoChart..::..DrawChart Method
HippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawChart()()()() | DrawChart (Call Method) (Overrides BaseChart..::..DrawChart()()()().)
Public method | DrawChart(SeriesList) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesList).)
Public method | DrawChart(SeriesListDictionary) | DrawChart (Overrides BaseChart..::..DrawChart(SeriesListDictionary).)

See Also

HippoChart Class
HippoChart Members


DrawChart Method

[image]

.NET Framework Class Library
HippoChart..::..DrawChart Method
HippoChart Class See Also Send Feedback

DrawChart (Call Method)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Sub DrawChart
C#
public override void DrawChart()
Visual C++
public:
virtual void DrawChart() override
JavaScript
function drawChart();

Implements

IChart..::..DrawChart()()()()

See Also

HippoChart Class
DrawChart Overload


DrawChart Method (SeriesList)

[image]

.NET Framework Class Library
HippoChart..::..DrawChart Method (SeriesList)
HippoChart Class See Also Send Feedback

DrawChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Sub DrawChart ( _
    chartsource As SeriesList _
)
C#
public override void DrawChart(
    SeriesList chartsource
)
Visual C++
public:
virtual void DrawChart(
    SeriesList^ chartsource
) override
JavaScript
function drawChart(chartsource);

Parameters

chartsource
Type: Hippo..::..SeriesList
SeriesList

Implements

IChart..::..DrawChart(SeriesList)

See Also

HippoChart Class
DrawChart Overload


DrawChart Method (SeriesListDictionary)

[image]

.NET Framework Class Library
HippoChart..::..DrawChart Method (SeriesListDictionary)
HippoChart Class See Also Send Feedback

DrawChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Sub DrawChart ( _
    chartsources As SeriesListDictionary _
)
C#
public override void DrawChart(
    SeriesListDictionary chartsources
)
Visual C++
public:
virtual void DrawChart(
    SeriesListDictionary^ chartsources
) override
JavaScript
function drawChart(chartsources);

Parameters

chartsources
Type: Hippo..::..SeriesListDictionary
SeriesListDictionary

Implements

IChart..::..DrawChart(SeriesListDictionary)

See Also

HippoChart Class
DrawChart Overload


DrawDefault Method

[image]

.NET Framework Class Library
HippoChart..::..DrawDefault Method
HippoChart Class See Also Send Feedback

기본 바탕 차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Sub DrawDefault
C#
public override void DrawDefault()
Visual C++
public:
virtual void DrawDefault() override
JavaScript
function drawDefault();

Implements

IChart..::..DrawDefault()()()()

See Also

HippoChart Class


DrawDefault2 Method

[image]

.NET Framework Class Library
HippoChart..::..DrawDefault2 Method
HippoChart Class See Also Send Feedback

기본 바탕 차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawDefault2
C#
public void DrawDefault2()
Visual C++
public:
void DrawDefault2()
JavaScript
function drawDefault2();

See Also

HippoChart Class


HippoChart Properties

[image] [image]

.NET Framework Class Library
HippoChart Properties
HippoChart Class See Also Send Feedback

The HippoChart type exposes the following members.

Properties

 | Name | Description
Public property | BaseGraphic | 차트 기본 그래픽을 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | BaseImage | 차트 기본 바탕 이미지를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ChartSource | 차트 데이터 소스를 설정하고 가져옵니다.
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ErrorMessage | 에러메세지를 가져옵니다.
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | IsComplete | 차트 생성의 완료 여부를 가져옵니다.
Public property | IsDisposable | 리소스를 자동 해제할 것인가 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석을 할 것인지 여부를 설정하고 가져옵니다.
Public property | IsScroll | 차트 스크롤을 사용하는지 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | LegendBox | 범례를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Logo | 로고를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | NameColumn | 차트 이름 컬럼를을 설정하고 가져옵니다.
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | ValueColumns | 차트 값 컬럼들을 설정하고 가져옵니다.
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다. (Inherited from BaseChart.)
Public property | WorkFlowMessage | 차트가 생성되는 진행 상황을 모니터링합니다.
Public property | WorkFlowStepIndex | 차트 생성 워크 플로우 단계 인덱스

See Also

HippoChart Class


ChartSource Property

[image]

.NET Framework Class Library
HippoChart..::..ChartSource Property
HippoChart Class See Also Send Feedback

차트 데이터 소스를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartSource As DataTable
    Get
    Set
C#
public DataTable ChartSource { get; set; }
Visual C++
public:
property DataTable^ ChartSource {
    DataTable^ get ();
    void set (DataTable^ value);
}
JavaScript
function get_chartSource();
function set_chartSource(value);

See Also

HippoChart Class


ErrorMessage Property

[image]

.NET Framework Class Library
HippoChart..::..ErrorMessage Property
HippoChart Class See Also Send Feedback

에러메세지를 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorMessage As String
    Get
C#
public string ErrorMessage { get; }
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
}
JavaScript
function get_errorMessage();

See Also

HippoChart Class


IsComplete Property

[image]

.NET Framework Class Library
HippoChart..::..IsComplete Property
HippoChart Class See Also Send Feedback

차트 생성의 완료 여부를 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property IsComplete As Boolean
    Get
C#
public bool IsComplete { get; }
Visual C++
public:
property bool IsComplete {
    bool get ();
}
JavaScript
function get_isComplete();

See Also

HippoChart Class


IsDisposable Property

[image]

.NET Framework Class Library
HippoChart..::..IsDisposable Property
HippoChart Class See Also Send Feedback

리소스를 자동 해제할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDisposable As Boolean
    Get
    Set
C#
public bool IsDisposable { get; set; }
Visual C++
public:
property bool IsDisposable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDisposable();
function set_isDisposable(value);

See Also

HippoChart Class


IsEmptyanalysis Property

[image]

.NET Framework Class Library
HippoChart..::..IsEmptyanalysis Property
HippoChart Class See Also Send Feedback

공간 분석을 할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsEmptyanalysis As Boolean
    Get
    Set
C#
public bool IsEmptyanalysis { get; set; }
Visual C++
public:
property bool IsEmptyanalysis {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isEmptyanalysis();
function set_isEmptyanalysis(value);

See Also

HippoChart Class


IsScroll Property

[image]

.NET Framework Class Library
HippoChart..::..IsScroll Property
HippoChart Class See Also Send Feedback

차트 스크롤을 사용하는지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsScroll As Boolean
    Get
    Set
C#
public bool IsScroll { get; set; }
Visual C++
public:
property bool IsScroll {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isScroll();
function set_isScroll(value);

See Also

HippoChart Class


NameColumn Property

[image]

.NET Framework Class Library
HippoChart..::..NameColumn Property
HippoChart Class See Also Send Feedback

차트 이름 컬럼를을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property NameColumn As String
    Get
    Set
C#
public string NameColumn { get; set; }
Visual C++
public:
property String^ NameColumn {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nameColumn();
function set_nameColumn(value);

See Also

HippoChart Class


ValueColumns Property

[image]

.NET Framework Class Library
HippoChart..::..ValueColumns Property
HippoChart Class See Also Send Feedback

차트 값 컬럼들을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ValueColumns As String()
    Get
    Set
C#
public string[] ValueColumns { get; set; }
Visual C++
public:
property array<String^>^ ValueColumns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_valueColumns();
function set_valueColumns(value);

See Also

HippoChart Class


WorkFlowMessage Property

[image]

.NET Framework Class Library
HippoChart..::..WorkFlowMessage Property
HippoChart Class See Also Send Feedback

차트가 생성되는 진행 상황을 모니터링합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property WorkFlowMessage As String
    Get
    Set
C#
public string WorkFlowMessage { get; set; }
Visual C++
public:
property String^ WorkFlowMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_workFlowMessage();
function set_workFlowMessage(value);

See Also

HippoChart Class


WorkFlowStepIndex Property

[image]

.NET Framework Class Library
HippoChart..::..WorkFlowStepIndex Property
HippoChart Class See Also Send Feedback

차트 생성 워크 플로우 단계 인덱스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property WorkFlowStepIndex As Integer
    Get
    Set
C#
public int WorkFlowStepIndex { get; set; }
Visual C++
public:
property int WorkFlowStepIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_workFlowStepIndex();
function set_workFlowStepIndex(value);

See Also

HippoChart Class


HippoCollectionBase(T) Class

[image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)> Class
Members See Also Send Feedback

히포차트 기본 컬렉션 베이스 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class HippoCollectionBase(Of T) _
    Inherits List(Of T)
C#
[SerializableAttribute]
public class HippoCollectionBase<T> : List<T>
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class HippoCollectionBase : public List<T>
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<'T>)>)>
Hippo..::..HippoCollectionBase<(Of <(<'T>)>)>
Hippo..::..Angles
Hippo..::..AxisAreaCollection
Hippo..::..AxisList
Hippo..::..AxisMarkerCollection
Hippo..::..AxisScaleRangeCollection
Hippo..::..AxisTickCollection
Hippo..::..AxisTickPointList
Hippo..::..BoxPlotList
Hippo..::..ItemNames
Hippo..::..LabelList
Hippo..::..OutlierList
Hippo..::..Percentages
Hippo..::..PieFigures
Hippo..::..SeriesCollection
Hippo..::..SeriesItemCollection
Hippo..::..SeriesListDictionary
Hippo..::..VectorList
Hippo.WindowsForm4..::..HippoRealTimeAttributeCollection

See Also

HippoCollectionBase<(Of <(<'T>)>)> Members


HippoCollectionBase(T) Members

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)> Members
HippoCollectionBase<(Of <(<'T>)>)> Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The HippoCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HippoCollectionBase<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' T >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' T >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' T >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' T >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' T >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' T >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' T >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class


HippoCollectionBase(T) Constructor

[image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)> Constructor
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoCollectionBase()
Visual C++
public:
HippoCollectionBase()
JavaScript
Hippo.HippoCollectionBase = function();

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class


HippoCollectionBase(T) Methods

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)> Methods
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

The HippoCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' T >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' T >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' T >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' T >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..BinarySearch Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


CopyTo Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..CopyTo Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


FindIndex Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..FindIndex Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..FindLastIndex Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


IndexOf Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..IndexOf Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..LastIndexOf Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


Reverse Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..Reverse Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


Sort Method

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)>..::..Sort Method
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class
HippoCollectionBase<(Of <(<'T>)>)> Members


HippoCollectionBase(T) Properties

[image] [image]

.NET Framework Class Library
HippoCollectionBase<(Of <(<'T>)>)> Properties
HippoCollectionBase<(Of <(<'T>)>)> Class See Also Send Feedback

The HippoCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' T >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' T >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' T >)>)>.)

See Also

HippoCollectionBase<(Of <(<'T>)>)> Class


HippoCollectionBase2(E, T) Class

[image]

.NET Framework Class Library
HippoCollectionBase2<(Of <(<'E, T>)>)> Class
Members See Also Send Feedback

히포차트 기본 컬렉션 베이스 클래스 두가지 타입 버전

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class HippoCollectionBase2(Of E, T) _
    Inherits SortedList(Of E, T)
C#
[SerializableAttribute]
public class HippoCollectionBase2<E, T> : SortedList<E, T>
Visual C++
[SerializableAttribute]
generic<typename E, typename T>
public ref class HippoCollectionBase2 : public SortedList<E, T>
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

E
T

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..SortedList <(Of <(<'E, T>)>)>
Hippo..::..HippoCollectionBase2<(Of <(<'E, T>)>)>
Hippo..::..AnalysisItemCollection

See Also

HippoCollectionBase2<(Of <(<'E, T>)>)> Members


HippoCollectionBase2(E, T) Members

[image] [image]

.NET Framework Class Library
HippoCollectionBase2<(Of <(<'E, T>)>)> Members
HippoCollectionBase2<(Of <(<'E, T>)>)> Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The HippoCollectionBase2<(Of <(<'E, T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HippoCollectionBase2<(Of <(<'E, T>)>)> |

Methods

 | Name | Description
Public method | Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | Clear | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ContainsKey | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ContainsValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOfKey | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | IndexOfValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | RemoveAt | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | TryGetValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Comparer | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Count | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Item | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Contains | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Contains | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..CopyTo | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..IsFixedSize | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..IsReadOnly | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..IsReadOnly | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Item | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

See Also

HippoCollectionBase2<(Of <(<'E, T>)>)> Class


HippoCollectionBase2(E, T) Constructor

[image]

.NET Framework Class Library
HippoCollectionBase2<(Of <(<'E, T>)>)> Constructor
HippoCollectionBase2<(Of <(<'E, T>)>)> Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoCollectionBase2()
Visual C++
public:
HippoCollectionBase2()
JavaScript
Hippo.HippoCollectionBase2 = function();

See Also

HippoCollectionBase2<(Of <(<'E, T>)>)> Class


HippoCollectionBase2(E, T) Methods

[image] [image]

.NET Framework Class Library
HippoCollectionBase2<(Of <(<'E, T>)>)> Methods
HippoCollectionBase2<(Of <(<'E, T>)>)> Class See Also Send Feedback

The HippoCollectionBase2<(Of <(<'E, T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | Clear | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ContainsKey | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ContainsValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOfKey | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | IndexOfValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | RemoveAt | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public method | TryGetValue | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Add | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Contains | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Contains | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..CopyTo | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Remove | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

See Also

HippoCollectionBase2<(Of <(<'E, T>)>)> Class


HippoCollectionBase2(E, T) Properties

[image] [image]

.NET Framework Class Library
HippoCollectionBase2<(Of <(<'E, T>)>)> Properties
HippoCollectionBase2<(Of <(<'E, T>)>)> Class See Also Send Feedback

The HippoCollectionBase2<(Of <(<'E, T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Comparer | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Count | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Item | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Public property | Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IDictionary..::..IsFixedSize | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>)..::..IsReadOnly | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..IsReadOnly | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Item | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Keys | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary<(Of <<'(TKey, TValue>)>>)..::..Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)
Explicit interface implemetation | IDictionary..::..Values | (Inherited from SortedList <(Of <(<' E, T >)>)>.)

See Also

HippoCollectionBase2<(Of <(<'E, T>)>)> Class


HippoEngine Class

[image]

.NET Framework Class Library
HippoEngine Class
Members See Also Send Feedback

데이터베이스와 히포차트를 연동해주는 데이터 소스 엔진 클래스입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class HippoEngine
C#
public class HippoEngine
Visual C++
public ref class HippoEngine
JavaScript
Hippo.HippoEngine = function();

Type.createClass(
    'Hippo.HippoEngine');

Remarks

MS-SQL, Oracle, MySql와 같은 데이터 베이스와 Access, Excel, xml 을 지원합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..HippoEngine

See Also

HippoEngine Members


HippoEngine Members

[image] [image]

.NET Framework Class Library
HippoEngine Members
HippoEngine Class Constructors Methods Properties See Also Send Feedback

The HippoEngine type exposes the following members.

Constructors

 | Name | Description
Public method | HippoEngine()()()() | HippoEngine 생성자
Public method | HippoEngine(String) | HippoEngine 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSeriesList(array<String>[]()[][]) | 시리즈 리스트를 구합니다. (값 배열 만으로 간단한 시리즈리스트를 구성합니다)
Public method | GetSeriesList(array<Double>[]()[][], array<Double>[]()[][]) | 시리즈 리스트를 구합니다. (x축이 숫자형일 경우에 이름배열, 값 배열로 구성합니다)
Public method | GetSeriesList(String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][]) | 시리즈 리스트를 구합니다. (이름 배열, 값 배열을 통해 시리즈리스트를 구성합니다)
Public method | GetSeriesList(Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (main)
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (x축 데이터타입을 지정할 수 있는 방식입니다)
Public method | GetSeriesList(DataTable, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치 표현 여부를 설정할 수 있는 방식입니다)
Public method | GetSeriesList(AxisDataType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치표현, 데이터타입을 모두 설정할 수 있는 방식입니다)
Public method | GetSeriesListOfBoxPlot(DataTable, String, String) | GetSeriesListOfBoxPlot
Public method | GetSeriesListOfBoxPlot(DataSourceType, String, String) | GetSeriesListOfBoxPlot
Public method | GetSeriesListOfGantt(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataSourceType, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfStock(DataTable, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataSourceType, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataTable, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. ) 2015.4.20 일 추가됨
Public method | GetSeriesListOfStock(DataSourceType, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfVector(DataTable, String, String, String, String) | GetSeriesListOfVector
Public method | GetSeriesListOfVector(DataSourceType, String, String, String, String) | GetSeriesListOfVector
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | 연결 문자열을 설정하고 가져옵니다.
Public property | DataType | 데이터소스 타입을 설정하고 가져옵니다.
Public property | ErrorMessage | 에러 메세지
Public property | Query | 쿼리 문자열을 설정하고 가져옵니다.
Public property | XmlPath | Xml 파일의 경로를 설정하고 가져옵니다.

See Also

HippoEngine Class


HippoEngine Constructor

[image] [image]

.NET Framework Class Library
HippoEngine Constructor
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HippoEngine()()()() | HippoEngine 생성자
Public method | HippoEngine(String) | HippoEngine 생성자

See Also

HippoEngine Class
HippoEngine Members


HippoEngine Constructor

[image]

.NET Framework Class Library
HippoEngine Constructor
HippoEngine Class See Also Send Feedback

HippoEngine 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoEngine()
Visual C++
public:
HippoEngine()
JavaScript
Hippo.HippoEngine = function();

See Also

HippoEngine Class
HippoEngine Overload


HippoEngine Constructor (String)

[image]

.NET Framework Class Library
HippoEngine Constructor (String)
HippoEngine Class See Also Send Feedback

HippoEngine 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    connectionString As String _
)
C#
public HippoEngine(
    string connectionString
)
Visual C++
public:
HippoEngine(
    String^ connectionString
)
JavaScript
Hippo.HippoEngine = function(connectionString);

Parameters

connectionString
Type: System..::..String
연결문자열

See Also

HippoEngine Class
HippoEngine Overload


HippoEngine Methods

[image] [image]

.NET Framework Class Library
HippoEngine Methods
HippoEngine Class See Also Send Feedback

The HippoEngine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSeriesList(array<String>[]()[][]) | 시리즈 리스트를 구합니다. (값 배열 만으로 간단한 시리즈리스트를 구성합니다)
Public method | GetSeriesList(array<Double>[]()[][], array<Double>[]()[][]) | 시리즈 리스트를 구합니다. (x축이 숫자형일 경우에 이름배열, 값 배열로 구성합니다)
Public method | GetSeriesList(String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][]) | 시리즈 리스트를 구합니다. (이름 배열, 값 배열을 통해 시리즈리스트를 구성합니다)
Public method | GetSeriesList(Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (main)
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (x축 데이터타입을 지정할 수 있는 방식입니다)
Public method | GetSeriesList(DataTable, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치 표현 여부를 설정할 수 있는 방식입니다)
Public method | GetSeriesList(AxisDataType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치표현, 데이터타입을 모두 설정할 수 있는 방식입니다)
Public method | GetSeriesListOfBoxPlot(DataTable, String, String) | GetSeriesListOfBoxPlot
Public method | GetSeriesListOfBoxPlot(DataSourceType, String, String) | GetSeriesListOfBoxPlot
Public method | GetSeriesListOfGantt(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataSourceType, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfStock(DataTable, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataSourceType, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataTable, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. ) 2015.4.20 일 추가됨
Public method | GetSeriesListOfStock(DataSourceType, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfVector(DataTable, String, String, String, String) | GetSeriesListOfVector
Public method | GetSeriesListOfVector(DataSourceType, String, String, String, String) | GetSeriesListOfVector
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

HippoEngine Class


GetSeriesList Method

[image] [image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSeriesList(array<String>[]()[][]) | 시리즈 리스트를 구합니다. (값 배열 만으로 간단한 시리즈리스트를 구성합니다)
Public method | GetSeriesList(array<Double>[]()[][], array<Double>[]()[][]) | 시리즈 리스트를 구합니다. (x축이 숫자형일 경우에 이름배열, 값 배열로 구성합니다)
Public method | GetSeriesList(String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][]) | 시리즈 리스트를 구합니다. (이름 배열, 값 배열을 통해 시리즈리스트를 구성합니다)
Public method | GetSeriesList(Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (main)
Public method | GetSeriesList(array<String>[]()[][], array<String>[]()[][], Boolean) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (x축 데이터타입을 지정할 수 있는 방식입니다)
Public method | GetSeriesList(DataTable, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치 표현 여부를 설정할 수 있는 방식입니다)
Public method | GetSeriesList(AxisDataType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataSourceType, Boolean, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.
Public method | GetSeriesList(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다. (수치표현, 데이터타입을 모두 설정할 수 있는 방식입니다)

See Also

HippoEngine Class
HippoEngine Members


GetSeriesList Method (String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (값 배열 만으로 간단한 시리즈리스트를 구성합니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    array<String^>^ values
)
JavaScript
function getSeriesList(values);

Parameters

values
Type: array< System..::..String >[]()[][]
y축 이름 리스트

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (Double[], Double[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (array<Double>[]()[][], array<Double>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (x축이 숫자형일 경우에 이름배열, 값 배열로 구성합니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    xvalues As Double(), _
    yvalues As Double() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    double[] xvalues,
    double[] yvalues
)
Visual C++
public:
SeriesList^ GetSeriesList(
    array<double>^ xvalues,
    array<double>^ yvalues
)
JavaScript
function getSeriesList(xvalues, yvalues);

Parameters

xvalues
Type: array< System..::..Double >[]()[][]
yvalues
Type: array< System..::..Double >[]()[][]

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(name, ... values);

Parameters

name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (String[], Boolean)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (array<String>[]()[][], Boolean)
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    values As String(), _
    IsShowFigures As Boolean _
) As SeriesList
C#
public SeriesList GetSeriesList(
    string[] values,
    bool IsShowFigures
)
Visual C++
public:
SeriesList^ GetSeriesList(
    array<String^>^ values,
    bool IsShowFigures
)
JavaScript
function getSeriesList(values, IsShowFigures);

Parameters

values
Type: array< System..::..String >[]()[][]
y축 이름 리스트
IsShowFigures
Type: System..::..Boolean
수치표시 여부

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (String[], String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (array<String>[]()[][], array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (이름 배열, 값 배열을 통해 시리즈리스트를 구성합니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    names As String(), _
    values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    string[] names,
    string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    array<String^>^ names,
    array<String^>^ values
)
JavaScript
function getSeriesList(names, values);

Parameters

names
Type: array< System..::..String >[]()[][]
x축 이름 리스트
values
Type: array< System..::..String >[]()[][]
y축 이름 리스트

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    IsShowFigures As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    bool IsShowFigures,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    bool IsShowFigures,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(IsShowFigures, name, ... values);

Parameters

IsShowFigures
Type: System..::..Boolean
수치표시 여부
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataTable, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataTable, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (main)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    source As DataTable, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataTable source,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataTable^ source,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(source, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터소스
name
Type: System..::..String
이름 컬럼
values
Type: array< System..::..String >[]()[][]
값 컬럼들

Return Value

Remarks

기본형 메소드로 가장 권장되는 메소드. 실제 데이터를 DataTable 형식으로 구성한 후에 히포엔진으로 넘기는 방식입니다.

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (String[], String[], Boolean)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (array<String>[]()[][], array<String>[]()[][], Boolean)
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    names As String(), _
    values As String(), _
    IsShowFigures As Boolean _
) As SeriesList
C#
public SeriesList GetSeriesList(
    string[] names,
    string[] values,
    bool IsShowFigures
)
Visual C++
public:
SeriesList^ GetSeriesList(
    array<String^>^ names,
    array<String^>^ values,
    bool IsShowFigures
)
JavaScript
function getSeriesList(names, values, IsShowFigures);

Parameters

names
Type: array< System..::..String >[]()[][]
x축 이름 리스트
values
Type: array< System..::..String >[]()[][]
y축 이름 리스트
IsShowFigures
Type: System..::..Boolean
수치표시 여부

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    datatype As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    AxisDataType datatype,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    AxisDataType datatype,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(datatype, name, ... values);

Parameters

datatype
Type: Hippo..::..AxisDataType
x축 데이터 타입
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataSourceType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataSourceType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    dataType As DataSourceType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataSourceType dataType,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataSourceType dataType,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(dataType, name, ... values);

Parameters

dataType
Type: Hippo..::..DataSourceType
데이터 소스 타입
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataTable, AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataTable, AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (x축 데이터타입을 지정할 수 있는 방식입니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    source As DataTable, _
    datatype As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataTable source,
    AxisDataType datatype,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataTable^ source,
    AxisDataType datatype,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(source, datatype, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터소스
datatype
Type: Hippo..::..AxisDataType
x축 데이터 타입
name
Type: System..::..String
x축 컬럼
values
Type: array< System..::..String >[]()[][]
y축 컬럼들

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataTable, Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataTable, Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (수치 표현 여부를 설정할 수 있는 방식입니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    source As DataTable, _
    IsShowFigures As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataTable source,
    bool IsShowFigures,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataTable^ source,
    bool IsShowFigures,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(source, IsShowFigures, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터소스
IsShowFigures
Type: System..::..Boolean
수치표시 여부
name
Type: System..::..String
이름 컬럼
values
Type: array< System..::..String >[]()[][]
값 컬럼들

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (AxisDataType, Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (AxisDataType, Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    datatype As AxisDataType, _
    IsShowFigures As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    AxisDataType datatype,
    bool IsShowFigures,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    AxisDataType datatype,
    bool IsShowFigures,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(datatype, IsShowFigures, name, ... values);

Parameters

datatype
Type: Hippo..::..AxisDataType
x축 데이터 타입
IsShowFigures
Type: System..::..Boolean
수치표시 여부
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataSourceType, Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataSourceType, Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    dataType As DataSourceType, _
    IsShowFigures As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataSourceType dataType,
    bool IsShowFigures,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataSourceType dataType,
    bool IsShowFigures,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(dataType, IsShowFigures, name, ... values);

Parameters

dataType
Type: Hippo..::..DataSourceType
데이터 소스 타입
IsShowFigures
Type: System..::..Boolean
수치표시 여부
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesList Method (DataTable, Boolean, AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesList Method (DataTable, Boolean, AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다. (수치표현, 데이터타입을 모두 설정할 수 있는 방식입니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesList ( _
    source As DataTable, _
    IsShowFigures As Boolean, _
    datatype As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesList(
    DataTable source,
    bool IsShowFigures,
    AxisDataType datatype,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesList(
    DataTable^ source,
    bool IsShowFigures,
    AxisDataType datatype,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesList(source, IsShowFigures, datatype, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터소스
IsShowFigures
Type: System..::..Boolean
수치표시 여부
datatype
Type: Hippo..::..AxisDataType
x축 데이터 타입
name
Type: System..::..String
이름 컬럼
values
Type: array< System..::..String >[]()[][]
값 컬럼들

Return Value

See Also

HippoEngine Class
GetSeriesList Overload


GetSeriesListOfBoxPlot Method

[image] [image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfBoxPlot Method
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSeriesListOfBoxPlot(DataTable, String, String) | GetSeriesListOfBoxPlot
Public method | GetSeriesListOfBoxPlot(DataSourceType, String, String) | GetSeriesListOfBoxPlot

See Also

HippoEngine Class
HippoEngine Members


GetSeriesListOfBoxPlot Method (DataTable, String, String)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfBoxPlot Method (DataTable, String, String)
HippoEngine Class See Also Send Feedback

GetSeriesListOfBoxPlot

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfBoxPlot ( _
    source As DataTable, _
    groupName As String, _
    values As String _
) As SeriesList
C#
public SeriesList GetSeriesListOfBoxPlot(
    DataTable source,
    string groupName,
    string values
)
Visual C++
public:
SeriesList^ GetSeriesListOfBoxPlot(
    DataTable^ source,
    String^ groupName,
    String^ values
)
JavaScript
function getSeriesListOfBoxPlot(source, groupName, values);

Parameters

source
Type: System.Data..::..DataTable
groupName
Type: System..::..String
values
Type: System..::..String

Return Value

See Also

HippoEngine Class
GetSeriesListOfBoxPlot Overload


GetSeriesListOfBoxPlot Method (DataSourceType, String, String)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfBoxPlot Method (DataSourceType, String, String)
HippoEngine Class See Also Send Feedback

GetSeriesListOfBoxPlot

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfBoxPlot ( _
    dataType As DataSourceType, _
    groupName As String, _
    values As String _
) As SeriesList
C#
public SeriesList GetSeriesListOfBoxPlot(
    DataSourceType dataType,
    string groupName,
    string values
)
Visual C++
public:
SeriesList^ GetSeriesListOfBoxPlot(
    DataSourceType dataType,
    String^ groupName,
    String^ values
)
JavaScript
function getSeriesListOfBoxPlot(dataType, groupName, values);

Parameters

dataType
Type: Hippo..::..DataSourceType
groupName
Type: System..::..String
values
Type: System..::..String

Return Value

See Also

HippoEngine Class
GetSeriesListOfBoxPlot Overload


GetSeriesListOfGantt Method

[image] [image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfGantt Method
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSeriesListOfGantt(AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataSourceType, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)
Public method | GetSeriesListOfGantt(DataTable, Boolean, AxisDataType, String, array<String>[]()[][]) | 시리즈 리스트를 구합니다.(간트차트)

See Also

HippoEngine Class
HippoEngine Members


GetSeriesListOfGantt Method (AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfGantt Method (AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.(간트차트)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfGantt ( _
    dataFormat As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfGantt(
    AxisDataType dataFormat,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfGantt(
    AxisDataType dataFormat,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfGantt(dataFormat, name, ... values);

Parameters

dataFormat
Type: Hippo..::..AxisDataType
데이터 포맷(숫자, 날짜)
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesListOfGantt Overload


GetSeriesListOfGantt Method (DataTable, AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfGantt Method (DataTable, AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.(간트차트)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfGantt ( _
    source As DataTable, _
    dataFormat As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfGantt(
    DataTable source,
    AxisDataType dataFormat,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfGantt(
    DataTable^ source,
    AxisDataType dataFormat,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfGantt(source, dataFormat, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터 소스
dataFormat
Type: Hippo..::..AxisDataType
간트 데이터 타입(숫자형식, 날짜형식)
name
Type: System..::..String
이름 항목들
values
Type: array< System..::..String >[]()[][]
값 항목들(2개씩 짝수로 넘겨야되며, 홀수 인덱스 값이 시작기준이고 짝수 인덱스 값이 종료기준입니다.)

Return Value

See Also

HippoEngine Class
GetSeriesListOfGantt Overload


GetSeriesListOfGantt Method (DataSourceType, AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfGantt Method (DataSourceType, AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.(간트차트)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfGantt ( _
    dataType As DataSourceType, _
    dataFormat As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfGantt(
    DataSourceType dataType,
    AxisDataType dataFormat,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfGantt(
    DataSourceType dataType,
    AxisDataType dataFormat,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfGantt(dataType, dataFormat, name, ... values);

Parameters

dataType
Type: Hippo..::..DataSourceType
데이터 소스 타입
dataFormat
Type: Hippo..::..AxisDataType
데이터 포맷(숫자, 날짜)
name
Type: System..::..String
x축을 나타내는 컬럼 이름
values
Type: array< System..::..String >[]()[][]
y축을 나타내는 컬럼 이름

Return Value

See Also

HippoEngine Class
GetSeriesListOfGantt Overload


GetSeriesListOfGantt Method (DataTable, Boolean, AxisDataType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfGantt Method (DataTable, Boolean, AxisDataType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

시리즈 리스트를 구합니다.(간트차트)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfGantt ( _
    source As DataTable, _
    IsShowFigures As Boolean, _
    dataFormat As AxisDataType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfGantt(
    DataTable source,
    bool IsShowFigures,
    AxisDataType dataFormat,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfGantt(
    DataTable^ source,
    bool IsShowFigures,
    AxisDataType dataFormat,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfGantt(source, IsShowFigures, dataFormat, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
데이터 소스
IsShowFigures
Type: System..::..Boolean
수치표시 여부
dataFormat
Type: Hippo..::..AxisDataType
간트 데이터 타입(숫자형식, 날짜형식)
name
Type: System..::..String
이름 항목들
values
Type: array< System..::..String >[]()[][]
값 항목들(2개씩 짝수로 넘겨야되며, 홀수 인덱스 값이 시작기준이고 짝수 인덱스 값이 종료기준입니다.)

Return Value

See Also

HippoEngine Class
GetSeriesListOfGantt Overload


GetSeriesListOfStock Method

[image] [image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfStock Method
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSeriesListOfStock(DataTable, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataSourceType, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )
Public method | GetSeriesListOfStock(DataTable, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. ) 2015.4.20 일 추가됨
Public method | GetSeriesListOfStock(DataSourceType, Boolean, String, array<String>[]()[][]) | 주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )

See Also

HippoEngine Class
HippoEngine Members


GetSeriesListOfStock Method (DataTable, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfStock Method (DataTable, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfStock ( _
    source As DataTable, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfStock(
    DataTable source,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfStock(
    DataTable^ source,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfStock(source, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
name
Type: System..::..String
values
Type: array< System..::..String >[]()[][]

Return Value

See Also

HippoEngine Class
GetSeriesListOfStock Overload


GetSeriesListOfStock Method (DataSourceType, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfStock Method (DataSourceType, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfStock ( _
    dataType As DataSourceType, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfStock(
    DataSourceType dataType,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfStock(
    DataSourceType dataType,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfStock(dataType, name, ... values);

Parameters

dataType
Type: Hippo..::..DataSourceType
name
Type: System..::..String
values
Type: array< System..::..String >[]()[][]

Return Value

See Also

HippoEngine Class
GetSeriesListOfStock Overload


GetSeriesListOfStock Method (DataTable, Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfStock Method (DataTable, Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. ) 2015.4.20 일 추가됨

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfStock ( _
    source As DataTable, _
    isDateTime As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfStock(
    DataTable source,
    bool isDateTime,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfStock(
    DataTable^ source,
    bool isDateTime,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfStock(source, isDateTime, name, ... values);

Parameters

source
Type: System.Data..::..DataTable
isDateTime
Type: System..::..Boolean
X축이 날짜형인가 여부
name
Type: System..::..String
values
Type: array< System..::..String >[]()[][]

Return Value

See Also

HippoEngine Class
GetSeriesListOfStock Overload


GetSeriesListOfStock Method (DataSourceType, Boolean, String, String[])

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfStock Method (DataSourceType, Boolean, String, array<String>[]()[][])
HippoEngine Class See Also Send Feedback

주식차트 시리즈 리스트를 구합니다. (values 파라미터 넘기는 순서는 시가, 종가, 저가, 고가 순입니다. )

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfStock ( _
    dataType As DataSourceType, _
    isDateTime As Boolean, _
    name As String, _
    ParamArray values As String() _
) As SeriesList
C#
public SeriesList GetSeriesListOfStock(
    DataSourceType dataType,
    bool isDateTime,
    string name,
    params string[] values
)
Visual C++
public:
SeriesList^ GetSeriesListOfStock(
    DataSourceType dataType,
    bool isDateTime,
    String^ name,
    ... array<String^>^ values
)
JavaScript
function getSeriesListOfStock(dataType, isDateTime, name, ... values);

Parameters

dataType
Type: Hippo..::..DataSourceType
isDateTime
Type: System..::..Boolean
X축이 날짜형인가 여부
name
Type: System..::..String
values
Type: array< System..::..String >[]()[][]

Return Value

See Also

HippoEngine Class
GetSeriesListOfStock Overload


GetSeriesListOfVector Method

[image] [image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfVector Method
HippoEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSeriesListOfVector(DataTable, String, String, String, String) | GetSeriesListOfVector
Public method | GetSeriesListOfVector(DataSourceType, String, String, String, String) | GetSeriesListOfVector

See Also

HippoEngine Class
HippoEngine Members


GetSeriesListOfVector Method (DataTable, String, String, String, String)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfVector Method (DataTable, String, String, String, String)
HippoEngine Class See Also Send Feedback

GetSeriesListOfVector

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfVector ( _
    source As DataTable, _
    name As String, _
    forceColumn As String, _
    directionColumn As String, _
    stairColumn As String _
) As SeriesList
C#
public SeriesList GetSeriesListOfVector(
    DataTable source,
    string name,
    string forceColumn,
    string directionColumn,
    string stairColumn
)
Visual C++
public:
SeriesList^ GetSeriesListOfVector(
    DataTable^ source,
    String^ name,
    String^ forceColumn,
    String^ directionColumn,
    String^ stairColumn
)
JavaScript
function getSeriesListOfVector(source, name, forceColumn, directionColumn, stairColumn);

Parameters

source
Type: System.Data..::..DataTable
name
Type: System..::..String
forceColumn
Type: System..::..String
directionColumn
Type: System..::..String
stairColumn
Type: System..::..String

Return Value

See Also

HippoEngine Class
GetSeriesListOfVector Overload


GetSeriesListOfVector Method (DataSourceType, String, String, String, String)

[image]

.NET Framework Class Library
HippoEngine..::..GetSeriesListOfVector Method (DataSourceType, String, String, String, String)
HippoEngine Class See Also Send Feedback

GetSeriesListOfVector

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function GetSeriesListOfVector ( _
    dataType As DataSourceType, _
    name As String, _
    forceColumn As String, _
    directionColumn As String, _
    stairColumn As String _
) As SeriesList
C#
public SeriesList GetSeriesListOfVector(
    DataSourceType dataType,
    string name,
    string forceColumn,
    string directionColumn,
    string stairColumn
)
Visual C++
public:
SeriesList^ GetSeriesListOfVector(
    DataSourceType dataType,
    String^ name,
    String^ forceColumn,
    String^ directionColumn,
    String^ stairColumn
)
JavaScript
function getSeriesListOfVector(dataType, name, forceColumn, directionColumn, stairColumn);

Parameters

dataType
Type: Hippo..::..DataSourceType
name
Type: System..::..String
forceColumn
Type: System..::..String
directionColumn
Type: System..::..String
stairColumn
Type: System..::..String

Return Value

See Also

HippoEngine Class
GetSeriesListOfVector Overload


HippoEngine Properties

[image] [image]

.NET Framework Class Library
HippoEngine Properties
HippoEngine Class See Also Send Feedback

The HippoEngine type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString | 연결 문자열을 설정하고 가져옵니다.
Public property | DataType | 데이터소스 타입을 설정하고 가져옵니다.
Public property | ErrorMessage | 에러 메세지
Public property | Query | 쿼리 문자열을 설정하고 가져옵니다.
Public property | XmlPath | Xml 파일의 경로를 설정하고 가져옵니다.

See Also

HippoEngine Class


ConnectionString Property

[image]

.NET Framework Class Library
HippoEngine..::..ConnectionString Property
HippoEngine Class See Also Send Feedback

연결 문자열을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ConnectionString As String
    Get
    Set
C#
public string ConnectionString { get; set; }
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_connectionString();
function set_connectionString(value);

See Also

HippoEngine Class


DataType Property

[image]

.NET Framework Class Library
HippoEngine..::..DataType Property
HippoEngine Class See Also Send Feedback

데이터소스 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DataType As DataSourceType
    Get
    Set
C#
public DataSourceType DataType { get; set; }
Visual C++
public:
property DataSourceType DataType {
    DataSourceType get ();
    void set (DataSourceType value);
}
JavaScript
function get_dataType();
function set_dataType(value);

See Also

HippoEngine Class


ErrorMessage Property

[image]

.NET Framework Class Library
HippoEngine..::..ErrorMessage Property
HippoEngine Class See Also Send Feedback

에러 메세지

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorMessage As String
    Get
C#
public string ErrorMessage { get; }
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
}
JavaScript
function get_errorMessage();

See Also

HippoEngine Class


Query Property

[image]

.NET Framework Class Library
HippoEngine..::..Query Property
HippoEngine Class See Also Send Feedback

쿼리 문자열을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Query As String
    Get
    Set
C#
public string Query { get; set; }
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_query();
function set_query(value);

See Also

HippoEngine Class


XmlPath Property

[image]

.NET Framework Class Library
HippoEngine..::..XmlPath Property
HippoEngine Class See Also Send Feedback

Xml 파일의 경로를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XmlPath As String
    Get
    Set
C#
public string XmlPath { get; set; }
Visual C++
public:
property String^ XmlPath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_xmlPath();
function set_xmlPath(value);

See Also

HippoEngine Class


IChart Interface

[image]

.NET Framework Class Library
IChart Interface
Members See Also Send Feedback

차트가 가져야할 가장 기본적인 특징을 정의합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Interface IChart
C#
public interface IChart
Visual C++
public interface class IChart
JavaScript
Hippo.IChart = function();
Hippo.IChart.createInterface('Hippo.IChart');

See Also

IChart Members


IChart Members

[image] [image]

.NET Framework Class Library
IChart Members
IChart Interface Methods Properties See Also Send Feedback

The IChart type exposes the following members.

Methods

 | Name | Description
Public method | DrawChart()()()() | 차트를 그립니다.
Public method | DrawChart(SeriesList) | 차트를 그립니다.
Public method | DrawChart(SeriesListDictionary) | 차트를 그립니다.
Public method | DrawDefault | 바탕 차트를 그립니다.

Properties

 | Name | Description
Public property | ChartGraphic | 차트 그래픽
Public property | ChartID | 차트 고유 아이디
Public property | ChartImage | 차트 이미지
Public property | ChartRectangle | 차트 렉텡글
Public property | Designer | 차트 디자이너
Public property | DesignType | 디자인 타입
Public property | Direction | 시리즈 리스트 방향
Public property | Height2 | 차트 높이
Public property | Layout | 차트 레이아웃
Public property | Left | 차트 Left
Public property | LegendBox | 범례
Public property | Logo | 로고
Public property | PaletteType | 팔레트 타입
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션
Public property | Titles | 타이틀
Public property | Top | 차트 Top
Public property | Width2 | 차트 넓이

See Also

IChart Interface


IChart Methods

[image] [image]

.NET Framework Class Library
IChart Methods
IChart Interface See Also Send Feedback

The IChart type exposes the following members.

Methods

 | Name | Description
Public method | DrawChart()()()() | 차트를 그립니다.
Public method | DrawChart(SeriesList) | 차트를 그립니다.
Public method | DrawChart(SeriesListDictionary) | 차트를 그립니다.
Public method | DrawDefault | 바탕 차트를 그립니다.

See Also

IChart Interface


DrawChart Method

[image] [image]

.NET Framework Class Library
IChart..::..DrawChart Method
IChart Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawChart()()()() | 차트를 그립니다.
Public method | DrawChart(SeriesList) | 차트를 그립니다.
Public method | DrawChart(SeriesListDictionary) | 차트를 그립니다.

See Also

IChart Interface
IChart Members


DrawChart Method

[image]

.NET Framework Class Library
IChart..::..DrawChart Method
IChart Interface See Also Send Feedback

차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Sub DrawChart
C#
void DrawChart()
Visual C++
void DrawChart()
JavaScript
function drawChart();

See Also

IChart Interface
DrawChart Overload


DrawChart Method (SeriesList)

[image]

.NET Framework Class Library
IChart..::..DrawChart Method (SeriesList)
IChart Interface See Also Send Feedback

차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Sub DrawChart ( _
    SeriesList As SeriesList _
)
C#
void DrawChart(
    SeriesList SeriesList
)
Visual C++
void DrawChart(
    SeriesList^ SeriesList
)
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesList
시리즈 리스트

See Also

IChart Interface
DrawChart Overload


DrawChart Method (SeriesListDictionary)

[image]

.NET Framework Class Library
IChart..::..DrawChart Method (SeriesListDictionary)
IChart Interface See Also Send Feedback

차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Sub DrawChart ( _
    SeriesList As SeriesListDictionary _
)
C#
void DrawChart(
    SeriesListDictionary SeriesList
)
Visual C++
void DrawChart(
    SeriesListDictionary^ SeriesList
)
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesListDictionary
시리즈 리스트 컬렉션

See Also

IChart Interface
DrawChart Overload


DrawDefault Method

[image]

.NET Framework Class Library
IChart..::..DrawDefault Method
IChart Interface See Also Send Feedback

바탕 차트를 그립니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Sub DrawDefault
C#
void DrawDefault()
Visual C++
void DrawDefault()
JavaScript
function drawDefault();

See Also

IChart Interface


IChart Properties

[image] [image]

.NET Framework Class Library
IChart Properties
IChart Interface See Also Send Feedback

The IChart type exposes the following members.

Properties

 | Name | Description
Public property | ChartGraphic | 차트 그래픽
Public property | ChartID | 차트 고유 아이디
Public property | ChartImage | 차트 이미지
Public property | ChartRectangle | 차트 렉텡글
Public property | Designer | 차트 디자이너
Public property | DesignType | 디자인 타입
Public property | Direction | 시리즈 리스트 방향
Public property | Height2 | 차트 높이
Public property | Layout | 차트 레이아웃
Public property | Left | 차트 Left
Public property | LegendBox | 범례
Public property | Logo | 로고
Public property | PaletteType | 팔레트 타입
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션
Public property | Titles | 타이틀
Public property | Top | 차트 Top
Public property | Width2 | 차트 넓이

See Also

IChart Interface


ChartGraphic Property

[image]

.NET Framework Class Library
IChart..::..ChartGraphic Property
IChart Interface See Also Send Feedback

차트 그래픽

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property ChartGraphic As Graphics
    Get
    Set
C#
Graphics ChartGraphic { get; set; }
Visual C++
property Graphics^ ChartGraphic {
    Graphics^ get ();
    void set (Graphics^ value);
}
JavaScript
function get_chartGraphic();
function set_chartGraphic(value);

See Also

IChart Interface


ChartID Property

[image]

.NET Framework Class Library
IChart..::..ChartID Property
IChart Interface See Also Send Feedback

차트 고유 아이디

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property ChartID As String
    Get
    Set
C#
string ChartID { get; set; }
Visual C++
property String^ ChartID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_chartID();
function set_chartID(value);

See Also

IChart Interface


ChartImage Property

[image]

.NET Framework Class Library
IChart..::..ChartImage Property
IChart Interface See Also Send Feedback

차트 이미지

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property ChartImage As Bitmap
    Get
    Set
C#
Bitmap ChartImage { get; set; }
Visual C++
property Bitmap^ ChartImage {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
JavaScript
function get_chartImage();
function set_chartImage(value);

See Also

IChart Interface


ChartRectangle Property

[image]

.NET Framework Class Library
IChart..::..ChartRectangle Property
IChart Interface See Also Send Feedback

차트 렉텡글

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property ChartRectangle As RectangleF
    Get
    Set
C#
RectangleF ChartRectangle { get; set; }
Visual C++
property RectangleF ChartRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_chartRectangle();
function set_chartRectangle(value);

See Also

IChart Interface


Designer Property

[image]

.NET Framework Class Library
IChart..::..Designer Property
IChart Interface See Also Send Feedback

차트 디자이너

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Designer As ChartDesigner
    Get
    Set
C#
ChartDesigner Designer { get; set; }
Visual C++
property ChartDesigner^ Designer {
    ChartDesigner^ get ();
    void set (ChartDesigner^ value);
}
JavaScript
function get_designer();
function set_designer(value);

See Also

IChart Interface


DesignType Property

[image]

.NET Framework Class Library
IChart..::..DesignType Property
IChart Interface See Also Send Feedback

디자인 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property DesignType As ChartDesignType
    Get
    Set
C#
ChartDesignType DesignType { get; set; }
Visual C++
property ChartDesignType DesignType {
    ChartDesignType get ();
    void set (ChartDesignType value);
}
JavaScript
function get_designType();
function set_designType(value);

See Also

IChart Interface


Direction Property

[image]

.NET Framework Class Library
IChart..::..Direction Property
IChart Interface See Also Send Feedback

시리즈 리스트 방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Direction As GraphAreaLocation
    Get
    Set
C#
GraphAreaLocation Direction { get; set; }
Visual C++
property GraphAreaLocation Direction {
    GraphAreaLocation get ();
    void set (GraphAreaLocation value);
}
JavaScript
function get_direction();
function set_direction(value);

See Also

IChart Interface


Height2 Property

[image]

.NET Framework Class Library
IChart..::..Height2 Property
IChart Interface See Also Send Feedback

차트 높이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Height2 As Single
    Get
    Set
C#
float Height2 { get; set; }
Visual C++
property float Height2 {
    float get ();
    void set (float value);
}
JavaScript
function get_height2();
function set_height2(value);

See Also

IChart Interface


Layout Property

[image]

.NET Framework Class Library
IChart..::..Layout Property
IChart Interface See Also Send Feedback

차트 레이아웃

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Layout As Layout
    Get
    Set
C#
Layout Layout { get; set; }
Visual C++
property Layout^ Layout {
    Layout^ get ();
    void set (Layout^ value);
}
JavaScript
function get_layout();
function set_layout(value);

See Also

IChart Interface


Left Property

[image]

.NET Framework Class Library
IChart..::..Left Property
IChart Interface See Also Send Feedback

차트 Left

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Left As Single
    Get
    Set
C#
float Left { get; set; }
Visual C++
property float Left {
    float get ();
    void set (float value);
}
JavaScript
function get_left();
function set_left(value);

See Also

IChart Interface


LegendBox Property

[image]

.NET Framework Class Library
IChart..::..LegendBox Property
IChart Interface See Also Send Feedback

범례

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property LegendBox As LegendBox
    Get
    Set
C#
LegendBox LegendBox { get; set; }
Visual C++
property LegendBox^ LegendBox {
    LegendBox^ get ();
    void set (LegendBox^ value);
}
JavaScript
function get_legendBox();
function set_legendBox(value);

See Also

IChart Interface


Logo Property

[image]

.NET Framework Class Library
IChart..::..Logo Property
IChart Interface See Also Send Feedback

로고

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Logo As Logo
    Get
    Set
C#
Logo Logo { get; set; }
Visual C++
property Logo^ Logo {
    Logo^ get ();
    void set (Logo^ value);
}
JavaScript
function get_logo();
function set_logo(value);

See Also

IChart Interface


PaletteType Property

[image]

.NET Framework Class Library
IChart..::..PaletteType Property
IChart Interface See Also Send Feedback

팔레트 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property PaletteType As PaletteType
    Get
    Set
C#
PaletteType PaletteType { get; set; }
Visual C++
property PaletteType PaletteType {
    PaletteType get ();
    void set (PaletteType value);
}
JavaScript
function get_paletteType();
function set_paletteType(value);

See Also

IChart Interface


SeriesListDictionary Property

[image]

.NET Framework Class Library
IChart..::..SeriesListDictionary Property
IChart Interface See Also Send Feedback

시리즈 리스트 컬렉션

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property SeriesListDictionary As SeriesListDictionary
    Get
    Set
C#
SeriesListDictionary SeriesListDictionary { get; set; }
Visual C++
property SeriesListDictionary^ SeriesListDictionary {
    SeriesListDictionary^ get ();
    void set (SeriesListDictionary^ value);
}
JavaScript
function get_seriesListDictionary();
function set_seriesListDictionary(value);

See Also

IChart Interface


Titles Property

[image]

.NET Framework Class Library
IChart..::..Titles Property
IChart Interface See Also Send Feedback

타이틀

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Titles As Title
    Get
    Set
C#
Title Titles { get; set; }
Visual C++
property Title^ Titles {
    Title^ get ();
    void set (Title^ value);
}
JavaScript
function get_titles();
function set_titles(value);

See Also

IChart Interface


Top Property

[image]

.NET Framework Class Library
IChart..::..Top Property
IChart Interface See Also Send Feedback

차트 Top

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Top As Single
    Get
    Set
C#
float Top { get; set; }
Visual C++
property float Top {
    float get ();
    void set (float value);
}
JavaScript
function get_top();
function set_top(value);

See Also

IChart Interface


Width2 Property

[image]

.NET Framework Class Library
IChart..::..Width2 Property
IChart Interface See Also Send Feedback

차트 넓이

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property Width2 As Single
    Get
    Set
C#
float Width2 { get; set; }
Visual C++
property float Width2 {
    float get ();
    void set (float value);
}
JavaScript
function get_width2();
function set_width2(value);

See Also

IChart Interface


ILegendEntry Interface

[image]

.NET Framework Class Library
ILegendEntry Interface
Members See Also Send Feedback

범례에 표시되어야 하는 객체들이 구현합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Interface ILegendEntry
C#
public interface ILegendEntry
Visual C++
public interface class ILegendEntry
JavaScript
Hippo.ILegendEntry = function();
Hippo.ILegendEntry.createInterface('Hippo.ILegendEntry');

See Also

ILegendEntry Members


ILegendEntry Members

[image] [image]

.NET Framework Class Library
ILegendEntry Members
ILegendEntry Interface Properties See Also Send Feedback

The ILegendEntry type exposes the following members.

Properties

 | Name | Description
Public property | LegendVisible | LegendVisible

See Also

ILegendEntry Interface


ILegendEntry Properties

[image] [image]

.NET Framework Class Library
ILegendEntry Properties
ILegendEntry Interface See Also Send Feedback

The ILegendEntry type exposes the following members.

Properties

 | Name | Description
Public property | LegendVisible | LegendVisible

See Also

ILegendEntry Interface


LegendVisible Property

[image]

.NET Framework Class Library
ILegendEntry..::..LegendVisible Property
ILegendEntry Interface See Also Send Feedback

LegendVisible

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Property LegendVisible As Boolean
    Get
    Set
C#
bool LegendVisible { get; set; }
Visual C++
property bool LegendVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_legendVisible();
function set_legendVisible(value);

See Also

ILegendEntry Interface


ItemNames Class

[image]

.NET Framework Class Library
ItemNames Class
Members See Also Send Feedback

비좌표 차트(파이차트 등)의 각 시리즈아이템들의 이름 컬렉션을 관리하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class ItemNames _
    Inherits HippoCollectionBase(Of String)
C#
[SerializableAttribute]
public class ItemNames : HippoCollectionBase<string>
Visual C++
[SerializableAttribute]
public ref class ItemNames : public HippoCollectionBase<String^>
JavaScript
Hippo.ItemNames = function();

Type.createClass(
    'Hippo.ItemNames',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' String >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' String >)>)>
Hippo..::..ItemNames

See Also

ItemNames Members


ItemNames Members

[image] [image]

.NET Framework Class Library
ItemNames Members
ItemNames Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ItemNames type exposes the following members.

Constructors

 | Name | Description
Public method | ItemNames |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' String >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' String >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' String >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' String >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' String >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' String >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' String >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' String >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class


ItemNames Constructor

[image]

.NET Framework Class Library
ItemNames Constructor
ItemNames Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ItemNames()
Visual C++
public:
ItemNames()
JavaScript
Hippo.ItemNames = function();

See Also

ItemNames Class


ItemNames Methods

[image] [image]

.NET Framework Class Library
ItemNames Methods
ItemNames Class See Also Send Feedback

The ItemNames type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' String >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' String >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' String >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' String >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' String >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
ItemNames..::..BinarySearch Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


CopyTo Method

[image] [image]

.NET Framework Class Library
ItemNames..::..CopyTo Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


FindIndex Method

[image] [image]

.NET Framework Class Library
ItemNames..::..FindIndex Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
ItemNames..::..FindLastIndex Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


IndexOf Method

[image] [image]

.NET Framework Class Library
ItemNames..::..IndexOf Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
ItemNames..::..LastIndexOf Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


Reverse Method

[image] [image]

.NET Framework Class Library
ItemNames..::..Reverse Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


Sort Method

[image] [image]

.NET Framework Class Library
ItemNames..::..Sort Method
ItemNames Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class
ItemNames Members


ItemNames Properties

[image] [image]

.NET Framework Class Library
ItemNames Properties
ItemNames Class See Also Send Feedback

The ItemNames type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' String >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' String >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' String >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' String >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' String >)>)>.)

See Also

ItemNames Class


Kagi Class

[image]

.NET Framework Class Library
Kagi Class
Members See Also Send Feedback

Kagi 차트의 특성을 정의하는 클래스입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Kagi
C#
[SerializableAttribute]
public class Kagi
Visual C++
[SerializableAttribute]
public ref class Kagi
JavaScript
Hippo.Kagi = function();

Type.createClass(
    'Hippo.Kagi');

Inheritance Hierarchy

System..::..Object
Hippo..::..Kagi

See Also

Kagi Members


Kagi Members

[image] [image]

.NET Framework Class Library
Kagi Members
Kagi Class Constructors Methods Properties See Also Send Feedback

The Kagi type exposes the following members.

Constructors

 | Name | Description
Public method | Kagi | 카기 특성 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | KagiType | 카기 타입을 설정하고 가져옵니다.

See Also

Kagi Class


Kagi Constructor

[image]

.NET Framework Class Library
Kagi Constructor
Kagi Class See Also Send Feedback

카기 특성 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Kagi()
Visual C++
public:
Kagi()
JavaScript
Hippo.Kagi = function();

See Also

Kagi Class


Kagi Methods

[image] [image]

.NET Framework Class Library
Kagi Methods
Kagi Class See Also Send Feedback

The Kagi type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Kagi Class


Kagi Properties

[image] [image]

.NET Framework Class Library
Kagi Properties
Kagi Class See Also Send Feedback

The Kagi type exposes the following members.

Properties

 | Name | Description
Public property | KagiType | 카기 타입을 설정하고 가져옵니다.

See Also

Kagi Class


KagiType Property

[image]

.NET Framework Class Library
Kagi..::..KagiType Property
Kagi Class See Also Send Feedback

카기 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property KagiType As KagiType
    Get
    Set
C#
public KagiType KagiType { get; set; }
Visual C++
public:
property KagiType KagiType {
    KagiType get ();
    void set (KagiType value);
}
JavaScript
function get_kagiType();
function set_kagiType(value);

See Also

Kagi Class


KagiType Enumeration

[image]

.NET Framework Class Library
KagiType Enumeration
See Also Send Feedback

KagiType

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration KagiType
C#
public enum KagiType
Visual C++
public enum class KagiType
JavaScript
Hippo.KagiType = function();
Hippo.KagiType.createEnum('Hippo.KagiType', false);

Members

Member name | Description
Default |
Kagi |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Label Class

[image]

.NET Framework Class Library
Label Class
Members See Also Send Feedback

라벨 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Label
C#
[SerializableAttribute]
public class Label
Visual C++
[SerializableAttribute]
public ref class Label
JavaScript
Hippo.Label = function();

Type.createClass(
    'Hippo.Label');

Remarks

히포차트 내의 모든 텍스트를 표현하는 코어 클래스입니다. 예를 들어 수치표현, 축의 라벨 등 거의 모든 곳에 사용됩니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Label

See Also

Label Members


Label Members

[image] [image]

.NET Framework Class Library
Label Members
Label Class Constructors Methods Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label()()()() | 라벨 인스턴스를 생성합니다.
Public method | Label(String) | 라벨 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Font | 라벨 폰트
Public property | ForeColor | 글자 색
Public property | Text | 라벨 텍스트

See Also

Label Class


Label Constructor

[image] [image]

.NET Framework Class Library
Label Constructor
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Label()()()() | 라벨 인스턴스를 생성합니다.
Public method | Label(String) | 라벨 인스턴스를 생성합니다.

See Also

Label Class
Label Members


Label Constructor

[image]

.NET Framework Class Library
Label Constructor
Label Class See Also Send Feedback

라벨 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Label()
Visual C++
public:
Label()
JavaScript
Hippo.Label = function();

See Also

Label Class
Label Overload


Label Constructor (String)

[image]

.NET Framework Class Library
Label Constructor (String)
Label Class See Also Send Feedback

라벨 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    Text As String _
)
C#
public Label(
    string Text
)
Visual C++
public:
Label(
    String^ Text
)
JavaScript
Hippo.Label = function(Text);

Parameters

Text
Type: System..::..String
라벨 텍스트

See Also

Label Class
Label Overload


Label Methods

[image] [image]

.NET Framework Class Library
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Label Class


Label Properties

[image] [image]

.NET Framework Class Library
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | Font | 라벨 폰트
Public property | ForeColor | 글자 색
Public property | Text | 라벨 텍스트

See Also

Label Class


Font Property

[image]

.NET Framework Class Library
Label..::..Font Property
Label Class See Also Send Feedback

라벨 폰트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Font As Font
    Get
    Set
C#
public Font Font { get; set; }
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_font();
function set_font(value);

See Also

Label Class


ForeColor Property

[image]

.NET Framework Class Library
Label..::..ForeColor Property
Label Class See Also Send Feedback

글자 색

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

Label Class


Text Property

[image]

.NET Framework Class Library
Label..::..Text Property
Label Class See Also Send Feedback

라벨 텍스트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Text As String
    Get
    Set
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_text();
function set_text(value);

See Also

Label Class


LabelList Class

[image]

.NET Framework Class Library
LabelList Class
Members See Also Send Feedback

라벨 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LabelList _
    Inherits HippoCollectionBase(Of Label)
C#
[SerializableAttribute]
public class LabelList : HippoCollectionBase<Label>
Visual C++
[SerializableAttribute]
public ref class LabelList : public HippoCollectionBase<Label^>
JavaScript
Hippo.LabelList = function();

Type.createClass(
    'Hippo.LabelList',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Label >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Label >)>)>
Hippo..::..LabelList

See Also

LabelList Members


LabelList Members

[image] [image]

.NET Framework Class Library
LabelList Members
LabelList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LabelList type exposes the following members.

Constructors

 | Name | Description
Public method | LabelList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Label >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Label >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Label >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Label >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Label >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class


LabelList Constructor

[image]

.NET Framework Class Library
LabelList Constructor
LabelList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LabelList()
Visual C++
public:
LabelList()
JavaScript
Hippo.LabelList = function();

See Also

LabelList Class


LabelList Methods

[image] [image]

.NET Framework Class Library
LabelList Methods
LabelList Class See Also Send Feedback

The LabelList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Label >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Label >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
LabelList..::..BinarySearch Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
LabelList..::..CopyTo Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
LabelList..::..FindIndex Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
LabelList..::..FindLastIndex Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
LabelList..::..IndexOf Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
LabelList..::..LastIndexOf Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


Reverse Method

[image] [image]

.NET Framework Class Library
LabelList..::..Reverse Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


Sort Method

[image] [image]

.NET Framework Class Library
LabelList..::..Sort Method
LabelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class
LabelList Members


LabelList Properties

[image] [image]

.NET Framework Class Library
LabelList Properties
LabelList Class See Also Send Feedback

The LabelList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Label >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Label >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Label >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Label >)>)>.)

See Also

LabelList Class


Layout Class

[image]

.NET Framework Class Library
Layout Class
Members See Also Send Feedback

레이아웃 클래스 - 타이틀영역, 로고영역, 범례영역, 내부차트영역의 사각형을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Layout
C#
[SerializableAttribute]
public sealed class Layout
Visual C++
[SerializableAttribute]
public ref class Layout sealed
JavaScript
Hippo.Layout = function();

Type.createClass(
    'Hippo.Layout');

Inheritance Hierarchy

System..::..Object
Hippo..::..Layout

See Also

Layout Members


Layout Members

[image] [image]

.NET Framework Class Library
Layout Members
Layout Class Constructors Methods Properties See Also Send Feedback

The Layout type exposes the following members.

Constructors

 | Name | Description
Public method | Layout | Layout 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerRectangle | 그래프들이 배치되는 영역
Public property | LegendRectangle | 범례 그려지는 영역
Public property | LogoRectangle | 로고 그려지는 영역
Public property | TitleRectangle | 타이틀 그려지는 영역

See Also

Layout Class


Layout Constructor

[image]

.NET Framework Class Library
Layout Constructor
Layout Class See Also Send Feedback

Layout 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Layout()
Visual C++
public:
Layout()
JavaScript
Hippo.Layout = function();

See Also

Layout Class


Layout Methods

[image] [image]

.NET Framework Class Library
Layout Methods
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Layout Class


Layout Properties

[image] [image]

.NET Framework Class Library
Layout Properties
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Properties

 | Name | Description
Public property | InnerRectangle | 그래프들이 배치되는 영역
Public property | LegendRectangle | 범례 그려지는 영역
Public property | LogoRectangle | 로고 그려지는 영역
Public property | TitleRectangle | 타이틀 그려지는 영역

See Also

Layout Class


InnerRectangle Property

[image]

.NET Framework Class Library
Layout..::..InnerRectangle Property
Layout Class See Also Send Feedback

그래프들이 배치되는 영역

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property InnerRectangle As RectangleF
    Get
    Set
C#
public RectangleF InnerRectangle { get; set; }
Visual C++
public:
property RectangleF InnerRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_innerRectangle();
function set_innerRectangle(value);

See Also

Layout Class


LegendRectangle Property

[image]

.NET Framework Class Library
Layout..::..LegendRectangle Property
Layout Class See Also Send Feedback

범례 그려지는 영역

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendRectangle As RectangleF
    Get
    Set
C#
public RectangleF LegendRectangle { get; set; }
Visual C++
public:
property RectangleF LegendRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_legendRectangle();
function set_legendRectangle(value);

See Also

Layout Class


LogoRectangle Property

[image]

.NET Framework Class Library
Layout..::..LogoRectangle Property
Layout Class See Also Send Feedback

로고 그려지는 영역

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LogoRectangle As RectangleF
    Get
    Set
C#
public RectangleF LogoRectangle { get; set; }
Visual C++
public:
property RectangleF LogoRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_logoRectangle();
function set_logoRectangle(value);

See Also

Layout Class


TitleRectangle Property

[image]

.NET Framework Class Library
Layout..::..TitleRectangle Property
Layout Class See Also Send Feedback

타이틀 그려지는 영역

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleRectangle As RectangleF
    Get
    Set
C#
public RectangleF TitleRectangle { get; set; }
Visual C++
public:
property RectangleF TitleRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_titleRectangle();
function set_titleRectangle(value);

See Also

Layout Class


LegendBox Class

[image]

.NET Framework Class Library
LegendBox Class
Members See Also Send Feedback

범례 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendBox
C#
[SerializableAttribute]
public class LegendBox
Visual C++
[SerializableAttribute]
public ref class LegendBox
JavaScript
Hippo.LegendBox = function();

Type.createClass(
    'Hippo.LegendBox');

Remarks

하나의 범례를 의미합니다. 범례는 차트 레벨과 시리즈리스트 레벨 두 군데 설정요소를 가지고 있습니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendBox

See Also

LegendBox Members


LegendBox Members

[image] [image]

.NET Framework Class Library
LegendBox Members
LegendBox Class Constructors Methods Properties See Also Send Feedback

The LegendBox type exposes the following members.

Constructors

 | Name | Description
Public method | LegendBox | LegendBox 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 범례의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | DivideLineColor | 구분선 라인 색상를 가져오고 설정합니다.
Public property | FigureFormat | 값(value)을 표시할 수치 형식을 가져오고 설정합니다.
Public property | Header | 범례 헤더를 가져오고 설정합니다.
Public property | Height | 범례 세로 길이를 가져오고 설정합니다.
Public property | IsAutoSetting | 범례를 수동으로 설정할것인지 여부를 설정하고 가져옵니다.
Public property | IsDivideLine | 구분선을 표시할 것인가 여부를 가져오고 설정합니다.
Public property | IsShowHeader | 범례 헤더를 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | IsVerticalLine | 세로 구분선을 표시할 것인가 여부를 가져오고 설정합니다.
Public property | Label | 범례 폰트를 설정하고 가져옵니다.
Public property | LeftMargin | 범례가 그려지는 위치의 Left 마진 값을 설정하고 가져옵니다.
Public property | LegendBoxItems | 범례 아이템 박스 컬렉션를 가져오고 설정합니다.
Public property | LegendFormat | 범례 포맷을 가져오고 설정합니다.
Public property | Location | 범례 위치를 가져오고 설정합니다.
Public property | PercentDecimalPoint | 퍼센트를 표시할 소수 자리수를 설정하고 가져옵니다.
Public property | TopMargin | 범례가 그려지는 위치의 Top 마진 값을 설정하고 가져옵니다.
Public property | ValueDecimalPoint | value 에 표시할 소수 자리수를 설정하고 가져옵니다.
Public property | ValueType | 범례 값(value) 표시영역의 타입을 가져오고 설정합니다.
Public property | VerticalLineColor | 세로 구분선 라인 색상을 가져오고 설정합니다.
Public property | Visible | 범례를 표시할 것인가 여부를 가져오고 설정합니다.
Public property | Width | 범례 가로길이를 가져오고 설정합니다.

See Also

LegendBox Class


LegendBox Constructor

[image]

.NET Framework Class Library
LegendBox Constructor
LegendBox Class See Also Send Feedback

LegendBox 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendBox()
Visual C++
public:
LegendBox()
JavaScript
Hippo.LegendBox = function();

See Also

LegendBox Class


LegendBox Methods

[image] [image]

.NET Framework Class Library
LegendBox Methods
LegendBox Class See Also Send Feedback

The LegendBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendBox Class


LegendBox Properties

[image] [image]

.NET Framework Class Library
LegendBox Properties
LegendBox Class See Also Send Feedback

The LegendBox type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 범례의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | DivideLineColor | 구분선 라인 색상를 가져오고 설정합니다.
Public property | FigureFormat | 값(value)을 표시할 수치 형식을 가져오고 설정합니다.
Public property | Header | 범례 헤더를 가져오고 설정합니다.
Public property | Height | 범례 세로 길이를 가져오고 설정합니다.
Public property | IsAutoSetting | 범례를 수동으로 설정할것인지 여부를 설정하고 가져옵니다.
Public property | IsDivideLine | 구분선을 표시할 것인가 여부를 가져오고 설정합니다.
Public property | IsShowHeader | 범례 헤더를 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | IsVerticalLine | 세로 구분선을 표시할 것인가 여부를 가져오고 설정합니다.
Public property | Label | 범례 폰트를 설정하고 가져옵니다.
Public property | LeftMargin | 범례가 그려지는 위치의 Left 마진 값을 설정하고 가져옵니다.
Public property | LegendBoxItems | 범례 아이템 박스 컬렉션를 가져오고 설정합니다.
Public property | LegendFormat | 범례 포맷을 가져오고 설정합니다.
Public property | Location | 범례 위치를 가져오고 설정합니다.
Public property | PercentDecimalPoint | 퍼센트를 표시할 소수 자리수를 설정하고 가져옵니다.
Public property | TopMargin | 범례가 그려지는 위치의 Top 마진 값을 설정하고 가져옵니다.
Public property | ValueDecimalPoint | value 에 표시할 소수 자리수를 설정하고 가져옵니다.
Public property | ValueType | 범례 값(value) 표시영역의 타입을 가져오고 설정합니다.
Public property | VerticalLineColor | 세로 구분선 라인 색상을 가져오고 설정합니다.
Public property | Visible | 범례를 표시할 것인가 여부를 가져오고 설정합니다.
Public property | Width | 범례 가로길이를 가져오고 설정합니다.

See Also

LegendBox Class


BackColor Property

[image]

.NET Framework Class Library
LegendBox..::..BackColor Property
LegendBox Class See Also Send Feedback

범례의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

LegendBox Class


DivideLineColor Property

[image]

.NET Framework Class Library
LegendBox..::..DivideLineColor Property
LegendBox Class See Also Send Feedback

구분선 라인 색상를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DivideLineColor As Color
    Get
    Set
C#
public Color DivideLineColor { get; set; }
Visual C++
public:
property Color DivideLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_divideLineColor();
function set_divideLineColor(value);

See Also

LegendBox Class


FigureFormat Property

[image]

.NET Framework Class Library
LegendBox..::..FigureFormat Property
LegendBox Class See Also Send Feedback

값(value)을 표시할 수치 형식을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigureFormat As FigureFormat
    Get
    Set
C#
public FigureFormat FigureFormat { get; set; }
Visual C++
public:
property FigureFormat FigureFormat {
    FigureFormat get ();
    void set (FigureFormat value);
}
JavaScript
function get_figureFormat();
function set_figureFormat(value);

See Also

LegendBox Class


Header Property

[image]

.NET Framework Class Library
LegendBox..::..Header Property
LegendBox Class See Also Send Feedback

범례 헤더를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Header As LegendHeader
    Get
    Set
C#
public LegendHeader Header { get; set; }
Visual C++
public:
property LegendHeader^ Header {
    LegendHeader^ get ();
    void set (LegendHeader^ value);
}
JavaScript
function get_header();
function set_header(value);

See Also

LegendBox Class


Height Property

[image]

.NET Framework Class Library
LegendBox..::..Height Property
LegendBox Class See Also Send Feedback

범례 세로 길이를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height As Single
    Get
    Set
C#
public float Height { get; set; }
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}
JavaScript
function get_height();
function set_height(value);

See Also

LegendBox Class


IsAutoSetting Property

[image]

.NET Framework Class Library
LegendBox..::..IsAutoSetting Property
LegendBox Class See Also Send Feedback

범례를 수동으로 설정할것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsAutoSetting As Boolean
    Get
    Set
C#
public bool IsAutoSetting { get; set; }
Visual C++
public:
property bool IsAutoSetting {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAutoSetting();
function set_isAutoSetting(value);

See Also

LegendBox Class


IsDivideLine Property

[image]

.NET Framework Class Library
LegendBox..::..IsDivideLine Property
LegendBox Class See Also Send Feedback

구분선을 표시할 것인가 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDivideLine As Boolean
    Get
    Set
C#
public bool IsDivideLine { get; set; }
Visual C++
public:
property bool IsDivideLine {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDivideLine();
function set_isDivideLine(value);

See Also

LegendBox Class


IsShowHeader Property

[image]

.NET Framework Class Library
LegendBox..::..IsShowHeader Property
LegendBox Class See Also Send Feedback

범례 헤더를 보여줄 것인지 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowHeader As Boolean
    Get
    Set
C#
public bool IsShowHeader { get; set; }
Visual C++
public:
property bool IsShowHeader {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowHeader();
function set_isShowHeader(value);

See Also

LegendBox Class


IsVerticalLine Property

[image]

.NET Framework Class Library
LegendBox..::..IsVerticalLine Property
LegendBox Class See Also Send Feedback

세로 구분선을 표시할 것인가 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsVerticalLine As Boolean
    Get
    Set
C#
public bool IsVerticalLine { get; set; }
Visual C++
public:
property bool IsVerticalLine {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isVerticalLine();
function set_isVerticalLine(value);

See Also

LegendBox Class


Label Property

[image]

.NET Framework Class Library
LegendBox..::..Label Property
LegendBox Class See Also Send Feedback

범례 폰트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

LegendBox Class


LeftMargin Property

[image]

.NET Framework Class Library
LegendBox..::..LeftMargin Property
LegendBox Class See Also Send Feedback

범례가 그려지는 위치의 Left 마진 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LeftMargin As Single
    Get
    Set
C#
public float LeftMargin { get; set; }
Visual C++
public:
property float LeftMargin {
    float get ();
    void set (float value);
}
JavaScript
function get_leftMargin();
function set_leftMargin(value);

See Also

LegendBox Class


LegendBoxItems Property

[image]

.NET Framework Class Library
LegendBox..::..LegendBoxItems Property
LegendBox Class See Also Send Feedback

범례 아이템 박스 컬렉션를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendBoxItems As LegendBoxItemDictionary
    Get
    Set
C#
public LegendBoxItemDictionary LegendBoxItems { get; set; }
Visual C++
public:
property LegendBoxItemDictionary^ LegendBoxItems {
    LegendBoxItemDictionary^ get ();
    void set (LegendBoxItemDictionary^ value);
}
JavaScript
function get_legendBoxItems();
function set_legendBoxItems(value);

See Also

LegendBox Class


LegendFormat Property

[image]

.NET Framework Class Library
LegendBox..::..LegendFormat Property
LegendBox Class See Also Send Feedback

범례 포맷을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendFormat As LegendFormat
    Get
    Set
C#
public LegendFormat LegendFormat { get; set; }
Visual C++
public:
property LegendFormat LegendFormat {
    LegendFormat get ();
    void set (LegendFormat value);
}
JavaScript
function get_legendFormat();
function set_legendFormat(value);

See Also

LegendBox Class


Location Property

[image]

.NET Framework Class Library
LegendBox..::..Location Property
LegendBox Class See Also Send Feedback

범례 위치를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Location As LegendLocation
    Get
    Set
C#
public LegendLocation Location { get; set; }
Visual C++
public:
property LegendLocation Location {
    LegendLocation get ();
    void set (LegendLocation value);
}
JavaScript
function get_location();
function set_location(value);

See Also

LegendBox Class


PercentDecimalPoint Property

[image]

.NET Framework Class Library
LegendBox..::..PercentDecimalPoint Property
LegendBox Class See Also Send Feedback

퍼센트를 표시할 소수 자리수를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PercentDecimalPoint As Integer
    Get
    Set
C#
public int PercentDecimalPoint { get; set; }
Visual C++
public:
property int PercentDecimalPoint {
    int get ();
    void set (int value);
}
JavaScript
function get_percentDecimalPoint();
function set_percentDecimalPoint(value);

See Also

LegendBox Class


TopMargin Property

[image]

.NET Framework Class Library
LegendBox..::..TopMargin Property
LegendBox Class See Also Send Feedback

범례가 그려지는 위치의 Top 마진 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TopMargin As Single
    Get
    Set
C#
public float TopMargin { get; set; }
Visual C++
public:
property float TopMargin {
    float get ();
    void set (float value);
}
JavaScript
function get_topMargin();
function set_topMargin(value);

See Also

LegendBox Class


ValueDecimalPoint Property

[image]

.NET Framework Class Library
LegendBox..::..ValueDecimalPoint Property
LegendBox Class See Also Send Feedback

value 에 표시할 소수 자리수를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ValueDecimalPoint As Integer
    Get
    Set
C#
public int ValueDecimalPoint { get; set; }
Visual C++
public:
property int ValueDecimalPoint {
    int get ();
    void set (int value);
}
JavaScript
function get_valueDecimalPoint();
function set_valueDecimalPoint(value);

See Also

LegendBox Class


ValueType Property

[image]

.NET Framework Class Library
LegendBox..::..ValueType Property
LegendBox Class See Also Send Feedback

범례 값(value) 표시영역의 타입을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ValueType As LegendValueType
    Get
    Set
C#
public LegendValueType ValueType { get; set; }
Visual C++
public:
property LegendValueType ValueType {
    LegendValueType get ();
    void set (LegendValueType value);
}
JavaScript
function get_valueType();
function set_valueType(value);

See Also

LegendBox Class


VerticalLineColor Property

[image]

.NET Framework Class Library
LegendBox..::..VerticalLineColor Property
LegendBox Class See Also Send Feedback

세로 구분선 라인 색상을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property VerticalLineColor As Color
    Get
    Set
C#
public Color VerticalLineColor { get; set; }
Visual C++
public:
property Color VerticalLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_verticalLineColor();
function set_verticalLineColor(value);

See Also

LegendBox Class


Visible Property

[image]

.NET Framework Class Library
LegendBox..::..Visible Property
LegendBox Class See Also Send Feedback

범례를 표시할 것인가 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

LegendBox Class


Width Property

[image]

.NET Framework Class Library
LegendBox..::..Width Property
LegendBox Class See Also Send Feedback

범례 가로길이를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Single
    Get
    Set
C#
public float Width { get; set; }
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}
JavaScript
function get_width();
function set_width(value);

See Also

LegendBox Class


LegendBoxItem Class

[image]

.NET Framework Class Library
LegendBoxItem Class
Members See Also Send Feedback

범례박스아이템 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendBoxItem
C#
[SerializableAttribute]
public class LegendBoxItem
Visual C++
[SerializableAttribute]
public ref class LegendBoxItem
JavaScript
Hippo.LegendBoxItem = function();

Type.createClass(
    'Hippo.LegendBoxItem');

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendBoxItem

See Also

LegendBoxItem Members


LegendBoxItem Members

[image] [image]

.NET Framework Class Library
LegendBoxItem Members
LegendBoxItem Class Constructors Methods Properties See Also Send Feedback

The LegendBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | LegendBoxItem | LegendBoxItem 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Rows | 범례 아이템 박스의 row 컬렉션을 가져오고 설정합니다.

See Also

LegendBoxItem Class


LegendBoxItem Constructor

[image]

.NET Framework Class Library
LegendBoxItem Constructor
LegendBoxItem Class See Also Send Feedback

LegendBoxItem 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendBoxItem()
Visual C++
public:
LegendBoxItem()
JavaScript
Hippo.LegendBoxItem = function();

See Also

LegendBoxItem Class


LegendBoxItem Methods

[image] [image]

.NET Framework Class Library
LegendBoxItem Methods
LegendBoxItem Class See Also Send Feedback

The LegendBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendBoxItem Class


LegendBoxItem Properties

[image] [image]

.NET Framework Class Library
LegendBoxItem Properties
LegendBoxItem Class See Also Send Feedback

The LegendBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | Rows | 범례 아이템 박스의 row 컬렉션을 가져오고 설정합니다.

See Also

LegendBoxItem Class


Rows Property

[image]

.NET Framework Class Library
LegendBoxItem..::..Rows Property
LegendBoxItem Class See Also Send Feedback

범례 아이템 박스의 row 컬렉션을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Rows As LegendRowDictionary
    Get
    Set
C#
public LegendRowDictionary Rows { get; set; }
Visual C++
public:
property LegendRowDictionary^ Rows {
    LegendRowDictionary^ get ();
    void set (LegendRowDictionary^ value);
}
JavaScript
function get_rows();
function set_rows(value);

See Also

LegendBoxItem Class


LegendBoxItemDictionary Class

[image]

.NET Framework Class Library
LegendBoxItemDictionary Class
Members See Also Send Feedback

범례박스아이템 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendBoxItemDictionary _
    Inherits List(Of LegendBoxItem)
C#
[SerializableAttribute]
public class LegendBoxItemDictionary : List<LegendBoxItem>
Visual C++
[SerializableAttribute]
public ref class LegendBoxItemDictionary : public List<LegendBoxItem^>
JavaScript
Hippo.LegendBoxItemDictionary = function();

Type.createClass(
    'Hippo.LegendBoxItemDictionary',
    List`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' LegendBoxItem >)>)>
Hippo..::..LegendBoxItemDictionary

See Also

LegendBoxItemDictionary Members


LegendBoxItemDictionary Members

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary Members
LegendBoxItemDictionary Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LegendBoxItemDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | LegendBoxItemDictionary |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class


LegendBoxItemDictionary Constructor

[image]

.NET Framework Class Library
LegendBoxItemDictionary Constructor
LegendBoxItemDictionary Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendBoxItemDictionary()
Visual C++
public:
LegendBoxItemDictionary()
JavaScript
Hippo.LegendBoxItemDictionary = function();

See Also

LegendBoxItemDictionary Class


LegendBoxItemDictionary Methods

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary Methods
LegendBoxItemDictionary Class See Also Send Feedback

The LegendBoxItemDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..BinarySearch Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


CopyTo Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..CopyTo Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


FindIndex Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..FindIndex Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..FindLastIndex Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


IndexOf Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..IndexOf Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..LastIndexOf Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


Reverse Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..Reverse Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


Sort Method

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary..::..Sort Method
LegendBoxItemDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class
LegendBoxItemDictionary Members


LegendBoxItemDictionary Properties

[image] [image]

.NET Framework Class Library
LegendBoxItemDictionary Properties
LegendBoxItemDictionary Class See Also Send Feedback

The LegendBoxItemDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendBoxItem >)>)>.)

See Also

LegendBoxItemDictionary Class


LegendCell Class

[image]

.NET Framework Class Library
LegendCell Class
Members See Also Send Feedback

범례 하나의 셀을 나타내는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendCell
C#
[SerializableAttribute]
public class LegendCell
Visual C++
[SerializableAttribute]
public ref class LegendCell
JavaScript
Hippo.LegendCell = function();

Type.createClass(
    'Hippo.LegendCell');

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendCell

See Also

LegendCell Members


LegendCell Members

[image] [image]

.NET Framework Class Library
LegendCell Members
LegendCell Class Constructors Methods Properties See Also Send Feedback

The LegendCell type exposes the following members.

Constructors

 | Name | Description
Public method | LegendCell | LegendCell 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CellRectangle | 범례 셀 렉텡글을 가져오고 설정합니다.
Public property | HeaderType | 범례 헤더의 각 셀의 타입을 가져오고 설정합니다.

See Also

LegendCell Class


LegendCell Constructor

[image]

.NET Framework Class Library
LegendCell Constructor
LegendCell Class See Also Send Feedback

LegendCell 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendCell()
Visual C++
public:
LegendCell()
JavaScript
Hippo.LegendCell = function();

See Also

LegendCell Class


LegendCell Methods

[image] [image]

.NET Framework Class Library
LegendCell Methods
LegendCell Class See Also Send Feedback

The LegendCell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendCell Class


LegendCell Properties

[image] [image]

.NET Framework Class Library
LegendCell Properties
LegendCell Class See Also Send Feedback

The LegendCell type exposes the following members.

Properties

 | Name | Description
Public property | CellRectangle | 범례 셀 렉텡글을 가져오고 설정합니다.
Public property | HeaderType | 범례 헤더의 각 셀의 타입을 가져오고 설정합니다.

See Also

LegendCell Class


CellRectangle Property

[image]

.NET Framework Class Library
LegendCell..::..CellRectangle Property
LegendCell Class See Also Send Feedback

범례 셀 렉텡글을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property CellRectangle As RectangleF
    Get
    Set
C#
public RectangleF CellRectangle { get; set; }
Visual C++
public:
property RectangleF CellRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_cellRectangle();
function set_cellRectangle(value);

See Also

LegendCell Class


HeaderType Property

[image]

.NET Framework Class Library
LegendCell..::..HeaderType Property
LegendCell Class See Also Send Feedback

범례 헤더의 각 셀의 타입을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property HeaderType As LegendHeaderCellType
    Get
    Set
C#
public LegendHeaderCellType HeaderType { get; set; }
Visual C++
public:
property LegendHeaderCellType HeaderType {
    LegendHeaderCellType get ();
    void set (LegendHeaderCellType value);
}
JavaScript
function get_headerType();
function set_headerType(value);

See Also

LegendCell Class


LegendCellDictionary Class

[image]

.NET Framework Class Library
LegendCellDictionary Class
Members See Also Send Feedback

범례 셀 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendCellDictionary _
    Inherits List(Of LegendCell)
C#
[SerializableAttribute]
public class LegendCellDictionary : List<LegendCell>
Visual C++
[SerializableAttribute]
public ref class LegendCellDictionary : public List<LegendCell^>
JavaScript
Hippo.LegendCellDictionary = function();

Type.createClass(
    'Hippo.LegendCellDictionary',
    List`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' LegendCell >)>)>
Hippo..::..LegendCellDictionary

See Also

LegendCellDictionary Members


LegendCellDictionary Members

[image] [image]

.NET Framework Class Library
LegendCellDictionary Members
LegendCellDictionary Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LegendCellDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | LegendCellDictionary |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendCell >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class


LegendCellDictionary Constructor

[image]

.NET Framework Class Library
LegendCellDictionary Constructor
LegendCellDictionary Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendCellDictionary()
Visual C++
public:
LegendCellDictionary()
JavaScript
Hippo.LegendCellDictionary = function();

See Also

LegendCellDictionary Class


LegendCellDictionary Methods

[image] [image]

.NET Framework Class Library
LegendCellDictionary Methods
LegendCellDictionary Class See Also Send Feedback

The LegendCellDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendCell >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..BinarySearch Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


CopyTo Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..CopyTo Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


FindIndex Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..FindIndex Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..FindLastIndex Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


IndexOf Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..IndexOf Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..LastIndexOf Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


Reverse Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..Reverse Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


Sort Method

[image] [image]

.NET Framework Class Library
LegendCellDictionary..::..Sort Method
LegendCellDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class
LegendCellDictionary Members


LegendCellDictionary Properties

[image] [image]

.NET Framework Class Library
LegendCellDictionary Properties
LegendCellDictionary Class See Also Send Feedback

The LegendCellDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendCell >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendCell >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendCell >)>)>.)

See Also

LegendCellDictionary Class


LegendFormat Enumeration

[image]

.NET Framework Class Library
LegendFormat Enumeration
See Also Send Feedback

범례 포맷

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LegendFormat
C#
public enum LegendFormat
Visual C++
public enum class LegendFormat
JavaScript
Hippo.LegendFormat = function();
Hippo.LegendFormat.createEnum('Hippo.LegendFormat', false);

Members

Member name | Description
Icon_Name |
Value_Icon_Name |
Value_Percent_Icon_Name |
Percent_Icon_Name |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


LegendHeader Class

[image]

.NET Framework Class Library
LegendHeader Class
Members See Also Send Feedback

범례 헤더 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendHeader
C#
[SerializableAttribute]
public class LegendHeader
Visual C++
[SerializableAttribute]
public ref class LegendHeader
JavaScript
Hippo.LegendHeader = function();

Type.createClass(
    'Hippo.LegendHeader');

Remarks

범례에서 헤더 부분을 관리합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendHeader

See Also

LegendHeader Members


LegendHeader Members

[image] [image]

.NET Framework Class Library
LegendHeader Members
LegendHeader Class Constructors Methods Properties See Also Send Feedback

The LegendHeader type exposes the following members.

Constructors

 | Name | Description
Public method | LegendHeader | LegendHeader 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DivideLineColor | 헤더 구분선의 색상을 설정하고 가져옵니다.
Public property | Height | 범례 헤더 세로 길이를 설정하고 가져옵니다.
Public property | IconLabel | 아이콘 라벨을 설정하고 가져옵니다.
Public property | NameLabel | 이름 라벨을 설정하고 가져옵니다.
Public property | PercentLabel | 퍼센트 라벨을 설정하고 가져옵니다.
Public property | ValueLabel | 합(값) 라벨을 설정하고 가져옵니다.
Public property | Width | 범례 헤더 가로 길이를 설정하고 가져옵니다.

See Also

LegendHeader Class


LegendHeader Constructor

[image]

.NET Framework Class Library
LegendHeader Constructor
LegendHeader Class See Also Send Feedback

LegendHeader 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendHeader()
Visual C++
public:
LegendHeader()
JavaScript
Hippo.LegendHeader = function();

See Also

LegendHeader Class


LegendHeader Methods

[image] [image]

.NET Framework Class Library
LegendHeader Methods
LegendHeader Class See Also Send Feedback

The LegendHeader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendHeader Class


LegendHeader Properties

[image] [image]

.NET Framework Class Library
LegendHeader Properties
LegendHeader Class See Also Send Feedback

The LegendHeader type exposes the following members.

Properties

 | Name | Description
Public property | DivideLineColor | 헤더 구분선의 색상을 설정하고 가져옵니다.
Public property | Height | 범례 헤더 세로 길이를 설정하고 가져옵니다.
Public property | IconLabel | 아이콘 라벨을 설정하고 가져옵니다.
Public property | NameLabel | 이름 라벨을 설정하고 가져옵니다.
Public property | PercentLabel | 퍼센트 라벨을 설정하고 가져옵니다.
Public property | ValueLabel | 합(값) 라벨을 설정하고 가져옵니다.
Public property | Width | 범례 헤더 가로 길이를 설정하고 가져옵니다.

See Also

LegendHeader Class


DivideLineColor Property

[image]

.NET Framework Class Library
LegendHeader..::..DivideLineColor Property
LegendHeader Class See Also Send Feedback

헤더 구분선의 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DivideLineColor As Color
    Get
    Set
C#
public Color DivideLineColor { get; set; }
Visual C++
public:
property Color DivideLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_divideLineColor();
function set_divideLineColor(value);

See Also

LegendHeader Class


Height Property

[image]

.NET Framework Class Library
LegendHeader..::..Height Property
LegendHeader Class See Also Send Feedback

범례 헤더 세로 길이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height As Single
    Get
    Set
C#
public float Height { get; set; }
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}
JavaScript
function get_height();
function set_height(value);

See Also

LegendHeader Class


IconLabel Property

[image]

.NET Framework Class Library
LegendHeader..::..IconLabel Property
LegendHeader Class See Also Send Feedback

아이콘 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property IconLabel As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label IconLabel { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ IconLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_iconLabel();
function set_iconLabel(value);

See Also

LegendHeader Class


NameLabel Property

[image]

.NET Framework Class Library
LegendHeader..::..NameLabel Property
LegendHeader Class See Also Send Feedback

이름 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property NameLabel As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label NameLabel { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ NameLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_nameLabel();
function set_nameLabel(value);

See Also

LegendHeader Class


PercentLabel Property

[image]

.NET Framework Class Library
LegendHeader..::..PercentLabel Property
LegendHeader Class See Also Send Feedback

퍼센트 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property PercentLabel As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label PercentLabel { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ PercentLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_percentLabel();
function set_percentLabel(value);

See Also

LegendHeader Class


ValueLabel Property

[image]

.NET Framework Class Library
LegendHeader..::..ValueLabel Property
LegendHeader Class See Also Send Feedback

합(값) 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property ValueLabel As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label ValueLabel { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ ValueLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_valueLabel();
function set_valueLabel(value);

See Also

LegendHeader Class


Width Property

[image]

.NET Framework Class Library
LegendHeader..::..Width Property
LegendHeader Class See Also Send Feedback

범례 헤더 가로 길이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Single
    Get
    Set
C#
public float Width { get; set; }
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}
JavaScript
function get_width();
function set_width(value);

See Also

LegendHeader Class


LegendHeaderCellType Enumeration

[image]

.NET Framework Class Library
LegendHeaderCellType Enumeration
See Also Send Feedback

범례 헤더의 셀 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LegendHeaderCellType
C#
public enum LegendHeaderCellType
Visual C++
public enum class LegendHeaderCellType
JavaScript
Hippo.LegendHeaderCellType = function();
Hippo.LegendHeaderCellType.createEnum('Hippo.LegendHeaderCellType', false);

Members

Member name | Description
Value |
Percent |
Icon |
Name |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


LegendItem Class

[image]

.NET Framework Class Library
LegendItem Class
Members See Also Send Feedback

범례 아이템 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendItem
C#
[SerializableAttribute]
public class LegendItem
Visual C++
[SerializableAttribute]
public ref class LegendItem
JavaScript
Hippo.LegendItem = function();

Type.createClass(
    'Hippo.LegendItem');

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendItem

See Also

LegendItem Members


LegendItem Members

[image] [image]

.NET Framework Class Library
LegendItem Members
LegendItem Class Constructors Methods Properties See Also Send Feedback

The LegendItem type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItem | LegendItem 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaType | 범례 영역타입을 설정하고 가져옵니다.
Public property | Column | 범례 컬럼을 설정하고 가져옵니다.
Public property | IconColor | 범례 아이템 배경색을 설정하고 가져옵니다.
Public property | IconPath | 범례 아이템 아이콘 경로를 설정하고 가져옵니다.
Public property | IsDetailView | 범례의 값, 퍼센트를 표시할 것인지 여부를 설정하고 가져옵니다.
Public property | IsUse3D | 범례 아이템을 3D로 그릴 것인지 여부를 설정하고 가져옵니다.
Public property | Label | 범례 아이템 라벨을 설정하고 가져옵니다.
Public property | LegendBoxType | 범례 타입을 설정하고 가져옵니다.
Public property | Line | 범례 라인을 설정하고 가져옵니다.
Public property | Percent | 범례 아이템의 퍼센트 값을 설정하고 가져옵니다.
Public property | Point | 범례 포인트(점을 나타내는 클래스)를 설정하고 가져옵니다.
Public property | SeriesNumber | 범례 아이템의 세트를 구분하기 위한 시리즈 넘버를 설정하고 가져옵니다.
Public property | Value | 범례 아이템의 값을 설정하고 가져옵니다.

See Also

LegendItem Class


LegendItem Constructor

[image]

.NET Framework Class Library
LegendItem Constructor
LegendItem Class See Also Send Feedback

LegendItem 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendItem()
Visual C++
public:
LegendItem()
JavaScript
Hippo.LegendItem = function();

See Also

LegendItem Class


LegendItem Methods

[image] [image]

.NET Framework Class Library
LegendItem Methods
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendItem Class


LegendItem Properties

[image] [image]

.NET Framework Class Library
LegendItem Properties
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Properties

 | Name | Description
Public property | AreaType | 범례 영역타입을 설정하고 가져옵니다.
Public property | Column | 범례 컬럼을 설정하고 가져옵니다.
Public property | IconColor | 범례 아이템 배경색을 설정하고 가져옵니다.
Public property | IconPath | 범례 아이템 아이콘 경로를 설정하고 가져옵니다.
Public property | IsDetailView | 범례의 값, 퍼센트를 표시할 것인지 여부를 설정하고 가져옵니다.
Public property | IsUse3D | 범례 아이템을 3D로 그릴 것인지 여부를 설정하고 가져옵니다.
Public property | Label | 범례 아이템 라벨을 설정하고 가져옵니다.
Public property | LegendBoxType | 범례 타입을 설정하고 가져옵니다.
Public property | Line | 범례 라인을 설정하고 가져옵니다.
Public property | Percent | 범례 아이템의 퍼센트 값을 설정하고 가져옵니다.
Public property | Point | 범례 포인트(점을 나타내는 클래스)를 설정하고 가져옵니다.
Public property | SeriesNumber | 범례 아이템의 세트를 구분하기 위한 시리즈 넘버를 설정하고 가져옵니다.
Public property | Value | 범례 아이템의 값을 설정하고 가져옵니다.

See Also

LegendItem Class


AreaType Property

[image]

.NET Framework Class Library
LegendItem..::..AreaType Property
LegendItem Class See Also Send Feedback

범례 영역타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AreaType As AreaType
    Get
    Set
C#
public AreaType AreaType { get; set; }
Visual C++
public:
property AreaType AreaType {
    AreaType get ();
    void set (AreaType value);
}
JavaScript
function get_areaType();
function set_areaType(value);

See Also

LegendItem Class


Column Property

[image]

.NET Framework Class Library
LegendItem..::..Column Property
LegendItem Class See Also Send Feedback

범례 컬럼을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Column As Column
    Get
    Set
C#
public Column Column { get; set; }
Visual C++
public:
property Column^ Column {
    Column^ get ();
    void set (Column^ value);
}
JavaScript
function get_column();
function set_column(value);

See Also

LegendItem Class


IconColor Property

[image]

.NET Framework Class Library
LegendItem..::..IconColor Property
LegendItem Class See Also Send Feedback

범례 아이템 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IconColor As Color
    Get
    Set
C#
public Color IconColor { get; set; }
Visual C++
public:
property Color IconColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_iconColor();
function set_iconColor(value);

See Also

LegendItem Class


IconPath Property

[image]

.NET Framework Class Library
LegendItem..::..IconPath Property
LegendItem Class See Also Send Feedback

범례 아이템 아이콘 경로를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IconPath As String
    Get
    Set
C#
public string IconPath { get; set; }
Visual C++
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iconPath();
function set_iconPath(value);

See Also

LegendItem Class


IsDetailView Property

[image]

.NET Framework Class Library
LegendItem..::..IsDetailView Property
LegendItem Class See Also Send Feedback

범례의 값, 퍼센트를 표시할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDetailView As Boolean
    Get
    Set
C#
public bool IsDetailView { get; set; }
Visual C++
public:
property bool IsDetailView {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDetailView();
function set_isDetailView(value);

See Also

LegendItem Class


IsUse3D Property

[image]

.NET Framework Class Library
LegendItem..::..IsUse3D Property
LegendItem Class See Also Send Feedback

범례 아이템을 3D로 그릴 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsUse3D As Boolean
    Get
    Set
C#
public bool IsUse3D { get; set; }
Visual C++
public:
property bool IsUse3D {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isUse3D();
function set_isUse3D(value);

See Also

LegendItem Class


Label Property

[image]

.NET Framework Class Library
LegendItem..::..Label Property
LegendItem Class See Also Send Feedback

범례 아이템 라벨을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Label As Label
    Get
    Set
C#
public Label Label { get; set; }
Visual C++
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

LegendItem Class


LegendBoxType Property

[image]

.NET Framework Class Library
LegendItem..::..LegendBoxType Property
LegendItem Class See Also Send Feedback

범례 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendBoxType As ChartType
    Get
    Set
C#
public ChartType LegendBoxType { get; set; }
Visual C++
public:
property ChartType LegendBoxType {
    ChartType get ();
    void set (ChartType value);
}
JavaScript
function get_legendBoxType();
function set_legendBoxType(value);

See Also

LegendItem Class


Line Property

[image]

.NET Framework Class Library
LegendItem..::..Line Property
LegendItem Class See Also Send Feedback

범례 라인을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Line As Line
    Get
    Set
C#
public Line Line { get; set; }
Visual C++
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

LegendItem Class


Percent Property

[image]

.NET Framework Class Library
LegendItem..::..Percent Property
LegendItem Class See Also Send Feedback

범례 아이템의 퍼센트 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Percent As String
    Get
    Set
C#
public string Percent { get; set; }
Visual C++
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_percent();
function set_percent(value);

See Also

LegendItem Class


Point Property

[image]

.NET Framework Class Library
LegendItem..::..Point Property
LegendItem Class See Also Send Feedback

범례 포인트(점을 나타내는 클래스)를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Point As Points
    Get
    Set
C#
public Points Point { get; set; }
Visual C++
public:
property Points^ Point {
    Points^ get ();
    void set (Points^ value);
}
JavaScript
function get_point();
function set_point(value);

See Also

LegendItem Class


SeriesNumber Property

[image]

.NET Framework Class Library
LegendItem..::..SeriesNumber Property
LegendItem Class See Also Send Feedback

범례 아이템의 세트를 구분하기 위한 시리즈 넘버를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesNumber As String
    Get
    Set
C#
public string SeriesNumber { get; set; }
Visual C++
public:
property String^ SeriesNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_seriesNumber();
function set_seriesNumber(value);

See Also

LegendItem Class


Value Property

[image]

.NET Framework Class Library
LegendItem..::..Value Property
LegendItem Class See Also Send Feedback

범례 아이템의 값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As String
    Get
    Set
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

LegendItem Class


LegendLocation Enumeration

[image]

.NET Framework Class Library
LegendLocation Enumeration
See Also Send Feedback

범례 박스 위치

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LegendLocation
C#
public enum LegendLocation
Visual C++
public enum class LegendLocation
JavaScript
Hippo.LegendLocation = function();
Hippo.LegendLocation.createEnum('Hippo.LegendLocation', false);

Members

Member name | Description
Default |
Left |
Top |
Bottom |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


LegendRow Class

[image]

.NET Framework Class Library
LegendRow Class
Members See Also Send Feedback

범례박스아이템 로우 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendRow
C#
[SerializableAttribute]
public class LegendRow
Visual C++
[SerializableAttribute]
public ref class LegendRow
JavaScript
Hippo.LegendRow = function();

Type.createClass(
    'Hippo.LegendRow');

Inheritance Hierarchy

System..::..Object
Hippo..::..LegendRow

See Also

LegendRow Members


LegendRow Members

[image] [image]

.NET Framework Class Library
LegendRow Members
LegendRow Class Constructors Methods Properties See Also Send Feedback

The LegendRow type exposes the following members.

Constructors

 | Name | Description
Public method | LegendRow | LegendRow 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Cells | 범례 셀 컬렉션을 가져오고 설정합니다.(헤더의 개수에 따라 달라진다)
Public property | Item | 범례 아이템을 가져오고 설정합니다.(한 로우당 하나의 범례 아이템을 가진다)
Public property | ItemRectangle |

See Also

LegendRow Class


LegendRow Constructor

[image]

.NET Framework Class Library
LegendRow Constructor
LegendRow Class See Also Send Feedback

LegendRow 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    headerType As LegendFormat _
)
C#
public LegendRow(
    LegendFormat headerType
)
Visual C++
public:
LegendRow(
    LegendFormat headerType
)
JavaScript
Hippo.LegendRow = function(headerType);

Parameters

headerType
Type: Hippo..::..LegendFormat
헤더타입

See Also

LegendRow Class


LegendRow Methods

[image] [image]

.NET Framework Class Library
LegendRow Methods
LegendRow Class See Also Send Feedback

The LegendRow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LegendRow Class


LegendRow Properties

[image] [image]

.NET Framework Class Library
LegendRow Properties
LegendRow Class See Also Send Feedback

The LegendRow type exposes the following members.

Properties

 | Name | Description
Public property | Cells | 범례 셀 컬렉션을 가져오고 설정합니다.(헤더의 개수에 따라 달라진다)
Public property | Item | 범례 아이템을 가져오고 설정합니다.(한 로우당 하나의 범례 아이템을 가진다)
Public property | ItemRectangle |

See Also

LegendRow Class


Cells Property

[image]

.NET Framework Class Library
LegendRow..::..Cells Property
LegendRow Class See Also Send Feedback

범례 셀 컬렉션을 가져오고 설정합니다.(헤더의 개수에 따라 달라진다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Cells As LegendCellDictionary
    Get
    Set
C#
public LegendCellDictionary Cells { get; set; }
Visual C++
public:
property LegendCellDictionary^ Cells {
    LegendCellDictionary^ get ();
    void set (LegendCellDictionary^ value);
}
JavaScript
function get_cells();
function set_cells(value);

See Also

LegendRow Class


Item Property

[image]

.NET Framework Class Library
LegendRow..::..Item Property
LegendRow Class See Also Send Feedback

범례 아이템을 가져오고 설정합니다.(한 로우당 하나의 범례 아이템을 가진다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Item As LegendItem
    Get
    Set
C#
public LegendItem Item { get; set; }
Visual C++
public:
property LegendItem^ Item {
    LegendItem^ get ();
    void set (LegendItem^ value);
}
JavaScript
function get_item();
function set_item(value);

See Also

LegendRow Class


ItemRectangle Property

[image]

.NET Framework Class Library
LegendRow..::..ItemRectangle Property
LegendRow Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ItemRectangle As RectangleF
    Get
    Set
C#
public RectangleF ItemRectangle { get; set; }
Visual C++
public:
property RectangleF ItemRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_itemRectangle();
function set_itemRectangle(value);

See Also

LegendRow Class


LegendRowDictionary Class

[image]

.NET Framework Class Library
LegendRowDictionary Class
Members See Also Send Feedback

범례박스아이템 로우 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class LegendRowDictionary _
    Inherits List(Of LegendRow)
C#
[SerializableAttribute]
public class LegendRowDictionary : List<LegendRow>
Visual C++
[SerializableAttribute]
public ref class LegendRowDictionary : public List<LegendRow^>
JavaScript
Hippo.LegendRowDictionary = function();

Type.createClass(
    'Hippo.LegendRowDictionary',
    List`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' LegendRow >)>)>
Hippo..::..LegendRowDictionary

See Also

LegendRowDictionary Members


LegendRowDictionary Members

[image] [image]

.NET Framework Class Library
LegendRowDictionary Members
LegendRowDictionary Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LegendRowDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | LegendRowDictionary |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendRow >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class


LegendRowDictionary Constructor

[image]

.NET Framework Class Library
LegendRowDictionary Constructor
LegendRowDictionary Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public LegendRowDictionary()
Visual C++
public:
LegendRowDictionary()
JavaScript
Hippo.LegendRowDictionary = function();

See Also

LegendRowDictionary Class


LegendRowDictionary Methods

[image] [image]

.NET Framework Class Library
LegendRowDictionary Methods
LegendRowDictionary Class See Also Send Feedback

The LegendRowDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' LegendRow >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..BinarySearch Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


CopyTo Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..CopyTo Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


FindIndex Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..FindIndex Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..FindLastIndex Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


IndexOf Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..IndexOf Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..LastIndexOf Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


Reverse Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..Reverse Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


Sort Method

[image] [image]

.NET Framework Class Library
LegendRowDictionary..::..Sort Method
LegendRowDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class
LegendRowDictionary Members


LegendRowDictionary Properties

[image] [image]

.NET Framework Class Library
LegendRowDictionary Properties
LegendRowDictionary Class See Also Send Feedback

The LegendRowDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' LegendRow >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' LegendRow >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' LegendRow >)>)>.)

See Also

LegendRowDictionary Class


LegendValueType Enumeration

[image]

.NET Framework Class Library
LegendValueType Enumeration
See Also Send Feedback

범례 value 부분에 표시할 값의 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LegendValueType
C#
public enum LegendValueType
Visual C++
public enum class LegendValueType
JavaScript
Hippo.LegendValueType = function();
Hippo.LegendValueType.createEnum('Hippo.LegendValueType', false);

Members

Member name | Description
Sum |
Average |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Line Class

[image]

.NET Framework Class Library
Line Class
Members See Also Send Feedback

각종 라인의 속성을 관리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Line
C#
[SerializableAttribute]
public class Line
Visual C++
[SerializableAttribute]
public ref class Line
JavaScript
Hippo.Line = function();

Type.createClass(
    'Hippo.Line');

Remarks

히포차트내의 라인에 관련된 코어 클래스입니다. 라인차트, 마커, 틱 그리드라인 등 거의 모든 곳에 사용됩니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Line

See Also

Line Members


Line Members

[image] [image]

.NET Framework Class Library
Line Members
Line Class Constructors Methods Properties See Also Send Feedback

The Line type exposes the following members.

Constructors

 | Name | Description
Public method | Line | 라인 객체의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaDesignType | 라인 면적 디자인 타입을 가져오고 설정합니다.
Public property | DashCap | 라인 DashCap을 가져오고 설정합니다.
Public property | DashStyle | 라인 DashStyle을 가져오고 설정합니다.
Public property | EndCap | 라인 EndCap을 가져오고 설정합니다.
Public property | LineAreaColors | 라인 영역 배경색을 가져오고 설정합니다.
Public property | LineColor | 라인 색상을 가져오고 설정합니다.
Public property | LineWidth | 라인 굵기을 가져오고 설정합니다.
Public property | StartCap | 라인 StartCap을 가져오고 설정합니다.

See Also

Line Class


Line Constructor

[image]

.NET Framework Class Library
Line Constructor
Line Class See Also Send Feedback

라인 객체의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Line()
Visual C++
public:
Line()
JavaScript
Hippo.Line = function();

See Also

Line Class


Line Methods

[image] [image]

.NET Framework Class Library
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Line Class


Line Properties

[image] [image]

.NET Framework Class Library
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | AreaDesignType | 라인 면적 디자인 타입을 가져오고 설정합니다.
Public property | DashCap | 라인 DashCap을 가져오고 설정합니다.
Public property | DashStyle | 라인 DashStyle을 가져오고 설정합니다.
Public property | EndCap | 라인 EndCap을 가져오고 설정합니다.
Public property | LineAreaColors | 라인 영역 배경색을 가져오고 설정합니다.
Public property | LineColor | 라인 색상을 가져오고 설정합니다.
Public property | LineWidth | 라인 굵기을 가져오고 설정합니다.
Public property | StartCap | 라인 StartCap을 가져오고 설정합니다.

See Also

Line Class


AreaDesignType Property

[image]

.NET Framework Class Library
Line..::..AreaDesignType Property
Line Class See Also Send Feedback

라인 면적 디자인 타입을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AreaDesignType As AreaDesignType
    Get
    Set
C#
public AreaDesignType AreaDesignType { get; set; }
Visual C++
public:
property AreaDesignType AreaDesignType {
    AreaDesignType get ();
    void set (AreaDesignType value);
}
JavaScript
function get_areaDesignType();
function set_areaDesignType(value);

See Also

Line Class


DashCap Property

[image]

.NET Framework Class Library
Line..::..DashCap Property
Line Class See Also Send Feedback

라인 DashCap을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DashCap As DashCap
    Get
    Set
C#
public DashCap DashCap { get; set; }
Visual C++
public:
property DashCap DashCap {
    DashCap get ();
    void set (DashCap value);
}
JavaScript
function get_dashCap();
function set_dashCap(value);

See Also

Line Class


DashStyle Property

[image]

.NET Framework Class Library
Line..::..DashStyle Property
Line Class See Also Send Feedback

라인 DashStyle을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DashStyle As DashStyle
    Get
    Set
C#
public DashStyle DashStyle { get; set; }
Visual C++
public:
property DashStyle DashStyle {
    DashStyle get ();
    void set (DashStyle value);
}
JavaScript
function get_dashStyle();
function set_dashStyle(value);

See Also

Line Class


EndCap Property

[image]

.NET Framework Class Library
Line..::..EndCap Property
Line Class See Also Send Feedback

라인 EndCap을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property EndCap As LineCap
    Get
    Set
C#
public LineCap EndCap { get; set; }
Visual C++
public:
property LineCap EndCap {
    LineCap get ();
    void set (LineCap value);
}
JavaScript
function get_endCap();
function set_endCap(value);

See Also

Line Class


LineAreaColors Property

[image]

.NET Framework Class Library
Line..::..LineAreaColors Property
Line Class See Also Send Feedback

라인 영역 배경색을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LineAreaColors As Color()
    Get
    Set
C#
public Color[] LineAreaColors { get; set; }
Visual C++
public:
property array<Color>^ LineAreaColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
JavaScript
function get_lineAreaColors();
function set_lineAreaColors(value);

See Also

Line Class


LineColor Property

[image]

.NET Framework Class Library
Line..::..LineColor Property
Line Class See Also Send Feedback

라인 색상을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LineColor As Color
    Get
    Set
C#
public Color LineColor { get; set; }
Visual C++
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_lineColor();
function set_lineColor(value);

See Also

Line Class


LineWidth Property

[image]

.NET Framework Class Library
Line..::..LineWidth Property
Line Class See Also Send Feedback

라인 굵기을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LineWidth As Single
    Get
    Set
C#
public float LineWidth { get; set; }
Visual C++
public:
property float LineWidth {
    float get ();
    void set (float value);
}
JavaScript
function get_lineWidth();
function set_lineWidth(value);

See Also

Line Class


StartCap Property

[image]

.NET Framework Class Library
Line..::..StartCap Property
Line Class See Also Send Feedback

라인 StartCap을 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StartCap As LineCap
    Get
    Set
C#
public LineCap StartCap { get; set; }
Visual C++
public:
property LineCap StartCap {
    LineCap get ();
    void set (LineCap value);
}
JavaScript
function get_startCap();
function set_startCap(value);

See Also

Line Class


LineNullType Enumeration

[image]

.NET Framework Class Library
LineNullType Enumeration
See Also Send Feedback

라인류 차트의 데이터가 널일 경우 표시하는 종류

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LineNullType
C#
public enum LineNullType
Visual C++
public enum class LineNullType
JavaScript
Hippo.LineNullType = function();
Hippo.LineNullType.createEnum('Hippo.LineNullType', false);

Members

Member name | Description
Default |
Dash |
Dot |
DashDot |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Logo Class

[image]

.NET Framework Class Library
Logo Class
Members See Also Send Feedback

차트 로고(logo) 요소

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Logo
C#
[SerializableAttribute]
public class Logo
Visual C++
[SerializableAttribute]
public ref class Logo
JavaScript
Hippo.Logo = function();

Type.createClass(
    'Hippo.Logo');

Remarks

차트 하단에 홈페이지 주소, 회사이름, 차트 분류 등을 텍스트 관리할 수 있습니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Logo

See Also

Logo Members


Logo Members

[image] [image]

.NET Framework Class Library
Logo Members
Logo Class Constructors Methods Properties See Also Send Feedback

The Logo type exposes the following members.

Constructors

 | Name | Description
Public method | Logo | Logo

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Label | 로고 라벨
Public property | LogoAlign | 로고 위치

See Also

Logo Class


Logo Constructor

[image]

.NET Framework Class Library
Logo Constructor
Logo Class See Also Send Feedback

Logo

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Logo()
Visual C++
public:
Logo()
JavaScript
Hippo.Logo = function();

See Also

Logo Class


Logo Methods

[image] [image]

.NET Framework Class Library
Logo Methods
Logo Class See Also Send Feedback

The Logo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Logo Class


Logo Properties

[image] [image]

.NET Framework Class Library
Logo Properties
Logo Class See Also Send Feedback

The Logo type exposes the following members.

Properties

 | Name | Description
Public property | Label | 로고 라벨
Public property | LogoAlign | 로고 위치

See Also

Logo Class


Label Property

[image]

.NET Framework Class Library
Logo..::..Label Property
Logo Class See Also Send Feedback

로고 라벨

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Logo Class


LogoAlign Property

[image]

.NET Framework Class Library
Logo..::..LogoAlign Property
Logo Class See Also Send Feedback

로고 위치

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LogoAlign As StringAlignment
    Get
    Set
C#
public StringAlignment LogoAlign { get; set; }
Visual C++
public:
property StringAlignment LogoAlign {
    StringAlignment get ();
    void set (StringAlignment value);
}
JavaScript
function get_logoAlign();
function set_logoAlign(value);

See Also

Logo Class


OrganizationElement Class

[image]

.NET Framework Class Library
OrganizationElement Class
Members See Also Send Feedback

조직도 구성원 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class OrganizationElement
C#
public class OrganizationElement
Visual C++
public ref class OrganizationElement
JavaScript
Hippo.OrganizationElement = function();

Type.createClass(
    'Hippo.OrganizationElement');

Inheritance Hierarchy

System..::..Object
Hippo..::..OrganizationElement

See Also

OrganizationElement Members


OrganizationElement Members

[image] [image]

.NET Framework Class Library
OrganizationElement Members
OrganizationElement Class Constructors Methods Properties See Also Send Feedback

The OrganizationElement type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationElement()()()() | OrganizationElement
Public method | OrganizationElement(String) | OrganizationElement
Public method | OrganizationElement(String, Int32) | OrganizationElement
Public method | OrganizationElement(String, Int32, Image) | OrganizationElement

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessKey | 조직원에 엑세스할 수 있는 키 값을 설정하고 가져옵니다. (자동 설정)
Public property | BackColor | 조직원 객체에 사용되는 배경색을 설정하고 가져옵니다. 배경색은 상단 타이틀 영역에 표시됩니다.
Public property | ForeColor | 조직원 객체에 사용할 글자색을 설정하고 가져옵니다.
Public property | GroupName | 조직원이 속한 그룹 이름을 설정하고 가져옵니다.
Public property | IsAutoSize | 조직원 객체의 사격형의 크기를 자동 설정할지 여부를 설정하고 가져옵니다.
Public property | IsImageView | 조직원의 사진을 보여줄 것인지 여부를 설정하고 가져옵니다.
Public property | Location | 조직원 객체의 위치를 설정하고 가져옵니다.
Public property | Memo | 조직원에 대한 설명을 설정하고 가져욉니다.
Public property | MemoFont | 조직원의 하단 설명 부분의 폰트를 설정하고 가져옵니다.
Public property | Name | 조직원의 이름을 설정하고 가져옵니다.
Public property | NameFont | 조직원의 이름 부분의 폰트를 설정하고 가져옵니다.
Public property | OutLineColor | 조직원 객체에 사용되는 외곽 라인 색상을 설정하고 가져옵니다.
Public property | Parent | 조직원의 직속 부모 조직원을 설정하고 가져옵니다.
Public property | Picture | 조직원의 사진 이미지 객체를 설정하고 가져옵니다.
Public property | Position | 조직원의 직위를 설정하고 가져옵니다.
Public property | Size | 조직원 객체의 크기를 설정하고 가져옵니다.
Public property | Step | 조직원의 단계를 설정하고 가져옵니다. 단계란, 조직도에서의 층을 의미하며 0부터 시작합니다.
Public property | TitleForeColor | 조직원의 타이틀 부분의 글자색을 설정하고 가져옵니다.
Public property | Type | 조직원의 타입을 설정하고 가져옵니다.

See Also

OrganizationElement Class


OrganizationElement Constructor

[image] [image]

.NET Framework Class Library
OrganizationElement Constructor
OrganizationElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OrganizationElement()()()() | OrganizationElement
Public method | OrganizationElement(String) | OrganizationElement
Public method | OrganizationElement(String, Int32) | OrganizationElement
Public method | OrganizationElement(String, Int32, Image) | OrganizationElement

See Also

OrganizationElement Class
OrganizationElement Members


OrganizationElement Constructor

[image]

.NET Framework Class Library
OrganizationElement Constructor
OrganizationElement Class See Also Send Feedback

OrganizationElement

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public OrganizationElement()
Visual C++
public:
OrganizationElement()
JavaScript
Hippo.OrganizationElement = function();

See Also

OrganizationElement Class
OrganizationElement Overload


OrganizationElement Constructor (String)

[image]

.NET Framework Class Library
OrganizationElement Constructor (String)
OrganizationElement Class See Also Send Feedback

OrganizationElement

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    OrganizationName As String _
)
C#
public OrganizationElement(
    string OrganizationName
)
Visual C++
public:
OrganizationElement(
    String^ OrganizationName
)
JavaScript
Hippo.OrganizationElement = function(OrganizationName);

Parameters

OrganizationName
Type: System..::..String

See Also

OrganizationElement Class
OrganizationElement Overload


OrganizationElement Constructor (String, Int32)

[image]

.NET Framework Class Library
OrganizationElement Constructor (String, Int32)
OrganizationElement Class See Also Send Feedback

OrganizationElement

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    OrganizationName As String, _
    Parent As Integer _
)
C#
public OrganizationElement(
    string OrganizationName,
    int Parent
)
Visual C++
public:
OrganizationElement(
    String^ OrganizationName,
    int Parent
)
JavaScript
Hippo.OrganizationElement = function(OrganizationName, Parent);

Parameters

OrganizationName
Type: System..::..String
Parent
Type: System..::..Int32

See Also

OrganizationElement Class
OrganizationElement Overload


OrganizationElement Constructor (String, Int32, Image)

[image]

.NET Framework Class Library
OrganizationElement Constructor (String, Int32, Image)
OrganizationElement Class See Also Send Feedback

OrganizationElement

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    OrganizationName As String, _
    Parent As Integer, _
    Picture As Image _
)
C#
public OrganizationElement(
    string OrganizationName,
    int Parent,
    Image Picture
)
Visual C++
public:
OrganizationElement(
    String^ OrganizationName,
    int Parent,
    Image^ Picture
)
JavaScript
Hippo.OrganizationElement = function(OrganizationName, Parent, Picture);

Parameters

OrganizationName
Type: System..::..String
Parent
Type: System..::..Int32
Picture
Type: System.Drawing..::..Image

See Also

OrganizationElement Class
OrganizationElement Overload


OrganizationElement Methods

[image] [image]

.NET Framework Class Library
OrganizationElement Methods
OrganizationElement Class See Also Send Feedback

The OrganizationElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

OrganizationElement Class


OrganizationElement Properties

[image] [image]

.NET Framework Class Library
OrganizationElement Properties
OrganizationElement Class See Also Send Feedback

The OrganizationElement type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | 조직원에 엑세스할 수 있는 키 값을 설정하고 가져옵니다. (자동 설정)
Public property | BackColor | 조직원 객체에 사용되는 배경색을 설정하고 가져옵니다. 배경색은 상단 타이틀 영역에 표시됩니다.
Public property | ForeColor | 조직원 객체에 사용할 글자색을 설정하고 가져옵니다.
Public property | GroupName | 조직원이 속한 그룹 이름을 설정하고 가져옵니다.
Public property | IsAutoSize | 조직원 객체의 사격형의 크기를 자동 설정할지 여부를 설정하고 가져옵니다.
Public property | IsImageView | 조직원의 사진을 보여줄 것인지 여부를 설정하고 가져옵니다.
Public property | Location | 조직원 객체의 위치를 설정하고 가져옵니다.
Public property | Memo | 조직원에 대한 설명을 설정하고 가져욉니다.
Public property | MemoFont | 조직원의 하단 설명 부분의 폰트를 설정하고 가져옵니다.
Public property | Name | 조직원의 이름을 설정하고 가져옵니다.
Public property | NameFont | 조직원의 이름 부분의 폰트를 설정하고 가져옵니다.
Public property | OutLineColor | 조직원 객체에 사용되는 외곽 라인 색상을 설정하고 가져옵니다.
Public property | Parent | 조직원의 직속 부모 조직원을 설정하고 가져옵니다.
Public property | Picture | 조직원의 사진 이미지 객체를 설정하고 가져옵니다.
Public property | Position | 조직원의 직위를 설정하고 가져옵니다.
Public property | Size | 조직원 객체의 크기를 설정하고 가져옵니다.
Public property | Step | 조직원의 단계를 설정하고 가져옵니다. 단계란, 조직도에서의 층을 의미하며 0부터 시작합니다.
Public property | TitleForeColor | 조직원의 타이틀 부분의 글자색을 설정하고 가져옵니다.
Public property | Type | 조직원의 타입을 설정하고 가져옵니다.

See Also

OrganizationElement Class


AccessKey Property

[image]

.NET Framework Class Library
OrganizationElement..::..AccessKey Property
OrganizationElement Class See Also Send Feedback

조직원에 엑세스할 수 있는 키 값을 설정하고 가져옵니다. (자동 설정)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AccessKey As String
    Get
    Set
C#
public string AccessKey { get; set; }
Visual C++
public:
property String^ AccessKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accessKey();
function set_accessKey(value);

See Also

OrganizationElement Class


BackColor Property

[image]

.NET Framework Class Library
OrganizationElement..::..BackColor Property
OrganizationElement Class See Also Send Feedback

조직원 객체에 사용되는 배경색을 설정하고 가져옵니다. 배경색은 상단 타이틀 영역에 표시됩니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

OrganizationElement Class


ForeColor Property

[image]

.NET Framework Class Library
OrganizationElement..::..ForeColor Property
OrganizationElement Class See Also Send Feedback

조직원 객체에 사용할 글자색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

OrganizationElement Class


GroupName Property

[image]

.NET Framework Class Library
OrganizationElement..::..GroupName Property
OrganizationElement Class See Also Send Feedback

조직원이 속한 그룹 이름을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GroupName As String
    Get
    Set
C#
public string GroupName { get; set; }
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupName();
function set_groupName(value);

See Also

OrganizationElement Class


IsAutoSize Property

[image]

.NET Framework Class Library
OrganizationElement..::..IsAutoSize Property
OrganizationElement Class See Also Send Feedback

조직원 객체의 사격형의 크기를 자동 설정할지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsAutoSize As Boolean
    Get
    Set
C#
public bool IsAutoSize { get; set; }
Visual C++
public:
property bool IsAutoSize {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAutoSize();
function set_isAutoSize(value);

See Also

OrganizationElement Class


IsImageView Property

[image]

.NET Framework Class Library
OrganizationElement..::..IsImageView Property
OrganizationElement Class See Also Send Feedback

조직원의 사진을 보여줄 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsImageView As Boolean
    Get
    Set
C#
public bool IsImageView { get; set; }
Visual C++
public:
property bool IsImageView {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isImageView();
function set_isImageView(value);

See Also

OrganizationElement Class


Location Property

[image]

.NET Framework Class Library
OrganizationElement..::..Location Property
OrganizationElement Class See Also Send Feedback

조직원 객체의 위치를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Location As PointF
    Get
    Set
C#
public PointF Location { get; set; }
Visual C++
public:
property PointF Location {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_location();
function set_location(value);

See Also

OrganizationElement Class


Memo Property

[image]

.NET Framework Class Library
OrganizationElement..::..Memo Property
OrganizationElement Class See Also Send Feedback

조직원에 대한 설명을 설정하고 가져욉니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Memo As String
    Get
    Set
C#
public string Memo { get; set; }
Visual C++
public:
property String^ Memo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_memo();
function set_memo(value);

See Also

OrganizationElement Class


MemoFont Property

[image]

.NET Framework Class Library
OrganizationElement..::..MemoFont Property
OrganizationElement Class See Also Send Feedback

조직원의 하단 설명 부분의 폰트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property MemoFont As Font
    Get
    Set
C#
public Font MemoFont { get; set; }
Visual C++
public:
property Font^ MemoFont {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_memoFont();
function set_memoFont(value);

See Also

OrganizationElement Class


Name Property

[image]

.NET Framework Class Library
OrganizationElement..::..Name Property
OrganizationElement Class See Also Send Feedback

조직원의 이름을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

OrganizationElement Class


NameFont Property

[image]

.NET Framework Class Library
OrganizationElement..::..NameFont Property
OrganizationElement Class See Also Send Feedback

조직원의 이름 부분의 폰트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property NameFont As Font
    Get
    Set
C#
public Font NameFont { get; set; }
Visual C++
public:
property Font^ NameFont {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_nameFont();
function set_nameFont(value);

See Also

OrganizationElement Class


OutLineColor Property

[image]

.NET Framework Class Library
OrganizationElement..::..OutLineColor Property
OrganizationElement Class See Also Send Feedback

조직원 객체에 사용되는 외곽 라인 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property OutLineColor As Color
    Get
    Set
C#
public Color OutLineColor { get; set; }
Visual C++
public:
property Color OutLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_outLineColor();
function set_outLineColor(value);

See Also

OrganizationElement Class


Parent Property

[image]

.NET Framework Class Library
OrganizationElement..::..Parent Property
OrganizationElement Class See Also Send Feedback

조직원의 직속 부모 조직원을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Parent As Integer
    Get
    Set
C#
public int Parent { get; set; }
Visual C++
public:
property int Parent {
    int get ();
    void set (int value);
}
JavaScript
function get_parent();
function set_parent(value);

See Also

OrganizationElement Class


Picture Property

[image]

.NET Framework Class Library
OrganizationElement..::..Picture Property
OrganizationElement Class See Also Send Feedback

조직원의 사진 이미지 객체를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Picture As Image
    Get
    Set
C#
public Image Picture { get; set; }
Visual C++
public:
property Image^ Picture {
    Image^ get ();
    void set (Image^ value);
}
JavaScript
function get_picture();
function set_picture(value);

See Also

OrganizationElement Class


Position Property

[image]

.NET Framework Class Library
OrganizationElement..::..Position Property
OrganizationElement Class See Also Send Feedback

조직원의 직위를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Position As String
    Get
    Set
C#
public string Position { get; set; }
Visual C++
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_position();
function set_position(value);

See Also

OrganizationElement Class


Size Property

[image]

.NET Framework Class Library
OrganizationElement..::..Size Property
OrganizationElement Class See Also Send Feedback

조직원 객체의 크기를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Size As SizeF
    Get
    Set
C#
public SizeF Size { get; set; }
Visual C++
public:
property SizeF Size {
    SizeF get ();
    void set (SizeF value);
}
JavaScript
function get_size();
function set_size(value);

See Also

OrganizationElement Class


Step Property

[image]

.NET Framework Class Library
OrganizationElement..::..Step Property
OrganizationElement Class See Also Send Feedback

조직원의 단계를 설정하고 가져옵니다. 단계란, 조직도에서의 층을 의미하며 0부터 시작합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Step As Integer
    Get
    Set
C#
public int Step { get; set; }
Visual C++
public:
property int Step {
    int get ();
    void set (int value);
}
JavaScript
function get_step();
function set_step(value);

See Also

OrganizationElement Class


TitleForeColor Property

[image]

.NET Framework Class Library
OrganizationElement..::..TitleForeColor Property
OrganizationElement Class See Also Send Feedback

조직원의 타이틀 부분의 글자색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleForeColor As Color
    Get
    Set
C#
public Color TitleForeColor { get; set; }
Visual C++
public:
property Color TitleForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_titleForeColor();
function set_titleForeColor(value);

See Also

OrganizationElement Class


Type Property

[image]

.NET Framework Class Library
OrganizationElement..::..Type Property
OrganizationElement Class See Also Send Feedback

조직원의 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Type As OrganizationType
    Get
    Set
C#
public OrganizationType Type { get; set; }
Visual C++
public:
property OrganizationType Type {
    OrganizationType get ();
    void set (OrganizationType value);
}
JavaScript
function get_type();
function set_type(value);

See Also

OrganizationElement Class


OrganizationType Enumeration

[image]

.NET Framework Class Library
OrganizationType Enumeration
See Also Send Feedback

조직원 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration OrganizationType
C#
public enum OrganizationType
Visual C++
public enum class OrganizationType
JavaScript
Hippo.OrganizationType = function();
Hippo.OrganizationType.createEnum('Hippo.OrganizationType', false);

Members

Member name | Description
President |
Inspection |
Group |
Employee |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Outlier Class

[image]

.NET Framework Class Library
Outlier Class
Members See Also Send Feedback

박스플롯 이상치 객체 - 이상치 데이터는, 현재 CHART에서 제공하는 SeriesItem 객체와 유사한 객체의 배열로 데이터를 등록할 수 있도록 함

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Outlier
C#
[SerializableAttribute]
public class Outlier
Visual C++
[SerializableAttribute]
public ref class Outlier
JavaScript
Hippo.Outlier = function();

Type.createClass(
    'Hippo.Outlier');

Inheritance Hierarchy

System..::..Object
Hippo..::..Outlier

See Also

Outlier Members


Outlier Members

[image] [image]

.NET Framework Class Library
Outlier Members
Outlier Class Constructors Methods Properties See Also Send Feedback

The Outlier type exposes the following members.

Constructors

 | Name | Description
Public method | Outlier | 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | FigurPoint | 이상치 포인트를 설정하고 가져옵니다.
Public property | Font | 이상치 폰트를 설정하고 가져옵니다.
Public property | ForeColor | 이상치 표시 색상을 설정하고 가져옵니다.
Public property | Points | 이상치 포인트 객체
Public property | PointText | 이상치 표현 문자
Public property | Value | 이상치 값

See Also

Outlier Class


Outlier Constructor

[image]

.NET Framework Class Library
Outlier Constructor
Outlier Class See Also Send Feedback

생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Outlier()
Visual C++
public:
Outlier()
JavaScript
Hippo.Outlier = function();

See Also

Outlier Class


Outlier Methods

[image] [image]

.NET Framework Class Library
Outlier Methods
Outlier Class See Also Send Feedback

The Outlier type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Outlier Class


Outlier Properties

[image] [image]

.NET Framework Class Library
Outlier Properties
Outlier Class See Also Send Feedback

The Outlier type exposes the following members.

Properties

 | Name | Description
Public property | FigurPoint | 이상치 포인트를 설정하고 가져옵니다.
Public property | Font | 이상치 폰트를 설정하고 가져옵니다.
Public property | ForeColor | 이상치 표시 색상을 설정하고 가져옵니다.
Public property | Points | 이상치 포인트 객체
Public property | PointText | 이상치 표현 문자
Public property | Value | 이상치 값

See Also

Outlier Class


FigurPoint Property

[image]

.NET Framework Class Library
Outlier..::..FigurPoint Property
Outlier Class See Also Send Feedback

이상치 포인트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigurPoint As PointF
    Get
    Set
C#
public PointF FigurPoint { get; set; }
Visual C++
public:
property PointF FigurPoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_figurPoint();
function set_figurPoint(value);

See Also

Outlier Class


Font Property

[image]

.NET Framework Class Library
Outlier..::..Font Property
Outlier Class See Also Send Feedback

이상치 폰트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Font As Font
    Get
    Set
C#
public Font Font { get; set; }
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_font();
function set_font(value);

See Also

Outlier Class


ForeColor Property

[image]

.NET Framework Class Library
Outlier..::..ForeColor Property
Outlier Class See Also Send Feedback

이상치 표시 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

Outlier Class


Points Property

[image]

.NET Framework Class Library
Outlier..::..Points Property
Outlier Class See Also Send Feedback

이상치 포인트 객체

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Points As Points
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Points Points { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Points^ Points {
    Points^ get ();
    void set (Points^ value);
}
JavaScript
function get_points();
function set_points(value);

See Also

Outlier Class


PointText Property

[image]

.NET Framework Class Library
Outlier..::..PointText Property
Outlier Class See Also Send Feedback

이상치 표현 문자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PointText As String
    Get
    Set
C#
public string PointText { get; set; }
Visual C++
public:
property String^ PointText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pointText();
function set_pointText(value);

See Also

Outlier Class


Value Property

[image]

.NET Framework Class Library
Outlier..::..Value Property
Outlier Class See Also Send Feedback

이상치 값

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As Double
    Get
    Set
C#
public double Value { get; set; }
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}
JavaScript
function get_value();
function set_value(value);

See Also

Outlier Class


OutlierList Class

[image]

.NET Framework Class Library
OutlierList Class
Members See Also Send Feedback

박스플롯 이상치 리스트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class OutlierList _
    Inherits HippoCollectionBase(Of Outlier)
C#
[SerializableAttribute]
public class OutlierList : HippoCollectionBase<Outlier>
Visual C++
[SerializableAttribute]
public ref class OutlierList : public HippoCollectionBase<Outlier^>
JavaScript
Hippo.OutlierList = function();

Type.createClass(
    'Hippo.OutlierList',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Outlier >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Outlier >)>)>
Hippo..::..OutlierList

See Also

OutlierList Members


OutlierList Members

[image] [image]

.NET Framework Class Library
OutlierList Members
OutlierList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The OutlierList type exposes the following members.

Constructors

 | Name | Description
Public method | OutlierList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Outlier >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Outlier >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Outlier >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class


OutlierList Constructor

[image]

.NET Framework Class Library
OutlierList Constructor
OutlierList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public OutlierList()
Visual C++
public:
OutlierList()
JavaScript
Hippo.OutlierList = function();

See Also

OutlierList Class


OutlierList Methods

[image] [image]

.NET Framework Class Library
OutlierList Methods
OutlierList Class See Also Send Feedback

The OutlierList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Outlier >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Outlier >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
OutlierList..::..BinarySearch Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
OutlierList..::..CopyTo Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
OutlierList..::..FindIndex Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
OutlierList..::..FindLastIndex Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
OutlierList..::..IndexOf Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
OutlierList..::..LastIndexOf Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


Reverse Method

[image] [image]

.NET Framework Class Library
OutlierList..::..Reverse Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


Sort Method

[image] [image]

.NET Framework Class Library
OutlierList..::..Sort Method
OutlierList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class
OutlierList Members


OutlierList Properties

[image] [image]

.NET Framework Class Library
OutlierList Properties
OutlierList Class See Also Send Feedback

The OutlierList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Outlier >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Outlier >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Outlier >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Outlier >)>)>.)

See Also

OutlierList Class


Palette Class

[image]

.NET Framework Class Library
Palette Class
Members See Also Send Feedback

Palette 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Palette _
    Implements IPalette
C#
[SerializableAttribute]
public class Palette : IPalette
Visual C++
[SerializableAttribute]
public ref class Palette : IPalette
JavaScript
Hippo.Palette = function();

Type.createClass(
    'Hippo.Palette',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette

See Also

Palette Members


Palette Members

[image] [image]

.NET Framework Class Library
Palette Members
Palette Class Constructors Methods Properties See Also Send Feedback

The Palette type exposes the following members.

Constructors

 | Name | Description
Public method | Palette |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultBackColor | 차트 배경색을 설정하고 가져옵니다.
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor10 | 차트 기본색 10을 설정하고 가져옵니다.
Public property | DefaultColor11 | 차트 기본색 11을 설정하고 가져옵니다.
Public property | DefaultColor12 | 차트 기본색 12을 설정하고 가져옵니다.
Public property | DefaultColor13 | 차트 기본색 13을 설정하고 가져옵니다.
Public property | DefaultColor14 | 차트 기본색 14을 설정하고 가져옵니다.
Public property | DefaultColor15 | 차트 기본색 15을 설정하고 가져옵니다.
Public property | DefaultColor16 | 차트 기본색 16을 설정하고 가져옵니다.
Public property | DefaultColor17 | 차트 기본색 17을 설정하고 가져옵니다.
Public property | DefaultColor18 | 차트 기본색 18을 설정하고 가져옵니다.
Public property | DefaultColor19 | 차트 기본색 19을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor20 | 차트 기본색 20을 설정하고 가져옵니다.
Public property | DefaultColor21 | 차트 기본색 21을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.
Public property | DefaultColor6 | 차트 기본색 6을 설정하고 가져옵니다.
Public property | DefaultColor7 | 차트 기본색 7을 설정하고 가져옵니다.
Public property | DefaultColor8 | 차트 기본색 8을 설정하고 가져옵니다.
Public property | DefaultColor9 | 차트 기본색 9을 설정하고 가져옵니다.
Public property | DefaultCoodinateColor | 그래프 눈금색을 설정하고 가져옵니다.
Public property | DefaultInnerBackColor | 내부 사각형 색을 설정하고 가져옵니다.
Public property | DefaultLegendItemForeColor | 범례 아이템 글자 색상을 설정하고 가져옵니다.
Public property | DefaultLineColor | 그래프 대표 눈금색을 설정하고 가져옵니다.
Public property | DefaultLogoColor | 로고 글자색을 설정하고 가져옵니다.
Public property | DefaultPenColor | 기본 펜 색상을 설정하고 가져옵니다.
Public property | DefaultTitleColor | 타이틀 글자색을 설정하고 가져옵니다.
Public property | DefaultZeroLineColor | 좌표 평면그래프일 경우 제로 라인 색상을 설정하고 가져옵니다.
Public property | DefualtBackLineColor | 배경라인색을 설정하고 가져옵니다.

See Also

Palette Class


Palette Constructor

[image]

.NET Framework Class Library
Palette Constructor
Palette Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette()
Visual C++
public:
Palette()
JavaScript
Hippo.Palette = function();

See Also

Palette Class


Palette Methods

[image] [image]

.NET Framework Class Library
Palette Methods
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette Class


Palette Properties

[image] [image]

.NET Framework Class Library
Palette Properties
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Properties

 | Name | Description
Public property | DefaultBackColor | 차트 배경색을 설정하고 가져옵니다.
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor10 | 차트 기본색 10을 설정하고 가져옵니다.
Public property | DefaultColor11 | 차트 기본색 11을 설정하고 가져옵니다.
Public property | DefaultColor12 | 차트 기본색 12을 설정하고 가져옵니다.
Public property | DefaultColor13 | 차트 기본색 13을 설정하고 가져옵니다.
Public property | DefaultColor14 | 차트 기본색 14을 설정하고 가져옵니다.
Public property | DefaultColor15 | 차트 기본색 15을 설정하고 가져옵니다.
Public property | DefaultColor16 | 차트 기본색 16을 설정하고 가져옵니다.
Public property | DefaultColor17 | 차트 기본색 17을 설정하고 가져옵니다.
Public property | DefaultColor18 | 차트 기본색 18을 설정하고 가져옵니다.
Public property | DefaultColor19 | 차트 기본색 19을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor20 | 차트 기본색 20을 설정하고 가져옵니다.
Public property | DefaultColor21 | 차트 기본색 21을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.
Public property | DefaultColor6 | 차트 기본색 6을 설정하고 가져옵니다.
Public property | DefaultColor7 | 차트 기본색 7을 설정하고 가져옵니다.
Public property | DefaultColor8 | 차트 기본색 8을 설정하고 가져옵니다.
Public property | DefaultColor9 | 차트 기본색 9을 설정하고 가져옵니다.
Public property | DefaultCoodinateColor | 그래프 눈금색을 설정하고 가져옵니다.
Public property | DefaultInnerBackColor | 내부 사각형 색을 설정하고 가져옵니다.
Public property | DefaultLegendItemForeColor | 범례 아이템 글자 색상을 설정하고 가져옵니다.
Public property | DefaultLineColor | 그래프 대표 눈금색을 설정하고 가져옵니다.
Public property | DefaultLogoColor | 로고 글자색을 설정하고 가져옵니다.
Public property | DefaultPenColor | 기본 펜 색상을 설정하고 가져옵니다.
Public property | DefaultTitleColor | 타이틀 글자색을 설정하고 가져옵니다.
Public property | DefaultZeroLineColor | 좌표 평면그래프일 경우 제로 라인 색상을 설정하고 가져옵니다.
Public property | DefualtBackLineColor | 배경라인색을 설정하고 가져옵니다.

See Also

Palette Class


DefaultBackColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultBackColor Property
Palette Class See Also Send Feedback

차트 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultBackColor As Color
    Get
    Set
C#
public Color DefaultBackColor { get; set; }
Visual C++
public:
property Color DefaultBackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultBackColor();
function set_defaultBackColor(value);

See Also

Palette Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor1 Property
Palette Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette Class


DefaultColor10 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor10 Property
Palette Class See Also Send Feedback

차트 기본색 10을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor10 As Color
    Get
    Set
C#
public Color DefaultColor10 { get; set; }
Visual C++
public:
property Color DefaultColor10 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor10();
function set_defaultColor10(value);

See Also

Palette Class


DefaultColor11 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor11 Property
Palette Class See Also Send Feedback

차트 기본색 11을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor11 As Color
    Get
    Set
C#
public Color DefaultColor11 { get; set; }
Visual C++
public:
property Color DefaultColor11 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor11();
function set_defaultColor11(value);

See Also

Palette Class


DefaultColor12 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor12 Property
Palette Class See Also Send Feedback

차트 기본색 12을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor12 As Color
    Get
    Set
C#
public Color DefaultColor12 { get; set; }
Visual C++
public:
property Color DefaultColor12 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor12();
function set_defaultColor12(value);

See Also

Palette Class


DefaultColor13 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor13 Property
Palette Class See Also Send Feedback

차트 기본색 13을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor13 As Color
    Get
    Set
C#
public Color DefaultColor13 { get; set; }
Visual C++
public:
property Color DefaultColor13 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor13();
function set_defaultColor13(value);

See Also

Palette Class


DefaultColor14 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor14 Property
Palette Class See Also Send Feedback

차트 기본색 14을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor14 As Color
    Get
    Set
C#
public Color DefaultColor14 { get; set; }
Visual C++
public:
property Color DefaultColor14 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor14();
function set_defaultColor14(value);

See Also

Palette Class


DefaultColor15 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor15 Property
Palette Class See Also Send Feedback

차트 기본색 15을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor15 As Color
    Get
    Set
C#
public Color DefaultColor15 { get; set; }
Visual C++
public:
property Color DefaultColor15 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor15();
function set_defaultColor15(value);

See Also

Palette Class


DefaultColor16 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor16 Property
Palette Class See Also Send Feedback

차트 기본색 16을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor16 As Color
    Get
    Set
C#
public Color DefaultColor16 { get; set; }
Visual C++
public:
property Color DefaultColor16 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor16();
function set_defaultColor16(value);

See Also

Palette Class


DefaultColor17 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor17 Property
Palette Class See Also Send Feedback

차트 기본색 17을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor17 As Color
    Get
    Set
C#
public Color DefaultColor17 { get; set; }
Visual C++
public:
property Color DefaultColor17 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor17();
function set_defaultColor17(value);

See Also

Palette Class


DefaultColor18 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor18 Property
Palette Class See Also Send Feedback

차트 기본색 18을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor18 As Color
    Get
    Set
C#
public Color DefaultColor18 { get; set; }
Visual C++
public:
property Color DefaultColor18 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor18();
function set_defaultColor18(value);

See Also

Palette Class


DefaultColor19 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor19 Property
Palette Class See Also Send Feedback

차트 기본색 19을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor19 As Color
    Get
    Set
C#
public Color DefaultColor19 { get; set; }
Visual C++
public:
property Color DefaultColor19 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor19();
function set_defaultColor19(value);

See Also

Palette Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor2 Property
Palette Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette Class


DefaultColor20 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor20 Property
Palette Class See Also Send Feedback

차트 기본색 20을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor20 As Color
    Get
    Set
C#
public Color DefaultColor20 { get; set; }
Visual C++
public:
property Color DefaultColor20 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor20();
function set_defaultColor20(value);

See Also

Palette Class


DefaultColor21 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor21 Property
Palette Class See Also Send Feedback

차트 기본색 21을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor21 As Color
    Get
    Set
C#
public Color DefaultColor21 { get; set; }
Visual C++
public:
property Color DefaultColor21 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor21();
function set_defaultColor21(value);

See Also

Palette Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor3 Property
Palette Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor4 Property
Palette Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor5 Property
Palette Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette Class


DefaultColor6 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor6 Property
Palette Class See Also Send Feedback

차트 기본색 6을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor6 As Color
    Get
    Set
C#
public Color DefaultColor6 { get; set; }
Visual C++
public:
property Color DefaultColor6 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor6();
function set_defaultColor6(value);

See Also

Palette Class


DefaultColor7 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor7 Property
Palette Class See Also Send Feedback

차트 기본색 7을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor7 As Color
    Get
    Set
C#
public Color DefaultColor7 { get; set; }
Visual C++
public:
property Color DefaultColor7 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor7();
function set_defaultColor7(value);

See Also

Palette Class


DefaultColor8 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor8 Property
Palette Class See Also Send Feedback

차트 기본색 8을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor8 As Color
    Get
    Set
C#
public Color DefaultColor8 { get; set; }
Visual C++
public:
property Color DefaultColor8 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor8();
function set_defaultColor8(value);

See Also

Palette Class


DefaultColor9 Property

[image]

.NET Framework Class Library
Palette..::..DefaultColor9 Property
Palette Class See Also Send Feedback

차트 기본색 9을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor9 As Color
    Get
    Set
C#
public Color DefaultColor9 { get; set; }
Visual C++
public:
property Color DefaultColor9 {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultColor9();
function set_defaultColor9(value);

See Also

Palette Class


DefaultCoodinateColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultCoodinateColor Property
Palette Class See Also Send Feedback

그래프 눈금색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultCoodinateColor As Color
    Get
    Set
C#
public Color DefaultCoodinateColor { get; set; }
Visual C++
public:
property Color DefaultCoodinateColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultCoodinateColor();
function set_defaultCoodinateColor(value);

See Also

Palette Class


DefaultInnerBackColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultInnerBackColor Property
Palette Class See Also Send Feedback

내부 사각형 색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultInnerBackColor As Color
    Get
    Set
C#
public Color DefaultInnerBackColor { get; set; }
Visual C++
public:
property Color DefaultInnerBackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultInnerBackColor();
function set_defaultInnerBackColor(value);

See Also

Palette Class


DefaultLegendItemForeColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultLegendItemForeColor Property
Palette Class See Also Send Feedback

범례 아이템 글자 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultLegendItemForeColor As Color
    Get
    Set
C#
public Color DefaultLegendItemForeColor { get; set; }
Visual C++
public:
property Color DefaultLegendItemForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultLegendItemForeColor();
function set_defaultLegendItemForeColor(value);

See Also

Palette Class


DefaultLineColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultLineColor Property
Palette Class See Also Send Feedback

그래프 대표 눈금색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultLineColor As Color
    Get
    Set
C#
public Color DefaultLineColor { get; set; }
Visual C++
public:
property Color DefaultLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultLineColor();
function set_defaultLineColor(value);

See Also

Palette Class


DefaultLogoColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultLogoColor Property
Palette Class See Also Send Feedback

로고 글자색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultLogoColor As Color
    Get
    Set
C#
public Color DefaultLogoColor { get; set; }
Visual C++
public:
property Color DefaultLogoColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultLogoColor();
function set_defaultLogoColor(value);

See Also

Palette Class


DefaultPenColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultPenColor Property
Palette Class See Also Send Feedback

기본 펜 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultPenColor As Color
    Get
    Set
C#
public Color DefaultPenColor { get; set; }
Visual C++
public:
property Color DefaultPenColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultPenColor();
function set_defaultPenColor(value);

See Also

Palette Class


DefaultTitleColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultTitleColor Property
Palette Class See Also Send Feedback

타이틀 글자색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultTitleColor As Color
    Get
    Set
C#
public Color DefaultTitleColor { get; set; }
Visual C++
public:
property Color DefaultTitleColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultTitleColor();
function set_defaultTitleColor(value);

See Also

Palette Class


DefaultZeroLineColor Property

[image]

.NET Framework Class Library
Palette..::..DefaultZeroLineColor Property
Palette Class See Also Send Feedback

좌표 평면그래프일 경우 제로 라인 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultZeroLineColor As Color
    Get
    Set
C#
public Color DefaultZeroLineColor { get; set; }
Visual C++
public:
property Color DefaultZeroLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defaultZeroLineColor();
function set_defaultZeroLineColor(value);

See Also

Palette Class


DefualtBackLineColor Property

[image]

.NET Framework Class Library
Palette..::..DefualtBackLineColor Property
Palette Class See Also Send Feedback

배경라인색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefualtBackLineColor As Color
    Get
    Set
C#
public Color DefualtBackLineColor { get; set; }
Visual C++
public:
property Color DefualtBackLineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_defualtBackLineColor();
function set_defualtBackLineColor(value);

See Also

Palette Class


Palette10 Class

[image]

.NET Framework Class Library
Palette10 Class
Members See Also Send Feedback

Palette10 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette10 _
    Implements IPalette
C#
public class Palette10 : IPalette
Visual C++
public ref class Palette10 : IPalette
JavaScript
Hippo.Palette10 = function();

Type.createClass(
    'Hippo.Palette10',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette10

See Also

Palette10 Members


Palette10 Members

[image] [image]

.NET Framework Class Library
Palette10 Members
Palette10 Class Constructors Methods Properties See Also Send Feedback

The Palette10 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette10 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette10 Class


Palette10 Constructor

[image]

.NET Framework Class Library
Palette10 Constructor
Palette10 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette10()
Visual C++
public:
Palette10()
JavaScript
Hippo.Palette10 = function();

See Also

Palette10 Class


Palette10 Methods

[image] [image]

.NET Framework Class Library
Palette10 Methods
Palette10 Class See Also Send Feedback

The Palette10 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette10 Class


Palette10 Properties

[image] [image]

.NET Framework Class Library
Palette10 Properties
Palette10 Class See Also Send Feedback

The Palette10 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette10 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette10..::..DefaultColor1 Property
Palette10 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette10 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette10..::..DefaultColor2 Property
Palette10 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette10 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette10..::..DefaultColor3 Property
Palette10 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette10 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette10..::..DefaultColor4 Property
Palette10 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette10 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette10..::..DefaultColor5 Property
Palette10 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette10 Class


Palette11 Class

[image]

.NET Framework Class Library
Palette11 Class
Members See Also Send Feedback

Palette11 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette11 _
    Implements IPalette
C#
public class Palette11 : IPalette
Visual C++
public ref class Palette11 : IPalette
JavaScript
Hippo.Palette11 = function();

Type.createClass(
    'Hippo.Palette11',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette11

See Also

Palette11 Members


Palette11 Members

[image] [image]

.NET Framework Class Library
Palette11 Members
Palette11 Class Constructors Methods Properties See Also Send Feedback

The Palette11 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette11 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette11 Class


Palette11 Constructor

[image]

.NET Framework Class Library
Palette11 Constructor
Palette11 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette11()
Visual C++
public:
Palette11()
JavaScript
Hippo.Palette11 = function();

See Also

Palette11 Class


Palette11 Methods

[image] [image]

.NET Framework Class Library
Palette11 Methods
Palette11 Class See Also Send Feedback

The Palette11 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette11 Class


Palette11 Properties

[image] [image]

.NET Framework Class Library
Palette11 Properties
Palette11 Class See Also Send Feedback

The Palette11 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette11 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette11..::..DefaultColor1 Property
Palette11 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette11 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette11..::..DefaultColor2 Property
Palette11 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette11 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette11..::..DefaultColor3 Property
Palette11 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette11 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette11..::..DefaultColor4 Property
Palette11 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette11 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette11..::..DefaultColor5 Property
Palette11 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette11 Class


Palette12 Class

[image]

.NET Framework Class Library
Palette12 Class
Members See Also Send Feedback

Palette12 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette12 _
    Implements IPalette
C#
public class Palette12 : IPalette
Visual C++
public ref class Palette12 : IPalette
JavaScript
Hippo.Palette12 = function();

Type.createClass(
    'Hippo.Palette12',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette12

See Also

Palette12 Members


Palette12 Members

[image] [image]

.NET Framework Class Library
Palette12 Members
Palette12 Class Constructors Methods Properties See Also Send Feedback

The Palette12 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette12 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette12 Class


Palette12 Constructor

[image]

.NET Framework Class Library
Palette12 Constructor
Palette12 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette12()
Visual C++
public:
Palette12()
JavaScript
Hippo.Palette12 = function();

See Also

Palette12 Class


Palette12 Methods

[image] [image]

.NET Framework Class Library
Palette12 Methods
Palette12 Class See Also Send Feedback

The Palette12 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette12 Class


Palette12 Properties

[image] [image]

.NET Framework Class Library
Palette12 Properties
Palette12 Class See Also Send Feedback

The Palette12 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette12 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette12..::..DefaultColor1 Property
Palette12 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette12 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette12..::..DefaultColor2 Property
Palette12 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette12 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette12..::..DefaultColor3 Property
Palette12 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette12 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette12..::..DefaultColor4 Property
Palette12 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette12 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette12..::..DefaultColor5 Property
Palette12 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette12 Class


Palette2 Class

[image]

.NET Framework Class Library
Palette2 Class
Members See Also Send Feedback

Palette2 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Palette2 _
    Implements IPalette
C#
[SerializableAttribute]
public class Palette2 : IPalette
Visual C++
[SerializableAttribute]
public ref class Palette2 : IPalette
JavaScript
Hippo.Palette2 = function();

Type.createClass(
    'Hippo.Palette2',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette2

See Also

Palette2 Members


Palette2 Members

[image] [image]

.NET Framework Class Library
Palette2 Members
Palette2 Class Constructors Methods Properties See Also Send Feedback

The Palette2 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette2 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette2 Class


Palette2 Constructor

[image]

.NET Framework Class Library
Palette2 Constructor
Palette2 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette2()
Visual C++
public:
Palette2()
JavaScript
Hippo.Palette2 = function();

See Also

Palette2 Class


Palette2 Methods

[image] [image]

.NET Framework Class Library
Palette2 Methods
Palette2 Class See Also Send Feedback

The Palette2 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette2 Class


Palette2 Properties

[image] [image]

.NET Framework Class Library
Palette2 Properties
Palette2 Class See Also Send Feedback

The Palette2 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette2 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette2..::..DefaultColor1 Property
Palette2 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette2 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette2..::..DefaultColor2 Property
Palette2 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette2 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette2..::..DefaultColor3 Property
Palette2 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette2 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette2..::..DefaultColor4 Property
Palette2 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette2 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette2..::..DefaultColor5 Property
Palette2 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette2 Class


Palette3 Class

[image]

.NET Framework Class Library
Palette3 Class
Members See Also Send Feedback

Palette3 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette3 _
    Implements IPalette
C#
public class Palette3 : IPalette
Visual C++
public ref class Palette3 : IPalette
JavaScript
Hippo.Palette3 = function();

Type.createClass(
    'Hippo.Palette3',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette3

See Also

Palette3 Members


Palette3 Members

[image] [image]

.NET Framework Class Library
Palette3 Members
Palette3 Class Constructors Methods Properties See Also Send Feedback

The Palette3 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette3 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette3 Class


Palette3 Constructor

[image]

.NET Framework Class Library
Palette3 Constructor
Palette3 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette3()
Visual C++
public:
Palette3()
JavaScript
Hippo.Palette3 = function();

See Also

Palette3 Class


Palette3 Methods

[image] [image]

.NET Framework Class Library
Palette3 Methods
Palette3 Class See Also Send Feedback

The Palette3 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette3 Class


Palette3 Properties

[image] [image]

.NET Framework Class Library
Palette3 Properties
Palette3 Class See Also Send Feedback

The Palette3 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette3 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette3..::..DefaultColor1 Property
Palette3 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette3 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette3..::..DefaultColor2 Property
Palette3 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette3 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette3..::..DefaultColor3 Property
Palette3 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette3 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette3..::..DefaultColor4 Property
Palette3 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette3 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette3..::..DefaultColor5 Property
Palette3 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette3 Class


Palette4 Class

[image]

.NET Framework Class Library
Palette4 Class
Members See Also Send Feedback

Palette4 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette4 _
    Implements IPalette
C#
public class Palette4 : IPalette
Visual C++
public ref class Palette4 : IPalette
JavaScript
Hippo.Palette4 = function();

Type.createClass(
    'Hippo.Palette4',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette4

See Also

Palette4 Members


Palette4 Members

[image] [image]

.NET Framework Class Library
Palette4 Members
Palette4 Class Constructors Methods Properties See Also Send Feedback

The Palette4 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette4 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette4 Class


Palette4 Constructor

[image]

.NET Framework Class Library
Palette4 Constructor
Palette4 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette4()
Visual C++
public:
Palette4()
JavaScript
Hippo.Palette4 = function();

See Also

Palette4 Class


Palette4 Methods

[image] [image]

.NET Framework Class Library
Palette4 Methods
Palette4 Class See Also Send Feedback

The Palette4 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette4 Class


Palette4 Properties

[image] [image]

.NET Framework Class Library
Palette4 Properties
Palette4 Class See Also Send Feedback

The Palette4 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette4 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette4..::..DefaultColor1 Property
Palette4 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette4 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette4..::..DefaultColor2 Property
Palette4 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette4 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette4..::..DefaultColor3 Property
Palette4 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette4 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette4..::..DefaultColor4 Property
Palette4 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette4 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette4..::..DefaultColor5 Property
Palette4 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette4 Class


Palette5 Class

[image]

.NET Framework Class Library
Palette5 Class
Members See Also Send Feedback

Palette5 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette5 _
    Implements IPalette
C#
public class Palette5 : IPalette
Visual C++
public ref class Palette5 : IPalette
JavaScript
Hippo.Palette5 = function();

Type.createClass(
    'Hippo.Palette5',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette5

See Also

Palette5 Members


Palette5 Members

[image] [image]

.NET Framework Class Library
Palette5 Members
Palette5 Class Constructors Methods Properties See Also Send Feedback

The Palette5 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette5 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette5 Class


Palette5 Constructor

[image]

.NET Framework Class Library
Palette5 Constructor
Palette5 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette5()
Visual C++
public:
Palette5()
JavaScript
Hippo.Palette5 = function();

See Also

Palette5 Class


Palette5 Methods

[image] [image]

.NET Framework Class Library
Palette5 Methods
Palette5 Class See Also Send Feedback

The Palette5 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette5 Class


Palette5 Properties

[image] [image]

.NET Framework Class Library
Palette5 Properties
Palette5 Class See Also Send Feedback

The Palette5 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette5 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette5..::..DefaultColor1 Property
Palette5 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette5 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette5..::..DefaultColor2 Property
Palette5 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette5 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette5..::..DefaultColor3 Property
Palette5 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette5 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette5..::..DefaultColor4 Property
Palette5 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette5 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette5..::..DefaultColor5 Property
Palette5 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette5 Class


Palette6 Class

[image]

.NET Framework Class Library
Palette6 Class
Members See Also Send Feedback

Palette6 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette6 _
    Implements IPalette
C#
public class Palette6 : IPalette
Visual C++
public ref class Palette6 : IPalette
JavaScript
Hippo.Palette6 = function();

Type.createClass(
    'Hippo.Palette6',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette6

See Also

Palette6 Members


Palette6 Members

[image] [image]

.NET Framework Class Library
Palette6 Members
Palette6 Class Constructors Methods Properties See Also Send Feedback

The Palette6 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette6 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette6 Class


Palette6 Constructor

[image]

.NET Framework Class Library
Palette6 Constructor
Palette6 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette6()
Visual C++
public:
Palette6()
JavaScript
Hippo.Palette6 = function();

See Also

Palette6 Class


Palette6 Methods

[image] [image]

.NET Framework Class Library
Palette6 Methods
Palette6 Class See Also Send Feedback

The Palette6 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette6 Class


Palette6 Properties

[image] [image]

.NET Framework Class Library
Palette6 Properties
Palette6 Class See Also Send Feedback

The Palette6 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette6 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette6..::..DefaultColor1 Property
Palette6 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette6 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette6..::..DefaultColor2 Property
Palette6 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette6 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette6..::..DefaultColor3 Property
Palette6 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette6 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette6..::..DefaultColor4 Property
Palette6 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette6 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette6..::..DefaultColor5 Property
Palette6 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette6 Class


Palette7 Class

[image]

.NET Framework Class Library
Palette7 Class
Members See Also Send Feedback

Palette7 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette7 _
    Implements IPalette
C#
public class Palette7 : IPalette
Visual C++
public ref class Palette7 : IPalette
JavaScript
Hippo.Palette7 = function();

Type.createClass(
    'Hippo.Palette7',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette7

See Also

Palette7 Members


Palette7 Members

[image] [image]

.NET Framework Class Library
Palette7 Members
Palette7 Class Constructors Methods Properties See Also Send Feedback

The Palette7 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette7 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette7 Class


Palette7 Constructor

[image]

.NET Framework Class Library
Palette7 Constructor
Palette7 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette7()
Visual C++
public:
Palette7()
JavaScript
Hippo.Palette7 = function();

See Also

Palette7 Class


Palette7 Methods

[image] [image]

.NET Framework Class Library
Palette7 Methods
Palette7 Class See Also Send Feedback

The Palette7 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette7 Class


Palette7 Properties

[image] [image]

.NET Framework Class Library
Palette7 Properties
Palette7 Class See Also Send Feedback

The Palette7 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette7 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette7..::..DefaultColor1 Property
Palette7 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette7 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette7..::..DefaultColor2 Property
Palette7 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette7 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette7..::..DefaultColor3 Property
Palette7 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette7 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette7..::..DefaultColor4 Property
Palette7 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette7 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette7..::..DefaultColor5 Property
Palette7 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette7 Class


Palette8 Class

[image]

.NET Framework Class Library
Palette8 Class
Members See Also Send Feedback

Palette8 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette8 _
    Implements IPalette
C#
public class Palette8 : IPalette
Visual C++
public ref class Palette8 : IPalette
JavaScript
Hippo.Palette8 = function();

Type.createClass(
    'Hippo.Palette8',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette8

See Also

Palette8 Members


Palette8 Members

[image] [image]

.NET Framework Class Library
Palette8 Members
Palette8 Class Constructors Methods Properties See Also Send Feedback

The Palette8 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette8 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette8 Class


Palette8 Constructor

[image]

.NET Framework Class Library
Palette8 Constructor
Palette8 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette8()
Visual C++
public:
Palette8()
JavaScript
Hippo.Palette8 = function();

See Also

Palette8 Class


Palette8 Methods

[image] [image]

.NET Framework Class Library
Palette8 Methods
Palette8 Class See Also Send Feedback

The Palette8 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette8 Class


Palette8 Properties

[image] [image]

.NET Framework Class Library
Palette8 Properties
Palette8 Class See Also Send Feedback

The Palette8 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette8 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette8..::..DefaultColor1 Property
Palette8 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette8 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette8..::..DefaultColor2 Property
Palette8 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette8 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette8..::..DefaultColor3 Property
Palette8 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette8 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette8..::..DefaultColor4 Property
Palette8 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette8 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette8..::..DefaultColor5 Property
Palette8 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette8 Class


Palette9 Class

[image]

.NET Framework Class Library
Palette9 Class
Members See Also Send Feedback

Palette9 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Palette9 _
    Implements IPalette
C#
public class Palette9 : IPalette
Visual C++
public ref class Palette9 : IPalette
JavaScript
Hippo.Palette9 = function();

Type.createClass(
    'Hippo.Palette9',
    null,
    Hippo.IPalette);

Inheritance Hierarchy

System..::..Object
Hippo..::..Palette9

See Also

Palette9 Members


Palette9 Members

[image] [image]

.NET Framework Class Library
Palette9 Members
Palette9 Class Constructors Methods Properties See Also Send Feedback

The Palette9 type exposes the following members.

Constructors

 | Name | Description
Public method | Palette9 |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette9 Class


Palette9 Constructor

[image]

.NET Framework Class Library
Palette9 Constructor
Palette9 Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Palette9()
Visual C++
public:
Palette9()
JavaScript
Hippo.Palette9 = function();

See Also

Palette9 Class


Palette9 Methods

[image] [image]

.NET Framework Class Library
Palette9 Methods
Palette9 Class See Also Send Feedback

The Palette9 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Palette9 Class


Palette9 Properties

[image] [image]

.NET Framework Class Library
Palette9 Properties
Palette9 Class See Also Send Feedback

The Palette9 type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColor1 | 차트 기본색 1을 설정하고 가져옵니다.
Public property | DefaultColor2 | 차트 기본색 2을 설정하고 가져옵니다.
Public property | DefaultColor3 | 차트 기본색 3을 설정하고 가져옵니다.
Public property | DefaultColor4 | 차트 기본색 4을 설정하고 가져옵니다.
Public property | DefaultColor5 | 차트 기본색 5을 설정하고 가져옵니다.

See Also

Palette9 Class


DefaultColor1 Property

[image]

.NET Framework Class Library
Palette9..::..DefaultColor1 Property
Palette9 Class See Also Send Feedback

차트 기본색 1을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor1 As Color
    Get
    Set
C#
public Color DefaultColor1 { get; set; }
Visual C++
public:
virtual property Color DefaultColor1 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor1();
function set_defaultColor1(value);

See Also

Palette9 Class


DefaultColor2 Property

[image]

.NET Framework Class Library
Palette9..::..DefaultColor2 Property
Palette9 Class See Also Send Feedback

차트 기본색 2을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor2 As Color
    Get
    Set
C#
public Color DefaultColor2 { get; set; }
Visual C++
public:
virtual property Color DefaultColor2 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor2();
function set_defaultColor2(value);

See Also

Palette9 Class


DefaultColor3 Property

[image]

.NET Framework Class Library
Palette9..::..DefaultColor3 Property
Palette9 Class See Also Send Feedback

차트 기본색 3을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor3 As Color
    Get
    Set
C#
public Color DefaultColor3 { get; set; }
Visual C++
public:
virtual property Color DefaultColor3 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor3();
function set_defaultColor3(value);

See Also

Palette9 Class


DefaultColor4 Property

[image]

.NET Framework Class Library
Palette9..::..DefaultColor4 Property
Palette9 Class See Also Send Feedback

차트 기본색 4을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor4 As Color
    Get
    Set
C#
public Color DefaultColor4 { get; set; }
Visual C++
public:
virtual property Color DefaultColor4 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor4();
function set_defaultColor4(value);

See Also

Palette9 Class


DefaultColor5 Property

[image]

.NET Framework Class Library
Palette9..::..DefaultColor5 Property
Palette9 Class See Also Send Feedback

차트 기본색 5을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DefaultColor5 As Color
    Get
    Set
C#
public Color DefaultColor5 { get; set; }
Visual C++
public:
virtual property Color DefaultColor5 {
    Color get () sealed;
    void set (Color value) sealed;
}
JavaScript
function get_defaultColor5();
function set_defaultColor5(value);

See Also

Palette9 Class


PaletteType Enumeration

[image]

.NET Framework Class Library
PaletteType Enumeration
See Also Send Feedback

팔레트 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration PaletteType
C#
public enum PaletteType
Visual C++
public enum class PaletteType
JavaScript
Hippo.PaletteType = function();
Hippo.PaletteType.createEnum('Hippo.PaletteType', false);

Members

Member name | Description
Default |
Sky |
Soft |
Classic |
Sky2 |
Shadow |
Cool |
Bright |
Dark |
Green |
Lover |
Nature |
None |

Remarks

히포차트에서 지정하는 다양한 색상 팔레트 세트를 제공합니다.

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Percentages Class

[image]

.NET Framework Class Library
Percentages Class
Members See Also Send Feedback

비좌표 차트(파이차트 등)의 각 시리즈아이템들의 퍼센트값 컬렉션을 관리하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Percentages _
    Inherits HippoCollectionBase(Of Single)
C#
[SerializableAttribute]
public class Percentages : HippoCollectionBase<float>
Visual C++
[SerializableAttribute]
public ref class Percentages : public HippoCollectionBase<float>
JavaScript
Hippo.Percentages = function();

Type.createClass(
    'Hippo.Percentages',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Single >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Single >)>)>
Hippo..::..Percentages

See Also

Percentages Members


Percentages Members

[image] [image]

.NET Framework Class Library
Percentages Members
Percentages Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Percentages type exposes the following members.

Constructors

 | Name | Description
Public method | Percentages |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class


Percentages Constructor

[image]

.NET Framework Class Library
Percentages Constructor
Percentages Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Percentages()
Visual C++
public:
Percentages()
JavaScript
Hippo.Percentages = function();

See Also

Percentages Class


Percentages Methods

[image] [image]

.NET Framework Class Library
Percentages Methods
Percentages Class See Also Send Feedback

The Percentages type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
Percentages..::..BinarySearch Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


CopyTo Method

[image] [image]

.NET Framework Class Library
Percentages..::..CopyTo Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


FindIndex Method

[image] [image]

.NET Framework Class Library
Percentages..::..FindIndex Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
Percentages..::..FindLastIndex Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


IndexOf Method

[image] [image]

.NET Framework Class Library
Percentages..::..IndexOf Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
Percentages..::..LastIndexOf Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


Reverse Method

[image] [image]

.NET Framework Class Library
Percentages..::..Reverse Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


Sort Method

[image] [image]

.NET Framework Class Library
Percentages..::..Sort Method
Percentages Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class
Percentages Members


Percentages Properties

[image] [image]

.NET Framework Class Library
Percentages Properties
Percentages Class See Also Send Feedback

The Percentages type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

Percentages Class


PieFigures Class

[image]

.NET Framework Class Library
PieFigures Class
Members See Also Send Feedback

비좌표 차트(파이차트 등)의 각 시리즈아이템들의 실제값 컬렉션을 관리하는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class PieFigures _
    Inherits HippoCollectionBase(Of Single)
C#
[SerializableAttribute]
public class PieFigures : HippoCollectionBase<float>
Visual C++
[SerializableAttribute]
public ref class PieFigures : public HippoCollectionBase<float>
JavaScript
Hippo.PieFigures = function();

Type.createClass(
    'Hippo.PieFigures',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Single >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Single >)>)>
Hippo..::..PieFigures

See Also

PieFigures Members


PieFigures Members

[image] [image]

.NET Framework Class Library
PieFigures Members
PieFigures Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PieFigures type exposes the following members.

Constructors

 | Name | Description
Public method | PieFigures |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class


PieFigures Constructor

[image]

.NET Framework Class Library
PieFigures Constructor
PieFigures Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public PieFigures()
Visual C++
public:
PieFigures()
JavaScript
Hippo.PieFigures = function();

See Also

PieFigures Class


PieFigures Methods

[image] [image]

.NET Framework Class Library
PieFigures Methods
PieFigures Class See Also Send Feedback

The PieFigures type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
PieFigures..::..BinarySearch Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


CopyTo Method

[image] [image]

.NET Framework Class Library
PieFigures..::..CopyTo Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


FindIndex Method

[image] [image]

.NET Framework Class Library
PieFigures..::..FindIndex Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
PieFigures..::..FindLastIndex Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


IndexOf Method

[image] [image]

.NET Framework Class Library
PieFigures..::..IndexOf Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
PieFigures..::..LastIndexOf Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


Reverse Method

[image] [image]

.NET Framework Class Library
PieFigures..::..Reverse Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


Sort Method

[image] [image]

.NET Framework Class Library
PieFigures..::..Sort Method
PieFigures Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class
PieFigures Members


PieFigures Properties

[image] [image]

.NET Framework Class Library
PieFigures Properties
PieFigures Class See Also Send Feedback

The PieFigures type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Single >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Single >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Single >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Single >)>)>.)

See Also

PieFigures Class


PieType Enumeration

[image]

.NET Framework Class Library
PieType Enumeration
See Also Send Feedback

PieType

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration PieType
C#
public enum PieType
Visual C++
public enum class PieType
JavaScript
Hippo.PieType = function();
Hippo.PieType.createEnum('Hippo.PieType', false);

Members

Member name | Description
Normal |
TwoDemention |
Slice |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Points Class

[image]

.NET Framework Class Library
Points Class
Members See Also Send Feedback

점(포인트)를 나타내는 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Points
C#
[SerializableAttribute]
public class Points
Visual C++
[SerializableAttribute]
public ref class Points
JavaScript
Hippo.Points = function();

Type.createClass(
    'Hippo.Points');

Remarks

히포차트내의 포인트를 나타내는 코어 클래스

Inheritance Hierarchy

System..::..Object
Hippo..::..Points

See Also

Points Members


Points Members

[image] [image]

.NET Framework Class Library
Points Members
Points Class Constructors Methods Properties See Also Send Feedback

The Points type exposes the following members.

Constructors

 | Name | Description
Public method | Points()()()() | 포인트 인스턴스를 생성합니다.
Public method | Points(PointType) | 포인트 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | 포인트 색상을 설정하고 가져옵니다.
Public property | PointImage | 포인트 이미지을 설정하고 가져옵니다.
Public property | PointType | 포인트 타입을 설정하고 가져옵니다.
Public property | StringPoint | 포인트를 텍스트 혹은 특수 문자로 설정하는 값을 설정하고 가져옵니다. (예를들어, * )
Public property | Width | 포인트 넓이를 설정하고 가져옵니다.

See Also

Points Class


Points Constructor

[image] [image]

.NET Framework Class Library
Points Constructor
Points Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Points()()()() | 포인트 인스턴스를 생성합니다.
Public method | Points(PointType) | 포인트 인스턴스를 생성합니다.

See Also

Points Class
Points Members


Points Constructor

[image]

.NET Framework Class Library
Points Constructor
Points Class See Also Send Feedback

포인트 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Points()
Visual C++
public:
Points()
JavaScript
Hippo.Points = function();

See Also

Points Class
Points Overload


Points Constructor (PointType)

[image]

.NET Framework Class Library
Points Constructor (PointType)
Points Class See Also Send Feedback

포인트 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    pointtype As PointType _
)
C#
public Points(
    PointType pointtype
)
Visual C++
public:
Points(
    PointType pointtype
)
JavaScript
Hippo.Points = function(pointtype);

Parameters

pointtype
Type: Hippo..::..PointType
포인트 타입

See Also

Points Class
Points Overload


Points Methods

[image] [image]

.NET Framework Class Library
Points Methods
Points Class See Also Send Feedback

The Points type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Points Class


Points Properties

[image] [image]

.NET Framework Class Library
Points Properties
Points Class See Also Send Feedback

The Points type exposes the following members.

Properties

 | Name | Description
Public property | Color | 포인트 색상을 설정하고 가져옵니다.
Public property | PointImage | 포인트 이미지을 설정하고 가져옵니다.
Public property | PointType | 포인트 타입을 설정하고 가져옵니다.
Public property | StringPoint | 포인트를 텍스트 혹은 특수 문자로 설정하는 값을 설정하고 가져옵니다. (예를들어, * )
Public property | Width | 포인트 넓이를 설정하고 가져옵니다.

See Also

Points Class


Color Property

[image]

.NET Framework Class Library
Points..::..Color Property
Points Class See Also Send Feedback

포인트 색상을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Color As Color
    Get
    Set
C#
public Color Color { get; set; }
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}
JavaScript
function get_color();
function set_color(value);

See Also

Points Class


PointImage Property

[image]

.NET Framework Class Library
Points..::..PointImage Property
Points Class See Also Send Feedback

포인트 이미지을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PointImage As String
    Get
    Set
C#
public string PointImage { get; set; }
Visual C++
public:
property String^ PointImage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pointImage();
function set_pointImage(value);

See Also

Points Class


PointType Property

[image]

.NET Framework Class Library
Points..::..PointType Property
Points Class See Also Send Feedback

포인트 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PointType As PointType
    Get
    Set
C#
public PointType PointType { get; set; }
Visual C++
public:
property PointType PointType {
    PointType get ();
    void set (PointType value);
}
JavaScript
function get_pointType();
function set_pointType(value);

See Also

Points Class


StringPoint Property

[image]

.NET Framework Class Library
Points..::..StringPoint Property
Points Class See Also Send Feedback

포인트를 텍스트 혹은 특수 문자로 설정하는 값을 설정하고 가져옵니다. (예를들어, * )

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StringPoint As String
    Get
    Set
C#
public string StringPoint { get; set; }
Visual C++
public:
property String^ StringPoint {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stringPoint();
function set_stringPoint(value);

See Also

Points Class


Width Property

[image]

.NET Framework Class Library
Points..::..Width Property
Points Class See Also Send Feedback

포인트 넓이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width As Single
    Get
    Set
C#
public float Width { get; set; }
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}
JavaScript
function get_width();
function set_width(value);

See Also

Points Class


PointType Enumeration

[image]

.NET Framework Class Library
PointType Enumeration
See Also Send Feedback

포인트 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration PointType
C#
public enum PointType
Visual C++
public enum class PointType
JavaScript
Hippo.PointType = function();
Hippo.PointType.createEnum('Hippo.PointType', false);

Members

Member name | Description
None |
Circle |
Rectangle |
Triangle |
Star |
Image |
FillCircle |
FillRectangle |
FillTriangle |
String |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


PropertyEditorFormCore Class

[image]

.NET Framework Class Library
PropertyEditorFormCore Class
Members See Also Send Feedback

PropertyEditorFormCore
PropertyEditorFormCore

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class PropertyEditorFormCore _
    Inherits Form
C#
public class PropertyEditorFormCore : Form
Visual C++
public ref class PropertyEditorFormCore : public Form
JavaScript
Hippo.PropertyEditorFormCore = function();

Type.createClass(
    'Hippo.PropertyEditorFormCore',
    Form);

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Hippo..::..PropertyEditorFormCore

See Also

PropertyEditorFormCore Members


PropertyEditorFormCore Members

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore Members
PropertyEditorFormCore Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The PropertyEditorFormCore type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyEditorFormCore | PropertyEditorFormCore 인스턴스를 생성합니다.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

PropertyEditorFormCore Class


PropertyEditorFormCore Constructor

[image]

.NET Framework Class Library
PropertyEditorFormCore Constructor
PropertyEditorFormCore Class See Also Send Feedback

PropertyEditorFormCore 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    property As Object _
)
C#
public PropertyEditorFormCore(
    Object property
)
Visual C++
public:
PropertyEditorFormCore(
    Object^ property
)
JavaScript
Hippo.PropertyEditorFormCore = function(property);

Parameters

property
Type: System..::..Object

See Also

PropertyEditorFormCore Class


PropertyEditorFormCore Methods

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore Methods
PropertyEditorFormCore Class See Also Send Feedback

The PropertyEditorFormCore type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

PropertyEditorFormCore Class


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..AccessibilityNotifyClients Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


BeginInvoke Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..BeginInvoke Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Dispose Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Dispose Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Dispose Method (Boolean)

[image]

.NET Framework Class Library
PropertyEditorFormCore..::..Dispose Method (Boolean)
PropertyEditorFormCore Class See Also Send Feedback

사용 중인 모든 리소스를 정리합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
관리되는 리소스를 삭제해야 하면 true이고, 그렇지 않으면 false입니다.

See Also

PropertyEditorFormCore Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..GetChildAtPoint Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Invalidate Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Invalidate Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Invoke Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Invoke Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..MemberwiseClone Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


PerformLayout Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..PerformLayout Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


ResumeLayout Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..ResumeLayout Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..RtlTranslateAlignment Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Scale Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Scale Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Select Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Select Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


SetBounds Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..SetBounds Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Show Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Show Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


ShowDialog Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..ShowDialog Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


UpdateBounds Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..UpdateBounds Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


Validate Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..Validate Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


ValidateChildren Method

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore..::..ValidateChildren Method
PropertyEditorFormCore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PropertyEditorFormCore Class
PropertyEditorFormCore Members


PropertyEditorFormCore Properties

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore Properties
PropertyEditorFormCore Class See Also Send Feedback

The PropertyEditorFormCore type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

PropertyEditorFormCore Class


PropertyEditorFormCore Events

[image] [image]

.NET Framework Class Library
PropertyEditorFormCore Events
PropertyEditorFormCore Class See Also Send Feedback

The PropertyEditorFormCore type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

PropertyEditorFormCore Class


Radar Class

[image]

.NET Framework Class Library
Radar Class
Members See Also Send Feedback

방사형 차트의 특성을 정의합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Radar
C#
[SerializableAttribute]
public class Radar
Visual C++
[SerializableAttribute]
public ref class Radar
JavaScript
Hippo.Radar = function();

Type.createClass(
    'Hippo.Radar');

Inheritance Hierarchy

System..::..Object
Hippo..::..Radar

See Also

Radar Members


Radar Members

[image] [image]

.NET Framework Class Library
Radar Members
Radar Class Constructors Methods Properties See Also Send Feedback

The Radar type exposes the following members.

Constructors

 | Name | Description
Public method | Radar | 방사형 차트 특성 클래스의 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | 원의 내부 배경색을 설정하고 가져옵니다.
Public property | FillBackground | 방사형 차트의 내부를 채울 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowItemNames | 각 항목 이름들을 보일 것인가 여부를 설정하고 가져옵니다.
Public property | ShapeType | 방사형 차트의 외곽 모양을 설정하고 가져옵니다.

See Also

Radar Class


Radar Constructor

[image]

.NET Framework Class Library
Radar Constructor
Radar Class See Also Send Feedback

방사형 차트 특성 클래스의 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Radar()
Visual C++
public:
Radar()
JavaScript
Hippo.Radar = function();

See Also

Radar Class


Radar Methods

[image] [image]

.NET Framework Class Library
Radar Methods
Radar Class See Also Send Feedback

The Radar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Radar Class


Radar Properties

[image] [image]

.NET Framework Class Library
Radar Properties
Radar Class See Also Send Feedback

The Radar type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | 원의 내부 배경색을 설정하고 가져옵니다.
Public property | FillBackground | 방사형 차트의 내부를 채울 것인가 여부를 설정하고 가져옵니다.
Public property | IsShowItemNames | 각 항목 이름들을 보일 것인가 여부를 설정하고 가져옵니다.
Public property | ShapeType | 방사형 차트의 외곽 모양을 설정하고 가져옵니다.

See Also

Radar Class


BackColor Property

[image]

.NET Framework Class Library
Radar..::..BackColor Property
Radar Class See Also Send Feedback

원의 내부 배경색을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

Radar Class


FillBackground Property

[image]

.NET Framework Class Library
Radar..::..FillBackground Property
Radar Class See Also Send Feedback

방사형 차트의 내부를 채울 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FillBackground As Boolean
    Get
    Set
C#
public bool FillBackground { get; set; }
Visual C++
public:
property bool FillBackground {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fillBackground();
function set_fillBackground(value);

See Also

Radar Class


IsShowItemNames Property

[image]

.NET Framework Class Library
Radar..::..IsShowItemNames Property
Radar Class See Also Send Feedback

각 항목 이름들을 보일 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowItemNames As Boolean
    Get
    Set
C#
public bool IsShowItemNames { get; set; }
Visual C++
public:
property bool IsShowItemNames {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowItemNames();
function set_isShowItemNames(value);

See Also

Radar Class


ShapeType Property

[image]

.NET Framework Class Library
Radar..::..ShapeType Property
Radar Class See Also Send Feedback

방사형 차트의 외곽 모양을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ShapeType As RadarShapeType
    Get
    Set
C#
public RadarShapeType ShapeType { get; set; }
Visual C++
public:
property RadarShapeType ShapeType {
    RadarShapeType get ();
    void set (RadarShapeType value);
}
JavaScript
function get_shapeType();
function set_shapeType(value);

See Also

Radar Class


RadarPointType Enumeration

[image]

.NET Framework Class Library
RadarPointType Enumeration
See Also Send Feedback

방사형 차트 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration RadarPointType
C#
public enum RadarPointType
Visual C++
public enum class RadarPointType
JavaScript
Hippo.RadarPointType = function();
Hippo.RadarPointType.createEnum('Hippo.RadarPointType', false);

Members

Member name | Description
Point |
Line |
Area |
Pie |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


RadarShapeType Enumeration

[image]

.NET Framework Class Library
RadarShapeType Enumeration
See Also Send Feedback

방사형 차트의 외곽 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration RadarShapeType
C#
public enum RadarShapeType
Visual C++
public enum class RadarShapeType
JavaScript
Hippo.RadarShapeType = function();
Hippo.RadarShapeType.createEnum('Hippo.RadarShapeType', false);

Members

Member name | Description
Circle |
Polygon1 |
Polygon2 |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ScaleBreakType Enumeration

[image]

.NET Framework Class Library
ScaleBreakType Enumeration
See Also Send Feedback

스케일 브레이크의 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ScaleBreakType
C#
public enum ScaleBreakType
Visual C++
public enum class ScaleBreakType
JavaScript
Hippo.ScaleBreakType = function();
Hippo.ScaleBreakType.createEnum('Hippo.ScaleBreakType', false);

Members

Member name | Description
Wave |
Line |
WaveLine |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Series Class

[image]

.NET Framework Class Library
Series Class
Members See Also Send Feedback

Series (시리즈)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Series _
    Implements ILegendEntry
C#
[SerializableAttribute]
public class Series : ILegendEntry
Visual C++
[SerializableAttribute]
public ref class Series : ILegendEntry
JavaScript
Hippo.Series = function();

Type.createClass(
    'Hippo.Series',
    null,
    Hippo.ILegendEntry);

Remarks

일련의 데이터 집합을 의미하는 클래스. 하나의 차트를 의미하는 것이 시리즈리스트라면 내부에 3개의 라인이 그려진다면 3개의 시리즈가 있다라고 표현합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Series

See Also

Series Members


Series Members

[image] [image]

.NET Framework Class Library
Series Members
Series Class Constructors Methods Properties Events See Also Send Feedback

The Series type exposes the following members.

Constructors

 | Name | Description
Public method | Series | Series 생성자

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChartTransParentChanged | OnChartTransParentChanged 이벤트
Protected method | OnChartTypeChanged | OnChartTypeChanged 이벤트
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaType | 영역형 타입을 설정하고 가져온다.
Public property | ArrowLine | 화살표 라인을 설정하고 가져온다.
Public property | AxisIndex | 시리즈에서 사용할 축의 인덱스를 설정하고 가져온다. 기본값은 0입니다.
Public property | BoxPlotList | 박스플롯 아이템 리스트 설정 내용을 설정하고 가져옵니다.
Public property | BoxPlotsAttributes | 박스플롯 속성을 설정하고 가져옵니다.
Public property | ChartType | 차트 종류을 설정하고 가져온다.
Public property | Column | 컬럼 속성을 설정하고 가져온다.
Public property | ColumnRangeType | 컬럼류 차트의 막대가 그려지는 범위를 지정하는 타입을 설정하고 가져옵니다.
Public property | Description | 시리즈의 설명을 설정하고 가져옵니다.
Public property | ErrorBarPoint | 에러바 차트에서 가운데 포인트를 설정하고 가져옵니다.
Public property | ErrorBarType | 에러바 타입을 설정하고 가져옵니다.
Public property | ErrorLine | 에러바 차트에서의 라인객체를 설정하고 가져옵니다.
Public property | ErrorOffset | 에러바 차트에서 표준오차 범위를 설정하고 가져옵니다.
Public property | ErrorPercentage | 에러바 타입이 백분율일 경우 적용되는 오차 범위의 퍼센트 값을 설정하고 가져옵니다. (기본값 5)
Public property | FigureStringFormatFlags | 수치 글자의 그려지는 가로, 세로 형태를 설정하고 가져온다.
Public property | FigureTextLocation | 수치 표시
Public property | ForeColor | 시리즈 글자색(범례)을 설정하고 가져온다.
Public property | Gauge | 게이지 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.
Public property | HasNanData | 데이터가 Nan 인것을 가지고 있는지 여부를 설정하고 가져옵니다.
Public property | IsLineShadowEffect | 라인의 그림자 효과를 줄것인지 여부를 설정하고 가져온다.
Public property | IsShowAllFigureText | 시리즈 전체 데이터수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | items | 시리즈 내의 요소들을 설정하고 가져온다.
Public property | Kagi | 카기 타입을 설정하고 가져온다.
Public property | Label | 시리즈 라벨을 설정하고 가져온다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 라인 속성을 설정하고 가져온다.
Public property | LineNullColor | 라인차트류의 데이터가 널인 부분에 표시할 색상을 설정하고 가져온다.
Public property | LineNullType | 라인류 차트의 데이터가 널일 경우 표시할 라인 형태를 설정하고 가져온다.
Public property | Name | 시리즈 이름(범례)을 설정하고 가져온다.
Public property | Points | 포인트을 설정하고 가져온다.
Public property | RadarType | 방사형 차트의 타입을 설정하고 가져옵니다.
Public property | SeriesColor | 시리즈 생상을 설정하고 가져온다.
Public property | SeriesDojiCandleColor | 주식 차트의 도지(Doji)형의 색상을 설정하고 가져온다.
Public property | SeriesMinusCandleColor | 주식차트의 음봉 색상을 설정하고 가져온다.
Public property | SeriesPlusCandleColor | 주식차트의 양봉 색상을 설정하고 가져온다.
Public property | Transparency | 투명도(기본값 255)를 설정하고 가져온다.
Public property | UnAxisFactor | 비좌표 차트 요소를 설정하고 가져온다.
Public property | Visible | 시리즈의 보임 여부를 설정하고 가져온다.

Events

 | Name | Description
Public event | ChartTransParentChanged | 차트 투명도가 변경될때 발생합니다.
Public event | ChartTypeChanged | 차트 종류가 변경될때 발생합니다.

See Also

Series Class


Series Constructor

[image]

.NET Framework Class Library
Series Constructor
Series Class See Also Send Feedback

Series 생성자

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Series()
Visual C++
public:
Series()
JavaScript
Hippo.Series = function();

See Also

Series Class


Series Methods

[image] [image]

.NET Framework Class Library
Series Methods
Series Class See Also Send Feedback

The Series type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChartTransParentChanged | OnChartTransParentChanged 이벤트
Protected method | OnChartTypeChanged | OnChartTypeChanged 이벤트
Public method | ToString | (Inherited from Object.)

See Also

Series Class


OnChartTransParentChanged Method

[image]

.NET Framework Class Library
Series..::..OnChartTransParentChanged Method
Series Class See Also Send Feedback

OnChartTransParentChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartTransParentChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartTransParentChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartTransParentChanged(
    EventArgs^ e
)
JavaScript
function onChartTransParentChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

Series Class


OnChartTypeChanged Method

[image]

.NET Framework Class Library
Series..::..OnChartTypeChanged Method
Series Class See Also Send Feedback

OnChartTypeChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartTypeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartTypeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartTypeChanged(
    EventArgs^ e
)
JavaScript
function onChartTypeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

Series Class


Series Properties

[image] [image]

.NET Framework Class Library
Series Properties
Series Class See Also Send Feedback

The Series type exposes the following members.

Properties

 | Name | Description
Public property | AreaType | 영역형 타입을 설정하고 가져온다.
Public property | ArrowLine | 화살표 라인을 설정하고 가져온다.
Public property | AxisIndex | 시리즈에서 사용할 축의 인덱스를 설정하고 가져온다. 기본값은 0입니다.
Public property | BoxPlotList | 박스플롯 아이템 리스트 설정 내용을 설정하고 가져옵니다.
Public property | BoxPlotsAttributes | 박스플롯 속성을 설정하고 가져옵니다.
Public property | ChartType | 차트 종류을 설정하고 가져온다.
Public property | Column | 컬럼 속성을 설정하고 가져온다.
Public property | ColumnRangeType | 컬럼류 차트의 막대가 그려지는 범위를 지정하는 타입을 설정하고 가져옵니다.
Public property | Description | 시리즈의 설명을 설정하고 가져옵니다.
Public property | ErrorBarPoint | 에러바 차트에서 가운데 포인트를 설정하고 가져옵니다.
Public property | ErrorBarType | 에러바 타입을 설정하고 가져옵니다.
Public property | ErrorLine | 에러바 차트에서의 라인객체를 설정하고 가져옵니다.
Public property | ErrorOffset | 에러바 차트에서 표준오차 범위를 설정하고 가져옵니다.
Public property | ErrorPercentage | 에러바 타입이 백분율일 경우 적용되는 오차 범위의 퍼센트 값을 설정하고 가져옵니다. (기본값 5)
Public property | FigureStringFormatFlags | 수치 글자의 그려지는 가로, 세로 형태를 설정하고 가져온다.
Public property | FigureTextLocation | 수치 표시
Public property | ForeColor | 시리즈 글자색(범례)을 설정하고 가져온다.
Public property | Gauge | 게이지 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.
Public property | HasNanData | 데이터가 Nan 인것을 가지고 있는지 여부를 설정하고 가져옵니다.
Public property | IsLineShadowEffect | 라인의 그림자 효과를 줄것인지 여부를 설정하고 가져온다.
Public property | IsShowAllFigureText | 시리즈 전체 데이터수치를 보일 것인지 여부를 설정하고 가져옵니다.
Public property | items | 시리즈 내의 요소들을 설정하고 가져온다.
Public property | Kagi | 카기 타입을 설정하고 가져온다.
Public property | Label | 시리즈 라벨을 설정하고 가져온다.
Public property | LegendVisible | 범례에 보여줄 것인지 여부를 가져오고 설정합니다.
Public property | Line | 라인 속성을 설정하고 가져온다.
Public property | LineNullColor | 라인차트류의 데이터가 널인 부분에 표시할 색상을 설정하고 가져온다.
Public property | LineNullType | 라인류 차트의 데이터가 널일 경우 표시할 라인 형태를 설정하고 가져온다.
Public property | Name | 시리즈 이름(범례)을 설정하고 가져온다.
Public property | Points | 포인트을 설정하고 가져온다.
Public property | RadarType | 방사형 차트의 타입을 설정하고 가져옵니다.
Public property | SeriesColor | 시리즈 생상을 설정하고 가져온다.
Public property | SeriesDojiCandleColor | 주식 차트의 도지(Doji)형의 색상을 설정하고 가져온다.
Public property | SeriesMinusCandleColor | 주식차트의 음봉 색상을 설정하고 가져온다.
Public property | SeriesPlusCandleColor | 주식차트의 양봉 색상을 설정하고 가져온다.
Public property | Transparency | 투명도(기본값 255)를 설정하고 가져온다.
Public property | UnAxisFactor | 비좌표 차트 요소를 설정하고 가져온다.
Public property | Visible | 시리즈의 보임 여부를 설정하고 가져온다.

See Also

Series Class


AreaType Property

[image]

.NET Framework Class Library
Series..::..AreaType Property
Series Class See Also Send Feedback

영역형 타입을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property AreaType As AreaType
    Get
    Set
C#
[BindableAttribute(true)]
public AreaType AreaType { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property AreaType AreaType {
    AreaType get ();
    void set (AreaType value);
}
JavaScript
function get_areaType();
function set_areaType(value);

See Also

Series Class


ArrowLine Property

[image]

.NET Framework Class Library
Series..::..ArrowLine Property
Series Class See Also Send Feedback

화살표 라인을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property ArrowLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line ArrowLine { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ ArrowLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_arrowLine();
function set_arrowLine(value);

See Also

Series Class


AxisIndex Property

[image]

.NET Framework Class Library
Series..::..AxisIndex Property
Series Class See Also Send Feedback

시리즈에서 사용할 축의 인덱스를 설정하고 가져온다. 기본값은 0입니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property AxisIndex As Integer
    Get
    Set
C#
public int AxisIndex { get; set; }
Visual C++
public:
property int AxisIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_axisIndex();
function set_axisIndex(value);

See Also

Series Class


BoxPlotList Property

[image]

.NET Framework Class Library
Series..::..BoxPlotList Property
Series Class See Also Send Feedback

박스플롯 아이템 리스트 설정 내용을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property BoxPlotList As BoxPlotList
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public BoxPlotList BoxPlotList { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property BoxPlotList^ BoxPlotList {
    BoxPlotList^ get ();
    void set (BoxPlotList^ value);
}
JavaScript
function get_boxPlotList();
function set_boxPlotList(value);

See Also

Series Class


BoxPlotsAttributes Property

[image]

.NET Framework Class Library
Series..::..BoxPlotsAttributes Property
Series Class See Also Send Feedback

박스플롯 속성을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property BoxPlotsAttributes As BoxPlotsAttributes
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public BoxPlotsAttributes BoxPlotsAttributes { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property BoxPlotsAttributes^ BoxPlotsAttributes {
    BoxPlotsAttributes^ get ();
    void set (BoxPlotsAttributes^ value);
}
JavaScript
function get_boxPlotsAttributes();
function set_boxPlotsAttributes(value);

See Also

Series Class


ChartType Property

[image]

.NET Framework Class Library
Series..::..ChartType Property
Series Class See Also Send Feedback

차트 종류을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartType As ChartType
    Get
    Set
C#
public ChartType ChartType { get; set; }
Visual C++
public:
property ChartType ChartType {
    ChartType get ();
    void set (ChartType value);
}
JavaScript
function get_chartType();
function set_chartType(value);

See Also

Series Class


Column Property

[image]

.NET Framework Class Library
Series..::..Column Property
Series Class See Also Send Feedback

컬럼 속성을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Column As Column
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Column Column { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Column^ Column {
    Column^ get ();
    void set (Column^ value);
}
JavaScript
function get_column();
function set_column(value);

See Also

Series Class


ColumnRangeType Property

[image]

.NET Framework Class Library
Series..::..ColumnRangeType Property
Series Class See Also Send Feedback

컬럼류 차트의 막대가 그려지는 범위를 지정하는 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColumnRangeType As ColumnRangeType
    Get
    Set
C#
public ColumnRangeType ColumnRangeType { get; set; }
Visual C++
public:
property ColumnRangeType ColumnRangeType {
    ColumnRangeType get ();
    void set (ColumnRangeType value);
}
JavaScript
function get_columnRangeType();
function set_columnRangeType(value);

See Also

Series Class


Description Property

[image]

.NET Framework Class Library
Series..::..Description Property
Series Class See Also Send Feedback

시리즈의 설명을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Description As String
    Get
    Set
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Series Class


ErrorBarPoint Property

[image]

.NET Framework Class Library
Series..::..ErrorBarPoint Property
Series Class See Also Send Feedback

에러바 차트에서 가운데 포인트를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property ErrorBarPoint As Points
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Points ErrorBarPoint { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Points^ ErrorBarPoint {
    Points^ get ();
    void set (Points^ value);
}
JavaScript
function get_errorBarPoint();
function set_errorBarPoint(value);

See Also

Series Class


ErrorBarType Property

[image]

.NET Framework Class Library
Series..::..ErrorBarType Property
Series Class See Also Send Feedback

에러바 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ErrorBarType As ErrorBarType
    Get
    Set
C#
public ErrorBarType ErrorBarType { get; set; }
Visual C++
public:
property ErrorBarType ErrorBarType {
    ErrorBarType get ();
    void set (ErrorBarType value);
}
JavaScript
function get_errorBarType();
function set_errorBarType(value);

See Also

Series Class


ErrorLine Property

[image]

.NET Framework Class Library
Series..::..ErrorLine Property
Series Class See Also Send Feedback

에러바 차트에서의 라인객체를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property ErrorLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line ErrorLine { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ ErrorLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_errorLine();
function set_errorLine(value);

See Also

Series Class


ErrorOffset Property

[image]

.NET Framework Class Library
Series..::..ErrorOffset Property
Series Class See Also Send Feedback

에러바 차트에서 표준오차 범위를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ErrorOffset As Single
    Get
    Set
C#
public float ErrorOffset { get; set; }
Visual C++
public:
property float ErrorOffset {
    float get ();
    void set (float value);
}
JavaScript
function get_errorOffset();
function set_errorOffset(value);

See Also

Series Class


ErrorPercentage Property

[image]

.NET Framework Class Library
Series..::..ErrorPercentage Property
Series Class See Also Send Feedback

에러바 타입이 백분율일 경우 적용되는 오차 범위의 퍼센트 값을 설정하고 가져옵니다. (기본값 5)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ErrorPercentage As Double
    Get
    Set
C#
public double ErrorPercentage { get; set; }
Visual C++
public:
property double ErrorPercentage {
    double get ();
    void set (double value);
}
JavaScript
function get_errorPercentage();
function set_errorPercentage(value);

See Also

Series Class


FigureStringFormatFlags Property

[image]

.NET Framework Class Library
Series..::..FigureStringFormatFlags Property
Series Class See Also Send Feedback

수치 글자의 그려지는 가로, 세로 형태를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigureStringFormatFlags As StringFormatFlags
    Get
    Set
C#
public StringFormatFlags FigureStringFormatFlags { get; set; }
Visual C++
public:
property StringFormatFlags FigureStringFormatFlags {
    StringFormatFlags get ();
    void set (StringFormatFlags value);
}
JavaScript
function get_figureStringFormatFlags();
function set_figureStringFormatFlags(value);

See Also

Series Class


FigureTextLocation Property

[image]

.NET Framework Class Library
Series..::..FigureTextLocation Property
Series Class See Also Send Feedback

수치 표시

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigureTextLocation As FigureTextLocation
    Get
    Set
C#
public FigureTextLocation FigureTextLocation { get; set; }
Visual C++
public:
property FigureTextLocation FigureTextLocation {
    FigureTextLocation get ();
    void set (FigureTextLocation value);
}
JavaScript
function get_figureTextLocation();
function set_figureTextLocation(value);

See Also

Series Class


ForeColor Property

[image]

.NET Framework Class Library
Series..::..ForeColor Property
Series Class See Also Send Feedback

시리즈 글자색(범례)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ForeColor As Color
    Get
    Set
C#
public Color ForeColor { get; set; }
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_foreColor();
function set_foreColor(value);

See Also

Series Class


Gauge Property

[image]

.NET Framework Class Library
Series..::..Gauge Property
Series Class See Also Send Feedback

게이지 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Gauge As Gauge
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Gauge Gauge { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Gauge^ Gauge {
    Gauge^ get ();
    void set (Gauge^ value);
}
JavaScript
function get_gauge();
function set_gauge(value);

See Also

Series Class


HasNanData Property

[image]

.NET Framework Class Library
Series..::..HasNanData Property
Series Class See Also Send Feedback

데이터가 Nan 인것을 가지고 있는지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property HasNanData As Boolean
    Get
    Set
C#
public bool HasNanData { get; set; }
Visual C++
public:
property bool HasNanData {
    bool get ();
    void set (bool value);
}
JavaScript
function get_hasNanData();
function set_hasNanData(value);

See Also

Series Class


IsLineShadowEffect Property

[image]

.NET Framework Class Library
Series..::..IsLineShadowEffect Property
Series Class See Also Send Feedback

라인의 그림자 효과를 줄것인지 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property IsLineShadowEffect As Boolean
    Get
    Set
C#
[BindableAttribute(true)]
public bool IsLineShadowEffect { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property bool IsLineShadowEffect {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isLineShadowEffect();
function set_isLineShadowEffect(value);

See Also

Series Class


IsShowAllFigureText Property

[image]

.NET Framework Class Library
Series..::..IsShowAllFigureText Property
Series Class See Also Send Feedback

시리즈 전체 데이터수치를 보일 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowAllFigureText As Boolean
    Get
    Set
C#
public bool IsShowAllFigureText { get; set; }
Visual C++
public:
property bool IsShowAllFigureText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowAllFigureText();
function set_isShowAllFigureText(value);

See Also

Series Class


items Property

[image]

.NET Framework Class Library
Series..::..items Property
Series Class See Also Send Feedback

시리즈 내의 요소들을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property items As SeriesItemCollection
    Get
    Set
C#
[BindableAttribute(true)]
public SeriesItemCollection items { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property SeriesItemCollection^ items {
    SeriesItemCollection^ get ();
    void set (SeriesItemCollection^ value);
}
JavaScript
function get_items();
function set_items(value);

See Also

Series Class


Kagi Property

[image]

.NET Framework Class Library
Series..::..Kagi Property
Series Class See Also Send Feedback

카기 타입을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Kagi As Kagi
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Kagi Kagi { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Kagi^ Kagi {
    Kagi^ get ();
    void set (Kagi^ value);
}
JavaScript
function get_kagi();
function set_kagi(value);

See Also

Series Class


Label Property

[image]

.NET Framework Class Library
Series..::..Label Property
Series Class See Also Send Feedback

시리즈 라벨을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Series Class


LegendVisible Property

[image]

.NET Framework Class Library
Series..::..LegendVisible Property
Series Class See Also Send Feedback

범례에 보여줄 것인지 여부를 가져오고 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendVisible As Boolean
    Get
    Set
C#
public bool LegendVisible { get; set; }
Visual C++
public:
virtual property bool LegendVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_legendVisible();
function set_legendVisible(value);

Implements

ILegendEntry..::..LegendVisible

See Also

Series Class


Line Property

[image]

.NET Framework Class Library
Series..::..Line Property
Series Class See Also Send Feedback

라인 속성을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Line As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line Line { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_line();
function set_line(value);

See Also

Series Class


LineNullColor Property

[image]

.NET Framework Class Library
Series..::..LineNullColor Property
Series Class See Also Send Feedback

라인차트류의 데이터가 널인 부분에 표시할 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LineNullColor As Color
    Get
    Set
C#
public Color LineNullColor { get; set; }
Visual C++
public:
property Color LineNullColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_lineNullColor();
function set_lineNullColor(value);

See Also

Series Class


LineNullType Property

[image]

.NET Framework Class Library
Series..::..LineNullType Property
Series Class See Also Send Feedback

라인류 차트의 데이터가 널일 경우 표시할 라인 형태를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property LineNullType As LineNullType
    Get
    Set
C#
[BindableAttribute(true)]
public LineNullType LineNullType { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property LineNullType LineNullType {
    LineNullType get ();
    void set (LineNullType value);
}
JavaScript
function get_lineNullType();
function set_lineNullType(value);

See Also

Series Class


Name Property

[image]

.NET Framework Class Library
Series..::..Name Property
Series Class See Also Send Feedback

시리즈 이름(범례)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Series Class


Points Property

[image]

.NET Framework Class Library
Series..::..Points Property
Series Class See Also Send Feedback

포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Points As Points
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Points Points { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Points^ Points {
    Points^ get ();
    void set (Points^ value);
}
JavaScript
function get_points();
function set_points(value);

See Also

Series Class


RadarType Property

[image]

.NET Framework Class Library
Series..::..RadarType Property
Series Class See Also Send Feedback

방사형 차트의 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property RadarType As RadarPointType
    Get
    Set
C#
public RadarPointType RadarType { get; set; }
Visual C++
public:
property RadarPointType RadarType {
    RadarPointType get ();
    void set (RadarPointType value);
}
JavaScript
function get_radarType();
function set_radarType(value);

See Also

Series Class


SeriesColor Property

[image]

.NET Framework Class Library
Series..::..SeriesColor Property
Series Class See Also Send Feedback

시리즈 생상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesColor As Color
    Get
    Set
C#
public Color SeriesColor { get; set; }
Visual C++
public:
property Color SeriesColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_seriesColor();
function set_seriesColor(value);

See Also

Series Class


SeriesDojiCandleColor Property

[image]

.NET Framework Class Library
Series..::..SeriesDojiCandleColor Property
Series Class See Also Send Feedback

주식 차트의 도지(Doji)형의 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesDojiCandleColor As Color
    Get
    Set
C#
public Color SeriesDojiCandleColor { get; set; }
Visual C++
public:
property Color SeriesDojiCandleColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_seriesDojiCandleColor();
function set_seriesDojiCandleColor(value);

See Also

Series Class


SeriesMinusCandleColor Property

[image]

.NET Framework Class Library
Series..::..SeriesMinusCandleColor Property
Series Class See Also Send Feedback

주식차트의 음봉 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesMinusCandleColor As Color
    Get
    Set
C#
public Color SeriesMinusCandleColor { get; set; }
Visual C++
public:
property Color SeriesMinusCandleColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_seriesMinusCandleColor();
function set_seriesMinusCandleColor(value);

See Also

Series Class


SeriesPlusCandleColor Property

[image]

.NET Framework Class Library
Series..::..SeriesPlusCandleColor Property
Series Class See Also Send Feedback

주식차트의 양봉 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesPlusCandleColor As Color
    Get
    Set
C#
public Color SeriesPlusCandleColor { get; set; }
Visual C++
public:
property Color SeriesPlusCandleColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_seriesPlusCandleColor();
function set_seriesPlusCandleColor(value);

See Also

Series Class


Transparency Property

[image]

.NET Framework Class Library
Series..::..Transparency Property
Series Class See Also Send Feedback

투명도(기본값 255)를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Transparency As Integer
    Get
    Set
C#
public int Transparency { get; set; }
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}
JavaScript
function get_transparency();
function set_transparency(value);

See Also

Series Class


UnAxisFactor Property

[image]

.NET Framework Class Library
Series..::..UnAxisFactor Property
Series Class See Also Send Feedback

비좌표 차트 요소를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property UnAxisFactor As UnAxisFactors
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public UnAxisFactors UnAxisFactor { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property UnAxisFactors^ UnAxisFactor {
    UnAxisFactors^ get ();
    void set (UnAxisFactors^ value);
}
JavaScript
function get_unAxisFactor();
function set_unAxisFactor(value);

See Also

Series Class


Visible Property

[image]

.NET Framework Class Library
Series..::..Visible Property
Series Class See Also Send Feedback

시리즈의 보임 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

Series Class


Series Events

[image] [image]

.NET Framework Class Library
Series Events
Series Class See Also Send Feedback

The Series type exposes the following members.

Events

 | Name | Description
Public event | ChartTransParentChanged | 차트 투명도가 변경될때 발생합니다.
Public event | ChartTypeChanged | 차트 종류가 변경될때 발생합니다.

See Also

Series Class


ChartTransParentChanged Event

[image]

.NET Framework Class Library
Series..::..ChartTransParentChanged Event
Series Class See Also Send Feedback

차트 투명도가 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartTransParentChanged As EventHandler
C#
public event EventHandler ChartTransParentChanged
Visual C++
public:
 event EventHandler^ ChartTransParentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartTransParentChanged(value);
function remove_chartTransParentChanged(value);

See Also

Series Class


ChartTypeChanged Event

[image]

.NET Framework Class Library
Series..::..ChartTypeChanged Event
Series Class See Also Send Feedback

차트 종류가 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartTypeChanged As EventHandler
C#
public event EventHandler ChartTypeChanged
Visual C++
public:
 event EventHandler^ ChartTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartTypeChanged(value);
function remove_chartTypeChanged(value);

See Also

Series Class


SeriesCollection Class

[image]

.NET Framework Class Library
SeriesCollection Class
Members See Also Send Feedback

SeriesCollection

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class SeriesCollection _
    Inherits HippoCollectionBase(Of Series)
C#
[SerializableAttribute]
public class SeriesCollection : HippoCollectionBase<Series>
Visual C++
[SerializableAttribute]
public ref class SeriesCollection : public HippoCollectionBase<Series^>
JavaScript
Hippo.SeriesCollection = function();

Type.createClass(
    'Hippo.SeriesCollection',
    Hippo.HippoCollectionBase`1);

Remarks

시리즈들을 담고 있는 컬렉션으로 시리즈리스트가 소유합니다.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Series >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Series >)>)>
Hippo..::..SeriesCollection

See Also

SeriesCollection Members


SeriesCollection Members

[image] [image]

.NET Framework Class Library
SeriesCollection Members
SeriesCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SeriesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Series >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Series >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Series >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Series >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Series >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class


SeriesCollection Constructor

[image]

.NET Framework Class Library
SeriesCollection Constructor
SeriesCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public SeriesCollection()
Visual C++
public:
SeriesCollection()
JavaScript
Hippo.SeriesCollection = function();

See Also

SeriesCollection Class


SeriesCollection Methods

[image] [image]

.NET Framework Class Library
SeriesCollection Methods
SeriesCollection Class See Also Send Feedback

The SeriesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Series >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Series >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..BinarySearch Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..CopyTo Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..FindIndex Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..FindLastIndex Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..IndexOf Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..LastIndexOf Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..Reverse Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
SeriesCollection..::..Sort Method
SeriesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class
SeriesCollection Members


SeriesCollection Properties

[image] [image]

.NET Framework Class Library
SeriesCollection Properties
SeriesCollection Class See Also Send Feedback

The SeriesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Series >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Series >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Series >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Series >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Series >)>)>.)

See Also

SeriesCollection Class


SeriesCollectionEditor Class

[image]

.NET Framework Class Library
SeriesCollectionEditor Class
Members See Also Send Feedback

SeriesCollectionEditor

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class SeriesCollectionEditor _
    Inherits CollectionEditor
C#
public class SeriesCollectionEditor : CollectionEditor
Visual C++
public ref class SeriesCollectionEditor : public CollectionEditor
JavaScript
Hippo.SeriesCollectionEditor = function();

Type.createClass(
    'Hippo.SeriesCollectionEditor',
    CollectionEditor);

Inheritance Hierarchy

System..::..Object
System.Drawing.Design..::..UITypeEditor
System.ComponentModel.Design..::..CollectionEditor
Hippo..::..SeriesCollectionEditor

See Also

SeriesCollectionEditor Members


SeriesCollectionEditor Members

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor Members
SeriesCollectionEditor Class Constructors Methods Properties See Also Send Feedback

The SeriesCollectionEditor type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesCollectionEditor | SeriesCollectionEditor

Methods

 | Name | Description
Protected method | CancelChanges | (Inherited from CollectionEditor.)
Protected method | CanRemoveInstance | (Inherited from CollectionEditor.)
Protected method | CanSelectMultipleInstances | (Inherited from CollectionEditor.)
Protected method | CreateCollectionForm | (Inherited from CollectionEditor.)
Protected method | CreateCollectionItemType | CreateCollectionItemType (Overrides CollectionEditor..::..CreateCollectionItemType()()()().)
Protected method | CreateInstance | (Inherited from CollectionEditor.)
Protected method | CreateNewItemTypes | CreateNewItemTypes (Overrides CollectionEditor..::..CreateNewItemTypes()()()().)
Protected method | DestroyInstance | (Inherited from CollectionEditor.)
Public method | EditValue(IServiceProvider, Object) | (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Inherited from CollectionEditor.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetDisplayText | (Inherited from CollectionEditor.)
Public method | GetEditStyle()()()() | (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Inherited from CollectionEditor.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetItems | (Inherited from CollectionEditor.)
Protected method | GetObjectsFromInstance | (Inherited from CollectionEditor.)
Public method | GetPaintValueSupported()()()() | (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | (Inherited from UITypeEditor.)
Protected method | GetService | (Inherited from CollectionEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | (Inherited from UITypeEditor.)
Protected method | SetItems | (Inherited from CollectionEditor.)
Protected method | ShowHelp | (Inherited from CollectionEditor.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Protected property | CollectionItemType | (Inherited from CollectionEditor.)
Protected property | CollectionType | (Inherited from CollectionEditor.)
Protected property | Context | (Inherited from CollectionEditor.)
Protected property | HelpTopic | (Inherited from CollectionEditor.)
Public property | IsDropDownResizable | (Inherited from UITypeEditor.)
Protected property | NewItemTypes | (Inherited from CollectionEditor.)

See Also

SeriesCollectionEditor Class


SeriesCollectionEditor Constructor

[image]

.NET Framework Class Library
SeriesCollectionEditor Constructor
SeriesCollectionEditor Class See Also Send Feedback

SeriesCollectionEditor

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    type As Type _
)
C#
public SeriesCollectionEditor(
    Type type
)
Visual C++
public:
SeriesCollectionEditor(
    Type^ type
)
JavaScript
Hippo.SeriesCollectionEditor = function(type);

Parameters

type
Type: System..::..Type

See Also

SeriesCollectionEditor Class


SeriesCollectionEditor Methods

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor Methods
SeriesCollectionEditor Class See Also Send Feedback

The SeriesCollectionEditor type exposes the following members.

Methods

 | Name | Description
Protected method | CancelChanges | (Inherited from CollectionEditor.)
Protected method | CanRemoveInstance | (Inherited from CollectionEditor.)
Protected method | CanSelectMultipleInstances | (Inherited from CollectionEditor.)
Protected method | CreateCollectionForm | (Inherited from CollectionEditor.)
Protected method | CreateCollectionItemType | CreateCollectionItemType (Overrides CollectionEditor..::..CreateCollectionItemType()()()().)
Protected method | CreateInstance | (Inherited from CollectionEditor.)
Protected method | CreateNewItemTypes | CreateNewItemTypes (Overrides CollectionEditor..::..CreateNewItemTypes()()()().)
Protected method | DestroyInstance | (Inherited from CollectionEditor.)
Public method | EditValue(IServiceProvider, Object) | (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Inherited from CollectionEditor.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetDisplayText | (Inherited from CollectionEditor.)
Public method | GetEditStyle()()()() | (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Inherited from CollectionEditor.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetItems | (Inherited from CollectionEditor.)
Protected method | GetObjectsFromInstance | (Inherited from CollectionEditor.)
Public method | GetPaintValueSupported()()()() | (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | (Inherited from UITypeEditor.)
Protected method | GetService | (Inherited from CollectionEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | (Inherited from UITypeEditor.)
Protected method | SetItems | (Inherited from CollectionEditor.)
Protected method | ShowHelp | (Inherited from CollectionEditor.)
Public method | ToString | (Inherited from Object.)

See Also

SeriesCollectionEditor Class


CreateCollectionItemType Method

[image]

.NET Framework Class Library
SeriesCollectionEditor..::..CreateCollectionItemType Method
SeriesCollectionEditor Class See Also Send Feedback

CreateCollectionItemType

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Function CreateCollectionItemType As Type
C#
protected override Type CreateCollectionItemType()
Visual C++
protected:
virtual Type^ CreateCollectionItemType() override
JavaScript
function createCollectionItemType();

Return Value

See Also

SeriesCollectionEditor Class


CreateNewItemTypes Method

[image]

.NET Framework Class Library
SeriesCollectionEditor..::..CreateNewItemTypes Method
SeriesCollectionEditor Class See Also Send Feedback

CreateNewItemTypes

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Function CreateNewItemTypes As Type()
C#
protected override Type[] CreateNewItemTypes()
Visual C++
protected:
virtual array<Type^>^ CreateNewItemTypes() override
JavaScript
function createNewItemTypes();

Return Value

See Also

SeriesCollectionEditor Class


EditValue Method

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor..::..EditValue Method
SeriesCollectionEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditValue(IServiceProvider, Object) | (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Inherited from CollectionEditor.)

See Also

SeriesCollectionEditor Class
SeriesCollectionEditor Members


GetEditStyle Method

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor..::..GetEditStyle Method
SeriesCollectionEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEditStyle()()()() | (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Inherited from CollectionEditor.)

See Also

SeriesCollectionEditor Class
SeriesCollectionEditor Members


GetPaintValueSupported Method

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor..::..GetPaintValueSupported Method
SeriesCollectionEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPaintValueSupported()()()() | (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | (Inherited from UITypeEditor.)

See Also

SeriesCollectionEditor Class
SeriesCollectionEditor Members


PaintValue Method

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor..::..PaintValue Method
SeriesCollectionEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PaintValue(PaintValueEventArgs) | (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | (Inherited from UITypeEditor.)

See Also

SeriesCollectionEditor Class
SeriesCollectionEditor Members


SeriesCollectionEditor Properties

[image] [image]

.NET Framework Class Library
SeriesCollectionEditor Properties
SeriesCollectionEditor Class See Also Send Feedback

The SeriesCollectionEditor type exposes the following members.

Properties

 | Name | Description
Protected property | CollectionItemType | (Inherited from CollectionEditor.)
Protected property | CollectionType | (Inherited from CollectionEditor.)
Protected property | Context | (Inherited from CollectionEditor.)
Protected property | HelpTopic | (Inherited from CollectionEditor.)
Public property | IsDropDownResizable | (Inherited from UITypeEditor.)
Protected property | NewItemTypes | (Inherited from CollectionEditor.)

See Also

SeriesCollectionEditor Class


SeriesItem Class

[image]

.NET Framework Class Library
SeriesItem Class
Members See Also Send Feedback

SeriesItem

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class SeriesItem
C#
[SerializableAttribute]
public class SeriesItem
Visual C++
[SerializableAttribute]
public ref class SeriesItem
JavaScript
Hippo.SeriesItem = function();

Type.createClass(
    'Hippo.SeriesItem');

Remarks

한 개의 데이터를 의미합니다. 하나의 포인트일 수도 있고 하나의 막대일 수도 있으며 하나의 주식 캔들일 수도 있습니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..SeriesItem

See Also

SeriesItem Members


SeriesItem Members

[image] [image]

.NET Framework Class Library
SeriesItem Members
SeriesItem Class Constructors Methods Properties See Also Send Feedback

The SeriesItem type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesItem()()()() | SeriesItem
Public method | SeriesItem(Double) | SeriesItem

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrowLabel | 화살표 단계에 표시할 문자열을 설정하고 가져온다.
Public property | ArrowLine | 화살표 라인을 설정하고 가져온다.
Public property | Balloon | 풍선 도움말을 설정하고 가져온다.
Public property | ColumEndPoint | 막대의 끝(오른쪽 또는 아래) 포인트를 가져온다.
Public property | Column | 컬럼 속성을 설정하고 가져온다.
Public property | ColumStartPoint | 막대의 시작(왼쪽 또는 아래) 포인트를 가져온다.
Public property | Element | 조직도 구성원에 대한 내용을 설정하고 가져옵니다.
Public property | Enabled | 시리즈아이템의 Enabled(데이터분석 가용) 여부를 설정하고 가져옵니다.
Public property | FigurePoint | 각 수치의 실제 포인트 값을 설정하고 가져온다.
Public property | GanttName | 간트차트일 경우 각 항목별 추가 문자열을 삽입할 수 있습니다. 예) 각 일정별 참여하는 사람, 항목별 특이사항 등
Public property | GanttProcess | 간트차트의 세부 진행률을 설정하고 가져온다.
Public property | GroupName | 아이템 그룹 이름을 설정하고 가져옵니다
Public property | HighValue | 주식차트에 사용되는 속성으로 고가를 의미하는 값을 설정하고 가져온다.
Public property | Index | 시리즈아이템의 인덱스 번호를 가져온다.
Public property | IsDojiType | 주식 차트에서 항목이 시가와 종가같은 도지형인지 여부를 가져온다.
Public property | IsGroupBoss | 간트차트일 경우 일정의 그룹 부모인지 여부를 설정하고 가져옵니다.
Public property | IsMilestone | 간트차트일 경우 아이템이 마일스톤인지 여부를 설정하고 가져옵니다.
Public property | IsShowFigureText | 수치 텍스트를 보일것인지 여부를 설정하고 가져온다.
Public property | ItemColor | 아이템 색상을 설정하고 가져온다.
Public property | Label | 아이템 수치 라벨을 설정하고 가져온다.
Public property | Lengh | 파이 그래프의 가로 크기를 설정하고 가져온다. 설정 값이 클 수록 부채꼴은 작아집니다.
Public property | LowValue | 주식차트에 사용되는 속성으로 저가를 의미하는 값을 설정하고 가져온다.
Public property | Name | 아이템 이름을 설정하고 가져온다.
Public property | ParentIndex | 부모아이템의 인덱스 번호를 설정하고 가져온다. 간트차트일 경우 일정의 부모를 설정합니다.
Public property | Points | 포인트을 설정하고 가져온다.
Public property | Vector | 아이템의 벡터 특성을 설정하고 가져온다.
Public property | Visible | 시리즈아이템의 Visible 여부를 설정하고 가져옵니다.
Public property | XDateTimeValue | 아이템의 날짜형 x값을 설정하고 가져온다.
Public property | XValue | 아이템 값(x)을 설정하고 가져온다.
Public property | YDateTimeValue | 아이템의 날짜형 y값을 설정하고 가져온다.
Public property | YStartDateTimeValue | 아이템의 날짜형 y 시작 값을 설정하고 가져온다.
Public property | YStartValue | 아이템의 시작 값(y)을 설정하고 가져온다. (주식차트에서 시가를 의미합니다)
Public property | YValue | 아이템 값(y)을 설정하고 가져온다. (주식차트에서는 종가를 의미합니다)
Public property | YValueReplaceText | YValue 값을 대체하여 수치표시하는 텍스트 문구를 설정하고 가져옵니다.
Public property | ZValue | 아이템 값(Z)을 설정하고 가져온다.

See Also

SeriesItem Class


SeriesItem Constructor

[image] [image]

.NET Framework Class Library
SeriesItem Constructor
SeriesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SeriesItem()()()() | SeriesItem
Public method | SeriesItem(Double) | SeriesItem

See Also

SeriesItem Class
SeriesItem Members


SeriesItem Constructor

[image]

.NET Framework Class Library
SeriesItem Constructor
SeriesItem Class See Also Send Feedback

SeriesItem

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public SeriesItem()
Visual C++
public:
SeriesItem()
JavaScript
Hippo.SeriesItem = function();

See Also

SeriesItem Class
SeriesItem Overload


SeriesItem Constructor (Double)

[image]

.NET Framework Class Library
SeriesItem Constructor (Double)
SeriesItem Class See Also Send Feedback

SeriesItem

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    value As Double _
)
C#
public SeriesItem(
    double value
)
Visual C++
public:
SeriesItem(
    double value
)
JavaScript
Hippo.SeriesItem = function(value);

Parameters

value
Type: System..::..Double
아이템 값

See Also

SeriesItem Class
SeriesItem Overload


SeriesItem Methods

[image] [image]

.NET Framework Class Library
SeriesItem Methods
SeriesItem Class See Also Send Feedback

The SeriesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

SeriesItem Class


SeriesItem Properties

[image] [image]

.NET Framework Class Library
SeriesItem Properties
SeriesItem Class See Also Send Feedback

The SeriesItem type exposes the following members.

Properties

 | Name | Description
Public property | ArrowLabel | 화살표 단계에 표시할 문자열을 설정하고 가져온다.
Public property | ArrowLine | 화살표 라인을 설정하고 가져온다.
Public property | Balloon | 풍선 도움말을 설정하고 가져온다.
Public property | ColumEndPoint | 막대의 끝(오른쪽 또는 아래) 포인트를 가져온다.
Public property | Column | 컬럼 속성을 설정하고 가져온다.
Public property | ColumStartPoint | 막대의 시작(왼쪽 또는 아래) 포인트를 가져온다.
Public property | Element | 조직도 구성원에 대한 내용을 설정하고 가져옵니다.
Public property | Enabled | 시리즈아이템의 Enabled(데이터분석 가용) 여부를 설정하고 가져옵니다.
Public property | FigurePoint | 각 수치의 실제 포인트 값을 설정하고 가져온다.
Public property | GanttName | 간트차트일 경우 각 항목별 추가 문자열을 삽입할 수 있습니다. 예) 각 일정별 참여하는 사람, 항목별 특이사항 등
Public property | GanttProcess | 간트차트의 세부 진행률을 설정하고 가져온다.
Public property | GroupName | 아이템 그룹 이름을 설정하고 가져옵니다
Public property | HighValue | 주식차트에 사용되는 속성으로 고가를 의미하는 값을 설정하고 가져온다.
Public property | Index | 시리즈아이템의 인덱스 번호를 가져온다.
Public property | IsDojiType | 주식 차트에서 항목이 시가와 종가같은 도지형인지 여부를 가져온다.
Public property | IsGroupBoss | 간트차트일 경우 일정의 그룹 부모인지 여부를 설정하고 가져옵니다.
Public property | IsMilestone | 간트차트일 경우 아이템이 마일스톤인지 여부를 설정하고 가져옵니다.
Public property | IsShowFigureText | 수치 텍스트를 보일것인지 여부를 설정하고 가져온다.
Public property | ItemColor | 아이템 색상을 설정하고 가져온다.
Public property | Label | 아이템 수치 라벨을 설정하고 가져온다.
Public property | Lengh | 파이 그래프의 가로 크기를 설정하고 가져온다. 설정 값이 클 수록 부채꼴은 작아집니다.
Public property | LowValue | 주식차트에 사용되는 속성으로 저가를 의미하는 값을 설정하고 가져온다.
Public property | Name | 아이템 이름을 설정하고 가져온다.
Public property | ParentIndex | 부모아이템의 인덱스 번호를 설정하고 가져온다. 간트차트일 경우 일정의 부모를 설정합니다.
Public property | Points | 포인트을 설정하고 가져온다.
Public property | Vector | 아이템의 벡터 특성을 설정하고 가져온다.
Public property | Visible | 시리즈아이템의 Visible 여부를 설정하고 가져옵니다.
Public property | XDateTimeValue | 아이템의 날짜형 x값을 설정하고 가져온다.
Public property | XValue | 아이템 값(x)을 설정하고 가져온다.
Public property | YDateTimeValue | 아이템의 날짜형 y값을 설정하고 가져온다.
Public property | YStartDateTimeValue | 아이템의 날짜형 y 시작 값을 설정하고 가져온다.
Public property | YStartValue | 아이템의 시작 값(y)을 설정하고 가져온다. (주식차트에서 시가를 의미합니다)
Public property | YValue | 아이템 값(y)을 설정하고 가져온다. (주식차트에서는 종가를 의미합니다)
Public property | YValueReplaceText | YValue 값을 대체하여 수치표시하는 텍스트 문구를 설정하고 가져옵니다.
Public property | ZValue | 아이템 값(Z)을 설정하고 가져온다.

See Also

SeriesItem Class


ArrowLabel Property

[image]

.NET Framework Class Library
SeriesItem..::..ArrowLabel Property
SeriesItem Class See Also Send Feedback

화살표 단계에 표시할 문자열을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ArrowLabel As Label
    Get
    Set
C#
public Label ArrowLabel { get; set; }
Visual C++
public:
property Label^ ArrowLabel {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_arrowLabel();
function set_arrowLabel(value);

See Also

SeriesItem Class


ArrowLine Property

[image]

.NET Framework Class Library
SeriesItem..::..ArrowLine Property
SeriesItem Class See Also Send Feedback

화살표 라인을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property ArrowLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line ArrowLine { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ ArrowLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_arrowLine();
function set_arrowLine(value);

See Also

SeriesItem Class


Balloon Property

[image]

.NET Framework Class Library
SeriesItem..::..Balloon Property
SeriesItem Class See Also Send Feedback

풍선 도움말을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Balloon As Balloon
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Balloon Balloon { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Balloon^ Balloon {
    Balloon^ get ();
    void set (Balloon^ value);
}
JavaScript
function get_balloon();
function set_balloon(value);

See Also

SeriesItem Class


ColumEndPoint Property

[image]

.NET Framework Class Library
SeriesItem..::..ColumEndPoint Property
SeriesItem Class See Also Send Feedback

막대의 끝(오른쪽 또는 아래) 포인트를 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColumEndPoint As PointF
    Get
    Set
C#
public PointF ColumEndPoint { get; set; }
Visual C++
public:
property PointF ColumEndPoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_columEndPoint();
function set_columEndPoint(value);

See Also

SeriesItem Class


Column Property

[image]

.NET Framework Class Library
SeriesItem..::..Column Property
SeriesItem Class See Also Send Feedback

컬럼 속성을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Column As Column
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Column Column { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Column^ Column {
    Column^ get ();
    void set (Column^ value);
}
JavaScript
function get_column();
function set_column(value);

See Also

SeriesItem Class


ColumStartPoint Property

[image]

.NET Framework Class Library
SeriesItem..::..ColumStartPoint Property
SeriesItem Class See Also Send Feedback

막대의 시작(왼쪽 또는 아래) 포인트를 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ColumStartPoint As PointF
    Get
    Set
C#
public PointF ColumStartPoint { get; set; }
Visual C++
public:
property PointF ColumStartPoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_columStartPoint();
function set_columStartPoint(value);

See Also

SeriesItem Class


Element Property

[image]

.NET Framework Class Library
SeriesItem..::..Element Property
SeriesItem Class See Also Send Feedback

조직도 구성원에 대한 내용을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Element As OrganizationElement
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public OrganizationElement Element { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property OrganizationElement^ Element {
    OrganizationElement^ get ();
    void set (OrganizationElement^ value);
}
JavaScript
function get_element();
function set_element(value);

See Also

SeriesItem Class


Enabled Property

[image]

.NET Framework Class Library
SeriesItem..::..Enabled Property
SeriesItem Class See Also Send Feedback

시리즈아이템의 Enabled(데이터분석 가용) 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
    Get
    Set
C#
public bool Enabled { get; set; }
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enabled();
function set_enabled(value);

See Also

SeriesItem Class


FigurePoint Property

[image]

.NET Framework Class Library
SeriesItem..::..FigurePoint Property
SeriesItem Class See Also Send Feedback

각 수치의 실제 포인트 값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property FigurePoint As PointF
    Get
    Set
C#
public PointF FigurePoint { get; set; }
Visual C++
public:
property PointF FigurePoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_figurePoint();
function set_figurePoint(value);

Remarks

해당 속성은 차트내에서 해당 아이템이 위치하는 포인트를 알 수 있습니다.

See Also

SeriesItem Class


GanttName Property

[image]

.NET Framework Class Library
SeriesItem..::..GanttName Property
SeriesItem Class See Also Send Feedback

간트차트일 경우 각 항목별 추가 문자열을 삽입할 수 있습니다. 예) 각 일정별 참여하는 사람, 항목별 특이사항 등

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GanttName As Label
    Get
    Set
C#
public Label GanttName { get; set; }
Visual C++
public:
property Label^ GanttName {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_ganttName();
function set_ganttName(value);

See Also

SeriesItem Class


GanttProcess Property

[image]

.NET Framework Class Library
SeriesItem..::..GanttProcess Property
SeriesItem Class See Also Send Feedback

간트차트의 세부 진행률을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property GanttProcess As GanttProcess
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public GanttProcess GanttProcess { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property GanttProcess^ GanttProcess {
    GanttProcess^ get ();
    void set (GanttProcess^ value);
}
JavaScript
function get_ganttProcess();
function set_ganttProcess(value);

See Also

SeriesItem Class


GroupName Property

[image]

.NET Framework Class Library
SeriesItem..::..GroupName Property
SeriesItem Class See Also Send Feedback

아이템 그룹 이름을 설정하고 가져옵니다

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property GroupName As String
    Get
    Set
C#
public string GroupName { get; set; }
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupName();
function set_groupName(value);

See Also

SeriesItem Class


HighValue Property

[image]

.NET Framework Class Library
SeriesItem..::..HighValue Property
SeriesItem Class See Also Send Feedback

주식차트에 사용되는 속성으로 고가를 의미하는 값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property HighValue As Double
    Get
    Set
C#
public double HighValue { get; set; }
Visual C++
public:
property double HighValue {
    double get ();
    void set (double value);
}
JavaScript
function get_highValue();
function set_highValue(value);

See Also

SeriesItem Class


Index Property

[image]

.NET Framework Class Library
SeriesItem..::..Index Property
SeriesItem Class See Also Send Feedback

시리즈아이템의 인덱스 번호를 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Index As Integer
    Get
    Set
C#
public int Index { get; set; }
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}
JavaScript
function get_index();
function set_index(value);

See Also

SeriesItem Class


IsDojiType Property

[image]

.NET Framework Class Library
SeriesItem..::..IsDojiType Property
SeriesItem Class See Also Send Feedback

주식 차트에서 항목이 시가와 종가같은 도지형인지 여부를 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDojiType As Boolean
    Get
    Set
C#
public bool IsDojiType { get; set; }
Visual C++
public:
property bool IsDojiType {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDojiType();
function set_isDojiType(value);

See Also

SeriesItem Class


IsGroupBoss Property

[image]

.NET Framework Class Library
SeriesItem..::..IsGroupBoss Property
SeriesItem Class See Also Send Feedback

간트차트일 경우 일정의 그룹 부모인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsGroupBoss As Boolean
    Get
    Set
C#
public bool IsGroupBoss { get; set; }
Visual C++
public:
property bool IsGroupBoss {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGroupBoss();
function set_isGroupBoss(value);

See Also

SeriesItem Class


IsMilestone Property

[image]

.NET Framework Class Library
SeriesItem..::..IsMilestone Property
SeriesItem Class See Also Send Feedback

간트차트일 경우 아이템이 마일스톤인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsMilestone As Boolean
    Get
    Set
C#
public bool IsMilestone { get; set; }
Visual C++
public:
property bool IsMilestone {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isMilestone();
function set_isMilestone(value);

See Also

SeriesItem Class


IsShowFigureText Property

[image]

.NET Framework Class Library
SeriesItem..::..IsShowFigureText Property
SeriesItem Class See Also Send Feedback

수치 텍스트를 보일것인지 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowFigureText As Boolean
    Get
    Set
C#
public bool IsShowFigureText { get; set; }
Visual C++
public:
property bool IsShowFigureText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowFigureText();
function set_isShowFigureText(value);

See Also

SeriesItem Class


ItemColor Property

[image]

.NET Framework Class Library
SeriesItem..::..ItemColor Property
SeriesItem Class See Also Send Feedback

아이템 색상을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ItemColor As Color
    Get
    Set
C#
public Color ItemColor { get; set; }
Visual C++
public:
property Color ItemColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_itemColor();
function set_itemColor(value);

See Also

SeriesItem Class


Label Property

[image]

.NET Framework Class Library
SeriesItem..::..Label Property
SeriesItem Class See Also Send Feedback

아이템 수치 라벨을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

SeriesItem Class


Lengh Property

[image]

.NET Framework Class Library
SeriesItem..::..Lengh Property
SeriesItem Class See Also Send Feedback

파이 그래프의 가로 크기를 설정하고 가져온다. 설정 값이 클 수록 부채꼴은 작아집니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Lengh As Double
    Get
    Set
C#
public double Lengh { get; set; }
Visual C++
public:
property double Lengh {
    double get ();
    void set (double value);
}
JavaScript
function get_lengh();
function set_lengh(value);

See Also

SeriesItem Class


LowValue Property

[image]

.NET Framework Class Library
SeriesItem..::..LowValue Property
SeriesItem Class See Also Send Feedback

주식차트에 사용되는 속성으로 저가를 의미하는 값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LowValue As Double
    Get
    Set
C#
public double LowValue { get; set; }
Visual C++
public:
property double LowValue {
    double get ();
    void set (double value);
}
JavaScript
function get_lowValue();
function set_lowValue(value);

See Also

SeriesItem Class


Name Property

[image]

.NET Framework Class Library
SeriesItem..::..Name Property
SeriesItem Class See Also Send Feedback

아이템 이름을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

x축이 문자형일 경우에 해당 속성이 필요합니다.

See Also

SeriesItem Class


ParentIndex Property

[image]

.NET Framework Class Library
SeriesItem..::..ParentIndex Property
SeriesItem Class See Also Send Feedback

부모아이템의 인덱스 번호를 설정하고 가져온다. 간트차트일 경우 일정의 부모를 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ParentIndex As Integer
    Get
    Set
C#
public int ParentIndex { get; set; }
Visual C++
public:
property int ParentIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_parentIndex();
function set_parentIndex(value);

See Also

SeriesItem Class


Points Property

[image]

.NET Framework Class Library
SeriesItem..::..Points Property
SeriesItem Class See Also Send Feedback

포인트을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Points As Points
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Points Points { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Points^ Points {
    Points^ get ();
    void set (Points^ value);
}
JavaScript
function get_points();
function set_points(value);

See Also

SeriesItem Class


Vector Property

[image]

.NET Framework Class Library
SeriesItem..::..Vector Property
SeriesItem Class See Also Send Feedback

아이템의 벡터 특성을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Vector As Vector
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Vector Vector { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Vector^ Vector {
    Vector^ get ();
    void set (Vector^ value);
}
JavaScript
function get_vector();
function set_vector(value);

See Also

SeriesItem Class


Visible Property

[image]

.NET Framework Class Library
SeriesItem..::..Visible Property
SeriesItem Class See Also Send Feedback

시리즈아이템의 Visible 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Visible As Boolean
    Get
    Set
C#
public bool Visible { get; set; }
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

SeriesItem Class


XDateTimeValue Property

[image]

.NET Framework Class Library
SeriesItem..::..XDateTimeValue Property
SeriesItem Class See Also Send Feedback

아이템의 날짜형 x값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XDateTimeValue As DateTime
    Get
    Set
C#
public DateTime XDateTimeValue { get; set; }
Visual C++
public:
property DateTime XDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_xDateTimeValue();
function set_xDateTimeValue(value);

See Also

SeriesItem Class


XValue Property

[image]

.NET Framework Class Library
SeriesItem..::..XValue Property
SeriesItem Class See Also Send Feedback

아이템 값(x)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property XValue As Double
    Get
    Set
C#
public double XValue { get; set; }
Visual C++
public:
property double XValue {
    double get ();
    void set (double value);
}
JavaScript
function get_xValue();
function set_xValue(value);

Remarks

x축이 숫자형일 경우에 해당 속성의 입력이 필요합니다.

See Also

SeriesItem Class


YDateTimeValue Property

[image]

.NET Framework Class Library
SeriesItem..::..YDateTimeValue Property
SeriesItem Class See Also Send Feedback

아이템의 날짜형 y값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YDateTimeValue As DateTime
    Get
    Set
C#
public DateTime YDateTimeValue { get; set; }
Visual C++
public:
property DateTime YDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_yDateTimeValue();
function set_yDateTimeValue(value);

See Also

SeriesItem Class


YStartDateTimeValue Property

[image]

.NET Framework Class Library
SeriesItem..::..YStartDateTimeValue Property
SeriesItem Class See Also Send Feedback

아이템의 날짜형 y 시작 값을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YStartDateTimeValue As DateTime
    Get
    Set
C#
public DateTime YStartDateTimeValue { get; set; }
Visual C++
public:
property DateTime YStartDateTimeValue {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_yStartDateTimeValue();
function set_yStartDateTimeValue(value);

See Also

SeriesItem Class


YStartValue Property

[image]

.NET Framework Class Library
SeriesItem..::..YStartValue Property
SeriesItem Class See Also Send Feedback

아이템의 시작 값(y)을 설정하고 가져온다. (주식차트에서 시가를 의미합니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YStartValue As Double
    Get
    Set
C#
public double YStartValue { get; set; }
Visual C++
public:
property double YStartValue {
    double get ();
    void set (double value);
}
JavaScript
function get_yStartValue();
function set_yStartValue(value);

See Also

SeriesItem Class


YValue Property

[image]

.NET Framework Class Library
SeriesItem..::..YValue Property
SeriesItem Class See Also Send Feedback

아이템 값(y)을 설정하고 가져온다. (주식차트에서는 종가를 의미합니다)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YValue As Double
    Get
    Set
C#
public double YValue { get; set; }
Visual C++
public:
property double YValue {
    double get ();
    void set (double value);
}
JavaScript
function get_yValue();
function set_yValue(value);

See Also

SeriesItem Class


YValueReplaceText Property

[image]

.NET Framework Class Library
SeriesItem..::..YValueReplaceText Property
SeriesItem Class See Also Send Feedback

YValue 값을 대체하여 수치표시하는 텍스트 문구를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property YValueReplaceText As String
    Get
    Set
C#
public string YValueReplaceText { get; set; }
Visual C++
public:
property String^ YValueReplaceText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_yValueReplaceText();
function set_yValueReplaceText(value);

See Also

SeriesItem Class


ZValue Property

[image]

.NET Framework Class Library
SeriesItem..::..ZValue Property
SeriesItem Class See Also Send Feedback

아이템 값(Z)을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ZValue As Double
    Get
    Set
C#
public double ZValue { get; set; }
Visual C++
public:
property double ZValue {
    double get ();
    void set (double value);
}
JavaScript
function get_zValue();
function set_zValue(value);

See Also

SeriesItem Class


SeriesItemCollection Class

[image]

.NET Framework Class Library
SeriesItemCollection Class
Members See Also Send Feedback

SeriesItemCollection

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class SeriesItemCollection _
    Inherits HippoCollectionBase(Of SeriesItem)
C#
[SerializableAttribute]
public class SeriesItemCollection : HippoCollectionBase<SeriesItem>
Visual C++
[SerializableAttribute]
public ref class SeriesItemCollection : public HippoCollectionBase<SeriesItem^>
JavaScript
Hippo.SeriesItemCollection = function();

Type.createClass(
    'Hippo.SeriesItemCollection',
    Hippo.HippoCollectionBase`1);

Remarks

시리즈아이템을 담고 있는 컬렉션으로 시리즈가 소유합니다.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' SeriesItem >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' SeriesItem >)>)>
Hippo..::..SeriesItemCollection

See Also

SeriesItemCollection Members


SeriesItemCollection Members

[image] [image]

.NET Framework Class Library
SeriesItemCollection Members
SeriesItemCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SeriesItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesItemCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class


SeriesItemCollection Constructor

[image]

.NET Framework Class Library
SeriesItemCollection Constructor
SeriesItemCollection Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public SeriesItemCollection()
Visual C++
public:
SeriesItemCollection()
JavaScript
Hippo.SeriesItemCollection = function();

See Also

SeriesItemCollection Class


SeriesItemCollection Methods

[image] [image]

.NET Framework Class Library
SeriesItemCollection Methods
SeriesItemCollection Class See Also Send Feedback

The SeriesItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..BinarySearch Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


CopyTo Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..CopyTo Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


FindIndex Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..FindIndex Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..FindLastIndex Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


IndexOf Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..IndexOf Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..LastIndexOf Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


Reverse Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..Reverse Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


Sort Method

[image] [image]

.NET Framework Class Library
SeriesItemCollection..::..Sort Method
SeriesItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class
SeriesItemCollection Members


SeriesItemCollection Properties

[image] [image]

.NET Framework Class Library
SeriesItemCollection Properties
SeriesItemCollection Class See Also Send Feedback

The SeriesItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' SeriesItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' SeriesItem >)>)>.)

See Also

SeriesItemCollection Class


SeriesList Class

[image]

.NET Framework Class Library
SeriesList Class
Members See Also Send Feedback

SeriesList (시리즈리스트)

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class SeriesList
C#
[SerializableAttribute]
public class SeriesList
Visual C++
[SerializableAttribute]
public ref class SeriesList
JavaScript
Hippo.SeriesList = function();

Type.createClass(
    'Hippo.SeriesList');

Remarks

하나의 좌표평면을 기준으로하는 시리즈 집합으로 차트가 가지는 중요한 속성들을 관리하는 차트 단위 객체입니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..SeriesList

See Also

SeriesList Members


SeriesList Members

[image] [image]

.NET Framework Class Library
SeriesList Members
SeriesList Class Constructors Methods Properties Events See Also Send Feedback

The SeriesList type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesList | SeriesList 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChart3DShowChanged | OnChart3DShowChanged 이벤트
Protected method | OnChartMarginChanged | OnChartMarginChanged 이벤트
Protected method | OnChartTransParentChanged | OnChartTransParentChanged 이벤트
Protected method | OnChartTypeChanged | OnChartTypeChanged 이벤트
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AxisFactor | 차트 핵심 요소을 설정하고 가져온다.
Public property | ChartType | 대표 차트 타입을 설정하고 가져온다.
Public property | CoorcinateType | 좌표성질인지 여부를 설정하고 가져온다.
Public property | CoordinativeDirection | 축의 방향을 설정하고 가져옵니다.
Public property | Description | 차트 Description을 설정하고 가져옵니다.
Public property | Gantt | 간트차트의 속성들의 정의를 설정하고 가져온다.
Public property | GraphArea | 그래프 그려지는 내부 영역을 설정하고 가져온다.
Public property | GraphTitle | GraphTitle 을 설정하고 가져옵니다.
Public property | IsShow3D | 3D 입체로 그릴것인가 여부를 설정하고 가져온다.
Public property | IsShowStackedSumFigures | 스택형 차트의 아이템 합계 수치를 보일 것인가 여부를 설정하고 가져옵니다.
Public property | Legend | 이너 레전드를 설정하고 가져옵니다.
Public property | Margin | 차트 마진을 설정하고 가져온다.
Public property | PaletteType | 팔레트 타입을 설정하고 가져옵니다.
Public property | Radar | 방사형 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.
Public property | ScaleBreakType | 스케일 브레이크의 모양을 설정하고 가져옵니다.
Public property | SeriesCollection | 시리즈 컬렉션을 설정하고 가져옵니다.
Public property | StackType | 스택형 타입을 설정하고 가져온다.
Public property | Transparency | 투명도(기본값 255)를 설정하고 가져온다.

Events

 | Name | Description
Public event | Chart3DShowChanged | 차트 3D 설정이 변경될때 발생합니다.
Public event | ChartMarginChanged | 차트 마진이 변경될때 발생합니다.
Public event | ChartTransParentChanged | 차트 투명도가 변경될때 발생합니다.
Public event | ChartTypeChanged | 차트 종류가 변경될때 발생합니다.

See Also

SeriesList Class


SeriesList Constructor

[image]

.NET Framework Class Library
SeriesList Constructor
SeriesList Class See Also Send Feedback

SeriesList 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public SeriesList()
Visual C++
public:
SeriesList()
JavaScript
Hippo.SeriesList = function();

See Also

SeriesList Class


SeriesList Methods

[image] [image]

.NET Framework Class Library
SeriesList Methods
SeriesList Class See Also Send Feedback

The SeriesList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChart3DShowChanged | OnChart3DShowChanged 이벤트
Protected method | OnChartMarginChanged | OnChartMarginChanged 이벤트
Protected method | OnChartTransParentChanged | OnChartTransParentChanged 이벤트
Protected method | OnChartTypeChanged | OnChartTypeChanged 이벤트
Public method | ToString | (Inherited from Object.)

See Also

SeriesList Class


OnChart3DShowChanged Method

[image]

.NET Framework Class Library
SeriesList..::..OnChart3DShowChanged Method
SeriesList Class See Also Send Feedback

OnChart3DShowChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChart3DShowChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChart3DShowChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChart3DShowChanged(
    EventArgs^ e
)
JavaScript
function onChart3DShowChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

SeriesList Class


OnChartMarginChanged Method

[image]

.NET Framework Class Library
SeriesList..::..OnChartMarginChanged Method
SeriesList Class See Also Send Feedback

OnChartMarginChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMarginChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMarginChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMarginChanged(
    EventArgs^ e
)
JavaScript
function onChartMarginChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

SeriesList Class


OnChartTransParentChanged Method

[image]

.NET Framework Class Library
SeriesList..::..OnChartTransParentChanged Method
SeriesList Class See Also Send Feedback

OnChartTransParentChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartTransParentChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartTransParentChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartTransParentChanged(
    EventArgs^ e
)
JavaScript
function onChartTransParentChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

SeriesList Class


OnChartTypeChanged Method

[image]

.NET Framework Class Library
SeriesList..::..OnChartTypeChanged Method
SeriesList Class See Also Send Feedback

OnChartTypeChanged 이벤트

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartTypeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartTypeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartTypeChanged(
    EventArgs^ e
)
JavaScript
function onChartTypeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

SeriesList Class


SeriesList Properties

[image] [image]

.NET Framework Class Library
SeriesList Properties
SeriesList Class See Also Send Feedback

The SeriesList type exposes the following members.

Properties

 | Name | Description
Public property | AxisFactor | 차트 핵심 요소을 설정하고 가져온다.
Public property | ChartType | 대표 차트 타입을 설정하고 가져온다.
Public property | CoorcinateType | 좌표성질인지 여부를 설정하고 가져온다.
Public property | CoordinativeDirection | 축의 방향을 설정하고 가져옵니다.
Public property | Description | 차트 Description을 설정하고 가져옵니다.
Public property | Gantt | 간트차트의 속성들의 정의를 설정하고 가져온다.
Public property | GraphArea | 그래프 그려지는 내부 영역을 설정하고 가져온다.
Public property | GraphTitle | GraphTitle 을 설정하고 가져옵니다.
Public property | IsShow3D | 3D 입체로 그릴것인가 여부를 설정하고 가져온다.
Public property | IsShowStackedSumFigures | 스택형 차트의 아이템 합계 수치를 보일 것인가 여부를 설정하고 가져옵니다.
Public property | Legend | 이너 레전드를 설정하고 가져옵니다.
Public property | Margin | 차트 마진을 설정하고 가져온다.
Public property | PaletteType | 팔레트 타입을 설정하고 가져옵니다.
Public property | Radar | 방사형 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.
Public property | ScaleBreakType | 스케일 브레이크의 모양을 설정하고 가져옵니다.
Public property | SeriesCollection | 시리즈 컬렉션을 설정하고 가져옵니다.
Public property | StackType | 스택형 타입을 설정하고 가져온다.
Public property | Transparency | 투명도(기본값 255)를 설정하고 가져온다.

See Also

SeriesList Class


AxisFactor Property

[image]

.NET Framework Class Library
SeriesList..::..AxisFactor Property
SeriesList Class See Also Send Feedback

차트 핵심 요소을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property AxisFactor As AxisFactors
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public AxisFactors AxisFactor { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property AxisFactors^ AxisFactor {
    AxisFactors^ get ();
    void set (AxisFactors^ value);
}
JavaScript
function get_axisFactor();
function set_axisFactor(value);

See Also

SeriesList Class


ChartType Property

[image]

.NET Framework Class Library
SeriesList..::..ChartType Property
SeriesList Class See Also Send Feedback

대표 차트 타입을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartType As ChartType
    Get
    Set
C#
public ChartType ChartType { get; set; }
Visual C++
public:
property ChartType ChartType {
    ChartType get ();
    void set (ChartType value);
}
JavaScript
function get_chartType();
function set_chartType(value);

See Also

SeriesList Class


CoorcinateType Property

[image]

.NET Framework Class Library
SeriesList..::..CoorcinateType Property
SeriesList Class See Also Send Feedback

좌표성질인지 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property CoorcinateType As CoordinateType
    Get
    Set
C#
public CoordinateType CoorcinateType { get; set; }
Visual C++
public:
property CoordinateType CoorcinateType {
    CoordinateType get ();
    void set (CoordinateType value);
}
JavaScript
function get_coorcinateType();
function set_coorcinateType(value);

See Also

SeriesList Class


CoordinativeDirection Property

[image]

.NET Framework Class Library
SeriesList..::..CoordinativeDirection Property
SeriesList Class See Also Send Feedback

축의 방향을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property CoordinativeDirection As CoordinativeDirection
    Get
    Set
C#
[BindableAttribute(true)]
public CoordinativeDirection CoordinativeDirection { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property CoordinativeDirection CoordinativeDirection {
    CoordinativeDirection get ();
    void set (CoordinativeDirection value);
}
JavaScript
function get_coordinativeDirection();
function set_coordinativeDirection(value);

See Also

SeriesList Class


Description Property

[image]

.NET Framework Class Library
SeriesList..::..Description Property
SeriesList Class See Also Send Feedback

차트 Description을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Description As Descriptions
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Descriptions Description { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Descriptions^ Description {
    Descriptions^ get ();
    void set (Descriptions^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

SeriesList Class


Gantt Property

[image]

.NET Framework Class Library
SeriesList..::..Gantt Property
SeriesList Class See Also Send Feedback

간트차트의 속성들의 정의를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Gantt As Gantt
    Get
    Set
C#
[BindableAttribute(true)]
public Gantt Gantt { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property Gantt^ Gantt {
    Gantt^ get ();
    void set (Gantt^ value);
}
JavaScript
function get_gantt();
function set_gantt(value);

See Also

SeriesList Class


GraphArea Property

[image]

.NET Framework Class Library
SeriesList..::..GraphArea Property
SeriesList Class See Also Send Feedback

그래프 그려지는 내부 영역을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property GraphArea As GraphArea
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public GraphArea GraphArea { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property GraphArea^ GraphArea {
    GraphArea^ get ();
    void set (GraphArea^ value);
}
JavaScript
function get_graphArea();
function set_graphArea(value);

See Also

SeriesList Class


GraphTitle Property

[image]

.NET Framework Class Library
SeriesList..::..GraphTitle Property
SeriesList Class See Also Send Feedback

GraphTitle 을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property GraphTitle As Title
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Title GraphTitle { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Title^ GraphTitle {
    Title^ get ();
    void set (Title^ value);
}
JavaScript
function get_graphTitle();
function set_graphTitle(value);

See Also

SeriesList Class


IsShow3D Property

[image]

.NET Framework Class Library
SeriesList..::..IsShow3D Property
SeriesList Class See Also Send Feedback

3D 입체로 그릴것인가 여부를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShow3D As Boolean
    Get
    Set
C#
public bool IsShow3D { get; set; }
Visual C++
public:
property bool IsShow3D {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShow3D();
function set_isShow3D(value);

See Also

SeriesList Class


IsShowStackedSumFigures Property

[image]

.NET Framework Class Library
SeriesList..::..IsShowStackedSumFigures Property
SeriesList Class See Also Send Feedback

스택형 차트의 아이템 합계 수치를 보일 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShowStackedSumFigures As Boolean
    Get
    Set
C#
public bool IsShowStackedSumFigures { get; set; }
Visual C++
public:
property bool IsShowStackedSumFigures {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShowStackedSumFigures();
function set_isShowStackedSumFigures(value);

See Also

SeriesList Class


Legend Property

[image]

.NET Framework Class Library
SeriesList..::..Legend Property
SeriesList Class See Also Send Feedback

이너 레전드를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Legend As LegendBox
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public LegendBox Legend { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property LegendBox^ Legend {
    LegendBox^ get ();
    void set (LegendBox^ value);
}
JavaScript
function get_legend();
function set_legend(value);

See Also

SeriesList Class


Margin Property

[image]

.NET Framework Class Library
SeriesList..::..Margin Property
SeriesList Class See Also Send Feedback

차트 마진을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Margin As Integer
    Get
    Set
C#
public int Margin { get; set; }
Visual C++
public:
property int Margin {
    int get ();
    void set (int value);
}
JavaScript
function get_margin();
function set_margin(value);

See Also

SeriesList Class


PaletteType Property

[image]

.NET Framework Class Library
SeriesList..::..PaletteType Property
SeriesList Class See Also Send Feedback

팔레트 타입을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property PaletteType As PaletteType
    Get
    Set
C#
[BindableAttribute(true)]
public PaletteType PaletteType { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property PaletteType PaletteType {
    PaletteType get ();
    void set (PaletteType value);
}
JavaScript
function get_paletteType();
function set_paletteType(value);

See Also

SeriesList Class


Radar Property

[image]

.NET Framework Class Library
SeriesList..::..Radar Property
SeriesList Class See Also Send Feedback

방사형 차트의 특성을 정의하는 속성을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Radar As Radar
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Radar Radar { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Radar^ Radar {
    Radar^ get ();
    void set (Radar^ value);
}
JavaScript
function get_radar();
function set_radar(value);

See Also

SeriesList Class


ScaleBreakType Property

[image]

.NET Framework Class Library
SeriesList..::..ScaleBreakType Property
SeriesList Class See Also Send Feedback

스케일 브레이크의 모양을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ScaleBreakType As ScaleBreakType
    Get
    Set
C#
[BindableAttribute(true)]
public ScaleBreakType ScaleBreakType { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property ScaleBreakType ScaleBreakType {
    ScaleBreakType get ();
    void set (ScaleBreakType value);
}
JavaScript
function get_scaleBreakType();
function set_scaleBreakType(value);

See Also

SeriesList Class


SeriesCollection Property

[image]

.NET Framework Class Library
SeriesList..::..SeriesCollection Property
SeriesList Class See Also Send Feedback

시리즈 컬렉션을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property SeriesCollection As SeriesCollection
    Get
    Set
C#
[BindableAttribute(true)]
public SeriesCollection SeriesCollection { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property SeriesCollection^ SeriesCollection {
    SeriesCollection^ get ();
    void set (SeriesCollection^ value);
}
JavaScript
function get_seriesCollection();
function set_seriesCollection(value);

See Also

SeriesList Class


StackType Property

[image]

.NET Framework Class Library
SeriesList..::..StackType Property
SeriesList Class See Also Send Feedback

스택형 타입을 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property StackType As StackType
    Get
    Set
C#
public StackType StackType { get; set; }
Visual C++
public:
property StackType StackType {
    StackType get ();
    void set (StackType value);
}
JavaScript
function get_stackType();
function set_stackType(value);

See Also

SeriesList Class


Transparency Property

[image]

.NET Framework Class Library
SeriesList..::..Transparency Property
SeriesList Class See Also Send Feedback

투명도(기본값 255)를 설정하고 가져온다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Transparency As Integer
    Get
    Set
C#
public int Transparency { get; set; }
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}
JavaScript
function get_transparency();
function set_transparency(value);

See Also

SeriesList Class


SeriesList Events

[image] [image]

.NET Framework Class Library
SeriesList Events
SeriesList Class See Also Send Feedback

The SeriesList type exposes the following members.

Events

 | Name | Description
Public event | Chart3DShowChanged | 차트 3D 설정이 변경될때 발생합니다.
Public event | ChartMarginChanged | 차트 마진이 변경될때 발생합니다.
Public event | ChartTransParentChanged | 차트 투명도가 변경될때 발생합니다.
Public event | ChartTypeChanged | 차트 종류가 변경될때 발생합니다.

See Also

SeriesList Class


Chart3DShowChanged Event

[image]

.NET Framework Class Library
SeriesList..::..Chart3DShowChanged Event
SeriesList Class See Also Send Feedback

차트 3D 설정이 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event Chart3DShowChanged As EventHandler
C#
public event EventHandler Chart3DShowChanged
Visual C++
public:
 event EventHandler^ Chart3DShowChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chart3DShowChanged(value);
function remove_chart3DShowChanged(value);

See Also

SeriesList Class


ChartMarginChanged Event

[image]

.NET Framework Class Library
SeriesList..::..ChartMarginChanged Event
SeriesList Class See Also Send Feedback

차트 마진이 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMarginChanged As EventHandler
C#
public event EventHandler ChartMarginChanged
Visual C++
public:
 event EventHandler^ ChartMarginChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMarginChanged(value);
function remove_chartMarginChanged(value);

See Also

SeriesList Class


ChartTransParentChanged Event

[image]

.NET Framework Class Library
SeriesList..::..ChartTransParentChanged Event
SeriesList Class See Also Send Feedback

차트 투명도가 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartTransParentChanged As EventHandler
C#
public event EventHandler ChartTransParentChanged
Visual C++
public:
 event EventHandler^ ChartTransParentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartTransParentChanged(value);
function remove_chartTransParentChanged(value);

See Also

SeriesList Class


ChartTypeChanged Event

[image]

.NET Framework Class Library
SeriesList..::..ChartTypeChanged Event
SeriesList Class See Also Send Feedback

차트 종류가 변경될때 발생합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartTypeChanged As EventHandler
C#
public event EventHandler ChartTypeChanged
Visual C++
public:
 event EventHandler^ ChartTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartTypeChanged(value);
function remove_chartTypeChanged(value);

See Also

SeriesList Class


SeriesListDictionary Class

[image]

.NET Framework Class Library
SeriesListDictionary Class
Members See Also Send Feedback

SeriesListDictionary

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class SeriesListDictionary _
    Inherits HippoCollectionBase(Of SeriesList)
C#
[SerializableAttribute]
public class SeriesListDictionary : HippoCollectionBase<SeriesList>
Visual C++
[SerializableAttribute]
public ref class SeriesListDictionary : public HippoCollectionBase<SeriesList^>
JavaScript
Hippo.SeriesListDictionary = function();

Type.createClass(
    'Hippo.SeriesListDictionary',
    Hippo.HippoCollectionBase`1);

Remarks

시리즈리스트를 담고 있는 컬렉션으로 히포차트 객체가 소유합니다.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' SeriesList >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' SeriesList >)>)>
Hippo..::..SeriesListDictionary

See Also

SeriesListDictionary Members


SeriesListDictionary Members

[image] [image]

.NET Framework Class Library
SeriesListDictionary Members
SeriesListDictionary Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SeriesListDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | SeriesListDictionary |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' SeriesList >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class


SeriesListDictionary Constructor

[image]

.NET Framework Class Library
SeriesListDictionary Constructor
SeriesListDictionary Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public SeriesListDictionary()
Visual C++
public:
SeriesListDictionary()
JavaScript
Hippo.SeriesListDictionary = function();

See Also

SeriesListDictionary Class


SeriesListDictionary Methods

[image] [image]

.NET Framework Class Library
SeriesListDictionary Methods
SeriesListDictionary Class See Also Send Feedback

The SeriesListDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' SeriesList >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..BinarySearch Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


CopyTo Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..CopyTo Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


FindIndex Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..FindIndex Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..FindLastIndex Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


IndexOf Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..IndexOf Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..LastIndexOf Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


Reverse Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..Reverse Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


Sort Method

[image] [image]

.NET Framework Class Library
SeriesListDictionary..::..Sort Method
SeriesListDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class
SeriesListDictionary Members


SeriesListDictionary Properties

[image] [image]

.NET Framework Class Library
SeriesListDictionary Properties
SeriesListDictionary Class See Also Send Feedback

The SeriesListDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' SeriesList >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' SeriesList >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' SeriesList >)>)>.)

See Also

SeriesListDictionary Class


ShapeType Enumeration

[image]

.NET Framework Class Library
ShapeType Enumeration
See Also Send Feedback

온도계 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ShapeType
C#
public enum ShapeType
Visual C++
public enum class ShapeType
JavaScript
Hippo.ShapeType = function();
Hippo.ShapeType.createEnum('Hippo.ShapeType', false);

Members

Member name | Description
Default |
Blend |
Thermometer |
Thermometer2 |
Horizontal |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


ShapeType2 Enumeration

[image]

.NET Framework Class Library
ShapeType2 Enumeration
See Also Send Feedback

게이지 모양

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ShapeType2
C#
public enum ShapeType2
Visual C++
public enum class ShapeType2
JavaScript
Hippo.ShapeType2 = function();
Hippo.ShapeType2.createEnum('Hippo.ShapeType2', false);

Members

Member name | Description
Gauge1 |
Gauge2 |
Gauge3 |
Gauge4 |
Gauge5 |
Gauge6 |
Gauge7 |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


StackType Enumeration

[image]

.NET Framework Class Library
StackType Enumeration
See Also Send Feedback

스택차트 타입

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration StackType
C#
public enum StackType
Visual C++
public enum class StackType
JavaScript
Hippo.StackType = function();
Hippo.StackType.createEnum('Hippo.StackType', false);

Members

Member name | Description
None |
Stacked |
FullStacked |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Theme Class

[image]

.NET Framework Class Library
Theme Class
Members See Also Send Feedback

Theme

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class Theme
C#
public class Theme
Visual C++
public ref class Theme
JavaScript
Hippo.Theme = function();

Type.createClass(
    'Hippo.Theme');

Inheritance Hierarchy

System..::..Object
Hippo..::..Theme

See Also

Theme Members


Theme Members

[image] [image]

.NET Framework Class Library
Theme Members
Theme Class Constructors Methods See Also Send Feedback

The Theme type exposes the following members.

Constructors

 | Name | Description
Public method | Theme |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Theme Class


Theme Constructor

[image]

.NET Framework Class Library
Theme Constructor
Theme Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Theme()
Visual C++
public:
Theme()
JavaScript
Hippo.Theme = function();

See Also

Theme Class


Theme Methods

[image] [image]

.NET Framework Class Library
Theme Methods
Theme Class See Also Send Feedback

The Theme type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Theme Class


Title Class

[image]

.NET Framework Class Library
Title Class
Members See Also Send Feedback

차트 타이틀 요소

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Title
C#
[SerializableAttribute]
public class Title
Visual C++
[SerializableAttribute]
public ref class Title
JavaScript
Hippo.Title = function();

Type.createClass(
    'Hippo.Title');

Remarks

차트 상단의 차트 제목, 이름 등을 설정할 수 있습니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..Title

See Also

Title Members


Title Members

[image] [image]

.NET Framework Class Library
Title Members
Title Class Constructors Methods Properties See Also Send Feedback

The Title type exposes the following members.

Constructors

 | Name | Description
Public method | Title | Title 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Label | 타이틀 라벨을 가져오거나 설정합니다.
Public property | TitleAlign | 타이틀 위치을 가져오거나 설정합니다.
Public property | TitleIconPath | 타이틀 앞에 위치할 이미지 경로 문자열을 가져오거나 설정합니다.

See Also

Title Class


Title Constructor

[image]

.NET Framework Class Library
Title Constructor
Title Class See Also Send Feedback

Title 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Title()
Visual C++
public:
Title()
JavaScript
Hippo.Title = function();

See Also

Title Class


Title Methods

[image] [image]

.NET Framework Class Library
Title Methods
Title Class See Also Send Feedback

The Title type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Title Class


Title Properties

[image] [image]

.NET Framework Class Library
Title Properties
Title Class See Also Send Feedback

The Title type exposes the following members.

Properties

 | Name | Description
Public property | Label | 타이틀 라벨을 가져오거나 설정합니다.
Public property | TitleAlign | 타이틀 위치을 가져오거나 설정합니다.
Public property | TitleIconPath | 타이틀 앞에 위치할 이미지 경로 문자열을 가져오거나 설정합니다.

See Also

Title Class


Label Property

[image]

.NET Framework Class Library
Title..::..Label Property
Title Class See Also Send Feedback

타이틀 라벨을 가져오거나 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Label As Label
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Label Label { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

Title Class


TitleAlign Property

[image]

.NET Framework Class Library
Title..::..TitleAlign Property
Title Class See Also Send Feedback

타이틀 위치을 가져오거나 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleAlign As StringAlignment
    Get
    Set
C#
public StringAlignment TitleAlign { get; set; }
Visual C++
public:
property StringAlignment TitleAlign {
    StringAlignment get ();
    void set (StringAlignment value);
}
JavaScript
function get_titleAlign();
function set_titleAlign(value);

See Also

Title Class


TitleIconPath Property

[image]

.NET Framework Class Library
Title..::..TitleIconPath Property
Title Class See Also Send Feedback

타이틀 앞에 위치할 이미지 경로 문자열을 가져오거나 설정합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TitleIconPath As String
    Get
    Set
C#
public string TitleIconPath { get; set; }
Visual C++
public:
property String^ TitleIconPath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_titleIconPath();
function set_titleIconPath(value);

See Also

Title Class


UnAxisDisplayItemType Enumeration

[image]

.NET Framework Class Library
UnAxisDisplayItemType Enumeration
See Also Send Feedback

파이 등 비좌표 차트에 표시할 내용

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration UnAxisDisplayItemType
C#
public enum UnAxisDisplayItemType
Visual C++
public enum class UnAxisDisplayItemType
JavaScript
Hippo.UnAxisDisplayItemType = function();
Hippo.UnAxisDisplayItemType.createEnum('Hippo.UnAxisDisplayItemType', false);

Members

Member name | Description
Percent |
Figure |
Name |
Angle |
Figure_Percent |
Percent_Name |
Figure_Name |
Angle_Name |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


UnAxisDrawer Class

[image]

.NET Framework Class Library
UnAxisDrawer Class
Members See Also Send Feedback

좌표 성질이 없는 차트의 기본 환경을 그린다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class UnAxisDrawer _
    Implements IDrawer, IDisposable
C#
public class UnAxisDrawer : IDrawer,
    IDisposable
Visual C++
public ref class UnAxisDrawer : IDrawer,
    IDisposable
JavaScript
Hippo.UnAxisDrawer = function();

Type.createClass(
    'Hippo.UnAxisDrawer',
    null,
    Hippo.IDrawer,
    IDisposable);

Remarks

호출 대상이 아닙니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..UnAxisDrawer

See Also

UnAxisDrawer Members


UnAxisDrawer Members

[image] [image]

.NET Framework Class Library
UnAxisDrawer Members
UnAxisDrawer Class Constructors Methods Properties See Also Send Feedback

The UnAxisDrawer type exposes the following members.

Constructors

 | Name | Description
Public method | UnAxisDrawer | UnAxisDrawer 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Dispose | Dispose
Public method | DrawEndChart | DrawEndChart
Public method | DrawStartChart | DrawStartChart
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DebugString | 디버그를 위한 문자열

See Also

UnAxisDrawer Class


UnAxisDrawer Constructor

[image]

.NET Framework Class Library
UnAxisDrawer Constructor
UnAxisDrawer Class See Also Send Feedback

UnAxisDrawer 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    graphic As Graphics _
)
C#
public UnAxisDrawer(
    Graphics graphic
)
Visual C++
public:
UnAxisDrawer(
    Graphics^ graphic
)
JavaScript
Hippo.UnAxisDrawer = function(graphic);

Parameters

graphic
Type: System.Drawing..::..Graphics

See Also

UnAxisDrawer Class


UnAxisDrawer Methods

[image] [image]

.NET Framework Class Library
UnAxisDrawer Methods
UnAxisDrawer Class See Also Send Feedback

The UnAxisDrawer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose
Public method | DrawEndChart | DrawEndChart
Public method | DrawStartChart | DrawStartChart
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UnAxisDrawer Class


Dispose Method

[image]

.NET Framework Class Library
UnAxisDrawer..::..Dispose Method
UnAxisDrawer Class See Also Send Feedback

Dispose

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

UnAxisDrawer Class


DrawEndChart Method

[image]

.NET Framework Class Library
UnAxisDrawer..::..DrawEndChart Method
UnAxisDrawer Class See Also Send Feedback

DrawEndChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function DrawEndChart ( _
    seriesList As SeriesList _
) As Graphics
C#
public Graphics DrawEndChart(
    SeriesList seriesList
)
Visual C++
public:
virtual Graphics^ DrawEndChart(
    SeriesList^ seriesList
) sealed
JavaScript
function drawEndChart(seriesList);

Parameters

seriesList
Type: Hippo..::..SeriesList

Return Value

See Also

UnAxisDrawer Class


DrawStartChart Method

[image]

.NET Framework Class Library
UnAxisDrawer..::..DrawStartChart Method
UnAxisDrawer Class See Also Send Feedback

DrawStartChart

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Function DrawStartChart ( _
    seriesList As SeriesList, _
    legendLocation As LegendLocation, _
    paletteType As PaletteType _
) As Graphics
C#
public Graphics DrawStartChart(
    SeriesList seriesList,
    LegendLocation legendLocation,
    PaletteType paletteType
)
Visual C++
public:
virtual Graphics^ DrawStartChart(
    SeriesList^ seriesList,
    LegendLocation legendLocation,
    PaletteType paletteType
) sealed
JavaScript
function drawStartChart(seriesList, legendLocation, paletteType);

Parameters

seriesList
Type: Hippo..::..SeriesList
legendLocation
Type: Hippo..::..LegendLocation
paletteType
Type: Hippo..::..PaletteType

Return Value

See Also

UnAxisDrawer Class


UnAxisDrawer Properties

[image] [image]

.NET Framework Class Library
UnAxisDrawer Properties
UnAxisDrawer Class See Also Send Feedback

The UnAxisDrawer type exposes the following members.

Properties

 | Name | Description
Public property | DebugString | 디버그를 위한 문자열

See Also

UnAxisDrawer Class


DebugString Property

[image]

.NET Framework Class Library
UnAxisDrawer..::..DebugString Property
UnAxisDrawer Class See Also Send Feedback

디버그를 위한 문자열

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DebugString As String
    Get
    Set
C#
public string DebugString { get; set; }
Visual C++
public:
virtual property String^ DebugString {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_debugString();
function set_debugString(value);

See Also

UnAxisDrawer Class


UnAxisFactors Class

[image]

.NET Framework Class Library
UnAxisFactors Class
Members See Also Send Feedback

비좌표 특징요소 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class UnAxisFactors
C#
[SerializableAttribute]
public class UnAxisFactors
Visual C++
[SerializableAttribute]
public ref class UnAxisFactors
JavaScript
Hippo.UnAxisFactors = function();

Type.createClass(
    'Hippo.UnAxisFactors');

Remarks

파이, 게이지, 방사형, 피라미드 등 비좌표 차트들의 중요 속성을 관리합니다. 게이지 차트의 축 설정과 파이 그래프의 3D height 등의 설정이 가능합니다. 또한, 비좌표차트내에 있는 미니 축(Axis)를 관리합니다.

Inheritance Hierarchy

System..::..Object
Hippo..::..UnAxisFactors

See Also

UnAxisFactors Members


UnAxisFactors Members

[image] [image]

.NET Framework Class Library
UnAxisFactors Members
UnAxisFactors Class Constructors Methods Properties See Also Send Feedback

The UnAxisFactors type exposes the following members.

Constructors

 | Name | Description
Public method | UnAxisFactors | UnAxisFactors 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Angles | 각 정보를 설정하고 가져옵니다.
Public property | Axis | 게이지 축을 설정하고 가져옵니다.
Public property | BackColor | 비좌표형 차트의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | Decimalpoint | 수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다.
Public property | InnerRectangles | 차트들이 그려질 공간을 설정하고 가져옵니다.
Public property | IsEmptyAutoSetting | 비좌표차트의 공간을 자동으로 설정할 것인가 여부를 설정하고 가져옵니다.
Public property | IsFigureTextLine | 비좌표 차트의 수치 텍스트를 그래프 외부에 표시할 경우 연결 라인을 표시할 것인지 여부를 설정하고 가져옵니다.
Public property | IsShadow | 파이, 도넷 차트 그림자 효과를 줄지 여부를 설정하고 가져옵니다.
Public property | ItemNames | 아이템 이름 정보를 설정하고 가져옵니다.
Public property | Percentages | 퍼센트 정보를 설정하고 가져옵니다.
Public property | PercentLineDisplayValue | 수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.
Public property | Pie3DDepth | 파이 깊이를 설정하고 가져옵니다.
Public property | PieFigures | 수치 정보를 설정하고 가져옵니다.
Public property | PieTypes | 파이 타입를 설정하고 가져옵니다.
Public property | TextLocation | 파이, 피라미드 등 비좌표 차트의 수치 표시 영역을 설정하고 가져옵니다.
Public property | UnAxisDisplayItemType | 파이 등 비좌표 차트에 표시할 수치의 여러 타입을 설정하고 가져옵니다. 기본값은 퍼센트만 표시합니다.

See Also

UnAxisFactors Class


UnAxisFactors Constructor

[image]

.NET Framework Class Library
UnAxisFactors Constructor
UnAxisFactors Class See Also Send Feedback

UnAxisFactors 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public UnAxisFactors()
Visual C++
public:
UnAxisFactors()
JavaScript
Hippo.UnAxisFactors = function();

See Also

UnAxisFactors Class


UnAxisFactors Methods

[image] [image]

.NET Framework Class Library
UnAxisFactors Methods
UnAxisFactors Class See Also Send Feedback

The UnAxisFactors type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UnAxisFactors Class


UnAxisFactors Properties

[image] [image]

.NET Framework Class Library
UnAxisFactors Properties
UnAxisFactors Class See Also Send Feedback

The UnAxisFactors type exposes the following members.

Properties

 | Name | Description
Public property | Angles | 각 정보를 설정하고 가져옵니다.
Public property | Axis | 게이지 축을 설정하고 가져옵니다.
Public property | BackColor | 비좌표형 차트의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.
Public property | Decimalpoint | 수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다.
Public property | InnerRectangles | 차트들이 그려질 공간을 설정하고 가져옵니다.
Public property | IsEmptyAutoSetting | 비좌표차트의 공간을 자동으로 설정할 것인가 여부를 설정하고 가져옵니다.
Public property | IsFigureTextLine | 비좌표 차트의 수치 텍스트를 그래프 외부에 표시할 경우 연결 라인을 표시할 것인지 여부를 설정하고 가져옵니다.
Public property | IsShadow | 파이, 도넷 차트 그림자 효과를 줄지 여부를 설정하고 가져옵니다.
Public property | ItemNames | 아이템 이름 정보를 설정하고 가져옵니다.
Public property | Percentages | 퍼센트 정보를 설정하고 가져옵니다.
Public property | PercentLineDisplayValue | 수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.
Public property | Pie3DDepth | 파이 깊이를 설정하고 가져옵니다.
Public property | PieFigures | 수치 정보를 설정하고 가져옵니다.
Public property | PieTypes | 파이 타입를 설정하고 가져옵니다.
Public property | TextLocation | 파이, 피라미드 등 비좌표 차트의 수치 표시 영역을 설정하고 가져옵니다.
Public property | UnAxisDisplayItemType | 파이 등 비좌표 차트에 표시할 수치의 여러 타입을 설정하고 가져옵니다. 기본값은 퍼센트만 표시합니다.

See Also

UnAxisFactors Class


Angles Property

[image]

.NET Framework Class Library
UnAxisFactors..::..Angles Property
UnAxisFactors Class See Also Send Feedback

각 정보를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Angles As Angles
    Get
    Set
C#
public Angles Angles { get; set; }
Visual C++
public:
property Angles^ Angles {
    Angles^ get ();
    void set (Angles^ value);
}
JavaScript
function get_angles();
function set_angles(value);

See Also

UnAxisFactors Class


Axis Property

[image]

.NET Framework Class Library
UnAxisFactors..::..Axis Property
UnAxisFactors Class See Also Send Feedback

게이지 축을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property Axis As Axis
    Get
    Set
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Axis Axis { get; set; }
Visual C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Axis^ Axis {
    Axis^ get ();
    void set (Axis^ value);
}
JavaScript
function get_axis();
function set_axis(value);

See Also

UnAxisFactors Class


BackColor Property

[image]

.NET Framework Class Library
UnAxisFactors..::..BackColor Property
UnAxisFactors Class See Also Send Feedback

비좌표형 차트의 배경색을 설정하고 가져옵니다. 4.3 버전에서 추가되었습니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property BackColor As Color
    Get
    Set
C#
public Color BackColor { get; set; }
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_backColor();
function set_backColor(value);

See Also

UnAxisFactors Class


Decimalpoint Property

[image]

.NET Framework Class Library
UnAxisFactors..::..Decimalpoint Property
UnAxisFactors Class See Also Send Feedback

수치를 소수점 몇째자리 까지 보여줄 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Decimalpoint As Integer
    Get
    Set
C#
public int Decimalpoint { get; set; }
Visual C++
public:
property int Decimalpoint {
    int get ();
    void set (int value);
}
JavaScript
function get_decimalpoint();
function set_decimalpoint(value);

See Also

UnAxisFactors Class


InnerRectangles Property

[image]

.NET Framework Class Library
UnAxisFactors..::..InnerRectangles Property
UnAxisFactors Class See Also Send Feedback

차트들이 그려질 공간을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property InnerRectangles As RectangleF
    Get
    Set
C#
public RectangleF InnerRectangles { get; set; }
Visual C++
public:
property RectangleF InnerRectangles {
    RectangleF get ();
    void set (RectangleF value);
}
JavaScript
function get_innerRectangles();
function set_innerRectangles(value);

See Also

UnAxisFactors Class


IsEmptyAutoSetting Property

[image]

.NET Framework Class Library
UnAxisFactors..::..IsEmptyAutoSetting Property
UnAxisFactors Class See Also Send Feedback

비좌표차트의 공간을 자동으로 설정할 것인가 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsEmptyAutoSetting As Boolean
    Get
    Set
C#
public bool IsEmptyAutoSetting { get; set; }
Visual C++
public:
property bool IsEmptyAutoSetting {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isEmptyAutoSetting();
function set_isEmptyAutoSetting(value);

See Also

UnAxisFactors Class


IsFigureTextLine Property

[image]

.NET Framework Class Library
UnAxisFactors..::..IsFigureTextLine Property
UnAxisFactors Class See Also Send Feedback

비좌표 차트의 수치 텍스트를 그래프 외부에 표시할 경우 연결 라인을 표시할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsFigureTextLine As Boolean
    Get
    Set
C#
public bool IsFigureTextLine { get; set; }
Visual C++
public:
property bool IsFigureTextLine {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isFigureTextLine();
function set_isFigureTextLine(value);

See Also

UnAxisFactors Class


IsShadow Property

[image]

.NET Framework Class Library
UnAxisFactors..::..IsShadow Property
UnAxisFactors Class See Also Send Feedback

파이, 도넷 차트 그림자 효과를 줄지 여부를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsShadow As Boolean
    Get
    Set
C#
public bool IsShadow { get; set; }
Visual C++
public:
property bool IsShadow {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isShadow();
function set_isShadow(value);

See Also

UnAxisFactors Class


ItemNames Property

[image]

.NET Framework Class Library
UnAxisFactors..::..ItemNames Property
UnAxisFactors Class See Also Send Feedback

아이템 이름 정보를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ItemNames As ItemNames
    Get
    Set
C#
public ItemNames ItemNames { get; set; }
Visual C++
public:
property ItemNames^ ItemNames {
    ItemNames^ get ();
    void set (ItemNames^ value);
}
JavaScript
function get_itemNames();
function set_itemNames(value);

See Also

UnAxisFactors Class


Percentages Property

[image]

.NET Framework Class Library
UnAxisFactors..::..Percentages Property
UnAxisFactors Class See Also Send Feedback

퍼센트 정보를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Percentages As Percentages
    Get
    Set
C#
public Percentages Percentages { get; set; }
Visual C++
public:
property Percentages^ Percentages {
    Percentages^ get ();
    void set (Percentages^ value);
}
JavaScript
function get_percentages();
function set_percentages(value);

See Also

UnAxisFactors Class


PercentLineDisplayValue Property

[image]

.NET Framework Class Library
UnAxisFactors..::..PercentLineDisplayValue Property
UnAxisFactors Class See Also Send Feedback

수치글자를 자동으로 표시할 경우 라인이 그려지는 퍼센트 한계값을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PercentLineDisplayValue As Integer
    Get
    Set
C#
public int PercentLineDisplayValue { get; set; }
Visual C++
public:
property int PercentLineDisplayValue {
    int get ();
    void set (int value);
}
JavaScript
function get_percentLineDisplayValue();
function set_percentLineDisplayValue(value);

See Also

UnAxisFactors Class


Pie3DDepth Property

[image]

.NET Framework Class Library
UnAxisFactors..::..Pie3DDepth Property
UnAxisFactors Class See Also Send Feedback

파이 깊이를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Pie3DDepth As Integer
    Get
    Set
C#
public int Pie3DDepth { get; set; }
Visual C++
public:
property int Pie3DDepth {
    int get ();
    void set (int value);
}
JavaScript
function get_pie3DDepth();
function set_pie3DDepth(value);

See Also

UnAxisFactors Class


PieFigures Property

[image]

.NET Framework Class Library
UnAxisFactors..::..PieFigures Property
UnAxisFactors Class See Also Send Feedback

수치 정보를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PieFigures As PieFigures
    Get
    Set
C#
public PieFigures PieFigures { get; set; }
Visual C++
public:
property PieFigures^ PieFigures {
    PieFigures^ get ();
    void set (PieFigures^ value);
}
JavaScript
function get_pieFigures();
function set_pieFigures(value);

See Also

UnAxisFactors Class


PieTypes Property

[image]

.NET Framework Class Library
UnAxisFactors..::..PieTypes Property
UnAxisFactors Class See Also Send Feedback

파이 타입를 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PieTypes As PieType
    Get
    Set
C#
public PieType PieTypes { get; set; }
Visual C++
public:
property PieType PieTypes {
    PieType get ();
    void set (PieType value);
}
JavaScript
function get_pieTypes();
function set_pieTypes(value);

See Also

UnAxisFactors Class


TextLocation Property

[image]

.NET Framework Class Library
UnAxisFactors..::..TextLocation Property
UnAxisFactors Class See Also Send Feedback

파이, 피라미드 등 비좌표 차트의 수치 표시 영역을 설정하고 가져옵니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property TextLocation As UnAxisFigureTextLocation
    Get
    Set
C#
public UnAxisFigureTextLocation TextLocation { get; set; }
Visual C++
public:
property UnAxisFigureTextLocation TextLocation {
    UnAxisFigureTextLocation get ();
    void set (UnAxisFigureTextLocation value);
}
JavaScript
function get_textLocation();
function set_textLocation(value);

See Also

UnAxisFactors Class


UnAxisDisplayItemType Property

[image]

.NET Framework Class Library
UnAxisFactors..::..UnAxisDisplayItemType Property
UnAxisFactors Class See Also Send Feedback

파이 등 비좌표 차트에 표시할 수치의 여러 타입을 설정하고 가져옵니다. 기본값은 퍼센트만 표시합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property UnAxisDisplayItemType As UnAxisDisplayItemType
    Get
    Set
C#
public UnAxisDisplayItemType UnAxisDisplayItemType { get; set; }
Visual C++
public:
property UnAxisDisplayItemType UnAxisDisplayItemType {
    UnAxisDisplayItemType get ();
    void set (UnAxisDisplayItemType value);
}
JavaScript
function get_unAxisDisplayItemType();
function set_unAxisDisplayItemType(value);

See Also

UnAxisFactors Class


UnAxisFigureTextLocation Enumeration

[image]

.NET Framework Class Library
UnAxisFigureTextLocation Enumeration
See Also Send Feedback

비좌표 차트의 수치 텍스트가 그려지는 영역을 나타냄

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration UnAxisFigureTextLocation
C#
public enum UnAxisFigureTextLocation
Visual C++
public enum class UnAxisFigureTextLocation
JavaScript
Hippo.UnAxisFigureTextLocation = function();
Hippo.UnAxisFigureTextLocation.createEnum('Hippo.UnAxisFigureTextLocation', false);

Members

Member name | Description
Auto |
Inner |
Outer |
Outer2 |

See Also

Hippo Namespace
Send feedback on this topic to Microsoft.


Vector Class

[image]

.NET Framework Class Library
Vector Class
Members See Also Send Feedback

벡터 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class Vector
C#
[SerializableAttribute]
public class Vector
Visual C++
[SerializableAttribute]
public ref class Vector
JavaScript
Hippo.Vector = function();

Type.createClass(
    'Hippo.Vector');

Inheritance Hierarchy

System..::..Object
Hippo..::..Vector

See Also

Vector Members


Vector Members

[image] [image]

.NET Framework Class Library
Vector Members
Vector Class Constructors Methods Properties See Also Send Feedback

The Vector type exposes the following members.

Constructors

 | Name | Description
Public method | Vector()()()() | 벡터 인스턴스를 생성합니다.
Public method | Vector(Double, Double) | 벡터 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | 방향
Public property | Force | 크기
Public property | Stair | 수층
Public property | VertorLine | 벡터라인

See Also

Vector Class


Vector Constructor

[image] [image]

.NET Framework Class Library
Vector Constructor
Vector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector()()()() | 벡터 인스턴스를 생성합니다.
Public method | Vector(Double, Double) | 벡터 인스턴스를 생성합니다.

See Also

Vector Class
Vector Members


Vector Constructor

[image]

.NET Framework Class Library
Vector Constructor
Vector Class See Also Send Feedback

벡터 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public Vector()
Visual C++
public:
Vector()
JavaScript
Hippo.Vector = function();

See Also

Vector Class
Vector Overload


Vector Constructor (Double, Double)

[image]

.NET Framework Class Library
Vector Constructor (Double, Double)
Vector Class See Also Send Feedback

벡터 인스턴스를 생성합니다.

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    direction As Double, _
    force As Double _
)
C#
public Vector(
    double direction,
    double force
)
Visual C++
public:
Vector(
    double direction,
    double force
)
JavaScript
Hippo.Vector = function(direction, force);

Parameters

direction
Type: System..::..Double
방향
force
Type: System..::..Double
크기

See Also

Vector Class
Vector Overload


Vector Methods

[image] [image]

.NET Framework Class Library
Vector Methods
Vector Class See Also Send Feedback

The Vector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Vector Class


Vector Properties

[image] [image]

.NET Framework Class Library
Vector Properties
Vector Class See Also Send Feedback

The Vector type exposes the following members.

Properties

 | Name | Description
Public property | Direction | 방향
Public property | Force | 크기
Public property | Stair | 수층
Public property | VertorLine | 벡터라인

See Also

Vector Class


Direction Property

[image]

.NET Framework Class Library
Vector..::..Direction Property
Vector Class See Also Send Feedback

방향

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Direction As Double
    Get
    Set
C#
public double Direction { get; set; }
Visual C++
public:
property double Direction {
    double get ();
    void set (double value);
}
JavaScript
function get_direction();
function set_direction(value);

See Also

Vector Class


Force Property

[image]

.NET Framework Class Library
Vector..::..Force Property
Vector Class See Also Send Feedback

크기

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Force As Double
    Get
    Set
C#
public double Force { get; set; }
Visual C++
public:
property double Force {
    double get ();
    void set (double value);
}
JavaScript
function get_force();
function set_force(value);

See Also

Vector Class


Stair Property

[image]

.NET Framework Class Library
Vector..::..Stair Property
Vector Class See Also Send Feedback

수층

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Stair As Double
    Get
    Set
C#
public double Stair { get; set; }
Visual C++
public:
property double Stair {
    double get ();
    void set (double value);
}
JavaScript
function get_stair();
function set_stair(value);

See Also

Vector Class


VertorLine Property

[image]

.NET Framework Class Library
Vector..::..VertorLine Property
Vector Class See Also Send Feedback

벡터라인

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Property VertorLine As Line
    Get
    Set
C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public Line VertorLine { get; set; }
Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public:
property Line^ VertorLine {
    Line^ get ();
    void set (Line^ value);
}
JavaScript
function get_vertorLine();
function set_vertorLine(value);

See Also

Vector Class


VectorList Class

[image]

.NET Framework Class Library
VectorList Class
Members See Also Send Feedback

벡터 컬렉션 클래스

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Class VectorList _
    Inherits HippoCollectionBase(Of Vector)
C#
[SerializableAttribute]
public class VectorList : HippoCollectionBase<Vector>
Visual C++
[SerializableAttribute]
public ref class VectorList : public HippoCollectionBase<Vector^>
JavaScript
Hippo.VectorList = function();

Type.createClass(
    'Hippo.VectorList',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Vector >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' Vector >)>)>
Hippo..::..VectorList

See Also

VectorList Members


VectorList Members

[image] [image]

.NET Framework Class Library
VectorList Members
VectorList Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The VectorList type exposes the following members.

Constructors

 | Name | Description
Public method | VectorList |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Vector >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Vector >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Vector >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Vector >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Vector >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class


VectorList Constructor

[image]

.NET Framework Class Library
VectorList Constructor
VectorList Class See Also Send Feedback

Namespace: Hippo
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public VectorList()
Visual C++
public:
VectorList()
JavaScript
Hippo.VectorList = function();

See Also

VectorList Class


VectorList Methods

[image] [image]

.NET Framework Class Library
VectorList Methods
VectorList Class See Also Send Feedback

The VectorList type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' Vector >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' Vector >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
VectorList..::..BinarySearch Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


CopyTo Method

[image] [image]

.NET Framework Class Library
VectorList..::..CopyTo Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


FindIndex Method

[image] [image]

.NET Framework Class Library
VectorList..::..FindIndex Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


FindLastIndex Method

[image] [image]

.NET Framework Class Library
VectorList..::..FindLastIndex Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


IndexOf Method

[image] [image]

.NET Framework Class Library
VectorList..::..IndexOf Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


LastIndexOf Method

[image] [image]

.NET Framework Class Library
VectorList..::..LastIndexOf Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


Reverse Method

[image] [image]

.NET Framework Class Library
VectorList..::..Reverse Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


Sort Method

[image] [image]

.NET Framework Class Library
VectorList..::..Sort Method
VectorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class
VectorList Members


VectorList Properties

[image] [image]

.NET Framework Class Library
VectorList Properties
VectorList Class See Also Send Feedback

The VectorList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' Vector >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' Vector >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' Vector >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' Vector >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' Vector >)>)>.)

See Also

VectorList Class


Hippo.specialcharts Namespace

[image]

.NET Framework Class Library
Hippo.specialcharts Namespace
Send Feedback

Delegates

 | Delegate | Description
Public delegate | RendererFunction |


RendererFunction Delegate

[image]

.NET Framework Class Library
RendererFunction Delegate
See Also Send Feedback

Namespace: Hippo.specialcharts
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Delegate Function RendererFunction ( _
    x As Double, _
    y As Double _
) As Double
C#
public delegate double RendererFunction(
    double x,
    double y
)
Visual C++
public delegate double RendererFunction(
    double x,
    double y
)
JavaScript
function(x, y);

Parameters

x
Type: System..::..Double
y
Type: System..::..Double

See Also

Hippo.specialcharts Namespace


Hippo.WindowsForm4 Namespace

[image]

.NET Framework Class Library
Hippo.WindowsForm4 Namespace
Send Feedback

Classes

 | Class | Description
Public class | ChartDataBindingEventArgs | ChartDataBindingEventArg
Public class | ContextMenuEventArgs | ContextMenuEventArg
Public class | hHippoChart | 히포차트 윈도우즈 폼 컨트롤
Public class | HippoRealTimeAttribute | HippoRealTimeAttribute
Public class | HippoRealTimeAttributeCollection | HippoRealTimeAttributeCollection
Public class | PropertyEditorForm | PropertyEditorForm
Public class | sHippoChart | 히포차트 윈도우즈 폼 스크롤링 컨트롤

Delegates

 | Delegate | Description
Public delegate | ChartDataBindingEventHandler | ContextMenuEventHandler
Public delegate | ContextMenuEventHandler | ContextMenuEventHandler

Enumerations

 | Enumeration | Description
Public enumeration | ContextMenuType | ContextMenuType - 오른쪽 버튼 기능
Public enumeration | LicenseTypes | 라이선스 타입
Public enumeration | ZoomStatus | 현재 줌 상태를 나타냅니다.


ChartDataBindingEventArgs Class

[image]

.NET Framework Class Library
ChartDataBindingEventArgs Class
Members See Also Send Feedback

ChartDataBindingEventArg

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class ChartDataBindingEventArgs _
    Inherits EventArgs
C#
public class ChartDataBindingEventArgs : EventArgs
Visual C++
public ref class ChartDataBindingEventArgs : public EventArgs
JavaScript
Hippo.WindowsForm4.ChartDataBindingEventArgs = function();

Type.createClass(
    'Hippo.WindowsForm4.ChartDataBindingEventArgs',
    EventArgs);

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Hippo.WindowsForm4..::..ChartDataBindingEventArgs

See Also

ChartDataBindingEventArgs Members
Hippo.WindowsForm4 Namespace


ChartDataBindingEventArgs Members

[image] [image]

.NET Framework Class Library
ChartDataBindingEventArgs Members
ChartDataBindingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ChartDataBindingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ChartDataBindingEventArgs | ChartDataBindingEventArg 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Value

See Also

ChartDataBindingEventArgs Class
Hippo.WindowsForm4 Namespace


ChartDataBindingEventArgs Constructor

[image]

.NET Framework Class Library
ChartDataBindingEventArgs Constructor
ChartDataBindingEventArgs Class See Also Send Feedback

ChartDataBindingEventArg 인스턴스를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public ChartDataBindingEventArgs()
Visual C++
public:
ChartDataBindingEventArgs()
JavaScript
Hippo.WindowsForm4.ChartDataBindingEventArgs = function();

See Also

ChartDataBindingEventArgs Class
Hippo.WindowsForm4 Namespace


ChartDataBindingEventArgs Methods

[image] [image]

.NET Framework Class Library
ChartDataBindingEventArgs Methods
ChartDataBindingEventArgs Class See Also Send Feedback

The ChartDataBindingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChartDataBindingEventArgs Class
Hippo.WindowsForm4 Namespace


ChartDataBindingEventArgs Properties

[image] [image]

.NET Framework Class Library
ChartDataBindingEventArgs Properties
ChartDataBindingEventArgs Class See Also Send Feedback

The ChartDataBindingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Value | Value

See Also

ChartDataBindingEventArgs Class
Hippo.WindowsForm4 Namespace


Value Property

[image]

.NET Framework Class Library
ChartDataBindingEventArgs..::..Value Property
ChartDataBindingEventArgs Class See Also Send Feedback

Value

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Value As String
    Get
    Set
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

ChartDataBindingEventArgs Class
Hippo.WindowsForm4 Namespace


ChartDataBindingEventHandler Delegate

[image]

.NET Framework Class Library
ChartDataBindingEventHandler Delegate
See Also Send Feedback

ContextMenuEventHandler

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Delegate Sub ChartDataBindingEventHandler ( _
    sender As Object, _
    e As ChartDataBindingEventArgs _
)
C#
public delegate void ChartDataBindingEventHandler(
    Object sender,
    ChartDataBindingEventArgs e
)
Visual C++
public delegate void ChartDataBindingEventHandler(
    Object^ sender,
    ChartDataBindingEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::..Object
e
Type: Hippo.WindowsForm4..::..ChartDataBindingEventArgs

See Also

Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Class

[image]

.NET Framework Class Library
ContextMenuEventArgs Class
Members See Also Send Feedback

ContextMenuEventArg

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class ContextMenuEventArgs _
    Inherits EventArgs
C#
public class ContextMenuEventArgs : EventArgs
Visual C++
public ref class ContextMenuEventArgs : public EventArgs
JavaScript
Hippo.WindowsForm4.ContextMenuEventArgs = function();

Type.createClass(
    'Hippo.WindowsForm4.ContextMenuEventArgs',
    EventArgs);

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Hippo.WindowsForm4..::..ContextMenuEventArgs

See Also

ContextMenuEventArgs Members
Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Members

[image] [image]

.NET Framework Class Library
ContextMenuEventArgs Members
ContextMenuEventArgs Class Constructors Methods Properties Events See Also Send Feedback

The ContextMenuEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ContextMenuEventArgs | ContextMenuEventArg 인스턴스를 생성합니다.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClick | ContextMenu Click Event Handler
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Cancel
Public property | ContextMenuType | ContextMenuType
Public property | Image | Icon Image
Public property | Name | Name

Events

 | Name | Description
Public event | Click | ContextMenu Click Event

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Constructor

[image]

.NET Framework Class Library
ContextMenuEventArgs Constructor
ContextMenuEventArgs Class See Also Send Feedback

ContextMenuEventArg 인스턴스를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    contextMenuType As ContextMenuType, _
    thisItem As ToolStripItem _
)
C#
public ContextMenuEventArgs(
    ContextMenuType contextMenuType,
    ToolStripItem thisItem
)
Visual C++
public:
ContextMenuEventArgs(
    ContextMenuType contextMenuType,
    ToolStripItem^ thisItem
)
JavaScript
Hippo.WindowsForm4.ContextMenuEventArgs = function(contextMenuType, thisItem);

Parameters

contextMenuType
Type: Hippo.WindowsForm4..::..ContextMenuType
thisItem
Type: System.Windows.Forms..::..ToolStripItem

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Methods

[image] [image]

.NET Framework Class Library
ContextMenuEventArgs Methods
ContextMenuEventArgs Class See Also Send Feedback

The ContextMenuEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClick | ContextMenu Click Event Handler
Public method | ToString | (Inherited from Object.)

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


OnClick Method

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..OnClick Method
ContextMenuEventArgs Class See Also Send Feedback

ContextMenu Click Event Handler

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnClick ( _
    e As EventArgs _
)
C#
protected virtual void OnClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnClick(
    EventArgs^ e
)
JavaScript
function onClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Properties

[image] [image]

.NET Framework Class Library
ContextMenuEventArgs Properties
ContextMenuEventArgs Class See Also Send Feedback

The ContextMenuEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Cancel
Public property | ContextMenuType | ContextMenuType
Public property | Image | Icon Image
Public property | Name | Name

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


Cancel Property

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..Cancel Property
ContextMenuEventArgs Class See Also Send Feedback

Cancel

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Cancel As Boolean
    Get
    Set
C#
public bool Cancel { get; set; }
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cancel();
function set_cancel(value);

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuType Property

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..ContextMenuType Property
ContextMenuEventArgs Class See Also Send Feedback

ContextMenuType

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ContextMenuType As ContextMenuType
    Get
C#
public ContextMenuType ContextMenuType { get; }
Visual C++
public:
property ContextMenuType ContextMenuType {
    ContextMenuType get ();
}
JavaScript
function get_contextMenuType();

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


Image Property

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..Image Property
ContextMenuEventArgs Class See Also Send Feedback

Icon Image

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Image As Bitmap
    Get
    Set
C#
public Bitmap Image { get; set; }
Visual C++
public:
property Bitmap^ Image {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
JavaScript
function get_image();
function set_image(value);

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


Name Property

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..Name Property
ContextMenuEventArgs Class See Also Send Feedback

Name

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuEventArgs Events

[image] [image]

.NET Framework Class Library
ContextMenuEventArgs Events
ContextMenuEventArgs Class See Also Send Feedback

The ContextMenuEventArgs type exposes the following members.

Events

 | Name | Description
Public event | Click | ContextMenu Click Event

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


Click Event

[image]

.NET Framework Class Library
ContextMenuEventArgs..::..Click Event
ContextMenuEventArgs Class See Also Send Feedback

ContextMenu Click Event

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event Click As EventHandler
C#
public event EventHandler Click
Visual C++
public:
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_click(value);
function remove_click(value);

See Also

ContextMenuEventArgs Class
Hippo.WindowsForm4 Namespace


ContextMenuEventHandler Delegate

[image]

.NET Framework Class Library
ContextMenuEventHandler Delegate
See Also Send Feedback

ContextMenuEventHandler

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Delegate Sub ContextMenuEventHandler ( _
    sender As Object, _
    e As ContextMenuEventArgs _
)
C#
public delegate void ContextMenuEventHandler(
    Object sender,
    ContextMenuEventArgs e
)
Visual C++
public delegate void ContextMenuEventHandler(
    Object^ sender,
    ContextMenuEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::..Object
e
Type: Hippo.WindowsForm4..::..ContextMenuEventArgs

See Also

Hippo.WindowsForm4 Namespace


ContextMenuType Enumeration

[image]

.NET Framework Class Library
ContextMenuType Enumeration
See Also Send Feedback

ContextMenuType - 오른쪽 버튼 기능

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ContextMenuType
C#
public enum ContextMenuType
Visual C++
public enum class ContextMenuType
JavaScript
Hippo.WindowsForm4.ContextMenuType = function();
Hippo.WindowsForm4.ContextMenuType.createEnum('Hippo.WindowsForm4.ContextMenuType', false);

Members

Member name | Description
Save |
ChartType |
LegendBox |
Effect |
Tools |
Copy |
UserMenu1 |
UserMenu2 |
UserMenu3 |
UserMenu4 |
UserMenu5 |
UserMenu6 |
UserMenu7 |
UserMenu8 |
UserMenu9 |
UserMenu10 |

See Also

Hippo.WindowsForm4 Namespace


hHippoChart Class

[image]

.NET Framework Class Library
hHippoChart Class
Members See Also Send Feedback

히포차트 윈도우즈 폼 컨트롤

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<ToolboxBitmapAttribute("C:\Program Files (x86)\Hippochart 4.3\winform\images\hhippo.bmp")> _
Public Class hHippoChart _
    Inherits UserControl _
    Implements IChart
C#
[ToolboxBitmapAttribute("C:\Program Files (x86)\Hippochart 4.3\winform\images\hhippo.bmp")]
public class hHippoChart : UserControl,
    IChart
Visual C++
[ToolboxBitmapAttribute(L"C:\Program Files (x86)\Hippochart 4.3\winform\images\hhippo.bmp")]
public ref class hHippoChart : public UserControl,
    IChart
JavaScript
Hippo.WindowsForm4.hHippoChart = function();

Type.createClass(
    'Hippo.WindowsForm4.hHippoChart',
    UserControl,
    Hippo.IChart);

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Hippo.WindowsForm4..::..hHippoChart

See Also

hHippoChart Members
Hippo.WindowsForm4 Namespace


hHippoChart Members

[image] [image]

.NET Framework Class Library
hHippoChart Members
hHippoChart Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The hHippoChart type exposes the following members.

Constructors

 | Name | Description
Public method | hHippoChart | hHippoChart 인스턴스를 생성합니다.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | ChangeChartTypes | 차트 전체의 차트 타입을 변경합니다.
Public method | Contains | (Inherited from Control.)
Public method | CopyToClipboard | 클립보드로 차트 이미지를 저장합니다.
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | doc_PrintPage | 프린트 이벤트 핸들러
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.
Public method | DrawDefault | 차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)
Public method | DrawRealTimeChart(Double, Int32) | 실시간 데이터를 그립니다.
Public method | DrawRealTimeChart(Int32, array<SeriesItem>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(Int32, array<Double>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(SeriesItem, Int32) | 실시간 데이터를 그립니다.
Public method | DrawSampleChart | 샘플 차트를 그립니다.
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Public method | ExportCSV | CSV 내보내기
Public method | ExportExcel | 엑셀 내보내기
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Control.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Control.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnChartClick | OnChartClick 이벤트
Protected method | OnChartContextMenuAdded | OnChartContextMenuAdded 이벤트
Protected method | OnChartDesignTypeChanged | OnChartDesignTypeChanged 이벤트
Protected method | OnChartDoubleClick | OnChartDoubleClick 이벤트
Protected method | OnChartMouseClick | OnChartMouseClick 이벤트
Protected method | OnChartMouseDoubleClick | OnChartMouseDoubleClick
Protected method | OnChartMouseDown | OnChartMouseDown
Protected method | OnChartMouseDrag | OnChartMouseLeave
Protected method | OnChartMouseEnter | OnChartMouseEnter
Protected method | OnChartMouseHover | ChartMouseHover
Protected method | OnChartMouseLeave | OnChartMouseLeave
Protected method | OnChartMouseMove | OnChartMouseMove
Protected method | OnChartMouseUp | OnChartMouseUp
Protected method | OnChartSizeChanged | OnChartSizeChanged 이벤트
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDataBinging | OnDataBinging 이벤트
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Control.)
Protected method | OnEnter | (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Control.)
Protected method | OnHandleDestroyed | (Inherited from Control.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | OnLoad 이벤트 (Overrides UserControl..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Control.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Control.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Public method | Print | 차트 이미지를 인쇄합니다.
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetAll | 차트의 모든 설정을 초기화합니다,
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetData | 차트의 데이터를 초기화 합니다.(시리즈 리스트 초기화)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRealTimeData | 실시간 데이터 셋을 초기화합니다.
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | SaveImage | 차트 이미지를 저장합니다.
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Control.)
Protected method | SetClientSizeCore | (Inherited from Control.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | HippoChart Beta v3.1 (since 2007.09) (Overrides Component..::..ToString()()()().)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ChartFileName | 차트 이미지 파일 이름을 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Protected property | DesignMode | (Inherited from Component.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | DragRectangle | 차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsDrag | 마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsUseContextMenu | 콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Location | (Inherited from Control.)
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | Message | 히포차트에서 발생하는 각종 메세지를 가져옵니다.
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProcessorType | CPU 플랫폼 타입을 설정하고 가져옵니다.
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RealTimeList | 실시간 차트 셋을 설정하고 가져옵니다.
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Protected property | ShowFocusCues | (Inherited from Control.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | ChartClick | 차트가 클릭될 때 발생합니다.
Public event | ChartContextMenuCreated | 차트 컨텍스트메뉴가 생성될 때 발생합니다.
Public event | ChartDataBinging | 이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다. (사용 중지된 이벤트)
Public event | ChartDesignTypeChanged | 차트 디자인타입이 변경될때 발생합니다.
Public event | ChartDoubleClick | 차트를 더블 클릭될 때 발생합니다.
Public event | ChartMouseClick | 차트에 마우스를 클릭될 때 발생합니다.
Public event | ChartMouseDoubleClick | 차트에 마우스를 더블클릭될 때 발생합니다.
Public event | ChartMouseDown | 차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.
Public event | ChartMouseDrag | 차트에 마우스를 드래그 할때 발생합니다.
Public event | ChartMouseEnter | 차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.
Public event | ChartMouseHover | 차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.
Public event | ChartMouseLeave | 차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.
Public event | ChartMouseMove | 차트에 마우스가 있을때 마우스가 움직이면 발생합니다.
Public event | ChartMouseUp | 차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.
Public event | ChartPrinting | 차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.
Public event | ChartSizeChanged | 차트 사이즈가 변경될때 발생합니다.
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


hHippoChart Constructor

[image]

.NET Framework Class Library
hHippoChart Constructor
hHippoChart Class See Also Send Feedback

hHippoChart 인스턴스를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public hHippoChart()
Visual C++
public:
hHippoChart()
JavaScript
Hippo.WindowsForm4.hHippoChart = function();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


hHippoChart Methods

[image] [image]

.NET Framework Class Library
hHippoChart Methods
hHippoChart Class See Also Send Feedback

The hHippoChart type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | ChangeChartTypes | 차트 전체의 차트 타입을 변경합니다.
Public method | Contains | (Inherited from Control.)
Public method | CopyToClipboard | 클립보드로 차트 이미지를 저장합니다.
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | doc_PrintPage | 프린트 이벤트 핸들러
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.
Public method | DrawDefault | 차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)
Public method | DrawRealTimeChart(Double, Int32) | 실시간 데이터를 그립니다.
Public method | DrawRealTimeChart(Int32, array<SeriesItem>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(Int32, array<Double>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(SeriesItem, Int32) | 실시간 데이터를 그립니다.
Public method | DrawSampleChart | 샘플 차트를 그립니다.
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Public method | ExportCSV | CSV 내보내기
Public method | ExportExcel | 엑셀 내보내기
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Control.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Control.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnChartClick | OnChartClick 이벤트
Protected method | OnChartContextMenuAdded | OnChartContextMenuAdded 이벤트
Protected method | OnChartDesignTypeChanged | OnChartDesignTypeChanged 이벤트
Protected method | OnChartDoubleClick | OnChartDoubleClick 이벤트
Protected method | OnChartMouseClick | OnChartMouseClick 이벤트
Protected method | OnChartMouseDoubleClick | OnChartMouseDoubleClick
Protected method | OnChartMouseDown | OnChartMouseDown
Protected method | OnChartMouseDrag | OnChartMouseLeave
Protected method | OnChartMouseEnter | OnChartMouseEnter
Protected method | OnChartMouseHover | ChartMouseHover
Protected method | OnChartMouseLeave | OnChartMouseLeave
Protected method | OnChartMouseMove | OnChartMouseMove
Protected method | OnChartMouseUp | OnChartMouseUp
Protected method | OnChartSizeChanged | OnChartSizeChanged 이벤트
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDataBinging | OnDataBinging 이벤트
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Control.)
Protected method | OnEnter | (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Control.)
Protected method | OnHandleDestroyed | (Inherited from Control.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | OnLoad 이벤트 (Overrides UserControl..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Control.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Control.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Public method | Print | 차트 이미지를 인쇄합니다.
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetAll | 차트의 모든 설정을 초기화합니다,
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetData | 차트의 데이터를 초기화 합니다.(시리즈 리스트 초기화)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRealTimeData | 실시간 데이터 셋을 초기화합니다.
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | SaveImage | 차트 이미지를 저장합니다.
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Control.)
Protected method | SetClientSizeCore | (Inherited from Control.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | HippoChart Beta v3.1 (since 2007.09) (Overrides Component..::..ToString()()()().)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..AccessibilityNotifyClients Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


BeginInvoke Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..BeginInvoke Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


ChangeChartTypes Method

[image]

.NET Framework Class Library
hHippoChart..::..ChangeChartTypes Method
hHippoChart Class See Also Send Feedback

차트 전체의 차트 타입을 변경합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ChangeChartTypes ( _
    type As ChartType _
)
C#
public void ChangeChartTypes(
    ChartType type
)
Visual C++
public:
void ChangeChartTypes(
    ChartType type
)
JavaScript
function changeChartTypes(type);

Parameters

type
Type: Hippo..::..ChartType
변경할 차트 타입

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


CopyToClipboard Method

[image]

.NET Framework Class Library
hHippoChart..::..CopyToClipboard Method
hHippoChart Class See Also Send Feedback

클립보드로 차트 이미지를 저장합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub CopyToClipboard
C#
public void CopyToClipboard()
Visual C++
public:
void CopyToClipboard()
JavaScript
function copyToClipboard();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Dispose Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
hHippoChart..::..Dispose Method (Boolean)
hHippoChart Class See Also Send Feedback

사용 중인 모든 리소스를 정리합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
관리되는 리소스를 삭제해야 하면 true이고, 그렇지 않으면 false입니다.

See Also

hHippoChart Class
Dispose Overload
Hippo.WindowsForm4 Namespace


doc_PrintPage Method

[image]

.NET Framework Class Library
hHippoChart..::..doc_PrintPage Method
hHippoChart Class See Also Send Feedback

프린트 이벤트 핸들러

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub doc_PrintPage ( _
    sender As Object, _
    e As PrintPageEventArgs _
)
C#
public void doc_PrintPage(
    Object sender,
    PrintPageEventArgs e
)
Visual C++
public:
void doc_PrintPage(
    Object^ sender,
    PrintPageEventArgs^ e
)
JavaScript
function doc_PrintPage(sender, e);

Parameters

sender
Type: System..::..Object
e
Type: System.Drawing.Printing..::..PrintPageEventArgs

Remarks

차트 실행 후 오른쪽 버튼/도구/인쇄 메뉴를 실행합니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


DrawChart Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..DrawChart Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


DrawChart Method

[image]

.NET Framework Class Library
hHippoChart..::..DrawChart Method
hHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart
C#
public void DrawChart()
Visual C++
public:
virtual void DrawChart() sealed
JavaScript
function drawChart();

Implements

IChart..::..DrawChart()()()()

Remarks

히포차트 기본 드로잉 메소드로 기존 설정 사항 그대로 다시 그립니다 (새로고침). 실시간 차트 구현 시 이용하기도 합니다.

See Also

hHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (SeriesList)

[image]

.NET Framework Class Library
hHippoChart..::..DrawChart Method (SeriesList)
hHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    SeriesList As SeriesList _
)
C#
public void DrawChart(
    SeriesList SeriesList
)
Visual C++
public:
virtual void DrawChart(
    SeriesList^ SeriesList
) sealed
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesList
시리즈리스트

Implements

IChart..::..DrawChart(SeriesList)

See Also

hHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (SeriesListDictionary)

[image]

.NET Framework Class Library
hHippoChart..::..DrawChart Method (SeriesListDictionary)
hHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    SeriesListDictionary As SeriesListDictionary _
)
C#
public void DrawChart(
    SeriesListDictionary SeriesListDictionary
)
Visual C++
public:
virtual void DrawChart(
    SeriesListDictionary^ SeriesListDictionary
) sealed
JavaScript
function drawChart(SeriesListDictionary);

Parameters

SeriesListDictionary
Type: Hippo..::..SeriesListDictionary
시리즈리스트 컬렉션

Implements

IChart..::..DrawChart(SeriesListDictionary)

See Also

hHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (DataTable, String, String[])

[image]

.NET Framework Class Library
hHippoChart..::..DrawChart Method (DataTable, String, array<String>[]()[][])
hHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    ChartSource As DataTable, _
    nameColumn As String, _
    ParamArray valueColumns As String() _
)
C#
public void DrawChart(
    DataTable ChartSource,
    string nameColumn,
    params string[] valueColumns
)
Visual C++
public:
void DrawChart(
    DataTable^ ChartSource,
    String^ nameColumn,
    ... array<String^>^ valueColumns
)
JavaScript
function drawChart(ChartSource, nameColumn, ... valueColumns);

Parameters

ChartSource
Type: System.Data..::..DataTable
데이터 소스
nameColumn
Type: System..::..String
이름 컬럼(x 축)
valueColumns
Type: array< System..::..String >[]()[][]
값 컬럼(y 축)

See Also

hHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawDefault Method

[image]

.NET Framework Class Library
hHippoChart..::..DrawDefault Method
hHippoChart Class See Also Send Feedback

차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawDefault
C#
public void DrawDefault()
Visual C++
public:
virtual void DrawDefault() sealed
JavaScript
function drawDefault();

Implements

IChart..::..DrawDefault()()()()

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


DrawRealTimeChart Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..DrawRealTimeChart Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRealTimeChart(Double, Int32) | 실시간 데이터를 그립니다.
Public method | DrawRealTimeChart(Int32, array<SeriesItem>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(Int32, array<Double>[]()[][]) | 실시간 데이터를 그립니다.(멀티 시리즈)
Public method | DrawRealTimeChart(SeriesItem, Int32) | 실시간 데이터를 그립니다.

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


DrawRealTimeChart Method (Double, Int32)

[image]

.NET Framework Class Library
hHippoChart..::..DrawRealTimeChart Method (Double, Int32)
hHippoChart Class See Also Send Feedback

실시간 데이터를 그립니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawRealTimeChart ( _
    data As Double, _
    maxDataCount As Integer _
)
C#
public void DrawRealTimeChart(
    double data,
    int maxDataCount
)
Visual C++
public:
void DrawRealTimeChart(
    double data,
    int maxDataCount
)
JavaScript
function drawRealTimeChart(data, maxDataCount);

Parameters

data
Type: System..::..Double
현재 그릴 값
maxDataCount
Type: System..::..Int32
한 화면에 보여질 데이터 개수

Remarks

Timer, Threading 등 을 통해 반복적으로 호출합니다. 첫번재 시리즈 리스트의 첫번째 시리즈에 값을 추가합니다.

See Also

hHippoChart Class
DrawRealTimeChart Overload
Hippo.WindowsForm4 Namespace


DrawRealTimeChart Method (Int32, SeriesItem[])

[image]

.NET Framework Class Library
hHippoChart..::..DrawRealTimeChart Method (Int32, array<SeriesItem>[]()[][])
hHippoChart Class See Also Send Feedback

실시간 데이터를 그립니다.(멀티 시리즈)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawRealTimeChart ( _
    maxDataCount As Integer, _
    ParamArray data As SeriesItem() _
)
C#
public void DrawRealTimeChart(
    int maxDataCount,
    params SeriesItem[] data
)
Visual C++
public:
void DrawRealTimeChart(
    int maxDataCount,
    ... array<SeriesItem^>^ data
)
JavaScript
function drawRealTimeChart(maxDataCount, ... data);

Parameters

maxDataCount
Type: System..::..Int32
한 화면에 보여지는 데이터 개수
data
Type: array< Hippo..::..SeriesItem >[]()[][]
데이터 배열

Remarks

Timer, Threading 등 을 통해 반복적으로 호출합니다. 멀티 시리즈 실시간 차트로 시리즈 데이터를 순차적 배열로 입력합니다.

See Also

hHippoChart Class
DrawRealTimeChart Overload
Hippo.WindowsForm4 Namespace


DrawRealTimeChart Method (Int32, Double[])

[image]

.NET Framework Class Library
hHippoChart..::..DrawRealTimeChart Method (Int32, array<Double>[]()[][])
hHippoChart Class See Also Send Feedback

실시간 데이터를 그립니다.(멀티 시리즈)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawRealTimeChart ( _
    maxDataCount As Integer, _
    ParamArray data As Double() _
)
C#
public void DrawRealTimeChart(
    int maxDataCount,
    params double[] data
)
Visual C++
public:
void DrawRealTimeChart(
    int maxDataCount,
    ... array<double>^ data
)
JavaScript
function drawRealTimeChart(maxDataCount, ... data);

Parameters

maxDataCount
Type: System..::..Int32
한 화면에 보여지는 데이터 개수
data
Type: array< System..::..Double >[]()[][]
데이터 배열

Remarks

Timer, Threading 등 을 통해 반복적으로 호출합니다. 멀티 시리즈 실시간 차트로 시리즈 데이터를 순차적 배열로 입력합니다.

See Also

hHippoChart Class
DrawRealTimeChart Overload
Hippo.WindowsForm4 Namespace


DrawRealTimeChart Method (SeriesItem, Int32)

[image]

.NET Framework Class Library
hHippoChart..::..DrawRealTimeChart Method (SeriesItem, Int32)
hHippoChart Class See Also Send Feedback

실시간 데이터를 그립니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawRealTimeChart ( _
    data As SeriesItem, _
    maxDataCount As Integer _
)
C#
public void DrawRealTimeChart(
    SeriesItem data,
    int maxDataCount
)
Visual C++
public:
void DrawRealTimeChart(
    SeriesItem^ data,
    int maxDataCount
)
JavaScript
function drawRealTimeChart(data, maxDataCount);

Parameters

data
Type: Hippo..::..SeriesItem
현재 그릴 값
maxDataCount
Type: System..::..Int32
한 화면에 보여질 데이터 개수

Remarks

Timer, Threading 등 을 통해 반복적으로 호출합니다. 첫번재 시리즈 리스트의 첫번째 시리즈에 값을 추가합니다.

See Also

hHippoChart Class
DrawRealTimeChart Overload
Hippo.WindowsForm4 Namespace


DrawSampleChart Method

[image]

.NET Framework Class Library
hHippoChart..::..DrawSampleChart Method
hHippoChart Class See Also Send Feedback

샘플 차트를 그립니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawSampleChart
C#
public void DrawSampleChart()
Visual C++
public:
void DrawSampleChart()
JavaScript
function drawSampleChart();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ExportCSV Method

[image]

.NET Framework Class Library
hHippoChart..::..ExportCSV Method
hHippoChart Class See Also Send Feedback

CSV 내보내기

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ExportCSV ( _
    seriesListIndex As Integer _
)
C#
public void ExportCSV(
    int seriesListIndex
)
Visual C++
public:
void ExportCSV(
    int seriesListIndex
)
JavaScript
function exportCSV(seriesListIndex);

Parameters

seriesListIndex
Type: System..::..Int32
시리즈리스트 인덱스

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ExportExcel Method

[image]

.NET Framework Class Library
hHippoChart..::..ExportExcel Method
hHippoChart Class See Also Send Feedback

엑셀 내보내기

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ExportExcel
C#
public void ExportExcel()
Visual C++
public:
void ExportExcel()
JavaScript
function exportExcel();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..GetChildAtPoint Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Invalidate Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Invalidate Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Invoke Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Invoke Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..MemberwiseClone Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


OnChartClick Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartClick Method
hHippoChart Class See Also Send Feedback

OnChartClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartClick ( _
    e As EventArgs _
)
C#
protected virtual void OnChartClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartClick(
    EventArgs^ e
)
JavaScript
function onChartClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartContextMenuAdded Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartContextMenuAdded Method
hHippoChart Class See Also Send Feedback

OnChartContextMenuAdded 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartContextMenuAdded ( _
    e As ContextMenuEventArgs _
)
C#
protected virtual void OnChartContextMenuAdded(
    ContextMenuEventArgs e
)
Visual C++
protected:
virtual void OnChartContextMenuAdded(
    ContextMenuEventArgs^ e
)
JavaScript
function onChartContextMenuAdded(e);

Parameters

e
Type: Hippo.WindowsForm4..::..ContextMenuEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartDesignTypeChanged Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartDesignTypeChanged Method
hHippoChart Class See Also Send Feedback

OnChartDesignTypeChanged 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartDesignTypeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartDesignTypeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartDesignTypeChanged(
    EventArgs^ e
)
JavaScript
function onChartDesignTypeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartDoubleClick Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartDoubleClick Method
hHippoChart Class See Also Send Feedback

OnChartDoubleClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartDoubleClick ( _
    e As EventArgs _
)
C#
protected virtual void OnChartDoubleClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartDoubleClick(
    EventArgs^ e
)
JavaScript
function onChartDoubleClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseClick Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseClick Method
hHippoChart Class See Also Send Feedback

OnChartMouseClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseClick ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseClick(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseClick(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseClick(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDoubleClick Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseDoubleClick Method
hHippoChart Class See Also Send Feedback

OnChartMouseDoubleClick

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDoubleClick ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseDoubleClick(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDoubleClick(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseDoubleClick(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDown Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseDown Method
hHippoChart Class See Also Send Feedback

OnChartMouseDown

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDown ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseDown(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDown(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseDown(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDrag Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseDrag Method
hHippoChart Class See Also Send Feedback

OnChartMouseLeave

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDrag ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseDrag(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDrag(
    EventArgs^ e
)
JavaScript
function onChartMouseDrag(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseEnter Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseEnter Method
hHippoChart Class See Also Send Feedback

OnChartMouseEnter

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseEnter ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseEnter(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseEnter(
    EventArgs^ e
)
JavaScript
function onChartMouseEnter(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseHover Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseHover Method
hHippoChart Class See Also Send Feedback

ChartMouseHover

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseHover ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseHover(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseHover(
    EventArgs^ e
)
JavaScript
function onChartMouseHover(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseLeave Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseLeave Method
hHippoChart Class See Also Send Feedback

OnChartMouseLeave

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseLeave ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseLeave(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseLeave(
    EventArgs^ e
)
JavaScript
function onChartMouseLeave(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseMove Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseMove Method
hHippoChart Class See Also Send Feedback

OnChartMouseMove

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseMove ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseMove(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseMove(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseMove(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseUp Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartMouseUp Method
hHippoChart Class See Also Send Feedback

OnChartMouseUp

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseUp ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseUp(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseUp(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseUp(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartSizeChanged Method

[image]

.NET Framework Class Library
hHippoChart..::..OnChartSizeChanged Method
hHippoChart Class See Also Send Feedback

OnChartSizeChanged 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartSizeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartSizeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartSizeChanged(
    EventArgs^ e
)
JavaScript
function onChartSizeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnDataBinging Method

[image]

.NET Framework Class Library
hHippoChart..::..OnDataBinging Method
hHippoChart Class See Also Send Feedback

OnDataBinging 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnDataBinging ( _
    e As EventArgs _
)
C#
protected virtual void OnDataBinging(
    EventArgs e
)
Visual C++
protected:
virtual void OnDataBinging(
    EventArgs^ e
)
JavaScript
function onDataBinging(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


OnLoad Method

[image]

.NET Framework Class Library
hHippoChart..::..OnLoad Method
hHippoChart Class See Also Send Feedback

OnLoad 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
C#
protected override void OnLoad(
    EventArgs e
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override
JavaScript
function onLoad(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


PerformLayout Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..PerformLayout Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Print Method

[image]

.NET Framework Class Library
hHippoChart..::..Print Method
hHippoChart Class See Also Send Feedback

차트 이미지를 인쇄합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Print ( _
    e As EventArgs _
)
C#
public void Print(
    EventArgs e
)
Visual C++
public:
void Print(
    EventArgs^ e
)
JavaScript
function print(e);

Parameters

e
Type: System..::..EventArgs

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ResetAll Method

[image]

.NET Framework Class Library
hHippoChart..::..ResetAll Method
hHippoChart Class See Also Send Feedback

차트의 모든 설정을 초기화합니다,

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ResetAll
C#
public void ResetAll()
Visual C++
public:
void ResetAll()
JavaScript
function resetAll();

Remarks

반복적으로 호출할 경우 성능에 좋지 않습니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ResetData Method

[image]

.NET Framework Class Library
hHippoChart..::..ResetData Method
hHippoChart Class See Also Send Feedback

차트의 데이터를 초기화 합니다.(시리즈 리스트 초기화)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ResetData
C#
public void ResetData()
Visual C++
public:
void ResetData()
JavaScript
function resetData();

Remarks

반복적으로 호출할 경우 성능에 좋지 않습니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ResetRealTimeData Method

[image]

.NET Framework Class Library
hHippoChart..::..ResetRealTimeData Method
hHippoChart Class See Also Send Feedback

실시간 데이터 셋을 초기화합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub ResetRealTimeData
C#
public void ResetRealTimeData()
Visual C++
public:
void ResetRealTimeData()
JavaScript
function resetRealTimeData();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ResumeLayout Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..ResumeLayout Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..RtlTranslateAlignment Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


SaveImage Method

[image]

.NET Framework Class Library
hHippoChart..::..SaveImage Method
hHippoChart Class See Also Send Feedback

차트 이미지를 저장합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub SaveImage ( _
    ImageName As String, _
    format As ImageFormat _
)
C#
public void SaveImage(
    string ImageName,
    ImageFormat format
)
Visual C++
public:
void SaveImage(
    String^ ImageName,
    ImageFormat^ format
)
JavaScript
function saveImage(ImageName, format);

Parameters

ImageName
Type: System..::..String
차트 이미지 전체 경로 (예: C:\My Pictures\hippoChart.png )
format
Type: System.Drawing.Imaging..::..ImageFormat
차트 이미지 포맷(예: png, gif, jpg ..)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Scale Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Scale Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Select Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Select Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


SetBounds Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..SetBounds Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


ToString Method

[image]

.NET Framework Class Library
hHippoChart..::..ToString Method
hHippoChart Class See Also Send Feedback

HippoChart Beta v3.1 (since 2007.09)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


UpdateBounds Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..UpdateBounds Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


Validate Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..Validate Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


ValidateChildren Method

[image] [image]

.NET Framework Class Library
hHippoChart..::..ValidateChildren Method
hHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

hHippoChart Class
hHippoChart Members
Hippo.WindowsForm4 Namespace


hHippoChart Properties

[image] [image]

.NET Framework Class Library
hHippoChart Properties
hHippoChart Class See Also Send Feedback

The hHippoChart type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ChartFileName | 차트 이미지 파일 이름을 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Protected property | DesignMode | (Inherited from Component.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | DragRectangle | 차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsDrag | 마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsUseContextMenu | 콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Location | (Inherited from Control.)
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | Message | 히포차트에서 발생하는 각종 메세지를 가져옵니다.
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProcessorType | CPU 플랫폼 타입을 설정하고 가져옵니다.
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RealTimeList | 실시간 차트 셋을 설정하고 가져옵니다.
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Protected property | ShowFocusCues | (Inherited from Control.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.
Public property | WindowTarget | (Inherited from Control.)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartFileName Property

[image]

.NET Framework Class Library
hHippoChart..::..ChartFileName Property
hHippoChart Class See Also Send Feedback

차트 이미지 파일 이름을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ChartFileName As String
    Get
C#
public string ChartFileName { get; }
Visual C++
public:
property String^ ChartFileName {
    String^ get ();
}
JavaScript
function get_chartFileName();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartGraphic Property

[image]

.NET Framework Class Library
hHippoChart..::..ChartGraphic Property
hHippoChart Class Example See Also Send Feedback

차트 그래픽를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartGraphic As Graphics
    Get
    Set
C#
public Graphics ChartGraphic { get; set; }
Visual C++
public:
virtual property Graphics^ ChartGraphic {
    Graphics^ get () sealed;
    void set (Graphics^ value) sealed;
}
JavaScript
function get_chartGraphic();
function set_chartGraphic(value);

Implements

IChart..::..ChartGraphic

Remarks

본 속성을 통해 히포차트의 Drawing 이후에 새로운 사용자 정의 Painting을 처리할 수 있습니다.

Examples

Copy image Copy Code
                    ...
                    this.hHippoChart1.DrawChart();

                    g = Graphics.FromImage(this.hHippoChart1.ChartImage);

                    if (g != null)
                    {
                        g.DrawString(
                        "테스트 글자",
                        new Font("굴림", 20, FontStyle.Italic),
                        new SolidBrush(Color.Red),
                        new PointF(this.hHippoChart1.SeriesListDictionary[0].AxisFactor.CoordinateRectangle.Left + 50, this.hHippoChart1.SeriesListDictionary[0].AxisFactor.CoordinateRectangle.Top + 40)
                   );

                   g.DrawEllipse(Pens.Red, new Rectangle(300, 150, 80, 80));

                   this.hHippoChart1.Refresh();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartID Property

[image]

.NET Framework Class Library
hHippoChart..::..ChartID Property
hHippoChart Class See Also Send Feedback

현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartID As String
    Get
    Set
C#
public string ChartID { get; set; }
Visual C++
public:
virtual property String^ ChartID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_chartID();
function set_chartID(value);

Implements

IChart..::..ChartID

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartImage Property

[image]

.NET Framework Class Library
hHippoChart..::..ChartImage Property
hHippoChart Class See Also Send Feedback

차트 이미지를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartImage As Bitmap
    Get
    Set
C#
public Bitmap ChartImage { get; set; }
Visual C++
public:
virtual property Bitmap^ ChartImage {
    Bitmap^ get () sealed;
    void set (Bitmap^ value) sealed;
}
JavaScript
function get_chartImage();
function set_chartImage(value);

Implements

IChart..::..ChartImage

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartRectangle Property

[image]

.NET Framework Class Library
hHippoChart..::..ChartRectangle Property
hHippoChart Class See Also Send Feedback

히포차트 전체 사각형를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartRectangle As RectangleF
    Get
    Set
C#
public RectangleF ChartRectangle { get; set; }
Visual C++
public:
virtual property RectangleF ChartRectangle {
    RectangleF get () sealed;
    void set (RectangleF value) sealed;
}
JavaScript
function get_chartRectangle();
function set_chartRectangle(value);

Implements

IChart..::..ChartRectangle

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Designer Property

[image]

.NET Framework Class Library
hHippoChart..::..Designer Property
hHippoChart Class See Also Send Feedback

차트 디자이너를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Designer As ChartDesigner
    Get
    Set
C#
[BindableAttribute(true)]
public ChartDesigner Designer { get; set; }
Visual C++
[BindableAttribute(true)]
public:
virtual property ChartDesigner^ Designer {
    ChartDesigner^ get () sealed;
    void set (ChartDesigner^ value) sealed;
}
JavaScript
function get_designer();
function set_designer(value);

Implements

IChart..::..Designer

Remarks

히포차트 바깥쪽 디자인을 담당하는 속성입니다. 전체 배경색을 담당하는 속성은 innerBackColor 입니다. (참고사항)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


DesignType Property

[image]

.NET Framework Class Library
hHippoChart..::..DesignType Property
hHippoChart Class See Also Send Feedback

차트 디자인 타입를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DesignType As ChartDesignType
    Get
    Set
C#
public ChartDesignType DesignType { get; set; }
Visual C++
public:
virtual property ChartDesignType DesignType {
    ChartDesignType get () sealed;
    void set (ChartDesignType value) sealed;
}
JavaScript
function get_designType();
function set_designType(value);

Implements

IChart..::..DesignType

Remarks

디자인타입은 히포차트 3.x 버전에서 많이 사용하던 속성으로 4.2 이상의 버전일 경우 사용을 권장하지 않습니다. 구 샘플코드를 이용하실 경우 해당 줄을 제거해주셔도 좋습니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Direction Property

[image]

.NET Framework Class Library
hHippoChart..::..Direction Property
hHippoChart Class See Also Send Feedback

그래프 영역의 방향를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Direction As GraphAreaLocation
    Get
    Set
C#
public GraphAreaLocation Direction { get; set; }
Visual C++
public:
virtual property GraphAreaLocation Direction {
    GraphAreaLocation get () sealed;
    void set (GraphAreaLocation value) sealed;
}
JavaScript
function get_direction();
function set_direction(value);

Implements

IChart..::..Direction

Remarks

다중 시리즈리스트일 경우에 사용하는 속성으로 시리즈리스트를 수직방향으로 추가, 수평방향으로 추가의 의미로 사용됩니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


DragRectangle Property

[image]

.NET Framework Class Library
hHippoChart..::..DragRectangle Property
hHippoChart Class See Also Send Feedback

차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property DragRectangle As Rectangle
    Get
C#
public Rectangle DragRectangle { get; }
Visual C++
public:
property Rectangle DragRectangle {
    Rectangle get ();
}
JavaScript
function get_dragRectangle();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Height2 Property

[image]

.NET Framework Class Library
hHippoChart..::..Height2 Property
hHippoChart Class See Also Send Feedback

차트 세로 길이를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height2 As Single
    Get
    Set
C#
public float Height2 { get; set; }
Visual C++
public:
virtual property float Height2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_height2();
function set_height2(value);

Implements

IChart..::..Height2

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


IsDrag Property

[image]

.NET Framework Class Library
hHippoChart..::..IsDrag Property
hHippoChart Class See Also Send Feedback

마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDrag As Boolean
    Get
    Set
C#
public bool IsDrag { get; set; }
Visual C++
public:
property bool IsDrag {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDrag();
function set_isDrag(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


IsEmptyanalysis Property

[image]

.NET Framework Class Library
hHippoChart..::..IsEmptyanalysis Property
hHippoChart Class See Also Send Feedback

공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsEmptyanalysis As Boolean
    Get
    Set
C#
public bool IsEmptyanalysis { get; set; }
Visual C++
public:
property bool IsEmptyanalysis {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isEmptyanalysis();
function set_isEmptyanalysis(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


IsUseContextMenu Property

[image]

.NET Framework Class Library
hHippoChart..::..IsUseContextMenu Property
hHippoChart Class See Also Send Feedback

콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsUseContextMenu As Boolean
    Get
    Set
C#
public bool IsUseContextMenu { get; set; }
Visual C++
public:
property bool IsUseContextMenu {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isUseContextMenu();
function set_isUseContextMenu(value);

Remarks

디자인모드에서의 설정을 권장합니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Layout Property

[image]

.NET Framework Class Library
hHippoChart..::..Layout Property
hHippoChart Class See Also Send Feedback

히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Layout As Layout
    Get
    Set
C#
public Layout Layout { get; set; }
Visual C++
public:
virtual property Layout^ Layout {
    Layout^ get () sealed;
    void set (Layout^ value) sealed;
}
JavaScript
function get_layout();
function set_layout(value);

Implements

IChart..::..Layout

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Left Property

[image]

.NET Framework Class Library
hHippoChart..::..Left Property
hHippoChart Class See Also Send Feedback

차트 X 위치를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Left As Single
    Get
    Set
C#
public float Left { get; set; }
Visual C++
public:
virtual property float Left {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_left();
function set_left(value);

Implements

IChart..::..Left

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


LegendBox Property

[image]

.NET Framework Class Library
hHippoChart..::..LegendBox Property
hHippoChart Class See Also Send Feedback

범례를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendBox As LegendBox
    Get
    Set
C#
public LegendBox LegendBox { get; set; }
Visual C++
public:
virtual property LegendBox^ LegendBox {
    LegendBox^ get () sealed;
    void set (LegendBox^ value) sealed;
}
JavaScript
function get_legendBox();
function set_legendBox(value);

Implements

IChart..::..LegendBox

Remarks

해당 속성은 시리즈리스트 레벨에도 존재합니다. 본 속성은 차트 바깥에 표시하는 범례이고 시리즈리스트 레벨의 범례는 차트 내부에 표시됩니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Logo Property

[image]

.NET Framework Class Library
hHippoChart..::..Logo Property
hHippoChart Class See Also Send Feedback

로고를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Logo As Logo
    Get
    Set
C#
public Logo Logo { get; set; }
Visual C++
public:
virtual property Logo^ Logo {
    Logo^ get () sealed;
    void set (Logo^ value) sealed;
}
JavaScript
function get_logo();
function set_logo(value);

Implements

IChart..::..Logo

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Message Property

[image]

.NET Framework Class Library
hHippoChart..::..Message Property
hHippoChart Class See Also Send Feedback

히포차트에서 발생하는 각종 메세지를 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property Message As String
    Get
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}
JavaScript
function get_message();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


PaletteType Property

[image]

.NET Framework Class Library
hHippoChart..::..PaletteType Property
hHippoChart Class See Also Send Feedback

팔레트 종류를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PaletteType As PaletteType
    Get
    Set
C#
public PaletteType PaletteType { get; set; }
Visual C++
public:
virtual property PaletteType PaletteType {
    PaletteType get () sealed;
    void set (PaletteType value) sealed;
}
JavaScript
function get_paletteType();
function set_paletteType(value);

Implements

IChart..::..PaletteType

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ProcessorType Property

[image]

.NET Framework Class Library
hHippoChart..::..ProcessorType Property
hHippoChart Class See Also Send Feedback

CPU 플랫폼 타입을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ProcessorType As String
    Get
    Set
C#
public string ProcessorType { get; set; }
Visual C++
public:
property String^ ProcessorType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorType();
function set_processorType(value);

Remarks

32, 64로 표시되는 플랫폼 타입은 공동작업 시 다른 플랫폼으로 인해 '개체참조가 개체 인스턴스로 설정되지 않았습니다' 라는 에러를 도출할 수 있습니다. 이럴 경우 디자인모드에서 해당 속성 값을 빈 값으로 지우시면 해결됩니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


RealTimeList Property

[image]

.NET Framework Class Library
hHippoChart..::..RealTimeList Property
hHippoChart Class See Also Send Feedback

실시간 차트 셋을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property RealTimeList As HippoRealTimeAttributeCollection
    Get
    Set
C#
public HippoRealTimeAttributeCollection RealTimeList { get; set; }
Visual C++
public:
property HippoRealTimeAttributeCollection^ RealTimeList {
    HippoRealTimeAttributeCollection^ get ();
    void set (HippoRealTimeAttributeCollection^ value);
}
JavaScript
function get_realTimeList();
function set_realTimeList(value);

Remarks

리얼타임리스트는 실시간을 구현하는 시리즈의 개수만큼 Add 를 해주어야합니다.

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


SeriesAreaRate Property

[image]

.NET Framework Class Library
hHippoChart..::..SeriesAreaRate Property
hHippoChart Class See Also Send Feedback

시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesAreaRate As String
    Get
    Set
C#
public string SeriesAreaRate { get; set; }
Visual C++
public:
property String^ SeriesAreaRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_seriesAreaRate();
function set_seriesAreaRate(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


SeriesListDictionary Property

[image]

.NET Framework Class Library
hHippoChart..::..SeriesListDictionary Property
hHippoChart Class See Also Send Feedback

시리즈 리스트 컬렉션를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesListDictionary As SeriesListDictionary
    Get
    Set
C#
public SeriesListDictionary SeriesListDictionary { get; set; }
Visual C++
public:
virtual property SeriesListDictionary^ SeriesListDictionary {
    SeriesListDictionary^ get () sealed;
    void set (SeriesListDictionary^ value) sealed;
}
JavaScript
function get_seriesListDictionary();
function set_seriesListDictionary(value);

Implements

IChart..::..SeriesListDictionary

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Titles Property

[image]

.NET Framework Class Library
hHippoChart..::..Titles Property
hHippoChart Class See Also Send Feedback

차트 타이틀를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Titles As Title
    Get
    Set
C#
public Title Titles { get; set; }
Visual C++
public:
virtual property Title^ Titles {
    Title^ get () sealed;
    void set (Title^ value) sealed;
}
JavaScript
function get_titles();
function set_titles(value);

Implements

IChart..::..Titles

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Top Property

[image]

.NET Framework Class Library
hHippoChart..::..Top Property
hHippoChart Class See Also Send Feedback

차트 Y 위치를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Top As Single
    Get
    Set
C#
public float Top { get; set; }
Visual C++
public:
virtual property float Top {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_top();
function set_top(value);

Implements

IChart..::..Top

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


Width2 Property

[image]

.NET Framework Class Library
hHippoChart..::..Width2 Property
hHippoChart Class See Also Send Feedback

차트 가로길이를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width2 As Single
    Get
    Set
C#
public float Width2 { get; set; }
Visual C++
public:
virtual property float Width2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_width2();
function set_width2(value);

Implements

IChart..::..Width2

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


hHippoChart Events

[image] [image]

.NET Framework Class Library
hHippoChart Events
hHippoChart Class See Also Send Feedback

The hHippoChart type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | ChartClick | 차트가 클릭될 때 발생합니다.
Public event | ChartContextMenuCreated | 차트 컨텍스트메뉴가 생성될 때 발생합니다.
Public event | ChartDataBinging | 이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다. (사용 중지된 이벤트)
Public event | ChartDesignTypeChanged | 차트 디자인타입이 변경될때 발생합니다.
Public event | ChartDoubleClick | 차트를 더블 클릭될 때 발생합니다.
Public event | ChartMouseClick | 차트에 마우스를 클릭될 때 발생합니다.
Public event | ChartMouseDoubleClick | 차트에 마우스를 더블클릭될 때 발생합니다.
Public event | ChartMouseDown | 차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.
Public event | ChartMouseDrag | 차트에 마우스를 드래그 할때 발생합니다.
Public event | ChartMouseEnter | 차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.
Public event | ChartMouseHover | 차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.
Public event | ChartMouseLeave | 차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.
Public event | ChartMouseMove | 차트에 마우스가 있을때 마우스가 움직이면 발생합니다.
Public event | ChartMouseUp | 차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.
Public event | ChartPrinting | 차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.
Public event | ChartSizeChanged | 차트 사이즈가 변경될때 발생합니다.
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartClick Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartClick Event
hHippoChart Class See Also Send Feedback

차트가 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartClick As EventHandler
C#
public event EventHandler ChartClick
Visual C++
public:
 event EventHandler^ ChartClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartClick(value);
function remove_chartClick(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartContextMenuCreated Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartContextMenuCreated Event
hHippoChart Class Example See Also Send Feedback

차트 컨텍스트메뉴가 생성될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartContextMenuCreated As ContextMenuEventHandler
C#
public event ContextMenuEventHandler ChartContextMenuCreated
Visual C++
public:
 event ContextMenuEventHandler^ ChartContextMenuCreated {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
JavaScript
function add_chartContextMenuCreated(value);
function remove_chartContextMenuCreated(value);

Remarks

컨텍스트 메뉴가 생성될 때 발생하는 이벤트를 통해 특정 메뉴를 취소할 수 있습니다.

Examples

Copy image Copy Code
                    private void hHippoChart1_ChartContextMenuCreated(object sender, ContextMenuEventArg e)
                       {
                           if (e.ContextMenuType == Hippo.ChartControl.ContextMenuType.Reset)
                           {
                               e.Cancel = true;
                           }
                        }

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDataBinging Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartDataBinging Event
hHippoChart Class See Also Send Feedback

이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다. (사용 중지된 이벤트)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDataBinging As EventHandler
C#
public event EventHandler ChartDataBinging
Visual C++
public:
 event EventHandler^ ChartDataBinging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDataBinging(value);
function remove_chartDataBinging(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDesignTypeChanged Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartDesignTypeChanged Event
hHippoChart Class See Also Send Feedback

차트 디자인타입이 변경될때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDesignTypeChanged As EventHandler
C#
public event EventHandler ChartDesignTypeChanged
Visual C++
public:
 event EventHandler^ ChartDesignTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDesignTypeChanged(value);
function remove_chartDesignTypeChanged(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDoubleClick Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartDoubleClick Event
hHippoChart Class See Also Send Feedback

차트를 더블 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDoubleClick As EventHandler
C#
public event EventHandler ChartDoubleClick
Visual C++
public:
 event EventHandler^ ChartDoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDoubleClick(value);
function remove_chartDoubleClick(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseClick Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseClick Event
hHippoChart Class See Also Send Feedback

차트에 마우스를 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseClick As MouseEventHandler
C#
public event MouseEventHandler ChartMouseClick
Visual C++
public:
 event MouseEventHandler^ ChartMouseClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseClick(value);
function remove_chartMouseClick(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDoubleClick Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseDoubleClick Event
hHippoChart Class See Also Send Feedback

차트에 마우스를 더블클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler ChartMouseDoubleClick
Visual C++
public:
 event MouseEventHandler^ ChartMouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseDoubleClick(value);
function remove_chartMouseDoubleClick(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDown Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseDown Event
hHippoChart Class See Also Send Feedback

차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDown As MouseEventHandler
C#
public event MouseEventHandler ChartMouseDown
Visual C++
public:
 event MouseEventHandler^ ChartMouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseDown(value);
function remove_chartMouseDown(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDrag Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseDrag Event
hHippoChart Class See Also Send Feedback

차트에 마우스를 드래그 할때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDrag As EventHandler
C#
public event EventHandler ChartMouseDrag
Visual C++
public:
 event EventHandler^ ChartMouseDrag {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseDrag(value);
function remove_chartMouseDrag(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseEnter Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseEnter Event
hHippoChart Class See Also Send Feedback

차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseEnter As EventHandler
C#
public event EventHandler ChartMouseEnter
Visual C++
public:
 event EventHandler^ ChartMouseEnter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseEnter(value);
function remove_chartMouseEnter(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseHover Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseHover Event
hHippoChart Class See Also Send Feedback

차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseHover As EventHandler
C#
public event EventHandler ChartMouseHover
Visual C++
public:
 event EventHandler^ ChartMouseHover {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseHover(value);
function remove_chartMouseHover(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseLeave Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseLeave Event
hHippoChart Class See Also Send Feedback

차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseLeave As EventHandler
C#
public event EventHandler ChartMouseLeave
Visual C++
public:
 event EventHandler^ ChartMouseLeave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseLeave(value);
function remove_chartMouseLeave(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseMove Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseMove Event
hHippoChart Class Example See Also Send Feedback

차트에 마우스가 있을때 마우스가 움직이면 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseMove As MouseEventHandler
C#
public event MouseEventHandler ChartMouseMove
Visual C++
public:
 event MouseEventHandler^ ChartMouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseMove(value);
function remove_chartMouseMove(value);

Remarks

해당 이벤트는 가장 많이 사용되는 이벤트 중 하나로 마우스를 특정 막대, 라인에 갖다대었을 때 Balloon 객체와 함께 수치를 보이게 하거나 마우스를 따라 십자 라인을 그려주는 액션 등에 활용됩니다. 아래 샘플 코드는 라인 차트에 마우스를 갖다댈 경우 풍선 도움말로 수치를 표시해주는 코드입니다.

Examples

Copy image Copy Code
                        private void Form1_Load(object sender, EventArgs e)
                        {
                             this.hHippoChart1.SeriesListDictionary.Clear();

                             SeriesList sList = new SeriesList();
                             sList.ChartType = ChartType.Line;

                             Random r = new Random();

                             for(int i = 0; i[1; i++)
                             {
                                 Series sr = new Series();
                                 sr.Line.LineWidth = 5;
                                 sr.Points.Width = 10;

                                 for(int x = 0; x[ 5; x++)
                                 {
                                     SeriesItem item = new SeriesItem();
                                     item.Name = "item" + x.ToString();
                                     item.YValue = r.Next(900);
                                     item.Balloon = new Balloon();
                                     item.Balloon.Label.Text = item.YValue.ToString();
                                     item.Balloon.Visible = false;

                                     sr.items.Add(item);
                                 }
                                 sList.SeriesCollection.Add(sr);
                             }
                            this.hHippoChart1.SeriesListDictionary.Add(sList);
                            this.hHippoChart1.DrawChart();
                            }

                            private void hHippoChart1_ChartMouseMove(object sender, MouseEventArgs e)
                            {
                                for (int i = 0; i [ this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items.Count; i++)
                                {
                                    float pwidth = this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items[i].Points.Width;
                                    PointF firstpoint
                                    = new PointF
                                    (
                                         this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items[i].FigurePoint.X - pwidth,
                                         this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items[i].FigurePoint.Y - pwidth
                                    );

                                    float lastPoX = (float)(firstpoint.X + pwidth);
                                    float lastPoY = (float)(firstpoint.Y + pwidth);
                                    PointF lastPoint = new PointF(lastPoX, lastPoY);
                                    if (e.X ]= firstpoint.X and e.X [= lastPoint.X and e.Y ]= firstpoint.Y and e.Y [= lastPoint.Y)
                                    {
                                        this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items[i].Balloon.Visible = true;
                                    }
                                    else
                                    {
                                        this.hHippoChart1.SeriesListDictionary[0].SeriesCollection[0].items[i].Balloon.Visible = false;
                                    }
                                }

                                this.hHippoChart1.DrawChart();
                            }
                       }

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseUp Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartMouseUp Event
hHippoChart Class See Also Send Feedback

차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseUp As MouseEventHandler
C#
public event MouseEventHandler ChartMouseUp
Visual C++
public:
 event MouseEventHandler^ ChartMouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseUp(value);
function remove_chartMouseUp(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartPrinting Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartPrinting Event
hHippoChart Class See Also Send Feedback

차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartPrinting As EventHandler
C#
public event EventHandler ChartPrinting
Visual C++
public:
 event EventHandler^ ChartPrinting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartPrinting(value);
function remove_chartPrinting(value);

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


ChartSizeChanged Event

[image]

.NET Framework Class Library
hHippoChart..::..ChartSizeChanged Event
hHippoChart Class Example See Also Send Feedback

차트 사이즈가 변경될때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartSizeChanged As EventHandler
C#
public event EventHandler ChartSizeChanged
Visual C++
public:
 event EventHandler^ ChartSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartSizeChanged(value);
function remove_chartSizeChanged(value);

Remarks

히포차트 윈폼 컨트롤을 더블클릭하면 해당 이벤트가 생성되며 기본 메소드의 호출만으로 차트의 새로고침을 구현합니다.

Examples

Copy image Copy Code
                    hHippochart1.DrawChart();

See Also

hHippoChart Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttribute Class

[image]

.NET Framework Class Library
HippoRealTimeAttribute Class
Members See Also Send Feedback

HippoRealTimeAttribute

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class HippoRealTimeAttribute
C#
public class HippoRealTimeAttribute
Visual C++
public ref class HippoRealTimeAttribute
JavaScript
Hippo.WindowsForm4.HippoRealTimeAttribute = function();

Type.createClass(
    'Hippo.WindowsForm4.HippoRealTimeAttribute');

Inheritance Hierarchy

System..::..Object
Hippo.WindowsForm4..::..HippoRealTimeAttribute

See Also

HippoRealTimeAttribute Members
Hippo.WindowsForm4 Namespace


HippoRealTimeAttribute Members

[image] [image]

.NET Framework Class Library
HippoRealTimeAttribute Members
HippoRealTimeAttribute Class Constructors Methods Properties See Also Send Feedback

The HippoRealTimeAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | HippoRealTimeAttribute | HippoRealTimeAttribute instance

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DataArray | 실시간 데이터 셋 배열을 설정하고 가져옵니다.
Public property | Index | 실시간 데이터 셋의 인덱스 값을 설정하고 가져옵니다.
Public property | RealTimeMaxDataCount | 실시간 데이터 셋의 최대 보여지는 개수를 설정하고 가져옵니다.
Public property | SeriesItemArray | 실시간 데이터 셋 시리즈아이템을 설정하고 가져옵니다.

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttribute Constructor

[image]

.NET Framework Class Library
HippoRealTimeAttribute Constructor
HippoRealTimeAttribute Class See Also Send Feedback

HippoRealTimeAttribute instance

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoRealTimeAttribute()
Visual C++
public:
HippoRealTimeAttribute()
JavaScript
Hippo.WindowsForm4.HippoRealTimeAttribute = function();

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttribute Methods

[image] [image]

.NET Framework Class Library
HippoRealTimeAttribute Methods
HippoRealTimeAttribute Class See Also Send Feedback

The HippoRealTimeAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttribute Properties

[image] [image]

.NET Framework Class Library
HippoRealTimeAttribute Properties
HippoRealTimeAttribute Class See Also Send Feedback

The HippoRealTimeAttribute type exposes the following members.

Properties

 | Name | Description
Public property | DataArray | 실시간 데이터 셋 배열을 설정하고 가져옵니다.
Public property | Index | 실시간 데이터 셋의 인덱스 값을 설정하고 가져옵니다.
Public property | RealTimeMaxDataCount | 실시간 데이터 셋의 최대 보여지는 개수를 설정하고 가져옵니다.
Public property | SeriesItemArray | 실시간 데이터 셋 시리즈아이템을 설정하고 가져옵니다.

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


DataArray Property

[image]

.NET Framework Class Library
HippoRealTimeAttribute..::..DataArray Property
HippoRealTimeAttribute Class See Also Send Feedback

실시간 데이터 셋 배열을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DataArray As Double()
    Get
    Set
C#
public double[] DataArray { get; set; }
Visual C++
public:
property array<double>^ DataArray {
    array<double>^ get ();
    void set (array<double>^ value);
}
JavaScript
function get_dataArray();
function set_dataArray(value);

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


Index Property

[image]

.NET Framework Class Library
HippoRealTimeAttribute..::..Index Property
HippoRealTimeAttribute Class See Also Send Feedback

실시간 데이터 셋의 인덱스 값을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Index As Integer
    Get
    Set
C#
public int Index { get; set; }
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}
JavaScript
function get_index();
function set_index(value);

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


RealTimeMaxDataCount Property

[image]

.NET Framework Class Library
HippoRealTimeAttribute..::..RealTimeMaxDataCount Property
HippoRealTimeAttribute Class See Also Send Feedback

실시간 데이터 셋의 최대 보여지는 개수를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property RealTimeMaxDataCount As Integer
    Get
    Set
C#
public int RealTimeMaxDataCount { get; set; }
Visual C++
public:
property int RealTimeMaxDataCount {
    int get ();
    void set (int value);
}
JavaScript
function get_realTimeMaxDataCount();
function set_realTimeMaxDataCount(value);

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


SeriesItemArray Property

[image]

.NET Framework Class Library
HippoRealTimeAttribute..::..SeriesItemArray Property
HippoRealTimeAttribute Class See Also Send Feedback

실시간 데이터 셋 시리즈아이템을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesItemArray As SeriesItem()
    Get
    Set
C#
public SeriesItem[] SeriesItemArray { get; set; }
Visual C++
public:
property array<SeriesItem^>^ SeriesItemArray {
    array<SeriesItem^>^ get ();
    void set (array<SeriesItem^>^ value);
}
JavaScript
function get_seriesItemArray();
function set_seriesItemArray(value);

See Also

HippoRealTimeAttribute Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttributeCollection Class

[image]

.NET Framework Class Library
HippoRealTimeAttributeCollection Class
Members See Also Send Feedback

HippoRealTimeAttributeCollection

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class HippoRealTimeAttributeCollection _
    Inherits HippoCollectionBase(Of HippoRealTimeAttribute)
C#
public class HippoRealTimeAttributeCollection : HippoCollectionBase<HippoRealTimeAttribute>
Visual C++
public ref class HippoRealTimeAttributeCollection : public HippoCollectionBase<HippoRealTimeAttribute^>
JavaScript
Hippo.WindowsForm4.HippoRealTimeAttributeCollection = function();

Type.createClass(
    'Hippo.WindowsForm4.HippoRealTimeAttributeCollection',
    Hippo.HippoCollectionBase`1);

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' HippoRealTimeAttribute >)>)>
Hippo..::..HippoCollectionBase <(Of <(<' HippoRealTimeAttribute >)>)>
Hippo.WindowsForm4..::..HippoRealTimeAttributeCollection

See Also

HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


HippoRealTimeAttributeCollection Members

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection Members
HippoRealTimeAttributeCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The HippoRealTimeAttributeCollection type exposes the following members.

Constructors

 | Name | Description
Public method | HippoRealTimeAttributeCollection |

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttributeCollection Constructor

[image]

.NET Framework Class Library
HippoRealTimeAttributeCollection Constructor
HippoRealTimeAttributeCollection Class See Also Send Feedback

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public HippoRealTimeAttributeCollection()
Visual C++
public:
HippoRealTimeAttributeCollection()
JavaScript
Hippo.WindowsForm4.HippoRealTimeAttributeCollection = function();

See Also

HippoRealTimeAttributeCollection Class
Hippo.WindowsForm4 Namespace


HippoRealTimeAttributeCollection Methods

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection Methods
HippoRealTimeAttributeCollection Class See Also Send Feedback

The HippoRealTimeAttributeCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | AddRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | AsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Clear | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Contains | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | Exists | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | Find | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLast | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ForEach | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Insert | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | InsertRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveAt | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | RemoveRange | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Reverse()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ToArray | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | ToString | (Inherited from Object.)
Public method | TrimExcess | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | TrueForAll | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
Hippo.WindowsForm4 Namespace


BinarySearch Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..BinarySearch Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


CopyTo Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..CopyTo Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


FindIndex Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..FindIndex Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


FindLastIndex Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..FindLastIndex Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..IndexOf Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


LastIndexOf Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..LastIndexOf Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


Reverse Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..Reverse Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


Sort Method

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection..::..Sort Method
HippoRealTimeAttributeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
HippoRealTimeAttributeCollection Members
Hippo.WindowsForm4 Namespace


HippoRealTimeAttributeCollection Properties

[image] [image]

.NET Framework Class Library
HippoRealTimeAttributeCollection Properties
HippoRealTimeAttributeCollection Class See Also Send Feedback

The HippoRealTimeAttributeCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public property | Count | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Public property | Item | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from List <(Of <(<' HippoRealTimeAttribute >)>)>.)

See Also

HippoRealTimeAttributeCollection Class
Hippo.WindowsForm4 Namespace


LicenseTypes Enumeration

[image]

.NET Framework Class Library
LicenseTypes Enumeration
See Also Send Feedback

라이선스 타입

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration LicenseTypes
C#
public enum LicenseTypes
Visual C++
public enum class LicenseTypes
JavaScript
Hippo.WindowsForm4.LicenseTypes = function();
Hippo.WindowsForm4.LicenseTypes.createEnum('Hippo.WindowsForm4.LicenseTypes', false);

Members

Member name | Description
Trial |
Error |
Goood |

See Also

Hippo.WindowsForm4 Namespace


PropertyEditorForm Class

[image]

.NET Framework Class Library
PropertyEditorForm Class
Members See Also Send Feedback

PropertyEditorForm

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Class PropertyEditorForm _
    Inherits Form
C#
public class PropertyEditorForm : Form
Visual C++
public ref class PropertyEditorForm : public Form
JavaScript
Hippo.WindowsForm4.PropertyEditorForm = function();

Type.createClass(
    'Hippo.WindowsForm4.PropertyEditorForm',
    Form);

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Hippo.WindowsForm4..::..PropertyEditorForm

See Also

PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


PropertyEditorForm Members

[image] [image]

.NET Framework Class Library
PropertyEditorForm Members
PropertyEditorForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The PropertyEditorForm type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyEditorForm | PropertyEditorForm 인스턴스를 생성합니다.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

PropertyEditorForm Class
Hippo.WindowsForm4 Namespace


PropertyEditorForm Constructor

[image]

.NET Framework Class Library
PropertyEditorForm Constructor
PropertyEditorForm Class See Also Send Feedback

PropertyEditorForm 인스턴스를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New ( _
    property As Object _
)
C#
public PropertyEditorForm(
    Object property
)
Visual C++
public:
PropertyEditorForm(
    Object^ property
)
JavaScript
Hippo.WindowsForm4.PropertyEditorForm = function(property);

Parameters

property
Type: System..::..Object

See Also

PropertyEditorForm Class
Hippo.WindowsForm4 Namespace


PropertyEditorForm Methods

[image] [image]

.NET Framework Class Library
PropertyEditorForm Methods
PropertyEditorForm Class See Also Send Feedback

The PropertyEditorForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

PropertyEditorForm Class
Hippo.WindowsForm4 Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..AccessibilityNotifyClients Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


BeginInvoke Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..BeginInvoke Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Dispose Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides Form..::..Dispose(Boolean).)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
PropertyEditorForm..::..Dispose Method (Boolean)
PropertyEditorForm Class See Also Send Feedback

사용 중인 모든 리소스를 정리합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
관리되는 리소스를 삭제해야 하면 true이고, 그렇지 않으면 false입니다.

See Also

PropertyEditorForm Class
Dispose Overload
Hippo.WindowsForm4 Namespace


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..GetChildAtPoint Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Invalidate Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Invalidate Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Invoke Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Invoke Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..MemberwiseClone Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


PerformLayout Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..PerformLayout Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


ResumeLayout Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..ResumeLayout Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..RtlTranslateAlignment Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Scale Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Scale Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Select Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Select Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


SetBounds Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..SetBounds Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Show Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Show Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


ShowDialog Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..ShowDialog Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


UpdateBounds Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..UpdateBounds Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


Validate Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..Validate Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


ValidateChildren Method

[image] [image]

.NET Framework Class Library
PropertyEditorForm..::..ValidateChildren Method
PropertyEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PropertyEditorForm Class
PropertyEditorForm Members
Hippo.WindowsForm4 Namespace


PropertyEditorForm Properties

[image] [image]

.NET Framework Class Library
PropertyEditorForm Properties
PropertyEditorForm Class See Also Send Feedback

The PropertyEditorForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

PropertyEditorForm Class
Hippo.WindowsForm4 Namespace


PropertyEditorForm Events

[image] [image]

.NET Framework Class Library
PropertyEditorForm Events
PropertyEditorForm Class See Also Send Feedback

The PropertyEditorForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

PropertyEditorForm Class
Hippo.WindowsForm4 Namespace


sHippoChart Class

[image]

.NET Framework Class Library
sHippoChart Class
Members See Also Send Feedback

히포차트 윈도우즈 폼 스크롤링 컨트롤

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<ToolboxBitmapAttribute("C:\Program Files (x86)\Hippochart 4.3\winform\images\shippo.bmp")> _
Public Class sHippoChart _
    Inherits UserControl _
    Implements IChart
C#
[ToolboxBitmapAttribute("C:\Program Files (x86)\Hippochart 4.3\winform\images\shippo.bmp")]
public class sHippoChart : UserControl,
    IChart
Visual C++
[ToolboxBitmapAttribute(L"C:\Program Files (x86)\Hippochart 4.3\winform\images\shippo.bmp")]
public ref class sHippoChart : public UserControl,
    IChart
JavaScript
Hippo.WindowsForm4.sHippoChart = function();

Type.createClass(
    'Hippo.WindowsForm4.sHippoChart',
    UserControl,
    Hippo.IChart);

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Hippo.WindowsForm4..::..sHippoChart

See Also

sHippoChart Members
Hippo.WindowsForm4 Namespace


sHippoChart Members

[image] [image]

.NET Framework Class Library
sHippoChart Members
sHippoChart Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The sHippoChart type exposes the following members.

Constructors

 | Name | Description
Public method | sHippoChart | sHippoChart

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | AutoScrolling | 스크롤 넓이를 재조정합니다.
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.
Public method | DrawDefault | 차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)
Public method | DrawSampleChart | 샘플 차트를 그립니다.
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Control.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Control.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnChartClick | OnChartClick 이벤트
Protected method | OnChartContextMenuAdded | OnChartContextMenuAdded 이벤트
Protected method | OnChartDesignTypeChanged | OnChartDesignTypeChanged 이벤트
Protected method | OnChartDoubleClick | OnChartDoubleClick 이벤트
Protected method | OnChartMouseClick | OnChartMouseClick 이벤트
Protected method | OnChartMouseDoubleClick | OnChartMouseDoubleClick
Protected method | OnChartMouseDown | OnChartMouseDown
Protected method | OnChartMouseDrag | OnChartMouseLeave
Protected method | OnChartMouseEnter | OnChartMouseEnter
Protected method | OnChartMouseHover | ChartMouseHover
Protected method | OnChartMouseLeave | OnChartMouseLeave
Protected method | OnChartMouseMove | OnChartMouseMove
Protected method | OnChartMouseUp | OnChartMouseUp
Protected method | OnChartSizeChanged | OnChartSizeChanged 이벤트
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDataBinging | OnDataBinging 이벤트
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Control.)
Protected method | OnEnter | (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Control.)
Protected method | OnHandleDestroyed | (Inherited from Control.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | OnLoad 이벤트 (Overrides UserControl..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Control.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Control.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Control.)
Protected method | SetClientSizeCore | (Inherited from Control.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | HippoChart Beta v3.1 (since 2007.09) (Overrides Component..::..ToString()()()().)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | Zoomin(RectangleF) | 줌인을 합니다.
Public method | Zoomin(Single) | 줌인을 합니다.
Public method | Zoomout | 줌아웃을 합니다. (원래 크기로)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Canvas | 범례와 타이틀, 로그 영역을 뺀 실제 그래프가 그려지는 영역 렉텡글을 가져옵니다.
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ChartFileName | 차트 이미지 파일 이름을 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Protected property | DesignMode | (Inherited from Component.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | DragRectangle | 차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsDrag | 마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsScroll | 차트 스크롤을 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsUseContextMenu | 콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Location | (Inherited from Control.)
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | Message | 히포차트에서 발생하는 각종 메세지를 가져옵니다.
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProcessorType | CPU 플랫폼 타입을 사용자가 지정합니다.
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RealTimeList | 실시간 차트 셋을 설정하고 가져옵니다.
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ScrollXaxisWidth |
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Protected property | ShowFocusCues | (Inherited from Control.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.
Public property | WindowTarget | (Inherited from Control.)
Public property | ZoomStatus | 현재 줌(Zoom) 상태를 가져옵니다.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | ChartClick | 차트가 클릭될 때 발생합니다.
Public event | ChartContextMenuCreated | 차트 컨텍스트메뉴가 생성될 때 발생합니다.
Public event | ChartDataBinging | 이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다.
Public event | ChartDesignTypeChanged | 차트 디자인타입이 변경될때 발생합니다.
Public event | ChartDoubleClick | 차트를 더블 클릭될 때 발생합니다.
Public event | ChartMouseClick | 차트에 마우스를 클릭될 때 발생합니다.
Public event | ChartMouseDoubleClick | 차트에 마우스를 더블클릭될 때 발생합니다.
Public event | ChartMouseDown | 차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.
Public event | ChartMouseDrag | 차트에 마우스를 드래그 할때 발생합니다.
Public event | ChartMouseEnter | 차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.
Public event | ChartMouseHover | 차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.
Public event | ChartMouseLeave | 차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.
Public event | ChartMouseMove | 차트에 마우스가 있을때 마우스가 움직이면 발생합니다.
Public event | ChartMouseUp | 차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.
Public event | ChartPrinting | 차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.
Public event | ChartSizeChanged | 차트 사이즈가 변경될때 발생합니다.
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


sHippoChart Constructor

[image]

.NET Framework Class Library
sHippoChart Constructor
sHippoChart Class See Also Send Feedback

sHippoChart

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub New
C#
public sHippoChart()
Visual C++
public:
sHippoChart()
JavaScript
Hippo.WindowsForm4.sHippoChart = function();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


sHippoChart Methods

[image] [image]

.NET Framework Class Library
sHippoChart Methods
sHippoChart Class See Also Send Feedback

The sHippoChart type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | AutoScrolling | 스크롤 넓이를 재조정합니다.
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.
Public method | DrawDefault | 차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)
Public method | DrawSampleChart | 샘플 차트를 그립니다.
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Control.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Control.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnChartClick | OnChartClick 이벤트
Protected method | OnChartContextMenuAdded | OnChartContextMenuAdded 이벤트
Protected method | OnChartDesignTypeChanged | OnChartDesignTypeChanged 이벤트
Protected method | OnChartDoubleClick | OnChartDoubleClick 이벤트
Protected method | OnChartMouseClick | OnChartMouseClick 이벤트
Protected method | OnChartMouseDoubleClick | OnChartMouseDoubleClick
Protected method | OnChartMouseDown | OnChartMouseDown
Protected method | OnChartMouseDrag | OnChartMouseLeave
Protected method | OnChartMouseEnter | OnChartMouseEnter
Protected method | OnChartMouseHover | ChartMouseHover
Protected method | OnChartMouseLeave | OnChartMouseLeave
Protected method | OnChartMouseMove | OnChartMouseMove
Protected method | OnChartMouseUp | OnChartMouseUp
Protected method | OnChartSizeChanged | OnChartSizeChanged 이벤트
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDataBinging | OnDataBinging 이벤트
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Control.)
Protected method | OnEnter | (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Control.)
Protected method | OnHandleDestroyed | (Inherited from Control.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | OnLoad 이벤트 (Overrides UserControl..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Control.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Control.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Control.)
Protected method | SetClientSizeCore | (Inherited from Control.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | HippoChart Beta v3.1 (since 2007.09) (Overrides Component..::..ToString()()()().)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | Zoomin(RectangleF) | 줌인을 합니다.
Public method | Zoomin(Single) | 줌인을 합니다.
Public method | Zoomout | 줌아웃을 합니다. (원래 크기로)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..AccessibilityNotifyClients Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


AutoScrolling Method

[image]

.NET Framework Class Library
sHippoChart..::..AutoScrolling Method
sHippoChart Class See Also Send Feedback

스크롤 넓이를 재조정합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub AutoScrolling
C#
public void AutoScrolling()
Visual C++
public:
void AutoScrolling()
JavaScript
function autoScrolling();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


BeginInvoke Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..BeginInvoke Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Dispose Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | (Inherited from Component.)
Protected method | Dispose(Boolean) | 사용 중인 모든 리소스를 정리합니다. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
sHippoChart..::..Dispose Method (Boolean)
sHippoChart Class See Also Send Feedback

사용 중인 모든 리소스를 정리합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
관리되는 리소스를 삭제해야 하면 true이고, 그렇지 않으면 false입니다.

See Also

sHippoChart Class
Dispose Overload
Hippo.WindowsForm4 Namespace


DrawChart Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..DrawChart Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawChart()()()() | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesList) | 히포 차트를 생성합니다.
Public method | DrawChart(SeriesListDictionary) | 히포 차트를 생성합니다.
Public method | DrawChart(DataTable, String, array<String>[]()[][]) | 히포 차트를 생성합니다.

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


DrawChart Method

[image]

.NET Framework Class Library
sHippoChart..::..DrawChart Method
sHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart
C#
public void DrawChart()
Visual C++
public:
virtual void DrawChart() sealed
JavaScript
function drawChart();

Implements

IChart..::..DrawChart()()()()

See Also

sHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (SeriesList)

[image]

.NET Framework Class Library
sHippoChart..::..DrawChart Method (SeriesList)
sHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    SeriesList As SeriesList _
)
C#
public void DrawChart(
    SeriesList SeriesList
)
Visual C++
public:
virtual void DrawChart(
    SeriesList^ SeriesList
) sealed
JavaScript
function drawChart(SeriesList);

Parameters

SeriesList
Type: Hippo..::..SeriesList
SeriesList

Implements

IChart..::..DrawChart(SeriesList)

See Also

sHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (SeriesListDictionary)

[image]

.NET Framework Class Library
sHippoChart..::..DrawChart Method (SeriesListDictionary)
sHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    SeriesListDictionary As SeriesListDictionary _
)
C#
public void DrawChart(
    SeriesListDictionary SeriesListDictionary
)
Visual C++
public:
virtual void DrawChart(
    SeriesListDictionary^ SeriesListDictionary
) sealed
JavaScript
function drawChart(SeriesListDictionary);

Parameters

SeriesListDictionary
Type: Hippo..::..SeriesListDictionary
SeriesListDictionary

Implements

IChart..::..DrawChart(SeriesListDictionary)

See Also

sHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawChart Method (DataTable, String, String[])

[image]

.NET Framework Class Library
sHippoChart..::..DrawChart Method (DataTable, String, array<String>[]()[][])
sHippoChart Class See Also Send Feedback

히포 차트를 생성합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawChart ( _
    ChartSource As DataTable, _
    nameColumn As String, _
    ParamArray valueColumns As String() _
)
C#
public void DrawChart(
    DataTable ChartSource,
    string nameColumn,
    params string[] valueColumns
)
Visual C++
public:
void DrawChart(
    DataTable^ ChartSource,
    String^ nameColumn,
    ... array<String^>^ valueColumns
)
JavaScript
function drawChart(ChartSource, nameColumn, ... valueColumns);

Parameters

ChartSource
Type: System.Data..::..DataTable
데이터 소스
nameColumn
Type: System..::..String
이름 컬럼(x 축)
valueColumns
Type: array< System..::..String >[]()[][]
값 컬럼(y 축)

See Also

sHippoChart Class
DrawChart Overload
Hippo.WindowsForm4 Namespace


DrawDefault Method

[image]

.NET Framework Class Library
sHippoChart..::..DrawDefault Method
sHippoChart Class See Also Send Feedback

차트의 기본 모양을 그립니다.(호출 대상이 아닙니다.)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawDefault
C#
public void DrawDefault()
Visual C++
public:
virtual void DrawDefault() sealed
JavaScript
function drawDefault();

Implements

IChart..::..DrawDefault()()()()

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


DrawSampleChart Method

[image]

.NET Framework Class Library
sHippoChart..::..DrawSampleChart Method
sHippoChart Class See Also Send Feedback

샘플 차트를 그립니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub DrawSampleChart
C#
public void DrawSampleChart()
Visual C++
public:
void DrawSampleChart()
JavaScript
function drawSampleChart();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..GetChildAtPoint Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Invalidate Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Invalidate Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Invoke Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Invoke Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..MemberwiseClone Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


OnChartClick Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartClick Method
sHippoChart Class See Also Send Feedback

OnChartClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartClick ( _
    e As EventArgs _
)
C#
protected virtual void OnChartClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartClick(
    EventArgs^ e
)
JavaScript
function onChartClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartContextMenuAdded Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartContextMenuAdded Method
sHippoChart Class See Also Send Feedback

OnChartContextMenuAdded 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartContextMenuAdded ( _
    e As ContextMenuEventArgs _
)
C#
protected virtual void OnChartContextMenuAdded(
    ContextMenuEventArgs e
)
Visual C++
protected:
virtual void OnChartContextMenuAdded(
    ContextMenuEventArgs^ e
)
JavaScript
function onChartContextMenuAdded(e);

Parameters

e
Type: Hippo.WindowsForm4..::..ContextMenuEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartDesignTypeChanged Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartDesignTypeChanged Method
sHippoChart Class See Also Send Feedback

OnChartDesignTypeChanged 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartDesignTypeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartDesignTypeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartDesignTypeChanged(
    EventArgs^ e
)
JavaScript
function onChartDesignTypeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartDoubleClick Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartDoubleClick Method
sHippoChart Class See Also Send Feedback

OnChartDoubleClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartDoubleClick ( _
    e As EventArgs _
)
C#
protected virtual void OnChartDoubleClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartDoubleClick(
    EventArgs^ e
)
JavaScript
function onChartDoubleClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseClick Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseClick Method
sHippoChart Class See Also Send Feedback

OnChartMouseClick 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseClick ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseClick(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseClick(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseClick(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDoubleClick Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseDoubleClick Method
sHippoChart Class See Also Send Feedback

OnChartMouseDoubleClick

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDoubleClick ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseDoubleClick(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDoubleClick(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseDoubleClick(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDown Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseDown Method
sHippoChart Class See Also Send Feedback

OnChartMouseDown

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDown ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseDown(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDown(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseDown(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseDrag Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseDrag Method
sHippoChart Class See Also Send Feedback

OnChartMouseLeave

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseDrag ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseDrag(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseDrag(
    EventArgs^ e
)
JavaScript
function onChartMouseDrag(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseEnter Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseEnter Method
sHippoChart Class See Also Send Feedback

OnChartMouseEnter

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseEnter ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseEnter(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseEnter(
    EventArgs^ e
)
JavaScript
function onChartMouseEnter(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseHover Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseHover Method
sHippoChart Class See Also Send Feedback

ChartMouseHover

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseHover ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseHover(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseHover(
    EventArgs^ e
)
JavaScript
function onChartMouseHover(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseLeave Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseLeave Method
sHippoChart Class See Also Send Feedback

OnChartMouseLeave

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseLeave ( _
    e As EventArgs _
)
C#
protected virtual void OnChartMouseLeave(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartMouseLeave(
    EventArgs^ e
)
JavaScript
function onChartMouseLeave(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseMove Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseMove Method
sHippoChart Class See Also Send Feedback

OnChartMouseMove

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseMove ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseMove(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseMove(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseMove(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartMouseUp Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartMouseUp Method
sHippoChart Class See Also Send Feedback

OnChartMouseUp

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartMouseUp ( _
    e As MouseEventArgs _
)
C#
protected virtual void OnChartMouseUp(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnChartMouseUp(
    MouseEventArgs^ e
)
JavaScript
function onChartMouseUp(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnChartSizeChanged Method

[image]

.NET Framework Class Library
sHippoChart..::..OnChartSizeChanged Method
sHippoChart Class See Also Send Feedback

OnChartSizeChanged 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnChartSizeChanged ( _
    e As EventArgs _
)
C#
protected virtual void OnChartSizeChanged(
    EventArgs e
)
Visual C++
protected:
virtual void OnChartSizeChanged(
    EventArgs^ e
)
JavaScript
function onChartSizeChanged(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnDataBinging Method

[image]

.NET Framework Class Library
sHippoChart..::..OnDataBinging Method
sHippoChart Class See Also Send Feedback

OnDataBinging 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overridable Sub OnDataBinging ( _
    e As EventArgs _
)
C#
protected virtual void OnDataBinging(
    EventArgs e
)
Visual C++
protected:
virtual void OnDataBinging(
    EventArgs^ e
)
JavaScript
function onDataBinging(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


OnLoad Method

[image]

.NET Framework Class Library
sHippoChart..::..OnLoad Method
sHippoChart Class See Also Send Feedback

OnLoad 이벤트

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
C#
protected override void OnLoad(
    EventArgs e
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override
JavaScript
function onLoad(e);

Parameters

e
Type: System..::..EventArgs

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


PerformLayout Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..PerformLayout Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


ResumeLayout Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..ResumeLayout Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..RtlTranslateAlignment Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Scale Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Scale Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Select Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Select Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


SetBounds Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..SetBounds Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


ToString Method

[image]

.NET Framework Class Library
sHippoChart..::..ToString Method
sHippoChart Class See Also Send Feedback

HippoChart Beta v3.1 (since 2007.09)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


UpdateBounds Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..UpdateBounds Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Validate Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Validate Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


ValidateChildren Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..ValidateChildren Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Zoomin Method

[image] [image]

.NET Framework Class Library
sHippoChart..::..Zoomin Method
sHippoChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Zoomin(RectangleF) | 줌인을 합니다.
Public method | Zoomin(Single) | 줌인을 합니다.

See Also

sHippoChart Class
sHippoChart Members
Hippo.WindowsForm4 Namespace


Zoomin Method (RectangleF)

[image]

.NET Framework Class Library
sHippoChart..::..Zoomin Method (RectangleF)
sHippoChart Class See Also Send Feedback

줌인을 합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Zoomin ( _
    zoomRactangle As RectangleF _
)
C#
public void Zoomin(
    RectangleF zoomRactangle
)
Visual C++
public:
void Zoomin(
    RectangleF zoomRactangle
)
JavaScript
function zoomin(zoomRactangle);

Parameters

zoomRactangle
Type: System.Drawing..::..RectangleF
줌 영역

See Also

sHippoChart Class
Zoomin Overload
Hippo.WindowsForm4 Namespace


Zoomin Method (Single)

[image]

.NET Framework Class Library
sHippoChart..::..Zoomin Method (Single)
sHippoChart Class See Also Send Feedback

줌인을 합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Zoomin ( _
    size As Single _
)
C#
public void Zoomin(
    float size
)
Visual C++
public:
void Zoomin(
    float size
)
JavaScript
function zoomin(size);

Parameters

size
Type: System..::..Single
몇배

See Also

sHippoChart Class
Zoomin Overload
Hippo.WindowsForm4 Namespace


Zoomout Method

[image]

.NET Framework Class Library
sHippoChart..::..Zoomout Method
sHippoChart Class See Also Send Feedback

줌아웃을 합니다. (원래 크기로)

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Sub Zoomout
C#
public void Zoomout()
Visual C++
public:
void Zoomout()
JavaScript
function zoomout();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


sHippoChart Properties

[image] [image]

.NET Framework Class Library
sHippoChart Properties
sHippoChart Class See Also Send Feedback

The sHippoChart type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Canvas | 범례와 타이틀, 로그 영역을 뺀 실제 그래프가 그려지는 영역 렉텡글을 가져옵니다.
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ChartFileName | 차트 이미지 파일 이름을 설정하고 가져옵니다.
Public property | ChartGraphic | 차트 그래픽를 설정하고 가져옵니다.
Public property | ChartID | 현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.
Public property | ChartImage | 차트 이미지를 설정하고 가져옵니다.
Public property | ChartRectangle | 히포차트 전체 사각형를 설정하고 가져옵니다.
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Designer | 차트 디자이너를 설정하고 가져옵니다.
Protected property | DesignMode | (Inherited from Component.)
Public property | DesignType | 차트 디자인 타입를 설정하고 가져옵니다.
Public property | Direction | 그래프 영역의 방향를 설정하고 가져옵니다.
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | DragRectangle | 차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | Height2 | 차트 세로 길이를 설정하고 가져옵니다.
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsDrag | 마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsEmptyanalysis | 공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsScroll | 차트 스크롤을 사용할 것인지 여부를 설정하고 가져옵니다.
Public property | IsUseContextMenu | 콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.
Public property | Layout | 히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | 차트 X 위치를 설정하고 가져옵니다.
Public property | LegendBox | 범례를 설정하고 가져옵니다.
Public property | Location | (Inherited from Control.)
Public property | Logo | 로고를 설정하고 가져옵니다.
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | Message | 히포차트에서 발생하는 각종 메세지를 가져옵니다.
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | PaletteType | 팔레트 종류를 설정하고 가져옵니다.
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProcessorType | CPU 플랫폼 타입을 사용자가 지정합니다.
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RealTimeList | 실시간 차트 셋을 설정하고 가져옵니다.
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ScrollXaxisWidth |
Public property | SeriesAreaRate | 시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )
Public property | SeriesListDictionary | 시리즈 리스트 컬렉션를 설정하고 가져옵니다.
Protected property | ShowFocusCues | (Inherited from Control.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Titles | 차트 타이틀를 설정하고 가져옵니다.
Public property | Top | 차트 Y 위치를 설정하고 가져옵니다.
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | Width2 | 차트 가로길이를 설정하고 가져옵니다.
Public property | WindowTarget | (Inherited from Control.)
Public property | ZoomStatus | 현재 줌(Zoom) 상태를 가져옵니다.

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Canvas Property

[image]

.NET Framework Class Library
sHippoChart..::..Canvas Property
sHippoChart Class See Also Send Feedback

범례와 타이틀, 로그 영역을 뺀 실제 그래프가 그려지는 영역 렉텡글을 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property Canvas As Rectangle
    Get
C#
public Rectangle Canvas { get; }
Visual C++
public:
property Rectangle Canvas {
    Rectangle get ();
}
JavaScript
function get_canvas();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartFileName Property

[image]

.NET Framework Class Library
sHippoChart..::..ChartFileName Property
sHippoChart Class See Also Send Feedback

차트 이미지 파일 이름을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ChartFileName As String
    Get
C#
public string ChartFileName { get; }
Visual C++
public:
property String^ ChartFileName {
    String^ get ();
}
JavaScript
function get_chartFileName();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartGraphic Property

[image]

.NET Framework Class Library
sHippoChart..::..ChartGraphic Property
sHippoChart Class See Also Send Feedback

차트 그래픽를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartGraphic As Graphics
    Get
    Set
C#
public Graphics ChartGraphic { get; set; }
Visual C++
public:
virtual property Graphics^ ChartGraphic {
    Graphics^ get () sealed;
    void set (Graphics^ value) sealed;
}
JavaScript
function get_chartGraphic();
function set_chartGraphic(value);

Implements

IChart..::..ChartGraphic

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartID Property

[image]

.NET Framework Class Library
sHippoChart..::..ChartID Property
sHippoChart Class See Also Send Feedback

현재 그리고 있는 차트의 아이디를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartID As String
    Get
    Set
C#
public string ChartID { get; set; }
Visual C++
public:
virtual property String^ ChartID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_chartID();
function set_chartID(value);

Implements

IChart..::..ChartID

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartImage Property

[image]

.NET Framework Class Library
sHippoChart..::..ChartImage Property
sHippoChart Class See Also Send Feedback

차트 이미지를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartImage As Bitmap
    Get
    Set
C#
public Bitmap ChartImage { get; set; }
Visual C++
public:
virtual property Bitmap^ ChartImage {
    Bitmap^ get () sealed;
    void set (Bitmap^ value) sealed;
}
JavaScript
function get_chartImage();
function set_chartImage(value);

Implements

IChart..::..ChartImage

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartRectangle Property

[image]

.NET Framework Class Library
sHippoChart..::..ChartRectangle Property
sHippoChart Class See Also Send Feedback

히포차트 전체 사각형를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ChartRectangle As RectangleF
    Get
    Set
C#
public RectangleF ChartRectangle { get; set; }
Visual C++
public:
virtual property RectangleF ChartRectangle {
    RectangleF get () sealed;
    void set (RectangleF value) sealed;
}
JavaScript
function get_chartRectangle();
function set_chartRectangle(value);

Implements

IChart..::..ChartRectangle

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Designer Property

[image]

.NET Framework Class Library
sHippoChart..::..Designer Property
sHippoChart Class See Also Send Feedback

차트 디자이너를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Designer As ChartDesigner
    Get
    Set
C#
[BindableAttribute(true)]
public ChartDesigner Designer { get; set; }
Visual C++
[BindableAttribute(true)]
public:
virtual property ChartDesigner^ Designer {
    ChartDesigner^ get () sealed;
    void set (ChartDesigner^ value) sealed;
}
JavaScript
function get_designer();
function set_designer(value);

Implements

IChart..::..Designer

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


DesignType Property

[image]

.NET Framework Class Library
sHippoChart..::..DesignType Property
sHippoChart Class See Also Send Feedback

차트 디자인 타입를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property DesignType As ChartDesignType
    Get
    Set
C#
public ChartDesignType DesignType { get; set; }
Visual C++
public:
virtual property ChartDesignType DesignType {
    ChartDesignType get () sealed;
    void set (ChartDesignType value) sealed;
}
JavaScript
function get_designType();
function set_designType(value);

Implements

IChart..::..DesignType

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Direction Property

[image]

.NET Framework Class Library
sHippoChart..::..Direction Property
sHippoChart Class See Also Send Feedback

그래프 영역의 방향를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Direction As GraphAreaLocation
    Get
    Set
C#
public GraphAreaLocation Direction { get; set; }
Visual C++
public:
virtual property GraphAreaLocation Direction {
    GraphAreaLocation get () sealed;
    void set (GraphAreaLocation value) sealed;
}
JavaScript
function get_direction();
function set_direction(value);

Implements

IChart..::..Direction

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


DragRectangle Property

[image]

.NET Framework Class Library
sHippoChart..::..DragRectangle Property
sHippoChart Class See Also Send Feedback

차트 드레그시에 사각 눈금 영역의 Rectangle을 반환합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property DragRectangle As Rectangle
    Get
C#
public Rectangle DragRectangle { get; }
Visual C++
public:
property Rectangle DragRectangle {
    Rectangle get ();
}
JavaScript
function get_dragRectangle();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Height2 Property

[image]

.NET Framework Class Library
sHippoChart..::..Height2 Property
sHippoChart Class See Also Send Feedback

차트 세로 길이를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Height2 As Single
    Get
    Set
C#
public float Height2 { get; set; }
Visual C++
public:
virtual property float Height2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_height2();
function set_height2(value);

Implements

IChart..::..Height2

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


IsDrag Property

[image]

.NET Framework Class Library
sHippoChart..::..IsDrag Property
sHippoChart Class See Also Send Feedback

마우스 드레그 시 사각 눈금 표시를 사용할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsDrag As Boolean
    Get
    Set
C#
public bool IsDrag { get; set; }
Visual C++
public:
property bool IsDrag {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDrag();
function set_isDrag(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


IsEmptyanalysis Property

[image]

.NET Framework Class Library
sHippoChart..::..IsEmptyanalysis Property
sHippoChart Class See Also Send Feedback

공간 분석 프로세스를 수행할 것인지 여부를 설정하고 가져옵니다. 기본값은 true

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsEmptyanalysis As Boolean
    Get
    Set
C#
public bool IsEmptyanalysis { get; set; }
Visual C++
public:
property bool IsEmptyanalysis {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isEmptyanalysis();
function set_isEmptyanalysis(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


IsScroll Property

[image]

.NET Framework Class Library
sHippoChart..::..IsScroll Property
sHippoChart Class See Also Send Feedback

차트 스크롤을 사용할 것인지 여부를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsScroll As Boolean
    Get
    Set
C#
public bool IsScroll { get; set; }
Visual C++
public:
property bool IsScroll {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isScroll();
function set_isScroll(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


IsUseContextMenu Property

[image]

.NET Framework Class Library
sHippoChart..::..IsUseContextMenu Property
sHippoChart Class See Also Send Feedback

콘텍스트 메뉴 사용 여부를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property IsUseContextMenu As Boolean
    Get
    Set
C#
public bool IsUseContextMenu { get; set; }
Visual C++
public:
property bool IsUseContextMenu {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isUseContextMenu();
function set_isUseContextMenu(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Layout Property

[image]

.NET Framework Class Library
sHippoChart..::..Layout Property
sHippoChart Class See Also Send Feedback

히포차트 디자인을 위한 기반 레이아웃 클래스를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Layout As Layout
    Get
    Set
C#
public Layout Layout { get; set; }
Visual C++
public:
virtual property Layout^ Layout {
    Layout^ get () sealed;
    void set (Layout^ value) sealed;
}
JavaScript
function get_layout();
function set_layout(value);

Implements

IChart..::..Layout

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Left Property

[image]

.NET Framework Class Library
sHippoChart..::..Left Property
sHippoChart Class See Also Send Feedback

차트 X 위치를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Left As Single
    Get
    Set
C#
public float Left { get; set; }
Visual C++
public:
virtual property float Left {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_left();
function set_left(value);

Implements

IChart..::..Left

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


LegendBox Property

[image]

.NET Framework Class Library
sHippoChart..::..LegendBox Property
sHippoChart Class See Also Send Feedback

범례를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property LegendBox As LegendBox
    Get
    Set
C#
public LegendBox LegendBox { get; set; }
Visual C++
public:
virtual property LegendBox^ LegendBox {
    LegendBox^ get () sealed;
    void set (LegendBox^ value) sealed;
}
JavaScript
function get_legendBox();
function set_legendBox(value);

Implements

IChart..::..LegendBox

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Logo Property

[image]

.NET Framework Class Library
sHippoChart..::..Logo Property
sHippoChart Class See Also Send Feedback

로고를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Logo As Logo
    Get
    Set
C#
public Logo Logo { get; set; }
Visual C++
public:
virtual property Logo^ Logo {
    Logo^ get () sealed;
    void set (Logo^ value) sealed;
}
JavaScript
function get_logo();
function set_logo(value);

Implements

IChart..::..Logo

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Message Property

[image]

.NET Framework Class Library
sHippoChart..::..Message Property
sHippoChart Class See Also Send Feedback

히포차트에서 발생하는 각종 메세지를 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property Message As String
    Get
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}
JavaScript
function get_message();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


PaletteType Property

[image]

.NET Framework Class Library
sHippoChart..::..PaletteType Property
sHippoChart Class See Also Send Feedback

팔레트 종류를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property PaletteType As PaletteType
    Get
    Set
C#
public PaletteType PaletteType { get; set; }
Visual C++
public:
virtual property PaletteType PaletteType {
    PaletteType get () sealed;
    void set (PaletteType value) sealed;
}
JavaScript
function get_paletteType();
function set_paletteType(value);

Implements

IChart..::..PaletteType

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ProcessorType Property

[image]

.NET Framework Class Library
sHippoChart..::..ProcessorType Property
sHippoChart Class See Also Send Feedback

CPU 플랫폼 타입을 사용자가 지정합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ProcessorType As String
    Get
    Set
C#
public string ProcessorType { get; set; }
Visual C++
public:
property String^ ProcessorType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorType();
function set_processorType(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


RealTimeList Property

[image]

.NET Framework Class Library
sHippoChart..::..RealTimeList Property
sHippoChart Class See Also Send Feedback

실시간 차트 셋을 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property RealTimeList As HippoRealTimeAttributeCollection
    Get
    Set
C#
public HippoRealTimeAttributeCollection RealTimeList { get; set; }
Visual C++
public:
property HippoRealTimeAttributeCollection^ RealTimeList {
    HippoRealTimeAttributeCollection^ get ();
    void set (HippoRealTimeAttributeCollection^ value);
}
JavaScript
function get_realTimeList();
function set_realTimeList(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ScrollXaxisWidth Property

[image]

.NET Framework Class Library
sHippoChart..::..ScrollXaxisWidth Property
sHippoChart Class See Also Send Feedback

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property ScrollXaxisWidth As Double
    Get
    Set
C#
public double ScrollXaxisWidth { get; set; }
Visual C++
public:
property double ScrollXaxisWidth {
    double get ();
    void set (double value);
}
JavaScript
function get_scrollXaxisWidth();
function set_scrollXaxisWidth(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


SeriesAreaRate Property

[image]

.NET Framework Class Library
sHippoChart..::..SeriesAreaRate Property
sHippoChart Class See Also Send Feedback

시리즈의 공간을 배분하는 비율을 설정하고 가져옵니다. 기본값은 1 : 1 (예, slist.SeriesAreaRate = "2 : 8"; )

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesAreaRate As String
    Get
    Set
C#
public string SeriesAreaRate { get; set; }
Visual C++
public:
property String^ SeriesAreaRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_seriesAreaRate();
function set_seriesAreaRate(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


SeriesListDictionary Property

[image]

.NET Framework Class Library
sHippoChart..::..SeriesListDictionary Property
sHippoChart Class See Also Send Feedback

시리즈 리스트 컬렉션를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property SeriesListDictionary As SeriesListDictionary
    Get
    Set
C#
public SeriesListDictionary SeriesListDictionary { get; set; }
Visual C++
public:
virtual property SeriesListDictionary^ SeriesListDictionary {
    SeriesListDictionary^ get () sealed;
    void set (SeriesListDictionary^ value) sealed;
}
JavaScript
function get_seriesListDictionary();
function set_seriesListDictionary(value);

Implements

IChart..::..SeriesListDictionary

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Titles Property

[image]

.NET Framework Class Library
sHippoChart..::..Titles Property
sHippoChart Class See Also Send Feedback

차트 타이틀를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Titles As Title
    Get
    Set
C#
public Title Titles { get; set; }
Visual C++
public:
virtual property Title^ Titles {
    Title^ get () sealed;
    void set (Title^ value) sealed;
}
JavaScript
function get_titles();
function set_titles(value);

Implements

IChart..::..Titles

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Top Property

[image]

.NET Framework Class Library
sHippoChart..::..Top Property
sHippoChart Class See Also Send Feedback

차트 Y 위치를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Top As Single
    Get
    Set
C#
public float Top { get; set; }
Visual C++
public:
virtual property float Top {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_top();
function set_top(value);

Implements

IChart..::..Top

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


Width2 Property

[image]

.NET Framework Class Library
sHippoChart..::..Width2 Property
sHippoChart Class See Also Send Feedback

차트 가로길이를 설정하고 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Property Width2 As Single
    Get
    Set
C#
public float Width2 { get; set; }
Visual C++
public:
virtual property float Width2 {
    float get () sealed;
    void set (float value) sealed;
}
JavaScript
function get_width2();
function set_width2(value);

Implements

IChart..::..Width2

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ZoomStatus Property

[image]

.NET Framework Class Library
sHippoChart..::..ZoomStatus Property
sHippoChart Class See Also Send Feedback

현재 줌(Zoom) 상태를 가져옵니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public ReadOnly Property ZoomStatus As ZoomStatus
    Get
C#
public ZoomStatus ZoomStatus { get; }
Visual C++
public:
property ZoomStatus ZoomStatus {
    ZoomStatus get ();
}
JavaScript
function get_zoomStatus();

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


sHippoChart Events

[image] [image]

.NET Framework Class Library
sHippoChart Events
sHippoChart Class See Also Send Feedback

The sHippoChart type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | ChartClick | 차트가 클릭될 때 발생합니다.
Public event | ChartContextMenuCreated | 차트 컨텍스트메뉴가 생성될 때 발생합니다.
Public event | ChartDataBinging | 이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다.
Public event | ChartDesignTypeChanged | 차트 디자인타입이 변경될때 발생합니다.
Public event | ChartDoubleClick | 차트를 더블 클릭될 때 발생합니다.
Public event | ChartMouseClick | 차트에 마우스를 클릭될 때 발생합니다.
Public event | ChartMouseDoubleClick | 차트에 마우스를 더블클릭될 때 발생합니다.
Public event | ChartMouseDown | 차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.
Public event | ChartMouseDrag | 차트에 마우스를 드래그 할때 발생합니다.
Public event | ChartMouseEnter | 차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.
Public event | ChartMouseHover | 차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.
Public event | ChartMouseLeave | 차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.
Public event | ChartMouseMove | 차트에 마우스가 있을때 마우스가 움직이면 발생합니다.
Public event | ChartMouseUp | 차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.
Public event | ChartPrinting | 차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.
Public event | ChartSizeChanged | 차트 사이즈가 변경될때 발생합니다.
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartClick Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartClick Event
sHippoChart Class See Also Send Feedback

차트가 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartClick As EventHandler
C#
public event EventHandler ChartClick
Visual C++
public:
 event EventHandler^ ChartClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartClick(value);
function remove_chartClick(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartContextMenuCreated Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartContextMenuCreated Event
sHippoChart Class See Also Send Feedback

차트 컨텍스트메뉴가 생성될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartContextMenuCreated As ContextMenuEventHandler
C#
public event ContextMenuEventHandler ChartContextMenuCreated
Visual C++
public:
 event ContextMenuEventHandler^ ChartContextMenuCreated {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
JavaScript
function add_chartContextMenuCreated(value);
function remove_chartContextMenuCreated(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDataBinging Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartDataBinging Event
sHippoChart Class See Also Send Feedback

이 이벤트를 통해 차트 데이터를 실시간으로 반영할 수 있습니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDataBinging As EventHandler
C#
public event EventHandler ChartDataBinging
Visual C++
public:
 event EventHandler^ ChartDataBinging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDataBinging(value);
function remove_chartDataBinging(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDesignTypeChanged Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartDesignTypeChanged Event
sHippoChart Class See Also Send Feedback

차트 디자인타입이 변경될때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDesignTypeChanged As EventHandler
C#
public event EventHandler ChartDesignTypeChanged
Visual C++
public:
 event EventHandler^ ChartDesignTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDesignTypeChanged(value);
function remove_chartDesignTypeChanged(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartDoubleClick Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartDoubleClick Event
sHippoChart Class See Also Send Feedback

차트를 더블 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartDoubleClick As EventHandler
C#
public event EventHandler ChartDoubleClick
Visual C++
public:
 event EventHandler^ ChartDoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartDoubleClick(value);
function remove_chartDoubleClick(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseClick Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseClick Event
sHippoChart Class See Also Send Feedback

차트에 마우스를 클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseClick As MouseEventHandler
C#
public event MouseEventHandler ChartMouseClick
Visual C++
public:
 event MouseEventHandler^ ChartMouseClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseClick(value);
function remove_chartMouseClick(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDoubleClick Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseDoubleClick Event
sHippoChart Class See Also Send Feedback

차트에 마우스를 더블클릭될 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler ChartMouseDoubleClick
Visual C++
public:
 event MouseEventHandler^ ChartMouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseDoubleClick(value);
function remove_chartMouseDoubleClick(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDown Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseDown Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 있을때 마우스 단추를 누를때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDown As MouseEventHandler
C#
public event MouseEventHandler ChartMouseDown
Visual C++
public:
 event MouseEventHandler^ ChartMouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseDown(value);
function remove_chartMouseDown(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseDrag Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseDrag Event
sHippoChart Class See Also Send Feedback

차트에 마우스를 드래그 할때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseDrag As EventHandler
C#
public event EventHandler ChartMouseDrag
Visual C++
public:
 event EventHandler^ ChartMouseDrag {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseDrag(value);
function remove_chartMouseDrag(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseEnter Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseEnter Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 보이는 부분으로 가져갈 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseEnter As EventHandler
C#
public event EventHandler ChartMouseEnter
Visual C++
public:
 event EventHandler^ ChartMouseEnter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseEnter(value);
function remove_chartMouseEnter(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseHover Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseHover Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 일정시간 동안 컨트롤의 내부에 있을 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseHover As EventHandler
C#
public event EventHandler ChartMouseHover
Visual C++
public:
 event EventHandler^ ChartMouseHover {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseHover(value);
function remove_chartMouseHover(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseLeave Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseLeave Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 보이는 부분에서 벗어날 때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseLeave As EventHandler
C#
public event EventHandler ChartMouseLeave
Visual C++
public:
 event EventHandler^ ChartMouseLeave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartMouseLeave(value);
function remove_chartMouseLeave(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseMove Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseMove Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 있을때 마우스가 움직이면 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseMove As MouseEventHandler
C#
public event MouseEventHandler ChartMouseMove
Visual C++
public:
 event MouseEventHandler^ ChartMouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseMove(value);
function remove_chartMouseMove(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartMouseUp Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartMouseUp Event
sHippoChart Class See Also Send Feedback

차트에 마우스가 있을때 마우스 단추를 놓으면 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartMouseUp As MouseEventHandler
C#
public event MouseEventHandler ChartMouseUp
Visual C++
public:
 event MouseEventHandler^ ChartMouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
JavaScript
function add_chartMouseUp(value);
function remove_chartMouseUp(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartPrinting Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartPrinting Event
sHippoChart Class See Also Send Feedback

차트 컨텍스트 메뉴의 도구/인쇄 기능을 클릭할때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartPrinting As EventHandler
C#
public event EventHandler ChartPrinting
Visual C++
public:
 event EventHandler^ ChartPrinting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartPrinting(value);
function remove_chartPrinting(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ChartSizeChanged Event

[image]

.NET Framework Class Library
sHippoChart..::..ChartSizeChanged Event
sHippoChart Class See Also Send Feedback

차트 사이즈가 변경될때 발생합니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Event ChartSizeChanged As EventHandler
C#
public event EventHandler ChartSizeChanged
Visual C++
public:
 event EventHandler^ ChartSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_chartSizeChanged(value);
function remove_chartSizeChanged(value);

See Also

sHippoChart Class
Hippo.WindowsForm4 Namespace


ZoomStatus Enumeration

[image]

.NET Framework Class Library
ZoomStatus Enumeration
See Also Send Feedback

현재 줌 상태를 나타냅니다.

Namespace: Hippo.WindowsForm4
Assembly: hwinformchart4 (in hwinformchart4.dll)

Syntax

Visual Basic
Public Enumeration ZoomStatus
C#
public enum ZoomStatus
Visual C++
public enum class ZoomStatus
JavaScript
Hippo.WindowsForm4.ZoomStatus = function();
Hippo.WindowsForm4.ZoomStatus.createEnum('Hippo.WindowsForm4.ZoomStatus', false);

Members

Member name | Description
In |
Out |

See Also

Hippo.WindowsForm4 Namespace